Subject: [sfc] I-D Action: draft-ietf-sfc-use-case-mobility-02.txt

From: [email-masked]
Date: Sat, 10 Jan 2015 07:17:35 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Service Function Chaining Working Group of the IETF.

        Title           : Service Function Chaining Use Cases in Mobile Networks
        Authors         : Walter Haeffner
                          Jeffrey Napper
                          Martin Stiemerling
                          Diego R. Lopez
                          Jim Uttaro
	Filename        : draft-ietf-sfc-use-case-mobility-02.txt
	Pages           : 20
	Date            : 2015-01-10

Abstract:
   This document provides some exemplary use cases for service function
   chaining in mobile service provider networks.  The objective of this
   draft is not to cover all conceivable service chains in detail.
   Rather, the intention is to localize and explain the application
   domain of service chaining within mobile networks as far as it is
   required to complement the problem statement
   [ietf-sfc-problem-statement] and architecture framework
   [ietf-sfc-arch] of the working group.

   Service function chains typically reside in a LAN segment which links
   the mobile access network to the actual application platforms located
   in the carrier's datacenters or somewhere else in the Internet.
   Service function chains (SFC) ensure a fair distribution of network
   resources according to agreed service policies, enhance the
   performance of service delivery or take care of security and privacy.
   SFCs may also include Value Added Services (VAS).  Commonly, SFCs are
   typical middlebox services.

   General considerations and specific use cases are presented in this
   document to demonstrate the different technical requirements of these
   goals for service function chaining in mobile service provider
   networks.

   The specification of service function chaining for mobile networks
   must take into account an interaction between service function chains
   and the 3GPP Policy and Charging Control (PCC) environment.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sfc-use-case-mobility/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-sfc-use-case-mobility-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-sfc-use-case-mobility-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Jeffrey Napper (jenapper)" <[email-masked]>
Date: Mon, 12 Jan 2015 12:11:43 +0000

This draft is largely wordsmithing and typos. There are a couple of new
paragraphs that are available from the diff tool.

Please send comments and suggestions to the list as we believe the
document is ready for last call. The document seems to be quite stable now.

Cheers,
Jeff

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Saturday, January 10, 2015 at 4:17 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [sfc] I-D Action: draft-ietf-sfc-use-case-mobility-02.txt

>_______________________________________________
>sfc mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/sfc

---

From: <[email-masked]>
Date: Thu, 15 Jan 2015 18:10:56 +0100

Dear authors,
Thanks for the update of the mobility SFC use cases draft. IMO the document is quite useful for further discussion on real-life applicability of SFC work. 

Just some minor comments below (mainly nit and typo picking, clarification proposals, and further smithing ...)
Sorry for that ;-) and thanks for all your work!

Best regards
Dirk

...
p.3
HSS  Home Subscriber System => HSS  Home Subscriber Server
GTP  GPRS (General Packet Radio Service) Tunnel Protocol => GTP  GPRS (General Packet Radio Service) Tunnelling Protocol

p.4:
Important use cases classes => Important use case classes

p.5:
  4.  functions like CG-NAT/PAT  =>  4.  functions like CG-NAT/NAPT (not sure about PAT!?)
P-GW, a xDSL network => P-GW, an xDSL network

p.6:
   basically only seen in mobile networks only.  The same may be true
   for video optimizers or HTTP header enrichment
=>   basically seen in mobile networks only.  The same may be true
   for video optimizers or HTTP header enrichment entities

p.7:
   The major functional components of a LTE network =>   The major functional components of an LTE network

   Figure 2 shows the end to end context including all major components
   of a LTE network.  The actual 3GPP mobile network includes the
   elements from the user equipment [UE] to the packet gateway [P-GW].

   Figure 2: End to end context including all major components of a LTE
    network.  The actual 3GPP mobile network includes the elements from
           the user equipment [UE] to the packet gateway [P-GW].

=> I propose to exchange the lower caption with the upper text and use '_an_ LTE' (;-))

according 3GPP standards.  => according to 3GPP standards.  

p.8:
   [TS.29.061], but service function chaining is not specified by 3GPP. 
=>   one may add:
A study on typical exemplary SFC use cases and potential requirements has been performed by 3GPP recently [TR.22.808] in the framework of Rel. 13.
[TR.22.808]	 "Study on Flexible Mobile Service Steering (FMSS)", 3GPP TR 22.808 V13.0.0, September 2014.

to differentiate their services to their
   subscribers and reflect the business model and of mobile operators.
=> to differentiate their services to their
   subscribers and reflect the business model and to distinguish between themselves and other mobile operators. (?)

p.10:
   devices address use Access Point Names (APNs) to address a service =>    devices use Access Point Names (APNs) to address a service
  While a FQDN =>   While an FQDN

p.11:
   UE:  terminal type (e.g., HTC one), =>    UE:  terminal type (e.g., phone capability, OS, vendor, ...), (?) <= [I suggest to omit real product names here]
3GPP PCC (Policy
   and Charging Architecture, [TS.23.203]) 
=> 3GPP PCC (Policy
   and Charging Control Architecture, [TS.23.203])

p.14:
   Specifically, the Steering Proxy includes a TCP proxy and an ICAP
   Client
=>    Specifically, the Steering Proxy includes a TCP proxy and an ICAP (Internet Content Adaptation Protocol)
   Client [include reference?]

p.18:
   PCRF and the link would be a Gx or Diameter-based Sd interface. =>    PCRF and the link would be via a Gx or Diameter-based Sd reference point. 
[correspondingly also on p.21]

p.19:
   individual VRF implementations etc. =>    individual VRF (virtual routing and forwarding) implementations etc. [reference to add?]
      related metadata is extremely diffcult. =>       related metadata is extremely difficult.

p.21:
   methods in a service chain.  Typically this data =>    methods in a service chain.  Typically these data
   plane.  A mechanism where such metadata is carried =>    plane.  A mechanism where such metadata are carried

p.22:
   o  asynchronously from the control plain  =>   o  asynchronously from the control plane 
   o  synchrounously, piggypacked with the user IP packet =>   o  synchronously, piggypacked with the user IP packet
      *  or carried with http header enrichements =>       *  or carried with http header enrichments

 -----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Jeffrey Napper (jenapper)
Sent: Montag, 12. Januar 2015 13:12
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [sfc] I-D Action: draft-ietf-sfc-use-case-mobility-02.txt

This draft is largely wordsmithing and typos. There are a couple of new paragraphs that are available from the diff tool.

Please send comments and suggestions to the list as we believe the document is ready for last call. The document seems to be quite stable now.

Cheers,
Jeff

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Saturday, January 10, 2015 at 4:17 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [sfc] I-D Action: draft-ietf-sfc-use-case-mobility-02.txt

>Please note that it may take a couple of minutes from the time of 
>submission until the htmlized version and diff are available at 
>tools.ietf.org.
>

---

From: "Jeffrey Napper (jenapper)" <[email-masked]>
Date: Wed, 21 Jan 2015 12:57:36 +0000

Thanks for the corrections, Dirk. I have added almost all of them to the
next revision including the FMSS reference, which was a good catch. I
edited the last one on p8 differently because there was simply an
extraneous 'and' to be deleted.

Cheers,
Jeff

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Thursday, January 15, 2015 at 6:10 PM
To: Jeffrey Napper <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [sfc] I-D Action: draft-ietf-sfc-use-case-mobility-02.txt

>Dear authors,
>Thanks for the update of the mobility SFC use cases draft. IMO the
>document is quite useful for further discussion on real-life
>applicability of SFC work.
>
>Just some minor comments below (mainly nit and typo picking,
>clarification proposals, and further smithing ...)
>GTP  GPRS (General Packet Radio Service) Tunnel Protocol => GTP  GPRS
>(General Packet Radio Service) Tunnelling Protocol
>
>p.4:
>A study on typical exemplary SFC use cases and potential requirements has
>been performed by 3GPP recently [TR.22.808] in the framework of Rel. 13.
>   subscribers and reflect the business model and to distinguish between
>themselves and other mobile operators. (?)
>
>p.10:
>   devices address use Access Point Names (APNs) to address a service =>
>  devices use Access Point Names (APNs) to address a service
>   UE:  terminal type (e.g., HTC one), =>    UE:  terminal type (e.g.,
>phone capability, OS, vendor, ...), (?) <= [I suggest to omit real
>product names here]
>3GPP PCC (Policy
>   PCRF and the link would be a Gx or Diameter-based Sd interface. =>
>PCRF and the link would be via a Gx or Diameter-based Sd reference point.
>   individual VRF implementations etc. =>    individual VRF (virtual
>routing and forwarding) implementations etc. [reference to add?]
>   plane.  A mechanism where such metadata is carried =>    plane.  A
>mechanism where such metadata are carried
>
>p.22:
>   o  synchrounously, piggypacked with the user IP packet =>   o
>synchronously, piggypacked with the user IP packet

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Wed, 21 Jan 2015 17:09:27 +0000

Hi Dirk,
Many thanks for your careful reading and comments.
Walter

Gesendet mit meinem HTC

----- Reply message -----
Von: "Jeffrey Napper (jenapper)" <[email-masked]>
An: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Betreff: [sfc] I-D Action: draft-ietf-sfc-use-case-mobility-02.txt
Datum: Mi., Jan 21, 2015 13:57

Cheers,
Jeff