Subject: [sfc] WG call for adoption of draft-quinn-sfc-nsh

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 26 Feb 2015 12:47:03 +0000

Greetings WG:

The document draft-quinn-sfc-nsh-07 (https://datatracker.ietf.org/doc/draft-quinn-sfc-nsh/) has recently been reissued. The authors of draft-zhang-sfc-sch-03 (http://datatracker.ietf.org/doc/draft-zhang-sfc-sch/) have joined the NSH document so that the WG can focus on a single encapsulation document going forward. This new version of NSH includes an open items section based on discussion between co-authors and members of the list. The WG will work through this list (and any other issues that need to be added) over the next weeks. We appreciate and recognize the hard work of both the NSH and SCH authors in pushing the SFC encapsulation work forward.

With that said, the chairs are calling for WG adoption of draft-quinn-sfc-nsh-07 as a WG document. The call for adoption will run for 2 weeks ending 3/12/2015.

Please note that this is a call for adoption, and not a last call for content of the document. Adopting a WG document simply means that the WG will focus its efforts on that particular draft going forward, and use that document for resolving open issues and documenting the WG’s decisions.

Please indicate whether you support adoption for not, and if not why. Issues you have with the current document itself can also be raised, but they should be raised in the context of what should be changed in the document going forward, rather than a pre-condition for adoption.

Finally, now is also a good time to poll for knowledge of any IPR that applies to this draft, in line with the IPR disclosure obligations for WG participants (see RFCs 3979, 4879, 3669 and 5378 for more details). If you are listed as a document author please respond to this email (to the chairs) whether or not you are aware of any relevant IPR.

Jim & Thomas

---

From: <[email-masked]>
Date: Thu, 26 Feb 2015 13:00:26 +0000

Hi all,

I support the adoption of this I-D as a WG document.

I have several open issues but I'm confident those will be addressed once the document is adopted as a WG item. BTW, it would be easier to track the issues using the IETF tracker tool.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Jim Guichard (jguichar)
Envoyé : jeudi 26 février 2015 13:47
À : [email-masked]
Objet : [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Please note that this is a call for adoption, and not a last call for content of the document. Adopting a WG document simply means that the WG will focus its efforts on that particular draft going forward, and use that document for resolving open issues and documenting the WG's decisions.

Jim & Thomas

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Thu, 26 Feb 2015 13:28:17 +0000

Support

Sent from my iPhone

On Feb 26, 2015, at 7:47 AM, "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>> wrote:

Greetings WG:

Jim & Thomas
_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 26 Feb 2015 14:07:06 +0000

+1 to WG adoption.

-Tiru

From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, February 26, 2015 6:30 PM
To: Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Hi all,

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Jim Guichard (jguichar)
Envoyé : jeudi 26 février 2015 13:47
À : [email-masked]<mailto:[email-masked]>
Objet : [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Jim & Thomas

---

From: "Victor Moreno (vimoreno)" <[email-masked]>
Date: Thu, 26 Feb 2015 14:40:04 +0000

Support WG adoption.

Victor

On Feb 26, 2015, at 4:47 AM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Greetings WG:

Jim & Thomas

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 26 Feb 2015 09:44:33 -0500

Thank you Jim.
Support as a co-author.

Yours,
Joel

On 2/26/15 7:47 AM, Jim Guichard (jguichar) wrote:
> Greetings WG:
>
> The document draft-quinn-sfc-nsh-07
> (https://datatracker.ietf.org/doc/draft-quinn-sfc-nsh/) has recently
> been reissued. ...

> With that said, the chairs are calling for WG adoption of
> draft-quinn-sfc-nsh-07 as a WG document. The call for adoption will run
> for 2 weeks ending 3/12/2015.
...

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Thu, 26 Feb 2015 15:22:18 +0000

I support it as well,

On 26 Feb 2015, at 15:44 , Joel M. Halpern <[email-masked]<mailto:[email-masked]>> wrote:

Thank you Jim.
Support as a co-author.

Yours,
Joel

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Thu, 26 Feb 2015 15:50:20 +0000

Support nsh draft doc - Walter

Gesendet mit meinem HTC

----- Reply message -----
Von: "Jim Guichard (jguichar)" <[email-masked]>
An: "[email-masked]" <[email-masked]>
Betreff: [sfc] WG call for adoption of draft-quinn-sfc-nsh
Datum: Do., Feb 26, 2015 13:47

Greetings WG:

Jim & Thomas

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 26 Feb 2015 11:22:09 -0500

+1 to accept but I would recommend pruning down the contributor list on the front page to a few editors.

I do not know of any IPR.

—Tom

> On Feb 26, 2015:7:47 AM, at 7:47 AM, Jim Guichard (jguichar) <[email-masked]> wrote:
> 
> Greetings WG:
> 
> The document draft-quinn-sfc-nsh-07 (https://datatracker.ietf.org/doc/draft-quinn-sfc-nsh <https://datatracker.ietf.org/doc/draft-quinn-sfc-nsh>/) has recently been reissued. The authors of draft-zhang-sfc-sch-03 (http://datatracker.ietf.org/doc/draft-zhang-sfc-sch <http://datatracker.ietf.org/doc/draft-zhang-sfc-sch>/) have joined the NSH document so that the WG can focus on a single encapsulation document going forward. This new version of NSH includes an open items section based on discussion between co-authors and members of the list. The WG will work through this list (and any other issues that need to be added) over the next weeks. We appreciate and recognize the hard work of both the NSH and SCH authors in pushing the SFC encapsulation work forward.
> 
> [email-masked]

---

From: Henry Fourie <[email-masked]>
Date: Thu, 26 Feb 2015 17:00:40 +0000

Support as a co-author.

-          Louis

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Thursday, February 26, 2015 4:47 AM
To: [email-masked]
Subject: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Jim & Thomas

---

From: Ron Parker <[email-masked]>
Date: Thu, 26 Feb 2015 18:15:50 +0000

Also support as co-author.

From: sfc [mailto:[email-masked]] On Behalf Of Henry Fourie
Sent: Thursday, February 26, 2015 12:01 PM
To: Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Support as a co-author.

-        Louis

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Thursday, February 26, 2015 4:47 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Jim & Thomas

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 26 Feb 2015 18:32:30 +0000

I support WG adoption of this document.

Thanks,

— Carlos.

On Feb 26, 2015, at 7:47 AM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Greetings WG:

Jim & Thomas

---

From: Rajeev Manur <[email-masked]>
Date: Thu, 26 Feb 2015 18:37:08 +0000

Support as co-author.

Thanks!
--Rajeev

From: sfc [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Thursday, February 26, 2015 10:32 AM
To: Jim Guichard (jguichar)
Cc: [email-masked]
Subject: Re: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Thanks,

- Carlos.

Greetings WG:

Jim & Thomas

---

From: Dave Dolson <[email-masked]>
Date: Thu, 26 Feb 2015 18:50:45 +0000

I support adoption.

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Thursday, February 26, 2015 7:47 AM
To: [email-masked]
Subject: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Jim & Thomas

---

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Thu, 26 Feb 2015 18:56:53 +0000

Support

Andrew

Sent from my iPhone

On Feb 26, 2015:7:47 AM, at 7:47 AM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Greetings WG:

Jim & Thomas

---

From: Cathy Zhang <[email-masked]>
Date: Thu, 26 Feb 2015 19:15:01 +0000

Support as a co-author.

Cathy

Greetings WG:

Jim & Thomas

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 26 Feb 2015 19:20:43 +0000

support

From: <Dolganow>, Andrew Dolganow <[email-masked]<mailto:[email-masked]>>
Date: Thursday 26 February 2015 19:56
To: Jim Guichard <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Support

Andrew

Sent from my iPhone

Greetings WG:

Jim & Thomas

---

From: Lucy yong <[email-masked]>
Date: Thu, 26 Feb 2015 19:36:23 +0000

Support!

Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Cathy Zhang
Sent: Thursday, February 26, 2015 1:15 PM
To: Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Support as a co-author.

Cathy

Greetings WG:

Jim & Thomas

---

From: "Muley, Praveen V (Praveen)" <[email-masked]>
Date: Thu, 26 Feb 2015 20:10:09 +0000

Support.

Sent from my iPhone

Greetings WG:

Jim & Thomas

---

From: Sumandra Majee <[email-masked]>
Date: Thu, 26 Feb 2015 12:14:55 -0800

Support

On Thursday, February 26, 2015 12:10 PM, "Muley, Praveen V (Praveen)" <[email-masked]> wrote:

Support. 

Sent from my iPhone

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Thu, 26 Feb 2015 20:44:05 +0000

Yes. Support.

Regards,
Nagendra

From: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 26, 2015 at 7:47 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Jim & Thomas

---

From: Wassim Haddad <[email-masked]>
Date: Thu, 26 Feb 2015 13:03:30 -0800

Support

Regards,
Wassim H.

---

From: "Elzur, Uri" <[email-masked]>
Date: Fri, 27 Feb 2015 01:37:00 +0000

+1

Thx

Uri ("Oo-Ree")
C: 949-378-7568

From: sfc [mailto:[email-masked]] On Behalf Of Wassim Haddad
Sent: Thursday, February 26, 2015 1:04 PM
To: Jim Guichard (jguichar)
Cc: Wassim Haddad; [email-masked]
Subject: Re: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Support

Regards,
Wassim H.

Greetings WG:

Jim & Thomas

---

From: Nicolas BOUTHORS <[email-masked]>
Date: Fri, 27 Feb 2015 08:07:23 +0000

Support

Br,

Nicolas.

Greetings WG:

Jim & Thomas

This message and any attachments (the "message") are confidential, intended solely for the addressees. If you are not the intended recipient, please notify the sender immediately by e-mail and delete this message from your system. In this case, you are not authorized to use, copy this message and/or disclose the content to any other person. E-mails are susceptible to alteration. Neither Qosmos nor any of its subsidiaries or affiliates shall be liable for the message if altered, changed or falsified.

Ce message et toutes ses pi?ces jointes (ci-apr?s le "message")sont confidentiels et ?tablis ? l'intention exclusive de ses destinataires. Si vous avez re?u ce message par erreur, merci d'en informer imm?diatement son ?metteur par courrier ?lectronique et d'effacer ce message de votre syst?me. Dans cette hypoth?se, vous n'?tes pas autoris? ? utiliser, copier ce message et/ou en divulguer le contenu ? un tiers. Tout message ?lectronique est susceptible d'alt?ration. Qosmos et ses filiales d?clinent toute responsabilit? au titre de ce message s'il a ?t? alt?r?, d?form? ou falsifi?.

---

From: Georgios Karagiannis <[email-masked]>
Date: Fri, 27 Feb 2015 09:54:40 +0000

Mee too,
Support!

Regards,
Georgios

Sent: Thursday, February 26, 2015 10:04 PM

Support

Regards,
Wassim H.

Greetings WG:

Jim & Thomas

---

From: Shunsuke Homma <[email-masked]>
Date: Fri, 27 Feb 2015 20:58:04 +0900

Support!

Shunsuke

On 2015/02/26 21:47, Jim Guichard (jguichar) wrote:
> been reissued. The authors of draft-zhang-sfc-sch-03
> (http://datatracker.ietf.org/doc/draft-zhang-sfc-sch/) have joined the
> NSH document so that the WG can focus on a single encapsulation document
> going forward. This new version of NSH includes an *open items *section
> based on discussion between co-authors and members of the list. The WG
> will work through this list (and any other issues that need to be added)
> over the next weeks. We appreciate and recognize the hard work of both
> the NSH and SCH authors in pushing the SFC encapsulation work forward.
>
> Please note that this is a call for adoption, and not a last call for
> content of the document. Adopting a WG document simply means that the WG
> will focus its efforts on that particular draft going forward, and use
> that document for resolving open issues and documenting the WG’s decisions.
>
> Please indicate whether you support adoption for not, and if not why.
> Issues you have with the current document itself can also be raised, but
> they should be raised in the context of what should be changed in the
> document going forward, rather than a pre-condition for adoption.
>
> Finally, now is also a good time to poll for knowledge of any IPR that
> applies to this draft, in line with the IPR disclosure obligations for
> WG participants (see RFCs 3979, 4879, 3669 and 5378 for more details).
> If you are listed as a document author please respond to this email (to
> the chairs) whether or not you are aware of any relevant IPR.
>
> Jim & Thomas
>
>

-- 
----------------------------------
Shunsuke Homma
<[email-masked]>
TEL: +81 422 59 3486
FAX: +81 422 60 7460

NTT Network Service System Labs.
Musashino city, Tokyo, Japan
----------------------------------

---

From: "Zarny, Myo" <[email-masked]>
Date: Fri, 27 Feb 2015 09:00:19 -0500

Support as a coauthor

Myo

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: 26 February 2015 7:47 AM
To: [email-masked]
Subject: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Jim & Thomas

---

From: BARRY GREENE <[email-masked]>
Date: Sat, 28 Feb 2015 06:34:57 +0700

+1

> On Feb 27, 2015, at 3:07 PM, Nicolas BOUTHORS <[email-masked]> wrote:
> 
> Support
> 
> Br,
> 
> Nicolas.
> 
> On Feb 26, 2015, at 4:47 AM, Jim Guichard (jguichar) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Greetings WG:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sfc <https://www.ietf.org/mailman/listinfo/sfc>
> 
> Ce message et toutes ses pièces jointes (ci-après le "message")sont confidentiels et établis à l'intention exclusive de ses destinataires. Si vous avez reçu ce message par erreur, merci d’en informer immédiatement son émetteur par courrier électronique et d’effacer ce message de votre système. Dans cette hypothèse, vous n’êtes pas autorisé à utiliser, copier ce message et/ou en divulguer le contenu à un tiers. Tout message électronique est susceptible d'altération. Qosmos et ses filiales déclinent toute responsabilité au titre de ce message s'il a été altéré, déformé ou falsifié.
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sfc <https://www.ietf.org/mailman/listinfo/sfc>

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 28 Feb 2015 09:51:34 +0000

Support.

By the way, I hope the NSH could be capable of: 1) containing the service chain/path info only; 2) containing the metadata only ;3) containing both service chain/path info and the metadata. Otherwise, we may need to design a separate header for containing the metadata in the case where the service chain/path info has been embodied by other means than the NSH itself. In this way, it's aligned with the following statement in the SFC architecture draft:

"4.3.1<https://tools.ietf.org/html/draft-ietf-sfc-architecture-04#section-4.3.1>.  Transport Derived SFF

   Service function forwarding, as described above, directly depends
   upon the use of the service path information contained in the SFC
   encapsulation.  However, existing implementations may not be able to
   act on the SFC encapsulation.  These platforms may opt to use
   existing transport information if it can be arranged to provide
   explicit service path information.

   This results in the same architectural behavior and meaning for
   service function forwarding and service function paths.  It is the
   responsibility of the control components to ensure that the transport
   path executed in such a case is fully aligned with the path
   identified by the information in the service chaining encapsulation.

"

Xiaohu

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Thursday, February 26, 2015 8:47 PM
To: [email-masked]
Subject: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Greetings WG:

Jim & Thomas

---

From: "Zarny, Myo" <[email-masked]>
Date: Sat, 28 Feb 2015 09:41:38 -0500

Hi Xiaohu,

Currently, the draft certainly supports two of your three scenarios: (1) SFC path only and (3) SFC path info and metadata.

As for the scenario of carrying just the metadata, can you clarify your ask? I take that you're not mandating that the base header not contain a service path header; but rather that the NSH be used to carry just the metadata only, correct? If it's the latter, the NSH does support your scenario. Yes, the Service Path Header is a required component of the header. But you can choose an implementation method to ignore the SP header values (SPID and SPI). (Implementation methods could range from zeroing the fields out to instructing NSH-aware devices to ignore them; etc.) If that meets your expectations, then, the header supports all three scenarios.

Now, to be precise and for full disclosure, all three scenarios are supported through MD-Type 2, which the draft currently recommends as a "SHOULD" implementation [Section 3.2].

Myo

From: sfc [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: 28 February 2015 4:52 AM
To: Jim Guichard (jguichar); [email-masked]
Subject: Re: [sfc] WG call for adoption of draft-quinn-sfc-nsh

Support.

"

Xiaohu

Greetings WG:

Jim & Thomas