Subject: Re: [sfc] [sfc-dev] SFC ODL IETF-92 Hackton

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 26 Feb 2015 16:17:39 +0000

Hi Xingjun,

You must have missed Charles’s other email that stated:

“We are still in the process of updating the event information and registration pages to include SFC. If you go to register in the meantime and do not see SFC listed as a technology, you can enter “SFC” in the “Other” area”.

From: Xingjun Chu <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 26, 2015 at 11:14 AM
To: Reinaldo Penno <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc-dev] SFC ODL IETF-92 Hackton

I don’t see SFC explicitly listed on the agenda as defined in the event link.

Regards
Xingjun

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Reinaldo Penno
Sent: Tuesday, February 24, 2015 4:46 PM
To: [email-masked]<mailto:[email-masked]>; Charles Eckel (eckelcu)
Cc: [email-masked]<mailto:[email-masked]>
Subject: [sfc-dev] SFC ODL IETF-92 Hackton

Event details:

https://developer.cisco.com/site/ietf-hackathon

Link to register: https://www.ietf.org/meeting/92/hackathon-signup.html

SFC Program:

Services Function Chaining in Opendaylight (Reinaldo Penno, Jim Guichard)

SFC ODL page: https://wiki.opendaylight.org/view/Service_Function_Chaining:Main

Strongly recommend watching the webex titled "Reinaldo SFC demo” at the bottom of the page above.

·         Introduction to SFC architecture in Opendaylight

·         Architecture of SFC Agent and data plane

·         Work items will cover both control and data plane:

·         SFC Agent auto-provisioning (SF/SFF configuration-less deployments) (Python)

o    SFC Agent Yang models (Yang)

·         SFC-OVS integration. (Java)

·         SFC/NSH Traceroute (Python, Standards work)

·         SFC Classifier (Python, Linux IPtables)

·         Netconf integration (Java)

·         Review of SFC Yang models and feedback into ODL (Yang, standards)

·         Implementation of Variable Length NSH packets (MD Type 02) in the data plane (Python)

We welcome comments on the program and suggestions

Thanks,

Reinaldo

---

From: Xingjun Chu <[email-masked]>
Date: Thu, 26 Feb 2015 16:59:09 +0000

Aha, thank you!  Jim

Cheers!
Xingjun

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Thursday, February 26, 2015 11:18 AM
To: Xingjun Chu; Reinaldo Penno; [email-masked]
Cc: [email-masked]
Subject: Re: [sfc] [sfc-dev] SFC ODL IETF-92 Hackton

Hi Xingjun,

You must have missed Charles's other email that stated:

"We are still in the process of updating the event information and registration pages to include SFC. If you go to register in the meantime and do not see SFC listed as a technology, you can enter "SFC" in the "Other" area".

I don't see SFC explicitly listed on the agenda as defined in the event link.

Regards
Xingjun

Event details:

SFC Program:

Strongly recommend watching the webex titled "Reinaldo SFC demo" at the bottom of the page above.

*         Introduction to SFC architecture in Opendaylight

*         Architecture of SFC Agent and data plane

*         Work items will cover both control and data plane:

*         SFC Agent auto-provisioning (SF/SFF configuration-less deployments) (Python)

*         SFC-OVS integration. (Java)

*         SFC/NSH Traceroute (Python, Standards work)

*         SFC Classifier (Python, Linux IPtables)

*         Netconf integration (Java)

*         Review of SFC Yang models and feedback into ODL (Yang, standards)

*         Implementation of Variable Length NSH packets (MD Type 02) in the data plane (Python)

Thanks,

Reinaldo