Subject: [sfc] SFC ODL IETF-92 Hackton

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Tue, 24 Feb 2015 21:48:38 +0000

Event details:

https://developer.cisco.com/site/ietf-hackathon
Link to register: https://www.ietf.org/meeting/92/hackathon-signup.html

SFC Program:

Services Function Chaining in Opendaylight (Reinaldo Penno, Jim Guichard)

SFC ODL page: https://wiki.opendaylight.org/view/Service_Function_Chaining:Main

Strongly recommend watching the webex titled "Reinaldo SFC demo” at the bottom of the page above.

  *   Introduction to SFC architecture in Opendaylight
  *   Architecture of SFC Agent and data plane
  *   Work items will cover both control and data plane:
  *   SFC Agent auto-provisioning (SF/SFF configuration-less deployments) (Python)
     *   SFC Agent Yang models (Yang)
  *   SFC-OVS integration. (Java)
  *   SFC/NSH Traceroute (Python, Standards work)
  *   SFC Classifier (Python, Linux IPtables)
  *   Netconf integration (Java)
  *   Review of SFC Yang models and feedback into ODL (Yang, standards)
  *   Implementation of Variable Length NSH packets (MD Type 02) in the data plane (Python)

We welcome comments on the program and suggestions

Thanks,

Reinaldo

---

From: Reinaldo Penno <[email-masked]>
Date: Tue, 24 Feb 2015 13:46:24 -0800

Event details: 

SFC ODL page: 
https://wiki.opendaylight.org/view/Service_Function_Chaining:Main

Strongly recommend watching the webex titled "Reinaldo SFC demo² at the
bottom of the page above.
* Introduction to SFC architecture in Opendaylight
* Architecture of SFC Agent and data plane
* Work items will cover both control and data plane:
* SFC Agent auto-provisioning (SF/SFF configuration-less deployments)
(Python)
* Implementation of Variable Length NSH packets (MD Type 02) in the data
plane (Python)

Thanks,

Reinaldo

---

From: Xingjun Chu <[email-masked]>
Date: Thu, 26 Feb 2015 16:14:14 +0000

I don't see SFC explicitly listed on the agenda as defined in the event link.

Regards
Xingjun

From: [email-masked] [mailto:[email-masked]] On Behalf Of Reinaldo Penno
Sent: Tuesday, February 24, 2015 4:46 PM
To: [email-masked]; Charles Eckel (eckelcu)
Cc: [email-masked]
Subject: [sfc-dev] SFC ODL IETF-92 Hackton

Event details:

SFC Program:

Strongly recommend watching the webex titled "Reinaldo SFC demo" at the bottom of the page above.

o    SFC Agent Yang models (Yang)

Thanks,

Reinaldo