Subject: Re: [sfc] Mobile use cases draft-ietf-sfc-use-case-mobility-03

From: Dave Dolson <[email-masked]>
Date: Tue, 3 Feb 2015 16:39:12 +0000

Would one of the authors (or anyone else) be able to answer my question?

-Dave

-----Original Message-----
From: Dave Dolson 
Sent: Monday, January 26, 2015 12:17 PM
To: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Mobile use cases draft-ietf-sfc-use-case-mobility-03

Authors of draft-ietf-sfc-use-case-mobility,

You make explicit reference (in section 2.2) to the care to be taken 
with bidirectional flows, which I agree with.

So, referring to your figure 5:

             +-------------------------+
             |          PCRF           |
             +----+--------------+-----+
                  |              |
                Gx-IF          Sd-IF
                  |              |
             +----+-----+   +----+-----+
   ==========O  [PCEF]  |   |          O--------[SFC 1] ---- [Appl. 1]
             |          |   |          O--------[SFC 2] ---- [Appl. 2]
   ==========O   P-GW   O---O  [TDF]   O--------[SFC 3] ---- [Appl. 3]
             |          |   |          O--------[SFC 4] ---- [Appl. 4]
   ==========O          |   |          O--------[SFC n] ---- [Appl. n]
             +----------+   +----------+
                        *              *
   3GPP Bearer         SGi            SGi

It isn't clear what device is selecting the chains for down-link traffic.

Given that the TDF is making application-specific decisions, how would 
one ensure the down-link traffic is classified to the same service 
functions as the up-link traffic, something very critical for many of 
the use cases?

  * a TDF can classify traffic using a wide variety of methods, 
    including signature-matching that uses fields only available at 
    the start of a flow, likely only appearing in one direction;
    (classification based solely on port number is rather weak). 
    So in the general case, decisions are made for TCP connections, 
    not for packets.

I propose that the picture is more like the following, with the TDF 
book-ending the service chains to ensure consistent classification of 
both up-link and down-link traffic for a given transport connection.

             +-------------------------+
             |          PCRF           |
             +----+--------------+-----+
                  |              |
                Gx-IF          Sd-IF
                  |              |
                  |         +----+------------------------------------+
                  |         |    [TDF]                                |
                  |         |       +----------------------------+    |
             +----+-----+   |       |                            |    |
   ==========O  [PCEF]  |   |       O---[SFC 1] ---- [Appl. 1]---O    |
             |          |   |       O---[SFC 2] ---- [Appl. 2]---O    |---
   ==========O   P-GW   O---O       O---[SFC 3] ---- [Appl. 3]---O    |
             |          |   |       O---[SFC 4] ---- [Appl. 4]---O    |
   ==========O          |   |       O---[SFC n] ---- [Appl. n]---O    |
             +----------+   +-------+                            +----+
                        *                                               *
   3GPP Bearer         SGi                                              SGi

Perhaps this is what you intended. Is this what you had in mind?

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Wed, 4 Feb 2015 21:16:21 +0000

Hi Dave,

Thanks for your comment. You are right. We have to explain the associated flows in some more detail. Our figure 5 indeed is very abstract just showing the connectivity of the functions. In our drawing 5 our [Appls]  are located somewhere in the internet or in a carrier's datacenter. Idea was to show that different Applications may use different SFCs and a TDF can make this more granular. Means the [Appls] itself are not part of a SFC (For sure, a SFC may also contain Value Added Services just considered to be a SF).

We currently think about how to draw/describe the picture more precisely. 

On logical level we could say the SFC (set of SFs) is sandwiched by two logical classifier functions:

                                    SFC-up
Up------->class-up -----           -----class-down<-----down
                                 SFC-down

Where class-up and class-down indeed may be components of one and the same classifier. Sometimes you need these two, sometimes one is sufficient. Sometimes we have a symmetric (bi-directional) SFC, in some cases the SFC may be unidirectional.

Further, TDF could reside within or outside a P-GW. 

Unfortunately we use different fonts in our email systems. Therefore I had to reconstruct your figure. Hope this  figure reflects somehow your original drawing (when using the appropriate font). But I do not fully understand the details of your figure:

            		 +------------------------------------+
           		 |          PCRF                           |
       		 +----+------------------------+-----+
                                  |                               |
                                Gx-IF                       Sd-IF
                                  |                              |
                                  |           +--------------+------------------------------+
                                  |           |               [TDF]                                 |
                                  |           |        +--------------------------------+     |
                        +----+-----+      |       |                                         |     |
   ==========O  [PCEF]  |     |       O---[SFC 1] ---- [Appl. 1]---O     |
                       |               |      |       O---[SFC 2] ---- [Appl. 2]---O     |--------
   ==========O   P-GW   O---O      O---[SFC 3] ---- [Appl. 3]---O     |
                       |               |      |       O---[SFC 4] ---- [Appl. 4]---O     |
   ==========O              |      |       O---[SFC n] ---- [Appl. n]---O     |
                       +-----------+       +-----+                                        +-----+
                                       *                                               		*
   3GPP Bearer              SGi                                                              SGi

I rather had drawn the figure somehow the following way arguing the TDF classifier is the "horse shoe" around the SFCs. Maybe you had the same in mind.

            		 +------------------------------------+
           		 |          PCRF                           |
       		 +----+------------------------+-----+
                                  |                               |
                                Gx-IF                       Sd-IF
                                  |                              |
                                  |           +--------------+------------------------------+
                                  |           |               [TDF]                                 |
                                  |           |        +--------------------------------+     |
                        +----+-----+      |       |                                         |     |
   ==========O  [PCEF]  |     |       O---[SFC 1] -------------------O     |		---- [Appl. 1]
                       |               |      |       O---[SFC 2] ------------------O     |--------		---- [Appl. 2]
   ==========O   P-GW   O---O      O---[SFC 3] ------------------O     |		---- [Appl. 3]
                       |               |      |       O---[SFC 4] ------------------O     |		---- [Appl. 4]
   ==========O              |      |       O---[SFC n] ---- -------------O     |		---- [Appl. n]
                       +-----------+       +-----+                                        +-----+
                                       *                                               		*
   3GPP Bearer              SGi                                                              SGi

What do you think?

Best regards,
Walter

-----Ursprüngliche Nachricht-----
Von: Dave Dolson [mailto:[email-masked]] 
Gesendet: Montag, 26. Januar 2015 18:17
An: [email-masked]'; Haeffner, Walter, Vodafone DE; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Betreff: Mobile use cases draft-ietf-sfc-use-case-mobility-03

You make explicit reference (in section 2.2) to the care to be taken with bidirectional flows, which I agree with.

Given that the TDF is making application-specific decisions, how would one ensure the down-link traffic is classified to the same service functions as the up-link traffic, something very critical for many of the use cases?

I propose that the picture is more like the following, with the TDF book-ending the service chains to ensure consistent classification of both up-link and down-link traffic for a given transport connection.

David Dolson

---

From: Dave Dolson <[email-masked]>
Date: Thu, 5 Feb 2015 03:24:25 +0000

Walter,
Thanks for the response. Yes, there are font problems. I think you'll find the email archives show my email formatted properly: http://www.ietf.org/mail-archive/web/sfc/current/msg03012.html

Unfortunately your drawing didn't come through properly at my end, but I think "horseshoe" describes my intention. 

I am primarily concerned with the special case of the bidirectional service chains, such as when service functions require both directions of a TCP flow.

Indeed, class-up and class-down should be within the same device when local decisions are made flow-by-flow.

I think it is fairly important to point this out in your document, since it changes how one thinks about the network architecture. In particular, the rules deployed to the TDF from the PCRF need to act on both up-link and down-link traffic.

-Dave

________________________________________
From: Haeffner, Walter, Vodafone DE [[email-masked]]
Sent: Wednesday, February 04, 2015 4:16 PM
To: Dave Dolson; [email-masked]'; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: AW: Mobile use cases draft-ietf-sfc-use-case-mobility-03

Hi Dave,

                                    SFC-up

What do you think?

Best regards,
Walter

-----Ursprüngliche Nachricht-----
Von: Dave Dolson [mailto:[email-masked]]
Gesendet: Montag, 26. Januar 2015 18:17
An: [email-masked]'; Haeffner, Walter, Vodafone DE; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Betreff: Mobile use cases draft-ietf-sfc-use-case-mobility-03

David Dolson