Subject: [sfc] FW: New Version Notification for draft-dolson-sfc-hierarchical-00.txt

From: Dave Dolson <[email-masked]>
Date: Mon, 25 May 2015 15:20:14 +0000

Greetings,

After presenting this concept of Hierarchical Service Chaining at IETF92 in Dallas,
we were encouraged to dedicate a draft to the concept. We have now done so.

These links are active now:

URL:            https://www.ietf.org/internet-drafts/draft-dolson-sfc-hierarchical-00.txt 
Status:         https://datatracker.ietf.org/doc/draft-dolson-sfc-hierarchical/ 
Htmlized:       https://tools.ietf.org/html/draft-dolson-sfc-hierarchical-00 

We welcome your feedback.

David Dolson
Senior Software Architect, Sandvine Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, May 25, 2015 11:09 AM
To: Shunsuke Homma; Diego R. Lopez; Dave Dolson; Diego Lopez; Dave Dolson; Shunsuke Homma
Subject: New Version Notification for draft-dolson-sfc-hierarchical-00.txt

A new version of I-D, draft-dolson-sfc-hierarchical-00.txt
has been successfully submitted by David Dolson and posted to the
IETF repository.

Name:		draft-dolson-sfc-hierarchical
Revision:	00
Title:		Hierarchical Service Chaining
Document date:	2015-05-25
Group:		Individual Submission
Pages:		11
URL:            https://www.ietf.org/internet-drafts/draft-dolson-sfc-hierarchical-00.txt
Status:         https://datatracker.ietf.org/doc/draft-dolson-sfc-hierarchical/
Htmlized:       https://tools.ietf.org/html/draft-dolson-sfc-hierarchical-00	

Abstract:
   This document describes a network architecture for deploying service
   function chaining with multiple levels of administration within an
   organization.

   The multiple levels of administration allow operators to
   compartmentalize a large network into multiple domains of
   responsibility, with each domain being independently managed and
   consequently easier to reason about.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Ron Parker <[email-masked]>
Date: Tue, 26 May 2015 13:23:40 +0000

Hi, Dave.

I'm very supportive of the hierarchical approach you describe in this draft.

One comment regarding the flow-aware domain gateway.   There are limitations to what is allowed within the the sub-domain under this approach.   In particular, 5-tuple modification such as would happen with NAT is disallowed.   

Also, certain higher order service functions, such as those that terminate HTTP may launch separate "sympathetic" flows -- on behalf of the original flow but with a unique 5-tuple.   The domain gateway would see "returning" packets for which it has no flow knowledge.   Treatment of "unrecognized" flows seen from the subdomain should be covered in the draft.

This HTTP termination also brings up another use case which I think is a powerful but orthogonal application of hierarchical SFC that you may wish to consider.   If you were to couple a domain gateway, as you've described it, with an HTTP terminating service function, then the subdomain could operate at the transaction level (i.e., sub-flow).    For the very same HTTP-over-TCP connection, one GET could visit a certain sequence of service functions whereas the next (possibly pipelined) GET could visit a different sequence of service functions.   The domain gateway/HTTP terminator would not only restore the higher domain SFC context, but reinsert the packets into the appropriate side of the split-TCP connection that it manages.

   Ron

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Dave Dolson
Sent: Monday, May 25, 2015 11:20 AM
To: [email-masked]
Subject: [sfc] FW: New Version Notification for draft-dolson-sfc-hierarchical-00.txt

Greetings,

After presenting this concept of Hierarchical Service Chaining at IETF92 in Dallas, we were encouraged to dedicate a draft to the concept. We have now done so.

David Dolson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 25, 2015 11:09 AM
To: Shunsuke Homma; Diego R. Lopez; Dave Dolson; Diego Lopez; Dave Dolson; Shunsuke Homma
Subject: New Version Notification for draft-dolson-sfc-hierarchical-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc

---

From: Dave Dolson <[email-masked]>
Date: Tue, 26 May 2015 18:35:06 +0000

Ron,
Thank you for taking the time to read it. You make some very good points.

I will add your points about the limitations of the stateful approach to section 3.1.1.

            State cannot be created by packets arriving from the lower-level 
            chain; when state cannot be found for such packets, they MUST be 
            dropped.

            This stateful approach is limited to use with lower-level service 
            functions that retain the 5-tuple of the packet. This approach
            cannot be used with lower-level service functions that modify the
            5-tuple (e.g., as done by a NAT) or otherwise create packets for new
            5-tuples other than those received (e.g., as an HTTP cache might do
            to retrieve content on behalf of the original flow). In both cases, 
            the fundamental problem is the inability to forward packets when 
            state cannot be found for the packet 5-tuples.

I'm not inclined to incorporate the HTTP gateway idea at this time, since I think it requires the gateway to become a TCP endpoint, vs. just decapsulating/encapsulating/forwarding packets.

-Dave

-----Original Message-----
From: Ron Parker [mailto:[email-masked]] 
Sent: Tuesday, May 26, 2015 9:24 AM
To: Dave Dolson; [email-masked]
Subject: RE: [sfc] FW: New Version Notification for draft-dolson-sfc-hierarchical-00.txt

Hi, Dave.

   Ron

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Dave Dolson
Sent: Monday, May 25, 2015 11:20 AM
To: [email-masked]
Subject: [sfc] FW: New Version Notification for draft-dolson-sfc-hierarchical-00.txt

Greetings,

David Dolson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 25, 2015 11:09 AM
To: Shunsuke Homma; Diego R. Lopez; Dave Dolson; Diego Lopez; Dave Dolson; Shunsuke Homma
Subject: New Version Notification for draft-dolson-sfc-hierarchical-00.txt

Abstract:

The IETF Secretariat