Subject: [sfc] Subscriber & Host Identification Considerations (was RE: Draft minutes for the SFC Meeting in Yokohama)

From: <[email-masked]>
Date: Thu, 26 Nov 2015 07:26:06 +0000

Hi Joel, all,

Some comments about this part of the minutes. 
Please see inline.

Cheers,
Med

> -----Message d'origine-----
> De : sfc [mailto:[email-masked]] De la part de Thomas Narten
> Envoyé : mercredi 25 novembre 2015 21:39
> À : [email-masked]
> Objet : [sfc] Draft minutes for the SFC Meeting in Yokohama
> 
> Below are the draft minutes for the Yokohama SFC meeting. Please send
> minor corrections to me directly, larger corrections should go to the
> list.
> 
> >         - SFC: Subscriber & Host Identification Considerations (TBD) -
> [10 minutes]
> >                - https://datatracker.ietf.org/doc/draft-sarikaya-sfc-
> hostid-serviceheader/
> 
> Presented by Behcet Sarikaya
> 
> Joel: on IMEI or subscriber ID, both arch and security draft indicate
> we should obscure that. 

[Med] draft-sarikaya-* inherits the security considerations from the arch RFC and CP draft. Furthermore, it includes a dedicated discussion about Privacy considerations (https://tools.ietf.org/html/draft-sarikaya-sfc-hostid-serviceheader-00#section-7). BTW, the draft does not recommend what information to enclose in the object as this is deployment-specific.  

Also it is a large thing to pass around. In
> security we said indirect IDs should be used. Also, we do have a draft
> for a list of useful TLVs, which has a subscriber ID. As a personal
> point of view, I'd rather see one draft of TLVs. WG also has a draft
> with proposed TLV for MD Type=2, pls join.

[Med] I guess you were referring to draft-quinn-sfc-nsh-tlv. When writing draft-sarikaya-* back in September, draft-quinn wasn't yet there. That's said, I'm OK with merging with draf-quinn.  

> 
> Behcet: open to merging. Problem with merging drafts is loss of
> rationale and use case.
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 26 Nov 2015 10:27:35 -0500

Thank you.  My concern about the IMSI / IMEI was to make sure that we 
kept to the agreement we had reached with the security folks on an 
indirect reference.  It sounds like you intended that, which means we 
are in agreement.

It seems to me  that it will be helpful to the WG to have a single 
document creating the initial metadata TLV type registry.

Yours,
Joel