Subject: [sfc] draft-ietf-sfc-nsf-01: It makes more sense to state "MD-type = 0x2" (zero or more Variable) as "MUST" and MD-type=0x1" as " SHOULD"

From: Linda Dunbar <[email-masked]>
Date: Wed, 18 Nov 2015 23:42:19 +0000

Paul and Uri,

The Section 3.2 of  draft-ietf-sfc-nsf-01 says:

As both MD-type 1 and MD-type 2 are specified by the draft, a more reasonable approach is having the minimum common part (i.e. the first 8 bytes) as the MUST. As the MD-TYPE 2 allows minimum 0 context header (or 16 bytes context header), the MD-TYPE 2 should be a MUST support. And MD-TYPE 1 is a "SHOULD" support.

Let's face it, the majority of SFC deployment probably won't need the all 16 bytes "context header" (which has higher chance of packet fragmentation).

Linda

---

From: <[email-masked]>
Date: Thu, 19 Nov 2015 06:25:17 +0000

Hi Linda, all,

Thank you for raising this point.

I agree with you "MD-type = 0x2" to be "MUST".

As for the MD-type==01, we have an issue related to this point that is on the tracker since 7 months...: http://trac.tools.ietf.org/wg/sfc/trac/ticket/2. I'm reproducing it here, fwiw in the hope to have some discussion about this point.

=======================
What is the rationale for defining two MD Types? Why MD Type#1 is mandatory to support? Wouldn't the format in Section 3.5 enough for the SFC use cases?
What is the rationale for defining these mandatory contexts headers? What is the motivation for defining mandatory context header?

The current text does not explain those aspects.

For the sake of interoperability (mainly to avoid multiple implementations with distinct behaviors) and given no technical motivation is provided (e.g. why MD-type 1 is mandatory why not the other way around, etc. ), one header format should be specified.

My personal point of view is that we need to choose. I'm personally for a minimalist header. Leaving both induces more complexity.

I suggest to remove the "MD type" field and MD-type 1 from the specification.

Moreover, I don't understand from the draft what is the rationale for classifying the context into these four categories. What is meant by "platform-specific metadata" or "service platform specific"?

    0 1 2 3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    | Network Platform Context |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    | Network Shared Context |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    | Service Platform Context |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    | Service Shared Context |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
==================

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Linda Dunbar
Envoyé : jeudi 19 novembre 2015 00:42
À : [email-masked]; Paul Quinn (paulq); Elzur, Uri
Objet : [sfc] draft-ietf-sfc-nsf-01: It makes more sense to state "MD-type = 0x2" (zero or more Variable) as "MUST" and MD-type=0x1" as " SHOULD"

Paul and Uri,

Linda