Subject: Re: [sfc] #14 (control-plane): Taeho's Comments

From: <[email-masked]>
Date: Tue, 17 Nov 2015 12:58:02 +0000

Hi Taeho,

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : 강태호(SDN Project) [mailto:[email-masked]]
> Envoyé : dimanche 4 octobre 2015 04:53
> À : sfc issue tracker; [email-masked];
> BOUCADAIR Mohamed IMT/OLN
> Cc : [email-masked]
> Objet : RE: [sfc] #14 (control-plane): Taeho's Comments
> 
> Hi,
> Sorry for late reaction.
> 
> Resiliency and load balancing might also include additional aspects like
> below:
> In section '4.11.1. Service Function Path Adjustment',

[Med] I guess you are referring to Section 4.10.1.

> SFP failover and SF/SFC load balancing are discussed.
> 
> In SFP failover,
> during the process of replacing failed SF instance with another instance,
> characteristics of SF(e.g. whether it is mandatory or optional SF) could
> be considered.
> And if it is mandatory, traffic should not bypass the SF but be forwarded
> to backup SF of same kind, etc.
> 

[Med] I'm not sure what is meant by "mandatory" or "optional" SF, but I guess I understood the point beneath your comment. Please let me know if this proposed change addresses your concern: 

OLD:
   SFP fail-over:   re-construct a SFP with replacing the failed SF
      instance with another instance of the same SF.

NEW:
   SFP fail-over:   re-construct a SFP with replacing the failed SF
      instance with another instance of the same SF or withdraw the
      failed SF from being invoked.  Note that withdrawing an SF may be
      envisaged if the resulting connectivity service is not broken
      (that is, packets bound to the updated SFP can be successfully
      delivered to their ultimate destinations).  Rerouting the traffic
      to another SF instance or withdrawing the failed SF is deployment-
      specific.

> In SF/SFC load balancing,
> mandatory/optional could also be considered in workload distribution.
> mandatory SF can be attached to multi SFF considering SFF
> characteristics(e.g. higher BW, memory, port number, and even NIC
> controller allocation).
> so that it is connected to SFF with more high availability.

[Med] Yes, but wow SFs are attached to SFFs is really deployment-specific.  

> Policy-based load balancing and resiliency can be supported by providing
> multiple instances of mandatory SF(Thanks to Ron's comment).

[Med] What about this change: 

OLD:
   SF/SFC Load balancing:   re-construct SFPs to distribute the workload
      among various SF instances.

NEW:
   SF/SFC Load balancing:   re-construct SFPs to distribute the workload
      among various SF instances.  Particularly, load distribution
      policies taken into account by the Control Element to re-compute an
      SFP or be provisioned as attributes to SFPs that will be installed
      using the control interfaces.

> 
> Best Regards,
> Taeho
> 
> 
> -----Original Message-----
> From: sfc [mailto:[email-masked]] On Behalf Of sfc issue tracker
> Sent: Wednesday, September 16, 2015 10:33 PM
> To: [email-masked];
> [email-masked]
> Cc: [email-masked]
> Subject: [sfc] #14 (control-plane): Taeho's Comments
> 
> #14: Taeho's Comments
> 
>  IMHO, for SFC resiliency, the aspect of high availability of SF/SFF
> should  be emphasized, including failover of SF.
>  Some attributes of SFF(e.g. high capacity) and SF(mandatory/optional)
> could be considered  for dynamic path selection and connectivity of SFs.
>  (http://datatracker.ietf.org/doc/draft-kang-sfc-dynamic-path-selection/)
>  Dynamic path selection of multiple instances of SF can be used for
> policy-  based load balancing as well.
> 
>  Draft-ww-sfc-control-plane-06 treats resiliency and load balancing,  and
> I think these parts could be further extended with support of WG.
> 
>  Best Regards,
>  Taeho
> 
> --
> -------------------------------------+----------------------------------
> -------------------------------------+---
>  Reporter:                           |      Owner:  draft-ietf-sfc-
> control-
>   [email-masked]       |  [email-masked]
>      Type:  enhancement              |     Status:  new
>  Priority:  minor                    |  Milestone:
> Component:  control-plane            |    Version:
>  Severity:  -                        |   Keywords:
> -------------------------------------+----------------------------------
> -------------------------------------+---
> 
> Ticket URL: <http://trac.tools.ietf.org/wg/sfc/trac/ticket/14>
> sfc <http://tools.ietf.org/sfc/>
> 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
> 
> 
> 이 메일은 지정된 수취인만을 위해 작성되었으며, 중요한 정보나 저작권을 포함하고 있을 수 있습니다. 어떠한 권한 없이, 본 문서에
> 포함된 정보의 전부 또는 일부를 무단으로 제3자에게 공개, 배포, 복사 또는 사용하는 것을 엄격히 금지합니다. 만약, 본 메일이 잘못
> 전송된 경우, 발신인 또는 당사에 알려주시고, 본 메일을 즉시 삭제하여 주시기 바랍니다.
> This E-mail may contain confidential information and/or copyright
> material. This email is intended for the use of the addressee only. If you
> receive this email by mistake, please either delete it without
> reproducing, distributing or retaining copies thereof or notify the sender
> immediately.

---

From: "sfc issue tracker" <[email-masked]>
Date: Wed, 25 Nov 2015 10:25:04 -0000

#14: Taeho's Comments

Comment (by [email-masked]):

 The following changes are made in -01:

 OLD:

 OLD:

 NEW:
    SF/SFP Load balancing:   re-construct SFPs to distribute the workload
       among various SF instances.  Particularly, load distribution
       policies can be taken into account by the Control Element to re-
       compute an SFP or be provisioned as attributes to SFPs that will
       be installed using the control interfaces.

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |       Owner:  draft-ietf-sfc-
  [email-masked]       |  [email-masked]
     Type:  enhancement              |      Status:  new
 Priority:  minor                    |   Milestone:
Component:  control-plane            |     Version:
 Severity:  -                        |  Resolution:
 Keywords:                           |
-------------------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/sfc/trac/ticket/14#comment:1>
sfc <http://tools.ietf.org/sfc/>