Subject: [sfc] 转发: New Version Notification for draft-xia-sfc-yang-oam-04.txt

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 26 Nov 2015 08:12:19 +0000

Hi all,
We update a new -04 version of this draft. Until now, this draft is focused on proposing the SFC specific OAM YANG model by inheriting and extending the existing work of SFC YANG model and LIME OAM YANG model. So, this draft will keep on being synchronized with the latest update of the related work of LIME and SFC YANG models. Meanwhile, the sfc oam framework and specific functions are also very important to be considered.
Your review and comments on this draft are greatly appreciated!

B.R.
Frank

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2015年11月26日 15:25
收件人: Xialiang (Frank); Mohamed Boucadair; Deepak Kumar; Qin Wu; wangzitao
主题: New Version Notification for draft-xia-sfc-yang-oam-04.txt

A new version of I-D, draft-xia-sfc-yang-oam-04.txt has been successfully submitted by Liang Xia and posted to the IETF repository.

Name:		draft-xia-sfc-yang-oam
Revision:	04
Title:		YANG Data Model for SFC Operations, Administration, and Maintenance (OAM)
Document date:	2015-11-25
Group:		Individual Submission
Pages:		21
URL:            https://www.ietf.org/internet-drafts/draft-xia-sfc-yang-oam-04.txt
Status:         https://datatracker.ietf.org/doc/draft-xia-sfc-yang-oam/
Htmlized:       https://tools.ietf.org/html/draft-xia-sfc-yang-oam-04
Diff:           https://www.ietf.org/rfcdiff?url2=draft-xia-sfc-yang-oam-04

Abstract:
   This document defines YANG data model for Service Function Chaining
   (SFC Operations, Administration, and Maintenance (OAM).  It extends
   from the basic YANG data model for Layer independent OAM Management
   defined in [I-D.ietf-lime-yang-oam-model] with SFC technology
   specifics.  It includes SFC OAM related configuration, state, and RPC
   information data.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 28 Nov 2015 16:38:29 +0000

Dear All,
this work underlines, in my opinion, one fundamental question that LIME WG been discussing for quite some time. Is data model of the particular OAM or  for that OAM? If the latter, then we will be developing OAM protocols to much whatever data model been created. Does that sound right? I think that we first build up OAM tool box and then describe its data model with YANG. If that’s the other way around, we may end up with cart before the horse.

                Regards,
                                Greg

From: Lime [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Saturday, November 28, 2015 6:50 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Lime] Fwd: [sfc] New Version Notification for draft-xia-sfc-yang-oam-04.txt

FYI.

Begin forwarded message:

From: "Xialiang (Frank)" <[email-masked]<mailto:[email-masked]>>
Date: November 26, 2015 at 3:12:19 AM EST
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] 转发: New Version Notification for draft-xia-sfc-yang-oam-04.txt

Hi all,

B.R.
Frank

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2015年11月26日 15:25
收件人: Xialiang (Frank); Mohamed Boucadair; Deepak Kumar; Qin Wu; wangzitao
主题: New Version Notification for draft-xia-sfc-yang-oam-04.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 28 Nov 2015 16:39:29 +0000

+yang-coord

From: Gregory Mirsky
Sent: Saturday, November 28, 2015 8:38 AM
To: 'Carlos Pignataro (cpignata)'; [email-masked]; [email-masked]'; Alia Atlas ([email-masked])
Cc: [email-masked]
Subject: RE: [Lime] Fwd: [sfc] New Version Notification for draft-xia-sfc-yang-oam-04.txt

Dear All,

                Regards,
                                Greg

From: Lime [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Saturday, November 28, 2015 6:50 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Lime] Fwd: [sfc] New Version Notification for draft-xia-sfc-yang-oam-04.txt

FYI.

Begin forwarded message:

Hi all,

B.R.
Frank

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2015年11月26日 15:25
收件人: Xialiang (Frank); Mohamed Boucadair; Deepak Kumar; Qin Wu; wangzitao
主题: New Version Notification for draft-xia-sfc-yang-oam-04.txt

Abstract:

The IETF Secretariat

---

From: Tom Taylor <[email-masked]>
Date: Sat, 28 Nov 2015 15:22:51 -0500

The charter as I understand it says that LIME shapes the tool 
development, which is the other way around from what you propose.

Tom Taylor

> Your review and comments on this draft are greatly appreciated!
...

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 29 Nov 2015 01:50:28 +0000

Hi Tom,
"guidance" is neither defining OAM protocols, nor forcing arbitrary model onto ones that already had been developed at IETF WGs (in general I compare creation of YANG data model to writing MIB - ones protocol or service are stable, we start and do it fast). That's my interpretation of LIME WG charter and, AFAIK, being stressed by our AD and chairs. But I may be wrong. Let's listen to what others would like to add to the discussion.

	Regards,
		Greg

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]] 
Sent: Saturday, November 28, 2015 12:23 PM
To: Gregory Mirsky; Carlos Pignataro (cpignata); [email-masked]; [email-masked]; Alia Atlas ([email-masked])
Cc: [email-masked]
Subject: Re: [sfc] [Lime] Fwd: New Version Notification for draft-xia-sfc-yang-oam-04.txt

The charter as I understand it says that LIME shapes the tool development, which is the other way around from what you propose.

Tom Taylor

On 28/11/2015 11:38 AM, Gregory Mirsky wrote:
> From: "Xialiang (Frank)" 
> <[email-masked]<mailto:[email-masked]>>
...

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 1 Dec 2015 00:50:17 +0000

Greg,

Given the right abstraction, the cart and the horse can go in parallel.

The existence of a YANG model, if well designed, should not constrained the potential future development of a new protocol (it might modify/augment the model, or not). Conversely, a (potential) design of a new protocol should not stop the development of the data model.

Thanks,

— Carlos.

> On Nov 28, 2015, at 11:39 AM, Gregory Mirsky <[email-masked]> wrote:
> 
> +yang-coord
> 
> From: Gregory Mirsky
> To: 'Carlos Pignataro (cpignata)'; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>'; Alia Atlas ([email-masked] <mailto:[email-masked]>)
> Cc: [email-masked] <mailto:[email-masked]>
> From: Lime [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Carlos Pignataro (cpignata)
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>
> From: "Xialiang (Frank)" <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> 发件人: [email-masked] <mailto:[email-masked]> [mailto:[email-masked] <mailto:[email-masked]>]
> 发送时间: 2015年11月26日 15:25
> URL:            https://www.ietf.org/internet-drafts/draft-xia-sfc-yang-oam-04.txt <https://www.ietf.org/internet-drafts/draft-xia-sfc-yang-oam-04.txt>
> Status:         https://datatracker.ietf.org/doc/draft-xia-sfc-yang-oam/ <https://datatracker.ietf.org/doc/draft-xia-sfc-yang-oam/>
> Htmlized:       https://tools.ietf.org/html/draft-xia-sfc-yang-oam-04 <https://tools.ietf.org/html/draft-xia-sfc-yang-oam-04>
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-xia-sfc-yang-oam-04 <https://www.ietf.org/rfcdiff?url2=draft-xia-sfc-yang-oam-04>
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sfc <https://www.ietf.org/mailman/listinfo/sfc>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 1 Dec 2015 00:59:09 +0000

Greg,

“Forcing” seems like hyperbole. (force /fôrs/verb 2. make (someone) do something against their will.)

“Arbitrary” seems like fallacy, (ar·bi·trar·y, adjective: based on random choice or personal whim, rather than any reason or system)

A well designed data model can most certainly guide (guide /ɡīd/ 1. show or indicate the way to (someone). 2. direct or have an influence on the course of action of (someone or something)) “other IETF working groups developing new OAM protocols or modifying existing OAM protocols, at any layer and for any technology” (as per charter).

And as per charter, “YANG model(s) specified in this working group must be usable and extensible by the existing OAM technologies”

Works both ways.

My personal opinion wearing no hats.

Thanks,

— Carlos.

> On Nov 28, 2015, at 8:50 PM, Gregory Mirsky <[email-masked]> wrote:
> 
> Hi Tom,

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 1 Dec 2015 01:45:29 +0000

Hi Carlos,
many thanks ☺.

                Regards,
                                Greg

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Monday, November 30, 2015 4:59 PM
To: Gregory Mirsky
Cc: Tom Taylor; [email-masked]; [email-masked]; Alia Atlas; [email-masked]
Subject: Re: [sfc] [Lime] Fwd: New Version Notification for draft-xia-sfc-yang-oam-04.txt

Greg,

“Arbitrary” seems like fallacy, (ar·bi·trar·y, adjective:
based on random choice or personal whim, rather than any reason or system
)

Works both ways.

Thanks,

— Carlos.

On Nov 28, 2015, at 8:50 PM, Gregory Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tom,

            Regards,
                        Greg

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]]
Sent: Saturday, November 28, 2015 12:23 PM
To: Gregory Mirsky; Carlos Pignataro (cpignata); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Alia Atlas ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] [Lime] Fwd: New Version Notification for draft-xia-sfc-yang-oam-04.txt

Tom Taylor

Dear All,

                Regards,
                                Greg

From: Lime [mailto:[email-masked]] On Behalf Of Carlos
Pignataro (cpignata)
Sent: Saturday, November 28, 2015 6:50 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Lime] Fwd: [sfc] New Version Notification for
draft-xia-sfc-yang-oam-04.txt

FYI.

Begin forwarded message:

From: "Xialiang (Frank)"
<[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>
Date: November 26, 2015 at 3:12:19 AM EST
To: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>
Subject: [sfc] 转发: New Version Notification for
draft-xia-sfc-yang-oam-04.txt

Hi all,