Subject: Re: [sfc] [Technical Errata Reported] RFC7665 (4528)

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 11 Nov 2015 00:32:38 +0000

Hi,

I believe this erratum is correct and should be Verified.

I tracked it down — this was introduced in revision -10 of the sfc-architecture document, while working on resolving one Security AD’s DISCUSS.

In particular, you can see the text presented as a proposal in Prague (https://www.ietf.org/proceedings/93/slides/slides-93-sfc-6.pdf <https://www.ietf.org/proceedings/93/slides/slides-93-sfc-6.pdf>, see Slide 11). We missed this one as a WG.

Thanks,

— Carlos.

> On Nov 9, 2015, at 8:38 PM, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC7665,
> "Service Function Chaining (SFC) Architecture".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=7665&eid=4528
> 
> --------------------------------------
> Type: Technical
> Reported by: Igor Duarte Cardoso <[email-masked]>
> 
> Section: 6
> 
> Original Text
> -------------
> packets at certain points on certain service chains, the control
> mechanism MUST verify that appropriate protective treatment of
> NSH information is available from the point where the
> information is added to the point where it will be removed.  If
> such mechanisms are unavailable, error notifications SHOULD be
> generated.
> 
> Corrected Text
> --------------
> packets at certain points on certain service chains, the control
> mechanism MUST verify that appropriate protective treatment of
> SFC encapsulation information is available from the point where the
> information is added to the point where it will be removed.  If
> such mechanisms are unavailable, error notifications SHOULD be
> generated.
> 
> Notes
> -----
> NSH has not been introduced earlier in the document. Moreover, the reference to NSH itself seems to have been a tiny mistake that slipped.
> The corrected text replaces NSH with SFC encapsulation.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
> 
> --------------------------------------
> RFC7665 (draft-ietf-sfc-architecture-11)
> --------------------------------------
> Title               : Service Function Chaining (SFC) Architecture
> Publication Date    : October 2015
> Author(s)           : J. Halpern, Ed., C. Pignataro, Ed.
> Category            : INFORMATIONAL
> Source              : Service Function Chaining
> Area                : Routing
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 10 Nov 2015 19:38:01 -0500

Agreed.  (And thanks for tracking down the details Carlos.)
Joel

On 11/10/15 7:32 PM, Carlos Pignataro (cpignata) wrote:
> I tracked it down — this was introduced in revision -10 of the
> sfc-architecture document, while working on resolving one Security AD’s
> DISCUSS.
>
> In particular, you can see the text presented as a proposal in Prague
> (https://www.ietf.org/proceedings/93/slides/slides-93-sfc-6.pdf, see
> Slide 11). We missed this one as a WG.
>
> Thanks,
>
> — Carlos.
>
>
>> On Nov 9, 2015, at 8:38 PM, RFC Errata System
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> NSH has not been introduced earlier in the document. Moreover, the
>> reference to NSH itself seems to have been a tiny mistake that slipped.

---

From: RFC Errata System <[email-masked]>
Date: Mon, 9 Nov 2015 11:38:28 -0800 (PST)

Section: 6

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------