Subject: Re: [sfc] metadata in draft-penno-sfc-packet-02

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 2 Dec 2015 22:59:13 +0000

From: sfc <[email-masked]<mailto:[email-masked]>> on behalf of Dave Dolson <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 2, 2015 at 1:47 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] metadata in draft-penno-sfc-packet-02

Starting a separate thread for metadata...
Referring to https://tools.ietf.org/html/draft-penno-sfc-packet-02

Section 7 proposes "service-path-invariant metadata. This is metadata that is the same for all packets traversing a certain path."

This seems to mean the metadata is in fact redundant with the path identifier, and might as well be configured on the control plane.

[RP] Yes, but that brings the issue as to whether SFs can receive and parse this additional config.  Similar pros and cons as sending all paths to the SFs

I think there are several other interesting classes of metadata:
- metadata that is the same for all packets of a given encapsulated traffic flow
   - e.g., a all packets for a given TCP connection have the same metadata
- metadata that is per-packet, and should NOT be cloned from one packet to another

[RP]  Didn't think much about the two types below.  Can you elaborate?

- metadata that is attributed to the source IP host
- metadata that is attributed to the destination IP host

Some have suggested these aspects be self-describing in the packet, using flags, but a dictionary or registry would be less wasteful of packet bytes.

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Wed, 2 Dec 2015 23:42:18 +0000

Question: Isn't it possible that different flows along one and the same physical chain and differing only in some metadata and probably the source address may have one and the same Path-ID?

Von: sfc [mailto:[email-masked]] Im Auftrag von Reinaldo Penno (repenno)
Gesendet: Mittwoch, 2. Dezember 2015 23:59
An: Dave Dolson; [email-masked]
Betreff: Re: [sfc] metadata in draft-penno-sfc-packet-02

David Dolson

---

From: Dave Dolson <[email-masked]>
Date: Thu, 3 Dec 2015 16:53:05 +0000

Regarding these:

What I intended to convey is some metadata that is a fact about one of the IP addresses of the packet carried within the NSH header.
E.g., "destination IP address is the target of a DDoS attack"
or, "source IP address is associated with charging account 123456"

The usefulness of knowing these metadata are about IP addresses is that an SF could clone metadata that it learned about an IP address into new packets that it creates.

Maybe the generalized concept is that metadata refers to a subject. Even if the full semantics of the metadata are not known, it is useful when injecting a packet into a service path to know the subject of various metadata types.

-Dave

From: Reinaldo Penno (repenno) [mailto:[email-masked]]
Sent: Wednesday, December 02, 2015 5:59 PM
To: Dave Dolson; [email-masked]
Subject: Re: [sfc] metadata in draft-penno-sfc-packet-02

David Dolson

---

From: Ron Parker <[email-masked]>
Date: Thu, 3 Dec 2015 17:42:01 +0000

Is it worth defining the "scope" of each piece of metadata?   I'm thinking of IPv6 options as a loose analogy - some IPv6 options are hop-by-hop whilst others are end-to-end.

   Ron

From: sfc [mailto:[email-masked]] On Behalf Of Dave Dolson
Sent: Thursday, December 3, 2015 11:53 AM
To: Reinaldo Penno (repenno) <[email-masked]>; [email-masked]
Subject: Re: [sfc] metadata in draft-penno-sfc-packet-02

Regarding these:

-Dave

From: Reinaldo Penno (repenno) [mailto:[email-masked]]
Sent: Wednesday, December 02, 2015 5:59 PM
To: Dave Dolson; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] metadata in draft-penno-sfc-packet-02

David Dolson