Subject: [sfc] metadata in draft-penno-sfc-packet-02

From: Dave Dolson <[email-masked]>
Date: Wed, 2 Dec 2015 21:47:20 +0000

Starting a separate thread for metadata...
Referring to https://tools.ietf.org/html/draft-penno-sfc-packet-02

Section 7 proposes "service-path-invariant metadata. This is metadata that is the same for all packets traversing a certain path."

This seems to mean the metadata is in fact redundant with the path identifier, and might as well be configured on the control plane.

I think there are several other interesting classes of metadata:
- metadata that is the same for all packets of a given encapsulated traffic flow
   - e.g., a all packets for a given TCP connection have the same metadata
- metadata that is per-packet, and should NOT be cloned from one packet to another
- metadata that is attributed to the source IP host
- metadata that is attributed to the destination IP host

Some have suggested these aspects be self-describing in the packet, using flags, but a dictionary or registry would be less wasteful of packet bytes.

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 2 Dec 2015 23:58:41 +0000

Yes, those would be flow-invariant.

From: "Haeffner, Walter, Vodafone DE" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 2, 2015 at 3:42 PM
To: Reinaldo Penno <[email-masked]<mailto:[email-masked]>>, Dave Dolson <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: AW: [sfc] metadata in draft-penno-sfc-packet-02

Question: Isn't it possible that different flows along one and the same physical chain and differing only in some metadata and probably the source address may have one and the same Path-ID?

Von: sfc [mailto:[email-masked]] Im Auftrag von Reinaldo Penno (repenno)
Gesendet: Mittwoch, 2. Dezember 2015 23:59
An: Dave Dolson; [email-masked]<mailto:[email-masked]>
Betreff: Re: [sfc] metadata in draft-penno-sfc-packet-02

From: sfc <[email-masked]<mailto:[email-masked]>> on behalf of Dave Dolson <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 2, 2015 at 1:47 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] metadata in draft-penno-sfc-packet-02

[RP] Yes, but that brings the issue as to whether SFs can receive and parse this additional config.  Similar pros and cons as sending all paths to the SFs

[RP]  Didn't think much about the two types below.  Can you elaborate?

David Dolson