Subject: [sfc] I-D Action: draft-ietf-sfc-nsh-06.txt

From: [email-masked]
Date: Tue, 23 Aug 2016 06:54:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Service Function Chaining of the IETF.

        Title           : Network Service Header
        Authors         : Paul Quinn
                          Uri Elzur
	Filename        : draft-ietf-sfc-nsh-06.txt
	Pages           : 37
	Date            : 2016-08-23

Abstract:
   This document describes a Network Service Header (NSH) inserted onto
   packets or frames to realize service function paths.  NSH also
   provides a mechanism for metadata exchange along the instantiated
   service path.  NSH is the SFC encapsulation required to support the
   Service Function Chaining (SFC) Architecture (defined in RFC7665).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sfc-nsh/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-sfc-nsh-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sfc-nsh-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Tue, 23 Aug 2016 14:02:07 +0000

Dear WG,

This version includes much of the feedback/review/comments from this list.

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [sfc] I-D Action: draft-ietf-sfc-nsh-06.txt
> Date: August 23, 2016 at 9:54:21 AM EDT
> To: <[email-masked]>
> Cc: [email-masked]
> 
> 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

---

From: <[email-masked]>
Date: Thu, 25 Aug 2016 15:40:02 +0000

Hi Paul,

I have a comment about this text:

   Type: the Type field is split into two ranges - 0 to 127 for non-
   critical options and 128-255 for critical options.  While the value
   allocation is the responsibility of the MD Class owner, critical
   options MUST NOT be allocated from the 0 to 127 range and non-
   critical options MUST NOT be allocated from the 128-255 range.

* Do you have an example of metadata that is critical for all chains, all deployments?
* Wouldn't be more appropriate to have one single registry for "type" with C-bit be a configurable parameter to be set by the administrator of the SFC-enabled domain?

Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : sfc [mailto:[email-masked]] De la part de Paul Quinn (paulq)
> Envoyé : mardi 23 août 2016 16:02
> À : [email-masked]
> Objet : [sfc] Fwd: I-D Action: draft-ietf-sfc-nsh-06.txt
> 
> Dear WG,
>