Subject: [sfc] FW: New Version Notification for draft-mackie-bess-nsh-bgp-control-plane-01.txt

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 1 Nov 2016 16:56:23 -0000

Hi SFC WG,

You may be interested in this draft. It provides a BGP control pane for an
(NSH-enabled) SFC network.

Currently the document is being discussed on the BESS mailing list which, from
reading the charters, is where it belongs.

Thanks,
Adrian

> -----Original Message-----
> From: BESS [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: 30 October 2016 16:19
> To: [email-masked]
> Subject: [bess] FW: New Version Notification for draft-mackie-bess-nsh-bgp-
> control-plane-01.txt
> 
> Hi Bess WG,
> 
> We made some updates to this document to tidy it and to get the terminology in
> line with RFC 7665.
> 
> Adrian
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: 30 October 2016 16:09
> > To: Eric Rosen; Adrian Farrel; John Drake; Jim Uttaro; Luay Jalil
> > Subject: New Version Notification for draft-mackie-bess-nsh-bgp-control-
> plane-
> > 01.txt
> >
> >
> > A new version of I-D, draft-mackie-bess-nsh-bgp-control-plane-01.txt
> > has been successfully submitted by Adrian Farrel and posted to the
> > IETF repository.
> >
> > Name:		draft-mackie-bess-nsh-bgp-control-plane
> > Revision:	01
> > Title:		BGP Control Plane for NSH SFC
> > Document date:	2016-10-30
> > Group:		Individual Submission
> > Pages:		37
> > URL:
https://www.ietf.org/internet-drafts/draft-mackie-bess-nsh-bgp-
> > control-plane-01.txt
> > Status:         https://datatracker.ietf.org/doc/draft-mackie-bess-nsh-bgp-
> control-
> > plane/
> > Htmlized:
https://tools.ietf.org/html/draft-mackie-bess-nsh-bgp-control-
> > plane-01
> > Diff:           https://www.ietf.org/rfcdiff?url2=draft-mackie-bess-nsh-bgp-
> control-
> > plane-01
> >
> > Abstract:
> >    This document describes the use of BGP as a control plane for
> >    networks that support Service Function Chaining (SFC).  The document
> >    introduces a new BGP address family called the SFC AFI/SAFI with two
> >    route types.  One route type is originated by a node to advertise
> >    that it hosts a particular instance of a specified service function.
> >    This route type also provides "instructions" on how to send a packet
> >    to the hosting node in a way that indicates that the service function
> >    has to be applied to the packet.  The other route type is used by a
> >    Controller to advertise the paths of "chains" of service functions,
> >    and to give a unique designator to each such path so that they can be
> >    used in conjunction with the Network Service Header.
> >
> >    This document adopts the SFC architecture described in RFC 7665.
> >
> >
> >
> >
> >
> > Please note that it may take a couple of minutes from the time of submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> 
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess

---

From: <[email-masked]>
Date: Wed, 2 Nov 2016 06:50:40 +0000

Hi Adrian,

Thank you for sharing the draft. 

While it is true that the SFC Data Plane architecture is defined in RFC 7665, an SFC Control Plane architecture is defined in another document: https://tools.ietf.org/html/draft-ietf-sfc-control-plane-08.

As I don't see it explained in your draft, can you please position this solution with regards to the SFC Control Architecture, especially indicate which control interface you are targeting? 

Thank you.

Cheers,
Med 

> -----Message d'origine-----
> De : sfc [mailto:[email-masked]] De la part de Adrian Farrel
> Envoyé : mardi 1 novembre 2016 17:56
> À : [email-masked]
> Cc : [email-masked]
> Objet : [sfc] FW: New Version Notification for draft-mackie-bess-nsh-bgp-
> control-plane-01.txt
> 
> Hi SFC WG,
> 
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc