Subject: [sfc] One question regarding IBN from draft-ietf-sfc-hierarchical-01

From: Nobin Mathew <[email-masked]>
Date: Wed, 16 Nov 2016 16:21:57 +0530

Hi Authors,

Internal Boundary Node (IBN)

   As mentioned in the previous section, a network element termed
   "Internal Boundary Node" (IBN) is responsible for bridging packets
   between SFC-enabled domains.  It behaves as an SF to the higher level
   (Section 2.1), and looks like a classifier and end-of-chain to the
   lower level (Section 2.2).

Above is the IBN definition copied from the draft,
My understanding here is an IBN is a normal forwarding device which do
a classification/switching (Ex; OVS).

1) So this drafts suggests the switch to do the NSH manipulation also ?

====draft copy=====

3.3.  Decrementing Service Index

   Because the IBN acts as an SFC-aware SF to the higher-level domain,
   it must decrement the Service Index in the NSH headers of the higher-
   level path.  This operation should be undertaken when the packet is
   first received by the IBN, before applying any of the strategies of
   Section 3.1, immediately prior to classification.

====draft copy=====

2) This means that, all the switch implementation should support the NSH
[here SI index decrement] manipulation, now may be not supported by
switches ?
3) Why its mentioned  that IBN is SFC-aware SF, even though its doing a
classification for the upper domain?

Please correct me if my understanding is wrong.

Regards
Nobin

---

From: Dave Dolson <[email-masked]>
Date: Wed, 16 Nov 2016 12:36:06 +0000

Nobin,
Thanks for reading the draft and asking questions!
Please see inline [DD].

From: Nobin Mathew [mailto:[email-masked]]
Sent: Wednesday, November 16, 2016 7:52 PM
To: Dave Dolson; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: One question regarding IBN from draft-ietf-sfc-hierarchical-01

Hi Authors,

Above is the IBN definition copied from the draft,
My understanding here is an IBN is a normal forwarding device which do a classification/switching (Ex; OVS).

[DD] I don’t think this is a correct interpretation to say “normal forwarding device”. The IBN is an NSH end-point, meaning it receives NSH packets over some transport such as Ethernet or VXLAN-GPE. You might be able to get OVS to act this way.

[DD] “Switch”? The draft does not use the term “switch” at all.

====draft copy=====

====draft copy=====

[DD] Because the IBN *is* an SF, yes it decrements the SI.

2) This means that, all the switch implementation should support the NSH [here SI index decrement] manipulation, now may be not supported by switches ?
[DD] Neither SFF nor SF nor Classifier are “switches” as people normally understand the term.

3) Why its mentioned  that IBN is SFC-aware SF, even though its doing a classification for the upper domain?
[DD] I hope you can understand the IBN as a kind of adapter between two domains. In the upper domain it plays the role of a Service Function, but in the lower domain it plays the roles of classifier and SFF. It is doing classification for the lower domain, not the upper domain.

---

From: Nobin Mathew <[email-masked]>
Date: Wed, 16 Nov 2016 19:46:37 +0530

Hi Dave,
Thank you for your reply.
So IBN is special purpose device, it could be a linux PC or an OVS , right?
Do you think the open implementation of OVS needs to support the SI index
decrementing [the IBN functionality] ?
Regards
Nobin

On Wed, Nov 16, 2016 at 6:06 PM, Dave Dolson <[email-masked]> wrote:

> *From:* Nobin Mathew [mailto:[email-masked]]
> *Sent:* Wednesday, November 16, 2016 7:52 PM
> *To:* Dave Dolson; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> *Cc:* [email-masked]
> *Subject:* One question regarding IBN from draft-ietf-sfc-hierarchical-01
>
>
>
> Hi Authors,
>
> [DD] Because the IBN **is** an SF, yes it decrements the SI.
>
>
>
> [DD] I hope you can understand the IBN as a kind of adapter between two
> domains. In the upper domain it plays the role of a Service Function, but
> in the lower domain it plays the roles of classifier and SFF. It is doing
> classification for the lower domain, not the upper domain.
>
>
>