Subject: [sfc] IETF 102 - SFC Minutes

From: Tal Mizrahi <[email-masked]>
Date: Sat, 21 Jul 2018 04:37:37 -0400

Hi,

A draft version of the minutes has been posted:

https://datatracker.ietf.org/meeting/102/materials/minutes-102-sfc-00

Please take a look and let us know if there are any comments or corrections.
[Or if you can help complete the missing name of an unidentified speaker
who came to the mic].

Thanks to John Strassner who helped with the minutes.

Cheers,
Tal.

---

From: <[email-masked]>
Date: Fri, 27 Jul 2018 08:44:13 +0000

Dear all,
unfortunately I could not attend the session and follow the discussion. From the minutes below I read that on draft ‘Name-Based Service Function Forwarder (nSFF) component within SFC framework’ Joel saw a number of issues that he asked the authors to address which I don’t know in detail. Have they be posted here on the list?

Nevertheless I had a quick view on the draft and find it interesting in providing a way to propose concrete SFC handling on different L2/L3-based transport.

My main suggestions to improve readability even more are
-              To separate customer service related use case from more operational ones e.g. on p.1:
use cases such as IoT, Content Distribution, Gaming, Network functions …=> use cases both customer related ones such as … as well as operational (or operator related) ones such as Network functions …
-              to explain some more acronyms (vTOR, AND/CMP, …),
-              to ensure consistency (on p.9 the text refers to ‘Delivery function in Fig. 3’ which I couldn’t find there),
-              and the question whether in 5.4.2 it should read ‘in steps 8 and 11’ instead of ‘in steps 8 and 10’ as I understood that step 11 with adding new TE information resembles encapsulation.
Furthermore I think I found some nits and typos which I directly reported to the authors for final check.
Thanks!
Best Regards
Dirk

From: sfc [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Samstag, 21. Juli 2018 10:38
To: [email-masked]; [email-masked]
Subject: [sfc] IETF 102 - SFC Minutes

Hi,

https://datatracker.ietf..org/meeting/102/materials/minutes-102-sfc-00<https://datatracker.ietf.org/meeting/102/materials/minutes-102-sfc-00>

Please take a look and let us know if there are any comments or corrections.
[Or if you can help complete the missing name of an unidentified speaker who came to the mic].

Cheers,
Tal.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 27 Jul 2018 10:55:14 -0400

Part of the point I made at the time was that I had sent my concerns 
directly to you, and had specifically asked that you acknowledge (not 
agree, not make a change, but acknowledge) the questions in your 
presentation.

While there are likely other issues, there were two important issues I 
commented on:
1) requiring a name resolution process in a fast path packet forwarding 
logic is painful.  We are even careful about how one deals with 
initially populating information from IPv6 ND (and IPv4 ARP).  And those 
have very long lifetime.  The argument for this mechanism is 
specifically to improve dynamics, so it requires very short lifetimes.
2) While some systems do insert packets into TCP tunnels, it has to be 
done with care, as it significantly complicates the buffering and packet 
handling.  It may be that you do not intend (as was said to me 
afterwards) to use TCP.  But the document specifically points to http:, 
which is over TCP.

Yours,
Joel

On 7/27/18 4:44 AM, [email-masked] wrote:
> Dear all,
> 
> unfortunately I could not attend the session and follow the discussion. 
>  From the minutes below I read that on draft ‘Name-Based Service 
> Function Forwarder (nSFF) component within SFC framework’Joel saw a 
> number of issues that he asked the authors to address which I don’t know 
> in detail. Have they be posted here on the list?
> 
> Nevertheless I had a quick view on the draft and find it interesting in 
> providing a way to propose concrete SFC handling on different 
> L2/L3-based transport.
> 
> use cases such as IoT, Content Distribution, Gaming, Network functions 
> …=> use cases both customer related ones such as … as well as 
> operational (or operator related) ones such as Network functions …
> 
> -              to ensure consistency (on p.9 the text refers to 
> ‘Delivery function in Fig. 3’ which I couldn’t find there),
> 
> -              and the question whether in 5.4.2 it should read ‘in 
> steps 8 and 11’ instead of ‘in steps 8 and 10’ as I understood that step 
> 11 with adding new TE information resembles encapsulation.
> 
> *From:*sfc [mailto:[email-masked]] *On Behalf Of *Tal Mizrahi
> *Sent:* Samstag, 21. Juli 2018 10:38
> *To:* [email-masked]; [email-masked]
> *Subject:* [sfc] IETF 102 - SFC Minutes
> 
> Hi,
> 
> https://datatracker.ietf..org/meeting/102/materials/minutes-102-sfc-00 
> <https://datatracker.ietf.org/meeting/102/materials/minutes-102-sfc-00>
>