Subject: Re: [sfc] New Version Notification for draft-lachos-multi-domain-sfc-alto-00.txt

From: Danny Alex Lachos Perez <[email-masked]>
Date: Mon, 2 Jul 2018 20:35:19 -0300

Dear WG members.

The main idea behalf this draft is to start a discussion (SFC, ALTO as well
as other WGs) regarding if, how, and under what conditions ALTO can be
useful to improve the multi-domain SFC process.

This version provides arguments why ALTO is a meaningful protocol in the
context of SFC traversing different domains, and it presents use case
examples about the how ALTO can be used to advertise and discover
(abstract) topology, resource and service information from different
domains, and then compute inter-domain service function paths.

Any comment, question, and suggestion from the WGs would be greatly
appreciated.

Ss

Danny Lachos

On Mon, Jul 2, 2018 at 5:12 PM <[email-masked]> wrote:

>
> A new version of I-D, draft-lachos-multi-domain-sfc-alto-00.txt
> has been successfully submitted by Danny Alex Lachos Perez and posted to
> the
> IETF repository.
>
> Name:           draft-lachos-multi-domain-sfc-alto
> Revision:       00
> Title:          Multi-domain Service Function Chaining with ALTO
> Document date:  2018-07-02
> Group:          Individual Submission
> Pages:          14
> URL:
> https://www.ietf.org/internet-drafts/draft-lachos-multi-domain-sfc-alto-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-lachos-multi-domain-sfc-alto/
> Htmlized:
> https://tools.ietf.org/html/draft-lachos-multi-domain-sfc-alto-00
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-lachos-multi-domain-sfc-alto
>
>
> Abstract:
>    Currently, Service Function Chaining (SFC) that span domains with
>    different technology, administration or ownership are being defined
>    by the SFC WG.  This document focuses on how the Application Layer
>    Traffic Optimization (ALTO) protocol can be used to advertise and
>    discover abstract topology, resource and service information from
>    different domains, and then compute inter-domain service function
>    paths.  Another important concern of this draft is to initiate a
>    discussion (ALTO, SFC as well as other WGs) regarding if, how, and
>    under what conditions ALTO can be useful to improve the multi-domain
>    SFC process.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>

---

From: <[email-masked]>
Date: Tue, 3 Jul 2018 12:03:27 +0000

Dear Danny,

Thank you for sharing this draft.

My main comments about this draft are as follows:

·         The SFC WG is currently scoped to one single administrative domain. Even for the work we have done about hierarchical SFC, the assumption is that sub-domains are managed by the same administrative entity.

·         Before getting into protocol details about how to realize inter-domain service chains, it would be really valuable to identify and describe concrete uses cases which require SFs from distinct administrative domains + justify why topology visibility is required + paths have to be computed end-to-end and so on.

FWIW, you may find some additional comments at:

·         .pdf: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/draft-lachos-multi-domain-sfc-alto-00-rev%20Med.pdf

·         .doc: https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-lachos-multi-domain-sfc-alto-00-rev%20Med.doc

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Danny Alex Lachos Perez
Envoyé : mardi 3 juillet 2018 01:35
À : [email-masked]; IETF ALTO; [email-masked]; [email-masked]
Cc : [email-masked]; Christian Rodolfo E. Rothenberg; Y. Richard Yang
Objet : Re: [sfc] New Version Notification for draft-lachos-multi-domain-sfc-alto-00.txt

Dear WG members.

The main idea behalf this draft is to start a discussion (SFC, ALTO as well as other WGs) regarding if, how, and under what conditions ALTO can be useful to improve the multi-domain SFC process.

This version provides arguments why ALTO is a meaningful protocol in the context of SFC traversing different domains, and it presents use case examples about the how ALTO can be used to advertise and discover (abstract) topology, resource and service information from different domains, and then compute inter-domain service function paths.

Any comment, question, and suggestion from the WGs would be greatly appreciated.

Ss

Danny Lachos

On Mon, Jul 2, 2018 at 5:12 PM <[email-masked]<mailto:[email-masked]>> wrote:

A new version of I-D, draft-lachos-multi-domain-sfc-alto-00.txt
has been successfully submitted by Danny Alex Lachos Perez and posted to the
IETF repository.

Name:           draft-lachos-multi-domain-sfc-alto
Revision:       00
Title:          Multi-domain Service Function Chaining with ALTO
Document date:  2018-07-02
Group:          Individual Submission
Pages:          14
URL:            https://www.ietf.org/internet-drafts/draft-lachos-multi-domain-sfc-alto-00.txt
Status:         https://datatracker.ietf.org/doc/draft-lachos-multi-domain-sfc-alto/
Htmlized:       https://tools.ietf.org/html/draft-lachos-multi-domain-sfc-alto-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-lachos-multi-domain-sfc-alto

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat