Subject: [sfc] RFC 8677 (Name-Based Service Function Forwarder (nSFF) Component within a SFC Framework) published

From: Akbar Rahman <[email-masked]>
Date: Thu, 21 Nov 2019 02:17:20 +0000

Hi Joel (& WG)

FYI - Our draft that initially started in the SFC WG, and then proceeded to the ISE route (with your guidance), has now been published as an RFC:

  *   RFC 8677 - Name-Based Service Function Forwarder (nSFF) Component within a SFC Framework
     *   https://tools.ietf.org/html/rfc8677

We would be happy to respond to any comments or feedback from the WG.

Best Regards,

Akbar

---

From: Davey Song <[email-masked]>
Date: Thu, 21 Nov 2019 12:12:30 +0800

Hi Akbar,

I just notice this RFC document. I did not quite follow the topic, but
according to the title, if you want to name a service and change
dynamically instead of L2/L3 address, why not using DNS for this purpose?

Best Regards,
Davey

On Thu, 21 Nov 2019 at 10:17, Akbar Rahman <[email-masked]>
wrote:

> Hi Joel (& WG)
>
>
>
>
>
> FYI – Our draft that initially started in the SFC WG, and then proceeded
> to the ISE route (with your guidance), has now been published as an RFC:
>
>
>
>    - RFC 8677 - Name-Based Service Function Forwarder (nSFF) Component
>    within a SFC Framework
>       - https://tools.ietf.org/html/rfc8677
>
>
>
>
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: Dirk Trossen <[email-masked]>
Date: Thu, 21 Nov 2019 08:43:24 +0000

Hi Davey,

Thanks for the email. As we outline in the document, alongside a 5G use case, we don’t see DNS as being suitable for the dynamic changes in the relationships, often realized virtualized and dynamically spun up albeit distributed named entities.

Best,

Dirk

From: sfc <[email-masked]> On Behalf Of Davey Song
Sent: 21 November 2019 04:13
To: Akbar Rahman <[email-masked]>
Cc: Joel M. Halpern <[email-masked]>; [email-masked]
Subject: Re: [sfc] RFC 8677 (Name-Based Service Function Forwarder (nSFF) Component within a SFC Framework) published

Hi Akbar,

I just notice this RFC document. I did not quite follow the topic, but according to the title, if you want to name a service and change dynamically instead of L2/L3 address, why not using DNS for this purpose?

Best Regards,
Davey

On Thu, 21 Nov 2019 at 10:17, Akbar Rahman <[email-masked]<mailto:[email-masked]>> wrote:
Hi Joel (& WG)

FYI – Our draft that initially started in the SFC WG, and then proceeded to the ISE route (with your guidance), has now been published as an RFC:

Best Regards,

Akbar
_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc