Subject: Re: [sfc] SFC Security

From: <[email-masked]>
Date: Tue, 2 Jun 2020 06:41:14 +0000

Hello WG,

I too believe draft-rebo-sfc-nsh-integrity is a good start to define security mechanisms for the NSH and therefore suggest this draft should be moved forward.

Cheers,

Christian.

-----Message d'origine-----
De : sfc [mailto:[email-masked]] De la part de Joel M. Halpern
Envoyé : mercredi 27 mai 2020 17:36
À : [email-masked]
Objet : [sfc] SFC Security

We as a working group hava milestone which the IESG felt was important, 
and which we agreed to work on, to provide security mechanisms for NSH.

We have one individual draft that suggests such mechansims:
https://datatracker.ietf.org/doc/draft-rebo-sfc-nsh-integrity/

Do folks think this is a good start?  A bad start?

For those folks who would like to be working on other things, the chairs 
note that we are very reluctant to engage in new work items until we can 
prove we can complete out commitments.

Yours,
Joel

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 3 Jun 2020 22:03:33 +0000

Hi,

I read this document and believe that this is a good start. I support this work.

Thanks,
Nagendra

On 5/27/20, 11:36 AM, "sfc on behalf of Joel M. Halpern" <[email-masked] on behalf of [email-masked]> wrote:

    Yours,
    Joel

---

From: <[email-masked]>
Date: Thu, 4 Jun 2020 09:34:40 +0000

Hi Joel and WG,
I agree with others that this is an excellent start to deal with SCF/NSH security and see many improvements in recent updates. I would suggest we should move it to WG draft status 
... if that was the question ;-)
Thanks to the authors!
Kind regards
Dirk

-----Original Message-----
From: sfc <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Mittwoch, 27. Mai 2020 17:36
To: [email-masked]
Subject: [sfc] SFC Security

We as a working group hava milestone which the IESG felt was important, and which we agreed to work on, to provide security mechanisms for NSH.

For those folks who would like to be working on other things, the chairs note that we are very reluctant to engage in new work items until we can prove we can complete out commitments.

Yours,
Joel

---

From: Shunsuke Homma <[email-masked]>
Date: Thu, 4 Jun 2020 21:53:34 +0900

Hi,

I reviewed the draft, and I also think it is good start to consider SFC/NSH
security. I'd like to support the work.

BTW, I have a small question about flavor 1 and 2. What is merit to encrypt
base header? Base header doesn't contain any privacy information, and there
are no effect on SFP if it is falsified.

Best regards,

Shunsuke

On Thu, Jun 4, 2020 at 6:35 PM <[email-masked]> wrote:

> Hi Joel and WG,
> I agree with others that this is an excellent start to deal with SCF/NSH
> security and see many improvements in recent updates. I would suggest we
> should move it to WG draft status
> .... if that was the question ;-)
> Thanks to the authors!
> Kind regards
> Dirk
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 4 Jun 2020 12:57:46 +0000

Hi,

I agree with Dirk and Sunshuke. This is a matter we have to address, the sooner the better, and a natural sequitur of previous work.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 04/06/2020, 14:54, "sfc on behalf of Shunsuke Homma" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi,

I reviewed the draft, and I also think it is good start to consider SFC/NSH security. I'd like to support the work.

BTW, I have a small question about flavor 1 and 2. What is merit to encrypt base header? Base header doesn't contain any privacy information, and there are no effect on SFP if it is falsified.

Best regards,

Shunsuke

On Thu, Jun 4, 2020 at 6:35 PM <[email-masked]<mailto:[email-masked]>> wrote:
Hi Joel and WG,
I agree with others that this is an excellent start to deal with SCF/NSH security and see many improvements in recent updates. I would suggest we should move it to WG draft status
..... if that was the question ;-)
Thanks to the authors!
Kind regards
Dirk

-----Original Message-----
From: sfc <[email-masked]<mailto:[email-masked]>> On Behalf Of Joel M. Halpern
Sent: Mittwoch, 27. Mai 2020 17:36
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] SFC Security

Yours,
Joel

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: <[email-masked]>
Date: Thu, 4 Jun 2020 14:21:56 +0000

Hi Shunsuke,

Thank you for the comment.

Actually, we don’t encrypt the base header for all flavors.

Some attacks are theoretically possible with a manipulation of the base header (set the version, decrement the TTL). Flavor 2 allows to detect such manipulations.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Shunsuke Homma
Envoyé : jeudi 4 juin 2020 14:54
À : <[email-masked]>
Cc : [email-masked]; [email-masked]
Objet : Re: [sfc] SFC Security

Hi,

Best regards,

Shunsuke

-----Original Message-----
From: sfc <[email-masked]<mailto:[email-masked]>> On Behalf Of Joel M. Halpern
Sent: Mittwoch, 27. Mai 2020 17:36
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] SFC Security

Yours,
Joel

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 4 Jun 2020 15:20:41 +0000

Hi,

Just a naming nit on this… Why do you use the term “flavor”? In other similar cases I’ve seen “level of assurance” (LoA) that seems to me more descriptive.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 04/06/2020, 16:22, "sfc on behalf of [email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Shunsuke,

Cheers,
Med

Hi,

Best regards,

Shunsuke

-----Original Message-----
From: sfc <[email-masked]<mailto:[email-masked]>> On Behalf Of Joel M. Halpern
Sent: Mittwoch, 27. Mai 2020 17:36
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] SFC Security

Yours,
Joel

---

From: <[email-masked]>
Date: Thu, 4 Jun 2020 15:45:03 +0000

Hi Diego,

We used it to refer to a “variant”, if you will.

Thank you for the proposal. Will consider it in the next iteration. Thanks

Cheers,
Med

De : Diego R. Lopez [mailto:[email-masked]]
Envoyé : jeudi 4 juin 2020 17:21
À : BOUCADAIR Mohamed TGI/OLN; Shunsuke Homma; <[email-masked]>
Cc : [email-masked]; [email-masked]
Objet : Re: [sfc] SFC Security

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi Shunsuke,

Cheers,
Med

Hi,

Best regards,

Shunsuke

-----Original Message-----
From: sfc <[email-masked]<mailto:[email-masked]>> On Behalf Of Joel M. Halpern
Sent: Mittwoch, 27. Mai 2020 17:36
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] SFC Security

Yours,
Joel

---

From: Shunsuke Homma <[email-masked]>
Date: Fri, 5 Jun 2020 10:30:25 +0900

Hi, Med.

Thank you for correcting my misunderstanding.

Yes, such attacks are possible. Then, I wonder how  large risks they have.
In my view, such attacks may cause irregular packet drops, but such risk is
too small compared with leak of metadata including privacy info or DOS
attacks to specific SFs by falsifying of SFP and SI.

Of course, flavor 2 would be better if its implementation and operation
costs are almost the same with flavor 1.  I hope it is clarified that the
pros/cons of each flavor and their applicable ranges if you provide two
options.

Best regards,

Shunsuke

On Thu, Jun 4, 2020 at 11:21 PM <[email-masked]> wrote:

> Some attacks are theoretically possible with a manipulation of the base
> header (set the version, decrement the TTL). Flavor 2 allows to detect such
> manipulations.
>
>
>
> Cheers,
>
> Med
>
>
>
> *De :* sfc [mailto:[email-masked]] *De la part de* Shunsuke Homma
> *Envoyé :* jeudi 4 juin 2020 14:54
> *À :* <[email-masked]>
> *Cc :* [email-masked]; [email-masked]
> *Objet :* Re: [sfc] SFC Security
>
>
>
> Hi,
>
> I reviewed the draft, and I also think it is good start to consider
> SFC/NSH security. I'd like to support the work.
>
> BTW, I have a small question about flavor 1 and 2. What is merit to
> encrypt base header? Base header doesn't contain any privacy information,
> and there are no effect on SFP if it is falsified.
>
>
>
> Best regards,
>
>
>
> Shunsuke
>
>
>
>
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 5 Jun 2020 13:16:57 +0000

Hi Med,

I understood you were referring to variants, just wanted to offer a different choice to name them…

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 04/06/2020, 17:45, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Diego,

Cheers,
Med

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi Shunsuke,

Cheers,
Med

Hi,

Best regards,

Shunsuke

-----Original Message-----
From: sfc <[email-masked]<mailto:[email-masked]>> On Behalf Of Joel M. Halpern
Sent: Mittwoch, 27. Mai 2020 17:36
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] SFC Security

Yours,
Joel

---

From: <[email-masked]>
Date: Mon, 8 Jun 2020 08:48:40 +0000

Hi Shunsuke,

Point taken.

Please note that this is one of the points we will need more feedback from the WG once the document is hopefully adopted: maintain both TLVs or pick only one. We will revive this point in due time. Thanks.

Cheers,
Med

De : Shunsuke Homma [mailto:[email-masked]]
Envoyé : vendredi 5 juin 2020 03:30
À : BOUCADAIR Mohamed TGI/OLN
Cc : <[email-masked]>; [email-masked]; [email-masked]
Objet : Re: [sfc] SFC Security

Hi, Med.

Yes, such attacks are possible. Then, I wonder how  large risks they have. In my view, such attacks may cause irregular packet drops, but such risk is too small compared with leak of metadata including privacy info or DOS attacks to specific SFs by falsifying of SFP and SI.

Of course, flavor 2 would be better if its implementation and operation costs are almost the same with flavor 1.  I hope it is clarified that the pros/cons of each flavor and their applicable ranges if you provide two options.

Best regards,

Shunsuke

On Thu, Jun 4, 2020 at 11:21 PM <[email-masked]<mailto:[email-masked]>> wrote:
Hi Shunsuke,

Cheers,
Med

De : sfc [mailto:[email-masked]<mailto:[email-masked]>] De la part de Shunsuke Homma
Envoyé : jeudi 4 juin 2020 14:54
À : <[email-masked]<mailto:[email-masked]>>
Cc : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Objet : Re: [sfc] SFC Security

Hi,

Best regards,

Shunsuke

-----Original Message-----
From: sfc <[email-masked]<mailto:[email-masked]>> On Behalf Of Joel M. Halpern
Sent: Mittwoch, 27. Mai 2020 17:36
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] SFC Security

Yours,
Joel