Subject: [sfc] Fwd: New Version Notification for draft-ietf-sfc-multi-layer-oam-06.txt

From: Greg Mirsky <[email-masked]>
Date: Tue, 2 Jun 2020 18:05:28 -0700

Dear All,
this version includes the reference to the SFC OAM Framework document that
was correctly pointed out by Carlos.

Regards,
Greg

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, Jun 2, 2020 at 6:00 PM
Subject: New Version Notification for draft-ietf-sfc-multi-layer-oam-06.txt
To: Cui(Linda) Wang <[email-masked]>, Bhumip Khasnabish <
[email-masked]>, Wei Meng <[email-masked]>, Greg Mirsky <
[email-masked]>

A new version of I-D, draft-ietf-sfc-multi-layer-oam-06.txt
has been successfully submitted by Greg Mirsky and posted to the
IETF repository.

Name:           draft-ietf-sfc-multi-layer-oam
Revision:       06
Title:          Active OAM for Service Function Chains in Networks
Document date:  2020-06-02
Group:          sfc
Pages:          18
URL:
https://www.ietf.org/internet-drafts/draft-ietf-sfc-multi-layer-oam-06.txt
Status:
https://datatracker.ietf.org/doc/draft-ietf-sfc-multi-layer-oam/
Htmlized:
https://tools.ietf.org/html/draft-ietf-sfc-multi-layer-oam-06
Htmlized:
https://datatracker.ietf.org/doc/html/draft-ietf-sfc-multi-layer-oam
Diff:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sfc-multi-layer-oam-06

Abstract:
   A set of requirements for active Operation, Administration and
   Maintenance (OAM) of Service Function Chains (SFCs) in networks is
   presented.  Based on these requirements an encapsulation of active
   OAM message in SFC and a mechanism to detect and localize defects
   described.  Also, this document updates RFC 8300 in the definition of
   O (OAM) bit in the Network Service Header (NSH) and defines how the
   active OAM message identified in SFC NSH.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 3 Jun 2020 01:59:45 +0000

Dear Greg,

Let me correct what I pointed out.

I did NOT point out that a reference / citation to the SFC OAM Framework was missing.

I DID point out that this is a solution over engineered in a corner without consideration for the work done on the framework.

An after-the-fact reference does not fix that :-)

Best,

Carlos.

> 2020/06/02 午後9:05、Greg Mirsky <[email-masked]>のメール:
> 
> Dear All,
> this version includes the reference to the SFC OAM Framework document that was correctly pointed out by Carlos.
> 
> Regards,
> Greg
> 
> From: <[email-masked] <mailto:[email-masked]>>
> To: Cui(Linda) Wang <[email-masked] <mailto:[email-masked]>>, Bhumip Khasnabish <[email-masked] <mailto:[email-masked]>>, Wei Meng <[email-masked] <mailto:[email-masked]>>, Greg Mirsky <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-sfc-multi-layer-oam-06.txt <https://www.ietf.org/internet-drafts/draft-ietf-sfc-multi-layer-oam-06.txt>
> Status:         https://datatracker.ietf.org/doc/draft-ietf-sfc-multi-layer-oam/ <https://datatracker.ietf.org/doc/draft-ietf-sfc-multi-layer-oam/>
> Htmlized:       https://tools.ietf.org/html/draft-ietf-sfc-multi-layer-oam-06 <https://tools.ietf.org/html/draft-ietf-sfc-multi-layer-oam-06>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-sfc-multi-layer-oam <https://datatracker.ietf.org/doc/html/draft-ietf-sfc-multi-layer-oam>
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-sfc-multi-layer-oam-06 <https://www.ietf.org/rfcdiff?url2=draft-ietf-sfc-multi-layer-oam-06>
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> 
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 2 Jun 2020 22:40:54 -0400

While Greg and Carlos discuss this, it would be helpful to the chairs if 
other folks who have opinions on these issues would speak up.

Thank you,
Joel

On 6/2/2020 9:59 PM, Carlos Pignataro (cpignata) wrote:
> I DID point out that this is a solution over engineered in a corner 
> without consideration for the work done on the framework.
> 
>> 2020/06/02 午後9:05、Greg Mirsky <[email-masked] 
>> <mailto:[email-masked]>>のメール:
>>
>> Dear All,
>> this version includes the reference to the SFC OAM Framework document 
>> that was correctly pointed out by Carlos.
>>
>> Regards,
>> Greg
>>
>> To: Cui(Linda) Wang <[email-masked] 
>> <mailto:[email-masked]>>, Bhumip Khasnabish <[email-masked] 
>> <mailto:[email-masked]>>, Wei Meng <[email-masked] 
>> <mailto:[email-masked]>>, Greg Mirsky <[email-masked] 
>> <mailto:[email-masked]>>
>>
>>
>>
>> Status: https://datatracker.ietf.org/doc/draft-ietf-sfc-multi-layer-oam/
>> Htmlized: https://tools.ietf.org/html/draft-ietf-sfc-multi-layer-oam-06
>> Htmlized: 
>> Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-sfc-multi-layer-oam-06
>>
>> Abstract: