Subject: Re: [sfc] IETF WG state changed for draft-ietf-sfc-proof-of-transit

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Thu, 25 Jun 2020 03:36:35 +0000

I think this draft is ready to be progress as an experimental RFC, support the WGLC.

Thanks,
Shwetha 

    > -----Original Message-----
    > From: sfc <mailto:[email-masked]> On Behalf Of Joel M. Halpern
    > Sent: Dienstag, 16. Juni 2020 15:42
    > To: mailto:[email-masked]
    > Subject: Re: [sfc] IETF WG state changed for 
    > draft-ietf-sfc-proof-of-transit
    > 
    > The chairs are starting the WG last call for 
    > draft-ietf-sfc-proof-of-transit.  Please reply explicitly whether you 
    > think this is ready to go to the IETF for publication as a Experimental RFC.
    > As noted below, the call runs through June 30.
    > 
    > Note that silence does not imply consent, so please speak up.
    > 
    > Yours,
    > Joel (& Jim)
    > 
    > On 6/16/2020 9:32 AM, IETF Secretariat wrote:
    > >
    > > The IETF WG state of draft-ietf-sfc-proof-of-transit has been 
    > > changed to "In WG Last Call" from "WG Document" by Joel Halpern:
    > >
    > > https://datatracker.ietf.org/doc/draft-ietf-sfc-proof-of-transit/
    > >
    > > Comment:
    > > This starts WG last call for this document, ending June 30.
    > >
    > 
    > _______________________________________________
    > sfc mailing list
    > mailto:[email-masked]
    > https://www.ietf.org/mailman/listinfo/sfc

---

From: Sashank Dara <[email-masked]>
Date: Thu, 25 Jun 2020 03:58:33 +0000

Dear SFC Team

I believe the POT protocols , have Internet wide applications .
As a co-author , I fully support publishing of the draft POT documents as experimental RFC

https://datatracker.ietf.org/doc/draft-ietf-sfc-proof-of-transit/

Regards,
Dr. Sashank Dara (Ph.D)
Co-Founder & CTO
Mob: +91 - 9448572488
https://www.seconize.co<https://www.seconize.co/>

<https://www.linkedin.com/company/seconize><https://www.facebook.com/seconize/><https://twitter.com/seconize_co><https://www.youtube.com/channel/UCFnAqVxvc2eHKmAu8w2PdJA>
<https://www.seconize.co/>

---

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Thu, 25 Jun 2020 11:01:44 +0000

Hello all,

I support progressing this draft to an Experimental RFC. Please consider the following comments (mostly editorial):

1)
Not sure what is implied by the sentence below (Sec 1): 
> A particular set of nodes "to be verified" is either described by a set of shares of a single secret.  

2)
The following sentence (Sec 1) describes about controller nodes and verifier nodes. While the former's role could be easily understood, I am not sure the latter node role is clearly defined. If it does not limit the scope, we may use only one terminology or clarify the difference, if we need to refer about two roles.
> The complete secret set is only known to  the controller and a verifier node, which is typically the ultimate node on a path that performs verification.

3)
Sec 7.9.1
OLD 
 Since these schemes introduce at least additional control requirements, the selection of order verification SHOULD be configurable the Controller management interface
NEW
Since these schemes introduce at least additional control requirements, the selection of order verification SHOULD be configurable BY the Controller management interface

4)
Sec 3.2 has the words Solution Approach duplicated

5)
Not sure if there is a missing reference here (Sec: 3.3.1.3): 
> For a general way to compute the modular multiplicative inverse, see   e.g., the Euclidean algorithm.

6)
General comment: It may be helpful to either have a diagram or a pointer to a diagram pointing out the different roles like Controller, ingress node. Also I am not sure if there is text (other than the section in Security Considerations) that explains that POT should be deployed in a set of nodes under a single administrative domain.

Thanks
Prasad

> > From: sfc <[email-masked]> On Behalf Of Joel M. Halpern
> > Sent: Dienstag, 16. Juni 2020 15:42
> > To: [email-masked]
> > Subject: Re: [sfc] IETF WG state changed for 
> > draft-ietf-sfc-proof-of-transit
> >
> > The chairs are starting the WG last call for 
> > draft-ietf-sfc-proof-of-transit.  Please reply explicitly whether 
> > you think this is ready to go to the IETF for publication as a Experimental RFC.
> > As noted below, the call runs through June 30.
> >
> > Note that silence does not imply consent, so please speak up.
> >
> > Yours,
> > Joel (& Jim)
> >
> > On 6/16/2020 9:32 AM, IETF Secretariat wrote:
> > >
> > > The IETF WG state of draft-ietf-sfc-proof-of-transit has been 
> > > changed to "In WG Last Call" from "WG Document" by Joel Halpern:
> > >
> > > Comment:
> > > This starts WG last call for this document, ending June 30.
> > >
> >
> > _______________________________________________
> > sfc mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/sfc

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 25 Jun 2020 20:37:58 +0000

Hi Frank,
 
I have watched this draft progress over the past few years, and have always
been impressed with the efficiency of the solution.  Reading through the
draft again now, I agree that it is ready to progress as an experimental
RFC.   The only nit comments that I have match up to the ones which you have
been working with Med.  And those seem to be addressed now.
 
Thanks,
Eric
 
> -----Message d'origine-----
> De : sfc [mailto:[email-masked]] De la part de Joel M. Halpern
> Envoyé : mardi 16 juin 2020 15:42
> À :  <mailto:[email-masked]> [email-masked]
> Objet : Re: [sfc] IETF WG state changed for
> draft-ietf-sfc-proof-of-transit.  Please reply explicitly whether you
> think this is ready to go to the IETF for publication as a Experimental
> RFC.
> > The IETF WG state of draft-ietf-sfc-proof-of-transit has been changed to
> "In
> > WG Last Call" from "WG Document" by Joel Halpern:
> >
> >  <https://datatracker.ietf.org/doc/draft-ietf-sfc-proof-of-transit/>
>  <mailto:[email-masked]> [email-masked]
>  <https://www.ietf.org/mailman/listinfo/sfc>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 25 Jun 2020 22:09:21 +0000

Hi,

As contributor and enthusiast implementer and user I support the publication of this draft.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

The IETF WG state of draft-ietf-sfc-proof-of-transit has been changed
to "In WG Last Call" from "WG Document" by Joel Halpern:

Comment:
This starts WG last call for this document, ending June 30.
_______________________________________________
sfc mailing list
 [email-masked]<mailto:[email-masked]>
 https://www.ietf.org/mailman/listinfo/sfc

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição