Subject: Re: [sidr] draft-ietf-sidr-pfx-validate-01

From: Geoff Huston <[email-masked]>
Date: Thu, 5 May 2011 13:54:58 +1000

On 22/02/2011, at 5:36 AM, Pradosh Mohapatra wrote:

> The -01 version of the draft addresses the comments that were received during the last call, most notably:
> 
> http://www.ietf.org/mail-archive/web/sidr/current/msg02168.html
> http://www.ietf.org/mail-archive/web/sidr/current/msg02204.html
> 
> Would be great to have a round of review to verify the comments were indeed addressed and see if there are any new comments/concerns.
> 

Hi I have now reviewed this version of the draft

My previous review comment is at http://www.ietf.org/mail-archive/web/sidr/current/msg02168.html

I note that you have elected to address my review comments by removing text rather than adding explanation or guidance.

The current text simply states:

   Policies which could be implemented include filtering routes based on
   validation state (for example, rejecting all "invalid" routes) or
   adjusting a route's degree of preference in the selection algorithm
   based on its validation state.  The latter could be accomplished by
   adjusting the value of such attributes as LOCAL_PREF.  Considering
   invalid routes for BGP decision process is a pure local policy matter
   and should be done with utmost care.

This test appears to be less than helpful in so far as it offer no guidance at all!

I'm afraid that my original comment that this document is not ready to head to the IESG is still the case for me, and my original comments in my earlier review still stand.

regards,

   Geoff

---

From: Randy Bush <[email-masked]>
Date: Thu, 05 May 2011 09:32:49 +0200

i think/hope these concerns were addressed by moving operational
recommendations to draft-ietf-sidr-origin-ops

randy

---

From: Geoff Huston <[email-masked]>
Date: Thu, 5 May 2011 17:43:48 +1000

> recommendations to draft-ietf-sidr-origin-ops

Thanks for this. I would suggest to the pfx-validate draft author(s) that the pfx-validate
document then make a more explicit reference to this origin-ops document as being the
place where the operational considerations of how to treat the various ROA validation
outcomes in the context of local routing policy and the operational implications of
such local policy settings is considered. The shift of material from the pfx-validate
draft to the origin-ops draft is not clear when reviewing the pfx-validate text.

(Fair warning - I've not done a nit-pick scan of the pfx-validate draft to ensure that
normative text is used appropriately throughout the draft. My quick scan pointed to the need to
carefully comb through the draft as there appears to be still some further
instances of use of "may" vs "MAY" etc.)

regards,

Geoff

---

From: Randy Bush <[email-masked]>
Date: Thu, 05 May 2011 10:06:22 +0200

> I would suggest to the pfx-validate draft author(s) that the
> pfx-validate document then make a more explicit reference to this
> origin-ops document as being the place where the operational
> considerations of how to treat the various ROA validation outcomes in
> the context of local routing policy and the operational implications
> of such local policy settings is considered. The shift of material
> from the pfx-validate draft to the origin-ops draft is not clear when
> reviewing the pfx-validate text.

good point.  thanks.

> I've not done a nit-pick scan of the pfx-validate draft to ensure that
> normative text is used appropriately throughout the draft.

i hang on tenterhooks :)

randy