Subject: [sidr] RIB Size Estimation for BGPSEC

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Tue, 24 May 2011 08:28:05 -0400

In response to a request during Q&A at the SIDR WG meeting, April 1, in Prague,
I am posting the results of modeling and estimation of the RIB size for BGPSEC.
(I plan to present this work at the SIDR WG meeting in Quebec.)

Here is the link for the slides:

http://www.antd.nist.gov/~ksriram/BGPSEC_RIB_Estimation.pdf

I will also shortly post an excel spread sheet so you can input your view
of the BGPSEC world (signed prefix-paths you expect to see in your PE router
or route reflector over time), and observe the corresponding RIB size estimates.

Key observations/conclusions – mostly copied from the summary/conclusions slide (Slide #26):

o RIB sizes have been estimated for realistic Route Reflector (RR) and Provider Edge (PE) scenarios (with input from a large, Tier 1 ISP).

o Different signature algorithms considered (RSA-2048, ECDSA-256).

o RIB memory needs to be engineered so it is adequate for algorithm/protocol transition down the road.

o 15% yearly growth for # unique eBGP prefixes (377K in 2011 to 2.7M in 2025).

o 9.55x multiplier applied to determine # eBGP prefix paths in RR (i.e., # eBGP prefix paths in RIB = 9.55 x # unique eBGP prefixes).

o BGPSEC adoption curve – truncated Normal distribution (slides 7-9).
 
o RIB memory requirements (for the RR) are 0.5GB in 2016 to 8.3 GB in 2020 to 32 GB in 2025 (worst case assuming RSA-2048 all the way; see Slides 14, 16).

o But algorithm transition to ECDSA-256 likely (should happen) before 2020 [or perhaps even from Day 1 of BGPSEC deployment?].

o Assuming such transition, 20 GB for RIB memory would be a conservative estimate –  good all the way out to 2025 (see Slide 25).
 
Comments/suggestions are welcome.

Sriram

K. Sriram
http://www.antd.nist.gov/~ksriram/

---

From: "t.petch" <[email-masked]>
Date: Fri, 27 May 2011 17:50:45 +0200

RRG, before looking for some architectures that would solve the world's routing
problems, did discuss the expected capacity of DFZ routers,  given the expected
rate of growth of technology, so as to work out how long the IETF has got to
come up with something new.

The consensus was that routers could not be expected to support more than 1M
entries in the RIB which is somewhat less than the 2.7M you expect in 2025.  And
the new architecture could make the world look very different by then, with
outer routing headers for delivery to location, and inner routing headers for
delivery to the identified host.

Tom Petch

----- Original Message -----
From: "Sriram, Kotikalapudi" <[email-masked]>
To: "sidr wg list" <[email-masked]>
Sent: Tuesday, May 24, 2011 2:28 PM
Subject: [sidr] RIB Size Estimation for BGPSEC

http://www.antd.nist.gov/~ksriram/BGPSEC_RIB_Estimation.pdf
{ file:///D:/Articles/BGPSEC_RIB_Estimation.pdf }

Key observations/conclusions – mostly copied from the summary/conclusions slide
(Slide #26):

o RIB sizes have been estimated for realistic Route Reflector (RR) and Provider
Edge (PE) scenarios (with input from a large, Tier 1 ISP).

o RIB memory needs to be engineered so it is adequate for algorithm/protocol
transition down the road.

o 9.55x multiplier applied to determine # eBGP prefix paths in RR (i.e., # eBGP
prefix paths in RIB = 9.55 x # unique eBGP prefixes).

o RIB memory requirements (for the RR) are 0.5GB in 2016 to 8.3 GB in 2020 to 32
GB in 2025 (worst case assuming RSA-2048 all the way; see Slides 14, 16).

o But algorithm transition to ECDSA-256 likely (should happen) before 2020 [or
perhaps even from Day 1 of BGPSEC deployment?].

o Assuming such transition, 20 GB for RIB memory would be a conservative
estimate –  good all the way out to 2025 (see Slide 25).

Sriram

K. Sriram
http://www.antd.nist.gov/~ksriram/
_______________________________________________
sidr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sidr

---

From: John Scudder <[email-masked]>
Date: Tue, 31 May 2011 10:47:58 -0700

On May 27, 2011, at 11:50 AM, t.petch wrote:

> entries in the RIB
[...]

Really?  I wouldn't put too much stock in that, given that current routers support substantially more than 1M.

> which is somewhat less than the 2.7M you expect in 2025.

More than that too.

Possibly you meant FIB and not RIB?  The reported numbers are wrong for that too, though not as egregiously.

--John