Subject: [sidr] transfer of resources and the RPKI (fwd)

From: Sandra Murphy <[email-masked]>
Date: Sun, 12 Jun 2011 14:58:59 -0400 (Eastern Daylight Time)

There's been a difficulty with the recipient list on the message I sent 
last week.

Here is the message, with the cc list as I sent it.

The archive only shows Andrew's address on the cc list and the personal 
copy I got back from the list only contains Andrew on the cc list.

Alex's reply directly to me shows the entire cc list, so there's a good 
chance that the important people did see the message.  However, the 
archived version again has just Andrew on the cc list.

I've asked ietf-action for help here and I will check with the cc list to 
be certain they saw last week's message.

--Sandy

---------- Forwarded message ----------
Date: Thu, 9 Jun 2011 15:22:43 -0400 (Eastern Daylight Time)
From: Sandra Murphy <[email-masked]>
To: [email-masked]
Cc: Nishal Goburdhan <[email-masked]>, [email-masked], [email-masked],
     Mark Kosters <[email-masked]>, Arturo Servin <[email-masked]>,
     [email-masked], [email-masked]
Subject: transfer of resources and the RPKI

Transfer of resources (both intra-RIR and inter-RIR) has been a hot topic 
recently in the RIRs.  The RIRs have said that they are working on the process 
of accomplishing resource transfers wrt the RPKI.

I believe the work of the SIDR WG would be aided by a better understanding of 
how the RIRs are considering doing transfer of resources in the RPKI. Would you 
share your ideas with the WG?

This message is cc'd to the RIR staff who are my guess of the right people to 
answer the question.  If I've missed the right person, please excuse me.

--Sandy, speaking as wg chair

---

From: Sandra Murphy <[email-masked]>
Date: Sun, 12 Jun 2011 16:09:57 -0400 (Eastern Daylight Time)

I may have found the explanation.

The mailman nodupes field (which is set for sidr) is intended to prevent a 
list server copy from being sent to a recipient who is receiving a copy 
directly (thru cc or to).

However, I found the following message on the ietf list, which says that 
some implementations have a "flaw" that seems to prune the cc list also.

http://www.ietf.org/mail-archive/web/ietf/current/msg37128.html

The important part is:

==============

Specifics:  Mailman has a per-recipient setting called "nodupes".  The
effect of this setting is that any recipient address that has the
nodupes flag set, and which appears in a To or CC field of a message
sent to the list, will not receive a copy of the message from the
list.  It also appears (from emperical testing with a limited sample)
that the list may also remove that recipient's address from the CC
field of the copy of the message sent to the list.

==============

It's the "remove the recipient's address from the CC field" part that
applies to this problem.

This behavior creates an impression that some people were not copied on
the message when they were.

--Sandy

On Sun, 12 Jun 2011, Sandra Murphy wrote:

> There's been a difficulty with the recipient list on the message I sent last 
> week.
>
> The archive only shows Andrew's address on the cc list and the personal copy 
> I got back from the list only contains Andrew on the cc list.
>
> chance that the important people did see the message.  However, the archived 
> version again has just Andrew on the cc list.
>
> I've asked ietf-action for help here and I will check with the cc list to be 
> certain they saw last week's message.
>
> --Sandy
>
> recently in the RIRs.  The RIRs have said that they are working on the 
> process of accomplishing resource transfers wrt the RPKI.
>
> how the RIRs are considering doing transfer of resources in the RPKI. Would 
> you share your ideas with the WG?
>
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: Arturo Servin <[email-masked]>
Date: Sun, 12 Jun 2011 19:32:03 -0300

At least I received, I guess the others received the message as well.

	Regarding the transfers and RPKI, as group (RIRs) we are working on it. We have different scenarios with different trade-offs and we are still discussing them. Nevertheless each idea gets complicate very easily and it may be difficult to explain it by e-mail. I'll try to document with the group some of the ideas that we have discussed and we will share them with the WG.

	Just to start, one question that we have is that  by "transfers" you are referring to the space where a RIR is a majority holder and some pieces of that space are allocated to another RIR (i.e. ERX), or to the "new" transfers that may happen by the depletion of the IPv4 address space.

Best wishes,
.as

On 12 Jun 2011, at 15:58, Sandra Murphy wrote:

> There's been a difficulty with the recipient list on the message I sent last week.
> 
> The archive only shows Andrew's address on the cc list and the personal copy I got back from the list only contains Andrew on the cc list.
> 
> Alex's reply directly to me shows the entire cc list, so there's a good chance that the important people did see the message.  However, the archived version again has just Andrew on the cc list.
> 
> I've asked ietf-action for help here and I will check with the cc list to be certain they saw last week's message.
> 
> --Sandy
> 
> Transfer of resources (both intra-RIR and inter-RIR) has been a hot topic recently in the RIRs.  The RIRs have said that they are working on the process of accomplishing resource transfers wrt the RPKI.
> 
> I believe the work of the SIDR WG would be aided by a better understanding of how the RIRs are considering doing transfer of resources in the RPKI. Would you share your ideas with the WG?
> 
> This message is cc'd to the RIR staff who are my guess of the right people to answer the question.  If I've missed the right person, please excuse me.
>

---

From: Randy Bush <[email-masked]>
Date: Sun, 12 Jun 2011 22:21:13 -0600

> Just to start, one question that we have is that by "transfers" you
> are referring to the space where a RIR is a majority holder and some
> pieces of that space are allocated to another RIR (i.e. ERX), or to
> the "new" transfers that may happen by the depletion of the IPv4
> address space.

uh, how does running out of the free pool cause transfers?  i suspect
you are assuming a lot of layer nine causality here which may or may
not hold and is not technically relevant.

the issues is transfers of address between any two arbitrary holders.

i.e., see

   http://archive.psg.com/071208.transfer.pdf

randy

---

From: Arturo Servin <[email-masked]>
Date: Mon, 13 Jun 2011 12:41:16 -0300

On 13 Jun 2011, at 01:21, Randy Bush wrote:

> uh, how does running out of the free pool cause transfers?

	Changes in RIRs inter-RIR-transfer policies, the trigger would be the depletion of the IPv4, but let's focus on the technical stuff.

>  i suspect

	Thanks for the link. Let me read the document and I will post some comments.

> randy

Regards,
.as

---

From: Sandra Murphy <[email-masked]>
Date: Mon, 13 Jun 2011 12:08:52 -0400 (Eastern Daylight Time)

> 	Just to start, one question that we have is that  by "transfers" you are referring to the space where a RIR is a majority holder and some pieces of that space are allocated to another RIR (i.e. ER…

I actually meant transfers in general, both intra-RIR and inter-RIR.  I 
think information on all types of transfer would be helpful to the working 
group.

--Sandy

> On 12 Jun 2011, at 15:58, Sandra Murphy wrote:

<snip>

---

From: Byron Ellacott <[email-masked]>
Date: Tue, 14 Jun 2011 15:30:07 +1000

To reassure the WG, I did see this message - but any comments I would make would simply be repeating Arturo at this point.

-- Byron, speaking for APNIC

---

From: Stephen Kent <[email-masked]>
Date: Tue, 14 Jun 2011 13:49:01 -0400

>    http://archive.psg.com/071208.transfer.pdf

I think folks perceive that exhaustion of the IPv4 space is 
triggering some transfers that might not otherwise have occurred, 
because the going price may now be higher.

Steve