Subject: [sidr] review/adoption of draft-george-sidr-as-migration

From: "George, Wes" <[email-masked]>
Date: Wed, 29 May 2013 09:59:52 -0400

All - I have not received any feedback regarding this draft since I posted the revision incorporating the solution into it in February. Perhaps it's time to call WG adoption so that it can move forward?

http://tools.ietf.org/html/draft-george-sidr-as-migration-01

Thanks,

Wes George

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Randy Bush <[email-masked]>
Date: Thu, 30 May 2013 06:38:10 -0700

> All - I have not received any feedback regarding this draft since I
> posted the revision incorporating the solution into it in
> February. Perhaps it's time to call WG adoption so that it can move
> forward?

i thought i had previously supported adoption.  but, just in case, i do
so now.

randy

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Thu, 30 May 2013 15:44:23 +0000

Hi George, 

Thanks for writing this document, I think it is very good work!

One comment before sending my support email. The document is intended as "Informational" but do have requirement language. Is this what you intended?

Personally, I would rather all requirements to be moved to the requirements document so we have one unique point to read. We could publish then this document even as a "BCP" on a specific practice. Does point 3.15 of the BGPSEC requirements document seams not to cover your own requirements in Section 4. Do you think we can move the BGPSEC specific requirements to the other document?

Regards,
Roque

On May 29, 2013, at 3:59 PM, "George, Wes" <[email-masked]> wrote:

> All – I have not received any feedback regarding this draft since I posted the revision incorporating the solution into it in February. Perhaps it’s time to call WG adoption so that it can move forward?
>  
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: "George, Wes" <[email-masked]>
Date: Thu, 30 May 2013 12:14:18 -0400

From: Roque Gagliano (rogaglia) [mailto:[email-masked]]

The document is intended as "Informational" but do have requirement language. Is this what you intended?
[WEG] originally, it was just covering the problem statement. This last revision added the solution, and thus required some normative language to guide the implementation. That probably means the doc type needs to change, but I was looking to the WG for feedback on how to proceed (whether this should remain a standalone document as companion to the BGPSec protocol draft, or be integrated into it, or what). Last meeting, it sounded like the preference was to have this remain a standalone document, but I didn't hear any real guidance on whether it should formally update the BGPSec document or not.

Personally, I would rather all requirements to be moved to the requirements document so we have one unique point to read. We could publish then this document even as a "BCP" on a specific practice. Does point 3.15 of the BGPSEC requirements document seams not to cover your own requirements in Section 4. Do you think we can move the BGPSEC specific requirements to the other document?
[WEG] I have no objection to moving section 4 to sidr-bgpsec-reqs to add to 3.15. I documented them here because as noted above, originally this was a problem statement, and so it seemed important to ensure that any solutions could be evaluated against their success in meeting these requirements that are specific to AS-migration and aliasing.

Wes

On May 29, 2013, at 3:59 PM, "George, Wes" <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

Wes George

[email-masked]<mailto:[email-masked]>

* Persona Not Validated - 1368524010073 <[email-masked]<mailto:[email-masked]>>
* Issuer: Symantec Corporation - Unverified

---

From: Randy Bush <[email-masked]>
Date: Thu, 30 May 2013 10:46:43 -0700

> The document is intended as "Informational" but do have requirement
> language.

normative language in an info doc is perfectly normal and acceptable.

this doc does not create protcol, protocol data elements, ...  it says
HOW to do some tricks with already defined protocol and pdus.  so info
seems not unreasonable to me.

btw, this is a *really* cute bit of work.

randy

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Fri, 31 May 2013 09:26:44 +0000

Randy,

> seems not unreasonable to me.

That is why I was proposing moving it to BCP.

> btw, this is a *really* cute bit of work.

+1

Roque

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Fri, 31 May 2013 09:30:02 +0000

Hi Wes,

If we follow that strategy (make sure requirements are listed in BGPSEC req. document and change status to BCP for this document), I support adoption.

r.

On May 30, 2013, at 6:14 PM, "George, Wes" <[email-masked]> wrote:

> [WEG] originally, it was just covering the problem statement. This last revision added the solution, and thus required some normative language to guide the implementation. That probably means the doc type needs to change, but I was looking to the WG for feedback on how to proceed (whether this should remain a standalone document as companion to the BGPSec protocol draft, or be integrated into it, or what). Last meeting, it sounded like the preference was to have this remain a standalone document, but I didn’t hear any real guidance on whether it should formally update the BGPSec document or not.
>  
> * Persona Not Validated - 1368524010073 <[email-masked]>

---

From: Randy Bush <[email-masked]>
Date: Fri, 31 May 2013 06:13:09 -0700

> That is why I was proposing moving it to BCP.

PBP, proposed best practice?

randy