Subject: Re: [sidr] key management drafts

From: "Murphy, Sandra" <[email-masked]>
Date: Fri, 2 Aug 2013 08:31:58 +0000

Seriously, folks.  Nothing?  Really?

--Sandy

________________________________________
From: [email-masked] [[email-masked]] on behalf of Murphy, Sandra [[email-masked]]
Sent: Friday, July 12, 2013 5:23 PM
To: [email-masked]
Subject: [sidr] key management drafts

Any system that uses cryptography finds that the key management aspects are a very important part.

We have two drafts at the moment that are related to key management - draft-ietf-sidr-bgpsec-rollover and draft-ietf-sidr-rtr-keying.

There's been little comment on these drafts since they were adopted as wg drafts.  Key management is not simple, and the impact on the system could be large.

So this is a poke to try to review these drafts and comment.

--Sandy, speaking for the co-chairs
_______________________________________________
sidr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sidr

---

From: Stephen Kent <[email-masked]>
Date: Thu, 29 Aug 2013 02:39:38 -0400

Sandy,

I support draft-ietf-sidr-rtr-keying, but it is clearly not ready. It 
contains quite
a few notes from Sean, embedded in the text, that need to be resolved.
It also needs to be updated to cite EST as an RFC. I'll send comments to 
Sean directly.

I am not supportive of draft-ietf-sidr-bgpsec-rollover in its current form.

Section 3.1 is too tentative to be in a standard, e.g., it says
" If we work under the assumption that an automatic mechanism will
exist to rollover a BGPSEC certificate, a possible process could be:"

I am very uncomfortable with Section 4, which proposes key rollover
as a way to deal with replay attacks.

The null security considerations section is inappropriate.

Steve