Subject: [sidr] WGLC for draft-ietf-sidr-origin-validation-signaling-04

From: Sandra Murphy <[email-masked]>
Date: Fri, 25 Apr 2014 19:53:14 -0400

The authors of BGP Prefix Origin Validation State Extended Community, draft-ietf-sidr-origin-validation-signaling-04 have requested a WGLC.

This message begins a two week WGLC, to end on 9 May 2014.  

The draft is available at http://tools.ietf.org/html/draft-ietf-sidr-origin-validation-signaling.

Please do send comments to the list, indicating whether you do or do not believe that the draft is ready for publication.

--Sandy, speaking as wg co-chair

---

From: Randy Bush <[email-masked]>
Date: Fri, 25 Apr 2014 23:28:13 -0700

from a running router

    policy-statement rpki {
        term valid {
            from {
                protocol bgp;
                validation-database valid;
            	}
            then {
		validation-state valid;
                community add whatever-the-heck-i-want;
                accept;
            	}
            }

there is an invalid drop policy-statement too, but no sense for it to
set a community as it ain't goin' nowhere.

randy

---

From: Sandra Murphy <[email-masked]>
Date: Mon, 28 Apr 2014 09:17:20 -0400

Could you say please whether this means you support publication or you do not?

--Sandy

---

From: Randy Bush <[email-masked]>
Date: Mon, 28 Apr 2014 21:21:36 +0300

>> set a community as it ain't goin' nowhere.

because the goal of this draft can already be reached simply through use
of existing means, i do not support publication.  i am not strongly
opposed.  it's just one more bit of ietf work that is not obviously
needed.

randy

---

From: Warren Kumari <[email-masked]>
Date: Mon, 28 Apr 2014 15:25:32 -0400

>>> set a community as it ain't goin' nowhere.

And from one of the IETF meeting routers:

 community RPKI_Invalid members 56554:102;
 community RPKI_Unknown members 56554:103;
 community RPKI_Valid members 56554:101;

policy-statement RPKI-Primary {
        term valid {
            from {
                protocol bgp;
                validation-database valid;
            }
            then {
                local-preference 210;
                validation-state valid;
                community add RPKI_Valid;
            }
        }
        term invalid {
            from {
                protocol bgp;
                validation-database invalid;
            }
            then {
                local-preference 190;
                validation-state invalid;
                community add RPKI_Invalid;
            }
        }
        term unknown {
            from {
                protocol bgp;
                validation-database unknown;
            }
            then {
                local-preference 200;
                validation-state unknown;
                community add RPKI_Unknown;
            }
        }
    }

I don't really see how the proposal (which is at least concise!) is
better / makes my life easier -- it seems like syntactic sugar to me,
but not actually harmful. I don't care if it gets published or not.
> opposed.  it's just one more bit of ietf work that is not obviously

... and this is the bit I'm actually responding to -- it is unusual
for an author to not support publication of their own document, and am
a little confused what it means. How should the chairs interpret this
-- It is a stronger statement if an author says that than if a random
participant does?

W

>
> randy
>
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr