Subject: [sidr] rpki-tree-validation vs. madi-sidr-rp

From: Stephen Kent <[email-masked]>
Date: Tue, 28 Jun 2016 14:19:41 -0400

Although I was not present at the BA SIDR meeting, I did participate 
remotely for one of the sessions. I recall the discussion of the I-D 
that tries to collect all of the RP requirements in one place, with 
cites to the sources of these requirements. It part, I recall folks at 
the mic arguing that this I-D was redundant relative to the existing WG 
document on tree validation. I don't think this is an accurate 
comparison of the two docs, although I agree that there is overlap 
between them.

RPKI tree validation describes how the RIPE RP software works. It 
includes references to 6 SIDR RFCs to explain why the software performs 
certain checks. The RP requirements doc cites 11 SIDR RFCs, plus the 
BGPsec (router cert) profile. Thus it appears that the requirements doc 
tries to address a wider set of RFCs relevant to RP requirements. More 
importantly, the requirements doc is generic, while the tree validation 
doc is expressly a description of one RP implementation. Thus it is an 
example of how that implementation tries to meet the RP requirements, 
not a general characterization of RP requirements.

Thus I think it appropriate to proceed with both docs.

Steve

---

From: Declan Ma <[email-masked]>
Date: Thu, 30 Jun 2016 13:09:02 +0800

Hi, all,

Speaking as the co-author of ‘Requirements for Resource Public Key Infrastructure (RPKI) Relying Parties’,

In addition to the clarification made by Steve, I would like to deliver a clear message here that this draft is intended to make the RP requirements well framed, which are segmented with orthogonal functionalities in different sections.

As such, those ‘functional components’ could be crafted and distributed across the operational timeline of an RP software . 

We would appreciate your comments on this document.

Di
ZDNS

> 在 2016年6月29日，02:19，Stephen Kent <[email-masked]> 写道：
> 
> Although I was not present at the BA SIDR meeting, I did participate remotely for one of the sessions. I recall the discussion of the I-D that tries to collect all of the RP requirements in one place, with cites to the sources of these requirements. It part, I recall folks at the mic arguing that this I-D was redundant relative to the existing WG document on tree validation. I don't think this is an accurate comparison of the two docs, although I agree that there is overlap between them.
> 
> RPKI tree validation describes how the RIPE RP software works. It includes references to 6 SIDR RFCs to explain why the software performs certain checks. The RP requirements doc cites 11 SIDR RFCs, plus the BGPsec (router cert) profile. Thus it appears that the requirements doc tries to address a wider set of RFCs relevant to RP requirements. More importantly, the requirements doc is generic, while the tree validation doc is expressly a description of one RP implementation. Thus it is an example of how that implementation tries to meet the RP requirements, not a general characterization of RP requirements.
> 
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: Tim Bruijnzeels <[email-masked]>
Date: Thu, 30 Jun 2016 16:46:57 +0200

Hi,

The point that I was trying to make, but maybe not clearly, is that rpki-tree-validation is indeed intended as an Informational document specifically detailing our implementation only, but that the RP implementers discussed earlier during WG sessions that we might want to create a generalised RP requirement, or even BCP validation document at a later stage. So I was just somewhat surprised to see this come up.

That being said, we are all busy, so I have no problem with you taking the lead in the effort to document the generalised RP requirements instead. Especially as an Informational document referencing the authoritative docs - as it seems to do.

Tim

> On 30 Jun 2016, at 07:09, Declan Ma <[email-masked]> wrote:
> 
> Hi, all,
>