Subject: [Sidrops] Fwd: New Version Notification for draft-yossigi-rpkimaxlen-02.txt

From: Job Snijders <[email-masked]>
Date: Mon, 5 Mar 2018 19:15:04 +0100

Dear working group,

This document has gone through a number of revisions outside the working group.

As authors we think it may be time to consider a call for adoption and
continue work on this document in context of the working group.

Thoughts?

Kind regards,

Job

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Mon, Mar 5, 2018 at 7:09 PM
Subject: New Version Notification for draft-yossigi-rpkimaxlen-02.txt
To: Job Snijders <[email-masked]>, Kotikalapudi Sriram
<[email-masked]>, Ben Maddison <[email-masked]>,
Yossi Gilad <[email-masked]>, Sharon Goldberg <[email-masked]>

A new version of I-D, draft-yossigi-rpkimaxlen-02.txt
has been successfully submitted by Job Snijders and posted to the
IETF repository.

Name:           draft-yossigi-rpkimaxlen
Revision:       02
Title:          The Use of Maxlength in the RPKI
Document date:  2018-03-05
Group:          Individual Submission
Pages:          10
URL:
https://www.ietf.org/internet-drafts/draft-yossigi-rpkimaxlen-02.txt
Status:         https://datatracker.ietf.org/doc/draft-yossigi-rpkimaxlen/
Htmlized:       https://tools.ietf.org/html/draft-yossigi-rpkimaxlen-02
Htmlized:
https://datatracker.ietf.org/doc/html/draft-yossigi-rpkimaxlen-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-yossigi-rpkimaxlen-02

Abstract:
   This document recommends that operators avoid using the maxLength
   attribute when issuing Route Origin Authorizations (ROAs) in the
   Resource Public Key Infrastructure (RPKI).  These recommendations
   complement those in [RFC7115].

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 05 Mar 2018 21:58:08 +0000

This is not a dumb draft.  Please adopt.

Nick
> Job Snijders <mailto:[email-masked]>
> 5 March 2018 at 18:15
> Dear working group,
>
> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops
> ------------------------------------------------------------------------

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Mon, 5 Mar 2018 22:05:57 +0000

Hi Job,

I agree on adoption.

Roque

— 
Roque Gagliano

Automation Software Architect EMEAR

+41 76 449 8867
 
Join the NSO Digital Ecosystem:
NSO on DevNet: www.cisco.com/go/nsodevnet <http://www.cisco.com/go/nsodevnet>
NSO Developer Hub: www.cisco.com/go/nsohub <http://www.cisco.com/go/nsohub>

On 05/03/18 19:15, "Sidrops on behalf of Job Snijders" <[email-masked] on behalf of [email-masked]> wrote:

    Dear working group,

    
    Thoughts?
    
    Kind regards,
    
    Job

    ---------- Forwarded message ----------
    From:  <[email-masked]>
    Date: Mon, Mar 5, 2018 at 7:09 PM
    Subject: New Version Notification for draft-yossigi-rpkimaxlen-02.txt
    To: Job Snijders <[email-masked]>, Kotikalapudi Sriram
    <[email-masked]>, Ben Maddison <[email-masked]>,
    Yossi Gilad <[email-masked]>, Sharon Goldberg <[email-masked]>

    
    Abstract:

    The IETF Secretariat

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Mar 2018 17:09:16 -0500

ah sweet... can we end this adoption call:
  26 Mar 2018

thanks!

On Mon, Mar 5, 2018 at 5:05 PM, Roque Gagliano (rogaglia) <
[email-masked]> wrote:

> NSO Developer Hub: www.cisco.com/go/nsohub <http://www.cisco.com/go/nsohub
> >
>
>
> On 05/03/18 19:15, "Sidrops on behalf of Job Snijders" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Dear working group,
>

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Mon, 5 Mar 2018 22:12:32 +0000

Hi,

As a separate note from my adoption comment, I believe the draft is missing one key point on the use of maxLenght related to RPKI convergence delay. So, if I set the Minimal ROAs but I need to perform a change (for any reason and not only DDoS), I would need to wait until RPKI converges around the globe to see my announcements accepted everywhere (getting RPs to fetch new crypto material and run validation logic).

The ability to perform any changes  in my routing policies at any time is key driver for the use of maxLenght and it would be nice to include that operational aspect in this BCP.

Regards,
Roque

—
Roque Gagliano

Join the NSO Digital Ecosystem:
NSO on DevNet: www.cisco.com/go/nsodevnet<http://www.cisco.com/go/nsodevnet>
NSO Developer Hub: www.cisco.com/go/nsohub<http://www.cisco.com/go/nsohub>

From: Sidrops <[email-masked]> on behalf of Nick Hilliard <[email-masked]>
Date: Monday 5 March 2018 at 22:58
To: Job Snijders <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Ben Maddison <[email-masked]>
Subject: Re: [Sidrops] Fwd: New Version Notification for draft-yossigi-rpkimaxlen-02.txt

Nick

Job Snijders<mailto:[email-masked]>
5 March 2018 at 18:15
Dear working group,

Thoughts?

Kind regards,

Job

---------- Forwarded message ----------
From: <[email-masked]><mailto:[email-masked]>
Date: Mon, Mar 5, 2018 at 7:09 PM
Subject: New Version Notification for draft-yossigi-rpkimaxlen-02.txt
To: Job Snijders <[email-masked]><mailto:[email-masked]>, Kotikalapudi Sriram
<[email-masked]><mailto:[email-masked]>, Ben Maddison <[email-masked]><mailto:[email-masked]>,
Yossi Gilad <[email-masked]><mailto:[email-masked]>, Sharon Goldberg <[email-masked]><mailto:[email-masked]>

Abstract:

The IETF Secretariat

_______________________________________________
Sidrops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sidrops

---

From: Job Snijders <[email-masked]>
Date: Mon, 5 Mar 2018 22:17:39 +0000

On Mon, Mar 05, 2018 at 10:12:32PM +0000, Roque Gagliano (rogaglia) wrote:
> As a separate note from my adoption comment, I believe the draft is
> missing one key point on the use of maxLenght related to RPKI
> convergence delay. So, if I set the Minimal ROAs but I need to perform
> a change (for any reason and not only DDoS), I would need to wait
> until RPKI converges around the globe to see my announcements accepted
> everywhere (getting RPs to fetch new crypto material and run
> validation logic).
> 
> The ability to perform any changes in my routing policies at any time
> is key driver for the use of maxLenght and it would be nice to include
> that operational aspect in this BCP.

Similarly, one would need to wait until RPKI converges around the globel
to see a hijack being mitigated; if the hijack was possible because
non-minimal ROAs were used.

A liberal application of MaxLength does indeed offer a degree of
flexibility, but as the draft describes, that flexibility comes at the
price of increased risk and less prototection.

Do you have a specific snippet of text as suggestion for inclusion?

Kind regards,

Job

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Mon, 5 Mar 2018 22:20:43 +0000

Hi Job,

I will send you some text and you are correct that the convergency delay goes in both directions.

Roque

On 05/03/18 23:17, "Sidrops on behalf of Job Snijders" <[email-masked] on behalf of [email-masked]> wrote:

    

    Kind regards,
    
    Job

---

From: Tim Bruijnzeels <[email-masked]>
Date: Tue, 6 Mar 2018 11:21:21 +0100

Support adoption!

> On 5 Mar 2018, at 23:09, Christopher Morrow <[email-masked]> wrote:
> 
> On Mon, Mar 5, 2018 at 5:05 PM, Roque Gagliano (rogaglia) <[email-masked]> wrote:
> Hi Job,
> 
> I agree on adoption.
> 
> Roque
> 
> —
> Roque Gagliano
>

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Fri, 16 Mar 2018 17:03:33 +0000

I read through the draft and find it important. 
I agree on adoption as well,

Oliver

On 3/5/18, 5:06 PM, "Sidrops on behalf of Roque Gagliano (rogaglia)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Job,
    
    I agree on adoption.
    
    Roque
    
    — 
    Roque Gagliano

    +41 76 449 8867
     
    Join the NSO Digital Ecosystem:
    NSO on DevNet: https://na01.safelinks.protection.outlook.com/?url=www.cisco.com%2Fgo%2Fnsodevnet&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=wtFSGaW7RQSWs%2FxdLx%2BZGLuqr0gbL%2FfofU8NktFEJWQ%3D&reserved=0 <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cisco.com%2Fgo%2Fnsodevnet&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=MEwdyrB4D6dzsxXlQs%2FfeP4DwFDsJHP%2BHQ7vWU0Yap0%3D&reserved=0>
    NSO Developer Hub: https://na01.safelinks.protection.outlook.com/?url=www.cisco.com%2Fgo%2Fnsohub&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=nyWV6uRObjH104d%2BX2zoxZAqeDnAzCyjiTJjL9u1vDM%3D&reserved=0 <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cisco.com%2Fgo%2Fnsohub&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=PdjkEOvRg8DHPjONKGwqMvu6BYGQboiRhv7YjC8uFpg%3D&reserved=0>

        Dear working group,

        
        Thoughts?
        
        Kind regards,
        
        Job

        ---------- Forwarded message ----------
        From:  <[email-masked]>
        Date: Mon, Mar 5, 2018 at 7:09 PM
        Subject: New Version Notification for draft-yossigi-rpkimaxlen-02.txt
        To: Job Snijders <[email-masked]>, Kotikalapudi Sriram
        <[email-masked]>, Ben Maddison <[email-masked]>,
        Yossi Gilad <[email-masked]>, Sharon Goldberg <[email-masked]>

        Name:           draft-yossigi-rpkimaxlen
        Revision:       02
        Title:          The Use of Maxlength in the RPKI
        Document date:  2018-03-05
        Group:          Individual Submission
        Pages:          10
        URL:
        https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-yossigi-rpkimaxlen-02.txt&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=OWB5yneINQLp5tzYQQvZg6koN3bHy7asN9JHbv%2FJRNk%3D&reserved=0
        Status:         https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-yossigi-rpkimaxlen%2F&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=225TBPvpIVi66I7SK6ANZ48J56Cjqhgxe21FxciVrng%3D&reserved=0
        Htmlized:       https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-yossigi-rpkimaxlen-02&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=6ABcQbOm7f2aTmW2EVVmwUKk9YQMBb4sbKYz6w6VqGU%3D&reserved=0
        Htmlized:
        https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yossigi-rpkimaxlen-02&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=NMae0U196Di%2FC%2BdZBRo7IH%2BDWD1qjyHmS5iXnmZNpsA%3D&reserved=0
        Diff:           https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-yossigi-rpkimaxlen-02&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=1EalS4U1Dvqici%2FZ2yFXF9bBK1Zsi4w5eyuvLewJy6o%3D&reserved=0
        
        Abstract:

        The IETF Secretariat
        
        _______________________________________________
        Sidrops mailing list
        [email-masked]
        https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=Tl3Z1XeHwXsXi%2Fb7jjkN38z%2B8mRPJ%2Bu44NBaE8LihXk%3D&reserved=0

    _______________________________________________
    Sidrops mailing list
    [email-masked]
    https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&data=02%7C01%7Coliver.borchert%40nist.gov%7C2d8996465f664637c4a708d582e558ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636558843906076617&sdata=Tl3Z1XeHwXsXi%2Fb7jjkN38z%2B8mRPJ%2Bu44NBaE8LihXk%3D&reserved=0