Subject: Re: [Sidrops] WGLC: draft-ietf-sidrops-rtr-keying - ENDS: 10/31/2018 (halloscream!)

From: Randy Bush <[email-masked]>
Date: Thu, 01 Nov 2018 19:24:02 +0700

> This didn't get any comments, so ... does that mean move forward? (which
> seems reasonable to me after a bunch of discussion in SIDR and revisions
> and comments there)

this is sidr[ops].  why don't we sit on it for a few years?

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Thu, 1 Nov 2018 13:30:08 +0000

Hi Randy/Chris,

I read the document and I found it well written. Probably Appendix B is the clearest part BTW. 

I am going to jump do give two cosmetic comments.

1) Why using "rtr" in the document's name? This got me confused that the document was related to RFC6810.

2) Section 3: You are giving as an option to use RFC2585. I understand that we are only exchanging signed documents and there is no need for SFTP/TLS but this may jump in further reviews from people outside of this domain as "unsecured" because of its use for FTP/HTTP. 

Maybe we should add an obvious comment such as: "Each of these options have security considerations described in the referred documents." 

Regards,
Roque

— 

    
    
    _______________________________________________
    Sidrops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sidrops

---

From: Sean Turner <[email-masked]>
Date: Thu, 1 Nov 2018 16:10:45 -0400

> On Nov 1, 2018, at 09:30, Roque Gagliano (rogaglia) <[email-masked]> wrote:
> 
> Hi Randy/Chris,
> 

Ah I see where that might be confusing for now, but rtr, which is router, goes away when it gets published ;)

> Maybe we should add an obvious comment such as: "Each of these options have security considerations described in the referred documents.” 

While the security considerations do not explicitly call out 2585, there is this bit and we are kind of hoping that it covers a wide variety of sins:

   This document defines no protocols so in some sense introduces no new
   security considerations.  However, it relies on many others and the
   security considerations in the referenced documents should be
   consulted; ...

spt

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 5 Nov 2018 13:18:26 +1100

Ok, I believe sean's efforts here lead to us agreeing to move forward. If
there are complaints from mgmt we can adjust the security considerations
portion to address those concerns, but for now... I'll plan to push this
forward to IESG by end of day today.

"Are there any IPR encumbered bits in this document?" (for the authors,
which I believe Randy said 'no' to... sean?)

On Fri, Nov 2, 2018 at 7:10 AM Sean Turner <[email-masked]> wrote:

> > 2) Section 3: You are giving as an option to use RFC2585. I understand
> that we are only exchanging signed documents and there is no need for
> SFTP/TLS but this may jump in further reviews from people outside of this
> domain as "unsecured" because of its use for FTP/HTTP.
> >
> > Maybe we should add an obvious comment such as: "Each of these options
> have security considerations described in the referred documents.”
>
> While the security considerations do not explicitly call out 2585, there
> is this bit and we are kind of hoping that it covers a wide variety of sins:
>
> > On 01/11/18 13:24, "Sidrops on behalf of Randy Bush" <
> [email-masked] on behalf of [email-masked]> wrote:
> >

---

From: Sean Turner <[email-masked]>
Date: Tue, 6 Nov 2018 09:31:57 +0700

> On Nov 5, 2018, at 09:18, Christopher Morrow <[email-masked]> wrote:
> 
> Ok, I believe sean's efforts here lead to us agreeing to move forward. If there are complaints from mgmt we can adjust the security considerations portion to address those concerns, but for now... I'll plan to push this forward to IESG by end of day today.
> 
> "Are there any IPR encumbered bits in this document?" (for the authors, which I believe Randy said 'no' to... sean?)

No