Subject: [Sidrops] I-D Action: draft-ietf-sidrops-rp-03.txt

From: [email-masked]
Date: Mon, 28 Jan 2019 21:25:22 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the SIDR Operations WG of the IETF.

        Title           : Requirements for Resource Public Key Infrastructure (RPKI) Relying Parties
        Authors         : Di Ma
                          Stephen Kent
	Filename        : draft-ietf-sidrops-rp-03.txt
	Pages           : 11
	Date            : 2019-01-28

Abstract:
   This document provides a single reference point for requirements for
   Relying Party (RP) software for use in the Resource Public Key
   Infrastructure (RPKI) in the context of securing Internet routing.
   It cites requirements that appear in several RPKI RFCs, making it
   easier for implementers to become aware of these requirements that
   are segmented with orthogonal functionalities.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sidrops-rp/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sidrops-rp-03
https://datatracker.ietf.org/doc/html/draft-ietf-sidrops-rp-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sidrops-rp-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Di Ma <[email-masked]>
Date: Tue, 29 Jan 2019 13:49:17 +0800

Hi, folks,

We authors just updated this draft as follow: 

1) TAL

Considering draft-ietf-sidrops-https-tal seems to be ready for WGLC, we authors replaced RFC 7730 with it where the TAL topics are mentioned.

2) Distributing RPKI validated cache

In light of a new model of how RP service the validated cache,  which by the way, has been used by Cloudflare, we authors are slightly changed the description in Section 5 in terms of distributing RPKI validated cache. 

That is, the RP may deliver the validated cache via HTTPs to a cache server who is responsible for provisioning validated cache to BGP speakers.

https://blog.cloudflare.com/rpki-details/

We think this method is making sense for big ISPs, ICPs and a third party RP in the cloud. 

And RPSTIR (bgpsecurity.net) the RP software has also supported transferring validated cache via https, which is expected to go public in Github this year. 

We would appreciate your comments.

And if there is no major changed needed hereafter, we expect WGLC issued for this document. 

Di

> 在 2019年1月29日，13:25，[email-masked] 写道：
> 
> 
> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops