Subject: Re: [Sidrops] [sidr] Opsdir last call review of draft-ietf-sidrops-rtr-keying-02

From: Sean Turner <[email-masked]>
Date: Tue, 15 Jan 2019 20:55:57 -0800

Apologies for just finding this now …

I seem to remember a WG discussion about whether this draft should be BCP or ST.  We discussed BCP addressing both what the IETF wanted to be the best practice as well as what is the actual current practice.  Since BGPsec was/is new it was/is hard to say it fell in the latter bucket and there was at least one person who felt that the router and operator driven methods weren’t the way to go in the future (hence why there is s8 the "advanced deployment scenarios” section).  So the WG said go ST and because this draft has exhausted me we just changed it to ST.  I will note that the SECDIR and RTGDIR both had this same comment it seems like we’re back to BCP.  I think there was another message somewhere about changing this to BCP so I will do that in -03 unless I hear otherwise.

spt

> On Dec 26, 2018, at 08:29, Christopher Morrow <[email-masked]> wrote:
> 
> BCP seems like a fine answer here, I'm not remembering why we would have swapped to ST from BCP.
> 
> On Wed, Dec 26, 2018 at 11:12 AM Warren Kumari <[email-masked]> wrote:
> [ + Sandy, Alvaro ]
> 
> On Wed, Dec 26, 2018 at 9:51 AM Scott Bradner <[email-masked]> wrote:
> that use of a MUST is commendable but its not exactly an interoperability issue 
> 
> to me “must” works in this case (and the other cases in this document)
> 
> but, that said, 2119 has been misused for kinda a long time so its not a new sin
> 
> 
> This document has a long history -- it was originally a product of the SIDR Working Group (as draft-ietf-sidr-rtr-keying), and only moved over to SIDROPS recently, when SIDR closed down (https://datatracker.ietf.org/wg/sidr/about/).
> 
> The document was originally a BCP (https://datatracker.ietf.org/doc/draft-ietf-sidr-rtr-keying/09/), but was changed to Standards Track in -10 (https://www.ietf.org/archive/id/draft-ietf-sidr-rtr-keying-10.txt).
> 
> 
> I have gone back through the agenda and minutes for IETF 92 (https://datatracker.ietf.org/doc/agenda-92-sidr/), IETF 93 (https://datatracker.ietf.org/doc/agenda-93-sidr/) and IETF 94 (https://datatracker.ietf.org/doc/agenda-94-sidr/). 
> I also went back and watched the video recordings from IETF 94: https://youtu.be/fElkBi4UMEA?t=2397 and wasn't able to find any discussion of why the change was made, but I *was* able to find some changes made between -09 and -10 which seem to be the outcome of those discussions. 
> 
> Authors / SIDROPS [0] & SIDR / chairs -  can y'all remember why the track change was made? 
> 
> Whatever the case, the IETF LC was done as Standards Track (a higher level), and so it could always be "downgraded" to BCP / informational during IESG Eval.
> I personally think it "feels" like BCP, but I don't have full history / inherited the document and don't want to be arbitrarily making changes.
> 
> 
> W
> [0]: SIDROPS and SIDR participant overlap is almost 100%.
> 
> 
>  
> Scott
> 
> > On Dec 26, 2018, at 9:25 AM, Randy Bush <[email-masked]> wrote:
> > 
> > mornin’ scott,
> > 
> >> it is hard to see why it should be standards track or why it should 
> >> be using RFC 2119 type terminology.
> > 
> > these are two separate issues.  
> > 
> > alvaro and the chairs can adjudicate what flavor of ice cream it should
> > be.  it my memory says it was a wg decision.  i really do not care.
> > 
> > as to 2119 language, i kinda feel it should remain.  it is used
> > sparingly. but is crucial when used.  e.g.
> > 
> >      all private keys MUST be protected when at rest in a secure
> >      fashion.
> > 
> > i suspect we would want to keep that strongly prescriptive; but it is
> > not a hill on which i am interested in dying.
> > 
> > randy
> 
> 
> 
> -- 
> I don't think the execution is relevant when it was obviously a bad idea in the first place.
> This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
>    ---maf
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: Warren Kumari <[email-masked]>
Date: Wed, 16 Jan 2019 15:14:30 -0500

On Tue, Jan 15, 2019 at 11:56 PM Sean Turner <[email-masked]> wrote:

> I seem to remember a WG discussion about whether this draft should be BCP
> or ST.  We discussed BCP addressing both what the IETF wanted to be the
> best practice as well as what is the actual current practice.  Since BGPsec
> was/is new it was/is hard to say it fell in the latter bucket and there was
> at least one person who felt that the router and operator driven methods
> weren’t the way to go in the future (hence why there is s8 the "advanced
> deployment scenarios” section).  So the WG said go ST and because this
> draft has exhausted me we just changed it to ST.

Ah, awesome, I'm glad someone remembers the original reason.

> I will note that the SECDIR and RTGDIR both had this same comment it seems
> like we’re back to BCP.  I think there was another message somewhere about
> changing this to BCP so I will do that in -03 unless I hear otherwise.
>

Yes please, and thank you for solving the mystery.
W

> > This document has a long history -- it was originally a product of the
> SIDR Working Group (as draft-ietf-sidr-rtr-keying), and only moved over to
> SIDROPS recently, when SIDR closed down (
> https://datatracker.ietf.org/wg/sidr/about/).
> >
> > The document was originally a BCP (
> https://datatracker.ietf.org/doc/draft-ietf-sidr-rtr-keying/09/), but was
> changed to Standards Track in -10 (
> https://www.ietf.org/archive/id/draft-ietf-sidr-rtr-keying-10.txt).
> >
> >
> > I have gone back through the agenda and minutes for IETF 92 (
> https://datatracker.ietf.org/doc/agenda-92-sidr/), IETF 93 (
> https://datatracker.ietf.org/doc/agenda-93-sidr/) and IETF 94 (
> https://datatracker.ietf.org/doc/agenda-94-sidr/).
> > I also went back and watched the video recordings from IETF 94:
> https://youtu.be/fElkBi4UMEA?t=2397 and wasn't able to find any
> discussion of why the change was made, but I *was* able to find some
> changes made between -09 and -10 which seem to be the outcome of those
> discussions.
> >
> > Whatever the case, the IETF LC was done as Standards Track (a higher
> level), and so it could always be "downgraded" to BCP / informational
> during IESG Eval.
> > I personally think it "feels" like BCP, but I don't have full history /
> inherited the document and don't want to be arbitrarily making changes.
> >
> >
> > W
> > This is like putting rabid weasels in your pants, and later expressing
> regret at having chosen those particular rabid weasels and that pair of
> pants.
> >    ---maf

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf