Subject: Re: [Sidrops] WG Adoption call draft-azimov-sidrops-aspa-verification

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Thu, 28 Feb 2019 16:16:06 +0000

Hi Alex,
I'll be happy to support but can you please take care of comment #1
prior to completion of the adoption call.
And while you are at it, comment #6 would be also easy to incorporate.
They should take no more than 10 minutes in all.
My other comments are important as well, but they only need discussion for now.

Comment #1:
I would strongly suggest deletion of the last two sentences of
the second paragraph in the Intro section.
You talk about downgrade attacks with BGPsec there.
The two sentences in question are inconsistent with how
incremental deployment of BGPsec really works.
Please read RFC 8205 Section 7.9 -- the idea of contiguous BGPsec ASes.
Regarding your attacker downgrading BGPsec comments,
John Scudder also suggested to you in IETF 102,
"It is not necessary to make that extreme claim for your proposal,
if I were you, I wouldn't."  See video at ~48 minute mark:
https://www.youtube.com/watch?v=LnXLB_MlpAs

Comment #2: Improvement of the algorithm for detection
Consider this topology example:

         AS3              AS5
         /       \        /
    AS2         AS4
   /
AS1

The peering relations are C2P going up and P2C going down (in the pic).
AS1, AS2 and AS4 have created ASPAs. AS3 has not created ASPA.
Let us say AS4 accidentally leaks to AS5 the route received from AS3.
The route's AS_PATH is AS4 AS3 AS2 AS1.
I think your algorithm (section 5) would fail to detect the leak.
But I would suggest a modified algorithm which is as follows:
At AS5, when it sees that AS3 does not have ASPA, it then considers
the ASPA of the next more recent AS in the path which is AS4 here.
>From AS4's ASPA, AS5 determines that AS3 is a provider of AS4,
and hence successfully detects that the update is a route leak.
So, I think the algorithm in section 5 needs to be modified per suggestion above.

Comment #3:
In the figure below, AS1 originates p1 and AS2 originates p2.
AS1 is a provider of AS2 for p1 and AS1 is a customer of AS2 for p2.
AS1 announces p1 to AS2 as P2C. AS2 announces p2 to AS1 as P2C.
AS3 is provider of AS2.

                   ---------P2C------->
                           p1 AS1 --->                                      -----p1 AS2 AS1--->
AS1------------------(hybrid/complex)----------AS2---------- C2P ----------->AS3
                         <--- p2 AS2
                   <---------P2C-------
AS1 creates an ASPA: {AS1, AS2, IPv4}
AS2 creates an ASPA: {AS2, AS1, IPv4}

Now consider AS2 leaks route for p1 to AS3. Then AS3 is unable to detect the leak.
AS3 looks at the ASPA: {AS1, AS2, IPv4} and determines that AS1 is a customer of AS2,
and hence determines incorrectly that the Update: p1 AS2 AS1 is not a leak.
The ASPA scheme fails to work in this case for leak detection.
This is a limitation of the ASPA scheme because ASPAs are per AFI and not per prefix.

Comment #4: Not all malicious leaks / hijacks are detected
In the topology below, AS2 leaks the path it learned from its peer AS4 to
its provider AS3 with path modification to avoid route leak detection,
or one may think of it as a hijack with feasible path insertion.
In either case, the Update: p2 AS2 AS1 from AS2 to AS3 is
illegitimate but defies detection despite all ASes participating in ASPA.

         AS3                                                             AS5
              \  p1 AS2 AS1                                     /
                \ p2 AS2 AS1                                 /
                   \                                                 /
                     \         <----p2 AS4 AS1--    /
                       AS2 -------p2p----------AS4
                          \                             /
                             \ p1 AS1          /p2 AS1
                                 \               /
                                     AS1
                                   (p1, p2)

Comment #5: Path verification vs. path feasibility
Based on the above examples, in the draft, perhaps it is better to say
that the path is assessed feasible rather than say that the path is verified.

Comment #6:
In paragraph #1 in the Intro section, [I-D.ymbk-idr-bgp-eotr-policy] is referenced.
Based on WG consensus, we merged [I-D.ymbk-idr-bgp-eotr-policy] and
[I-D.idr-route-leak-detection-mitigation] and the latter is the WG document
that we are working on together since April 2018.
So, [I-D.idr-route-leak-detection-mitigation] is the more appropriate
document to cite for the ongoing WG effort.

Thanks.
Sriram

---

From: Alexander Azimov <[email-masked]>
Date: Thu, 28 Feb 2019 20:53:07 +0300

Sriram,

I'm glad to see your comments! Please see my answers below.

Comment #1:
> “It is not necessary to make that extreme claim for your proposal,
>
> if I were you, I wouldn’t.”  See video at ~48 minute mark:
>
Can you please clarify to me next scenario with three ISPs:

   - Victim advertises /23 to Upstream, does use BGPSec, has ROA record
   with maxlength 24
   - Upstream, does use BGPSec
   - Attacker, advertises /24 that belongs to Upstream, adds its ASN in the
   beginning of ASPath, doesn't use BGPSec

Will Upsream, according to RFC8205, accept hijacked route from Attacker?
Anyway, I'm open for discussion about proper wording here.

> The route’s AS_PATH is AS4 AS3 AS2 AS1.
>
> From AS4’s ASPA, AS5 determines that AS3 is a provider of AS4,
>
This suggestion sounds great but it has an issue. Imagine that AS3 and AS4
have what is commonly named 'complex' relation. So they are both
customer-provider to one another. And in your scenario, where only AS4
creates ASPA it may result in rejection of valid routes, which will make
AS4 quite unhappy...

> This is a limitation of the ASPA scheme because ASPAs are per AFI and not
Fully agreed. Simplicity comes with its own cost.
And that's why we still need community-based leak detection that can work
per-prefix. And it's our duty as-coauthors (and my debt, which I need to
admit) to finally push it forward.
I'm going to add an explicit statement in the next version of the draft.

>          AS3
> AS5
Thinking about it as hijack adds simplicity to the picture. Customers may
still be hijacked by its direct or indirect providers. While it
significantly limits the attacker vector and highly unlikely to happen in
the real world, it must be clearly stated in the draft. Pushed to stack.

> that the path is assessed feasible rather than say that the path is
I'm not a native speaker but for me 'feasibility' sounds a bit odd. I would
be glad to learn other opinions from the wg members. Anyway, this question
should not become a showstopper.

> document to cite for the ongoing WG effort.
I don't think there was a need in such a detailed history of the question.
:)
Valid point. I'll change the link with the next update.

-- 
Best regards,
Alexander Azimov