Subject: Re: [Sidrops] WGLC for draft-ietf-sidrops-ov-egress-00.txt - ENDS 11/25/2019 (November 25 2019)

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Wed, 27 Nov 2019 21:10:38 +0000

I think the draft should make a recommendation that
the AS must create a ROA in the first place for the
prefix with the correct origin AS that will result
after the policies are applied.

I feel that the following paragraph in the draft is fuzzy/incorrect.

   "Configurations may have complex policy where the final announced
   origin AS may not be easily predicted before all policies have been
   run.  Therefore it SHOULD be possible to specify an origin validation
   policy which MUST BE run after such non-deterministic policies."

Is there such a thing as non-deterministic policy?
What does it mean to say that the outcome of applying
one or a set of policies is that it results in
a random AS being the origin AS?
Or, to say that the origin AS is not predictable?
Well, if it cannot be predicted then the sending AS under
consideration is not in a position to create
the ROA that is necessary. This cannot be.

Suggested text (or some variation of it):
The operator MUST determine the origin AS
based on policies that are applied on egress, and
MUST create a ROA accordingly.
The sending BGP speaker MUST perform origin validation
at egress (i.e., after the policies are applied).

Sriram

---

From: Randy Bush <[email-masked]>
Date: Wed, 27 Nov 2019 16:17:08 -0500

> after the policies are applied.

and their payments to ther RIR should be current

> a random AS being the origin AS?

non-derministic != random

in this case it is meant to refer to policy results which depend on
exogenous data

randy