Subject: Re: [Sidrops] IETF106 -- Singapore -- Call for Agenda Items

From: Tim Bruijnzeels <[email-masked]>
Date: Mon, 4 Nov 2019 15:24:07 +0100

Hi Keyur, WG,

> On 28 Oct 2019, at 13:53, Keyur Patel <[email-masked]> wrote:
> 
> Ack. Please make sure to submit the draft before the cut-off.

https://datatracker.ietf.org/doc/draft-sidrops-bruijnzeels-deprecate-rsync/ <https://datatracker.ietf.org/doc/draft-sidrops-bruijnzeels-deprecate-rsync/>

I just wrote this in my name, but I have spoken with some other people who may want to co-author if this goes further.

For now, I just wanted to get a -00 out there, so we can discuss as a WG.

Thanks,
Tim

> 
> Regards,
> Keyur
> 
>> On Oct 28, 2019, at 12:54 AM, Tim Bruijnzeels <[email-masked]> wrote:
>> 
>>  Hi Keyur,
>> 
>> I would like to take 10-15 minutes to talk about phasing out rsync as a mandatory transport in future. 
>> 
>> Spoiler: I believe that we can should start a discussion to make RRDP mandatory to implement, and rsync optional. But we need to do an inventory, and probably do measurements to track capabilities of servers and RPs. There is no draft yet, but I will submit something before the cut-off.
>> 
>> Tim
>> 
>>> On 25 Oct 2019, at 18:39, Keyur Patel <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi folks,
>>>  
>>> SIDROPS will meet at IETF106 on Wednesday, November 20th from 3:20 pm – 4:50 pm. Please forward any SIDROPS agenda items you may have to Chris and me. Please also make sure that your slides are available to the chairs by Friday morning (11/15/2019). Slides received after the deadline may not be available for use during the meeting.
>>>  
>>> Regards,
>>> Chris and Keyur 
>>>  
>>> _______________________________________________
>>> Sidrops mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/sidrops <https://www.ietf.org/mailman/listinfo/sidrops>
> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 4 Nov 2019 11:36:27 -0500

this would be grand to discuss.

On Mon, Nov 4, 2019 at 9:24 AM Tim Bruijnzeels <[email-masked]> wrote:
> https://datatracker.ietf.org/doc/draft-sidrops-bruijnzeels-deprecate-rsync/
>
> On 25 Oct 2019, at 18:39, Keyur Patel <[email-masked]> wrote:
>
> Hi folks,
>

---

From: Randy Bush <[email-masked]>
Date: Mon, 04 Nov 2019 10:49:18 -0800

tim,

great to get the draft out there.  wish it was more specific about how
this is operationally accomplished.  e.g. from the discussion i was
trying to have with you:

0 - publishers publish rcynic and some rrdp.  rps use rcynic and some
    use rrdp

1 - all publishers offer both.

2 - then you can ask all rps to move to rrdp and prefer it

3 - you can see, at the publishers, when no rcynic requests come

4 - you can turn off rcynic at the publishers

5 - you can remove rcynic from the rps

randy

---

From: Alexander Azimov <[email-masked]>
Date: Mon, 4 Nov 2019 22:44:30 +0300

Hi all,

I would like to take 10 minutes for ASPA drafts update.

-- 
Best regards,
Alexander Azimov

---

From: Randy Bush <[email-masked]>
Date: Mon, 04 Nov 2019 11:46:18 -0800

and we probably should spend a few minutes on the make before break
issue, which the exhumation of the transfer draft is meant to help.

randy

---

From: Keyur Patel <[email-masked]>
Date: Mon, 4 Nov 2019 19:48:41 +0000

Done.  Might assign 15 mins of schedule permits. :)

On Nov 4, 2019, at 11:44 AM, Alexander Azimov <[email-masked]> wrote:

Hi all,

пн, 4 нояб. 2019 г. в 21:49, Randy Bush <[email-masked]<mailto:[email-masked]>>:
tim,

randy

_______________________________________________
Sidrops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sidrops

--
Best regards,
Alexander Azimov

---

From: Keyur Patel <[email-masked]>
Date: Mon, 4 Nov 2019 19:49:51 +0000

Ack. Signed you up for 10 mins.

> On Nov 4, 2019, at 11:46 AM, Randy Bush <[email-masked]> wrote:
>

---

From: Tim Bruijnzeels <[email-masked]>
Date: Tue, 5 Nov 2019 13:53:14 +0100

Hi Randy,

> On 4 Nov 2019, at 19:49, Randy Bush <[email-masked]> wrote:
> 
> tim,
> 
> great to get the draft out there.  

Before responding to your points below, I want to highlight another aspect of this document:

I propose that rsync URIs continued to be used as identifiers, even if there may no longer be an rsync service. Identifiers will still be useful, and introducing e.g. URNs for this would introduce breaking changes, and this would make it much, much harder to progress.

> wish it was more specific about how

Indeed, for the moment document just focusses on an end goal where neither publishers, nor RPs need to implement rsync.

> 5 - you can remove rcynic from the rps

And after having reached out to some RIRs I have good hope that this is not too far off. Still, when we spoke I proposed a different timeline, which assumed (perhaps wrongly) that RPs would update their code, before publishers:

1 - all RPs support RRDP and prefer it

2 - you can see, at the publishers, when no rcynic requests come

3 - you can turn off rcynic at the publishers

4 - we ask all publishers to support RRDP

5 - RPs can drop support for rsync

I don't have enough information to know which comes first. Therefore the document currently just says that:
- RPs can drop support for rsync when all publishers support RRDP,
- publishers can drop support for rsync when (almost) all RPs support RRDP

The latter is a bit of an issue, because even if all recent RPs support RRDP, there will probably be some old versions deployed. There comes a point where you may need to leave some behind. Within reason of course, and after measuring. I don't think we can agree on a magic number. But some kind of flag day seems unavoidable.

I am all for discussing this on the list and during the session, but for now I did not feel comfortable proposing one way in the doc. Also, we probably would want to remove this before last-call (assuming adoption of course..).

Tim