Subject: Re: [Sidrops] Adopt draft-sidrops-bruijnzeels-deprecate-rsync?

From: Christopher Morrow <[email-masked]>
Date: Thu, 16 Jul 2020 13:24:23 -0400

Howdy!
It looks like this got a bunch of support, so could the authors please
kick out a renamed draft and let's see to the next stage? :)

thanks!
-chris
co-chair 1 of 3

On Wed, Apr 29, 2020 at 9:19 AM Tim Bruijnzeels <[email-masked]> wrote:
>
> Dear co-chairs, WG,
>
> As mentioned yesterday I would like ask the chairs to do a call for adoption on:
> https://datatracker.ietf.org/doc/draft-sidrops-bruijnzeels-deprecate-rsync/
>
> I am also more than happy to discuss the content, and adapt following discussion, but maybe this is better done if adopted :)
>
> Thanks
> Tim
> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops

---

From: Tim Bruijnzeels <[email-masked]>
Date: Tue, 21 Jul 2020 12:51:55 +0200

Hi Chris, WG,

I was away for the weekend and I missed the I-D cutoff. I have the renamed version ready, and will submit after 2020-07-25 23:59 UTC.

Do we need to discuss this again on during the meeting on Monday?

The issues that I think could be most controversial are:

1) rsync URIs as object identifiers (section 4)

In summary: the document proposes that we keep rsync URI as useful object identifiers even if the objects cannot be retrieved at that location. The main reason for this is pragmatism: introducing a new kind of object identifier (e.g. URN based) would introduce a breaking change and make deployment much, much harder.

2) rsync still allowed

Currently the document says (tries to say) that if operators want, they can still leave an rsync server running. While they are not required to do so, it is not forbidden either.

3) rsync URIs in RRDP - can they be trusted?

Finally, we recently had a discussion related to manifests (6484-bis) and a concern was raised that the rsync URIs in the RRDP XML cannot be trusted. I took this to the list on 25 June (subject RRDP and rsync URIs).

Essentially I argued that while any RRDP server can include any rsync URI in the <publish> and <withdraw> elements in its XML, this is not really an issue because relying parties know both the rsync URI *and* the RRDP server when validating - so they can look for the rsync URI at the relevant RRDP server only.

If desired I can include some words on this in a -01 version, after the -00 (rename only) has been submitted.

Please let me know if any of you feel that this should be discussed again during the WG session!

Tim

> On 16 Jul 2020, at 19:24, Christopher Morrow <[email-masked]> wrote:
> 
> Howdy!

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 21 Jul 2020 21:49:57 +0000

> I was away for the weekend and I missed the I-D cutoff. I have the renamed version ready, and will submit after 2020-07-25 23:59 UTC.

hopefully you had a good weekend! :)

> Do we need to discuss this again on during the meeting on Monday?

I don't THINK so? :) but we can mention it in the chair slides section
and say: "If there's more than a quick question we can just re-read
the renamed draft and interim in ~3 more weeks" ?

> Please let me know if any of you feel that this should be discussed again during the WG session!

I think just a quick note and then interim if we need more deep discussion.
I'd like the main focus to be agreeing on the -bis text... then we can
stack the next set of contentious discussions :)

---

From: Tim Bruijnzeels <[email-masked]>
Date: Wed, 22 Jul 2020 07:52:50 +0200

Hi Chris,

> On 21 Jul 2020, at 23:49, Christopher Morrow <[email-masked]> wrote:
> 

sure, let's see - maybe things can be resolved over email as well :)

> stack the next set of contentious discussions :)

works for me!