Subject: [Sidrops] [WGLC] draft-sidrops-bgpsec-validation-signaling-03 - ends 25/August/2020

From: Keyur Patel <[email-masked]>
Date: Tue, 11 Aug 2020 18:45:05 +0000

Hi Folks:

A working group last call has been requested for draft-sidrops-bgpsec-validation-signaling-03, “BGPsec Validation State Signaling”. Please reply to the list with your comments. The WGLC will end on August 25, 2020.

The draft can be found at:  https://tools.ietf.org/html/draft-sidrops-bgpsec-validation-signaling-03.  Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Regards,
Keyur

---

From: Nick Hilliard <[email-masked]>
Date: Tue, 11 Aug 2020 21:57:39 +0100

Keyur Patel wrote on 11/08/2020 19:45:
> A working group last call has been requested for 
> draft-sidrops-bgpsec-validation-signaling-03, “BGPsec Validation State 
> signaling”. Please reply to the list with your comments. The WGLC will end 
> on August 25, 2020.

In general, replicating validation functionality using BGP communities 
is a poor idea and from an ops point of view, it seems wiser as a long 
term objective to push vendors to support bgpsec than to implement hacks 
like this.  For this reason I don't support publication of the draft as 
an rfc.

Major issues:

1. The draft lacks a problem statement and a sunset clause.

2. Previously there's been a good deal of discussion on sidrops about 
RPKI validation state signalling.  Several problems were listed here:

> https://mailarchive.ietf.org/arch/msg/sidrops/YV1WfoxQNiwfOjtKIY1d6YJjRxM/

Most of the problems associated with validation state signalling 
identified in that email also apply to bgpsec validation state 
signalling, namely:

- crypto authentication is lost
- different and incompatible set of signalling hooks

In particular all the problems associated with RPKI validation state 
signalling over eBGP also apply to bgpsec state signalling over eBGP.

Defining this as non-transitive is a good start, but the language needs 
to change to ensure that it cannot escape an ASN.  Can I suggest the 
following text changes:

change:
>    If the router supports the extension as defined in this document, it
>    SHOULD attach the BGPsec path validation state extended community to
>    BGPsec UPDATE messages sent to BGP peers by mapping the locally
>    computed validation state into the last octet of the extended
>    community.  This SHOULD be done automatically for iBGP peers and
>    configurable for eBGP peers (see below).

to:
>    If the router supports the extension as defined in this document, it
>    SHOULD attach the BGPsec path validation state extended community to
>    BGPsec UPDATE messages sent to iBGP peers by mapping the locally
>    computed validation state into the last octet of the extended
>    community.

and change:
>    By default, routers SHOULD enable use of this
>    community on all iBGP sessions and routers SHOULD disable the use of
>    this community on all eBGP sessions.  Implementations MUST NOT send
>    more than one instance of the origin validation state extended
>    community and MUST drop (without processing) the BGPsec path
>    validation state extended community if received over an External BGP
>    (eBGP) peering session that has not be explicitly configured to
>    enable processing.

to:
>    By default, routers SHOULD enable use of this
>    community on all iBGP sessions.  Implementations MUST NOT send
>    more than one instance of the origin validation state extended
>    community, MUST NOT attach the BGPsec path validation state extended
>    community to BGPsec UPDATE messages sent to eBGP peers and MUST drop
>    (without processing) the BGPsec path validation state extended community
>    if received over an eBGP peering session.
Nick

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Wed, 26 Aug 2020 00:11:31 +0000

Nick,

This point has been made in the past (about origin validation signaling) and I think it is a bit of a red herring.

Operators can and are signaling validation state today with ad-hoc use of communities.  Operators do this for multiple reasons, including providing some resilience to the system should a router lose access to validating caches, to detect and diagnose RPKI state skew among routers in the same network etc.   Not having a standardized encoding of this practice won't be the determining factor of how this kind of signaling is used.

In the case of BGPsec, the need for diagnostics and resilience will be even higher.  Remember there is no "not found" in BGPsec to fall back to loss of contact with RPKI data.  If such signaling also facilitated performance optimizations or implementation of consistent policy decisions on routers that have deferred their own validation procedures, it actually might encourage more deployment than discourage it as you suggest.

In short, I see such mechanisms as supporting and encouraging deployment of these technologies - or at worse being a non-factor to the adoption question - as those who want to do this in non-standard ways will just continue to do so.

Oliver

-----------------------------------------------
Oliver Borchert, Computer Scientist
National Institute of Standards and Technology
(Office) +1.301.975.4856
(GVoice) +1.240.668.4117

On 8/11/20, 4:59 PM, "Sidrops on behalf of Nick Hilliard" <[email-masked] on behalf of [email-masked]> wrote:

    Major issues:

    2. Previously there's been a good deal of discussion on sidrops about 
    RPKI validation state signalling.  Several problems were listed here:

    > https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fsidrops%2FYV1WfoxQNiwfOjtKIY1d6YJjRxM%2F&amp;data=02%7C01%7Coliver.borchert%40nist.gov%7Cf3710792241d4bae15bc08d83e397d8c%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637327763936298280&amp;sdata=jfbGfpeLvSkbjjMYjIxzHtKA%2BmW3l%2B6Esky8QGrw1NQ%3D&amp;reserved=0

    Nick

    _______________________________________________
    Sidrops mailing list
    [email-masked]
    https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&amp;data=02%7C01%7Coliver.borchert%40nist.gov%7Cf3710792241d4bae15bc08d83e397d8c%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637327763936298280&amp;sdata=auM0IyvMSRptpkD2LVEWInQIJqTEanKyc4b%2BElrTEHc%3D&amp;reserved=0

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Wed, 26 Aug 2020 02:17:47 +0000

I support the publication of this draft as an RFC.
I've closely followed the draft's progress/revisions based on feedback/discussions at sidrops wg meetings.
I feel that the draft in its current version is well written and in good shape to advance.

Sriram

---

From: Mehmet Adalier <[email-masked]>
Date: Tue, 25 Aug 2020 20:37:28 -0700

>From an industry perspective, I support the publication of this draft as an RFC. 
I have reviewed the draft in detail. It is quite solid and I believe it will add value.

Mehmet Adalier
Antara Teknik LLC

On 8/25/20, 7:18 PM, "Sidrops on behalf of Sriram, Kotikalapudi (Fed)" <[email-masked] on behalf of kotikalapudi.sriram=[email-masked]> wrote:

    Sriram  
    _______________________________________________
    Sidrops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sidrops

---

From: Nick Hilliard <[email-masked]>
Date: Wed, 26 Aug 2020 10:54:47 +0100

Oliver,

the difficulty here is not that operators might be using this, it's 
whether these signals cross administrative boundaries.  It's one thing 
to use this on your own network, and even though it's not something that 
I'd view as being a very good idea, there are two mitigating factors: 1. 
your network, your rules and 2. it's ibgp only which means that your 
interior routing infrastructure will get a full view of all routes and 
will be able to make informed routing decisions, where bgpsec signaled 
routes can be evaluated in context alongside other candidate routes.

The difficulty here is applying this to EBGP.  If this draft ends up as 
a standards track document, this is giving the process the IETF stamp of 
approval that this is a good idea and recommended practice.  This is a 
very poor idea for the reasons which I've detailed previously.

Nick

---

From: "Montgomery, Douglas C. (Fed)" <[email-masked]>
Date: Wed, 26 Aug 2020 14:06:20 +0000

Nick,

I think that can and should be addressed in the security considerations section.  

The spec mandates that the signal be non-transitive - it only provides insight as to the validation result of your immediate peer.

Having said that, here are those that feel this functionality, especially in the case of BGPsec, provides useful functionality, that increases the resilience of the entire system, and provides a much-needed diagnostic capability (for operations and monitoring infrastructures).  

I suspect concerns of brittleness and lack of diagnostics are more of an impediment to adoption than concerns about distributed trust models.

The other choice is that operators will still do this in non-standard ways and we will lose the opportunity to leverage the potential robustness and diagnostic benefits.

In general, I think the supposition that we will somehow influence / constrain implementation and deployment architectures by not specifying simple mechanisms such as this, is already proven to be false.

dougm
--
DougM @ NIST

On 8/26/20, 5:55 AM, "Nick Hilliard" <[email-masked]> wrote:

    Oliver,

    Nick

    Borchert, Oliver (Fed) wrote on 26/08/2020 01:11:
    >      > https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fsidrops%2FYV1WfoxQNiwfOjtKIY1d6YJjRxM%2F&amp;data=02%7C01%7Cdougm%40nist.gov%7Ccdccd3e4feac413e5edd08d849a61c95%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637340325111492030&amp;sdata=JH6g44hs2umnzmrIpUEwH0sN4h%2BpvtvqMFg%2FiyGkfkg%3D&amp;reserved=0
    > 
    >      https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&amp;data=02%7C01%7Cdougm%40nist.gov%7Ccdccd3e4feac413e5edd08d849a61c95%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637340325111492030&amp;sdata=xZhWjlOCk7rDY3huLZoIDGdjo3D1JionK6dZ%2FqYF4EA%3D&amp;reserved=0
    > 
    > https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&amp;data=02%7C01%7Cdougm%40nist.gov%7Ccdccd3e4feac413e5edd08d849a61c95%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637340325111492030&amp;sdata=xZhWjlOCk7rDY3huLZoIDGdjo3D1JionK6dZ%2FqYF4EA%3D&amp;reserved=0
    >

---

From: Nick Hilliard <[email-masked]>
Date: Wed, 26 Aug 2020 16:32:29 +0100

Montgomery, Douglas C. (Fed) wrote on 26/08/2020 15:06:
> The spec mandates that the signal be non-transitive - it only
> provides insight as to the validation result of your immediate  peer.

This doesn't really work from an IETF standards track point of view 
because it's an actively harmful proposal at the point that tagged 
routes cross from one ASN to another, i.e. including immediate peers.

It's not appropriate to publish an RFC which makes a recommendation 
about a security mechanism in the text and then makes a statement in the 
security section that effectively nullifies the recommendation.

I get the other use cases that you're describing - these are all 
applicable to iBGP use, and I'm not arguing against them:  just against 
ever seeing this mechanism on an EBGP session.

Nick

> Having said that, here are those that feel this functionality,
> especially in the case of BGPsec, provides useful functionality, that
> increases the resilience of the entire system, and provides a
> much-needed diagnostic capability (for operations and monitoring
> infrastructures).
> 
> I suspect concerns of brittleness and lack of diagnostics are more of
> an impediment to adoption than concerns about distributed trust
> models.
> 
> The other choice is that operators will still do this in non-standard
> ways and we will lose the opportunity to leverage the potential
> robustness and diagnostic benefits.
> 
> In general, I think the supposition that we will somehow influence /
> constrain implementation and deployment architectures by not
> specifying simple mechanisms such as this, is already proven to be
> false.
> 
> dougm -- DougM @ NIST
> 
> whether these signals cross administrative boundaries.  It's one
> thing to use this on your own network, and even though it's not
> something that I'd view as being a very good idea, there are two
> mitigating factors: 1. your network, your rules and 2. it's ibgp only
> which means that your interior routing infrastructure will get a full
> view of all routes and will be able to make informed routing
> decisions, where bgpsec signaled routes can be evaluated in context
> alongside other candidate routes.
> 
> The difficulty here is applying this to EBGP.  If this draft ends up
> as a standards track document, this is giving the process the IETF
> stamp of approval that this is a good idea and recommended practice.
> This is a very poor idea for the reasons which I've detailed
> previously.
> 
> Nick
> 
>> This point has been made in the past (about origin validation
>> signaling) and I think it is a bit of a red herring.
>> 
>> Operators can and are signaling validation state today with ad-hoc
>> use of communities.  Operators do this for multiple reasons,
>> including providing some resilience to the system should a router
>> lose access to validating caches, to detect and diagnose RPKI state
>> skew among routers in the same network etc.   Not having a
>> standardized encoding of this practice won't be the determining
>> factor of how this kind of signaling is used.
>> 
>> In the case of BGPsec, the need for diagnostics and resilience will
>> be even higher.  Remember there is no "not found" in BGPsec to fall
>> back to loss of contact with RPKI data.  If such signaling also
>> facilitated performance optimizations or implementation of
>> consistent policy decisions on routers that have deferred their own
>> validation procedures, it actually might encourage more deployment
>> than discourage it as you suggest.
>> 
>> In short, I see such mechanisms as supporting and encouraging
>> deployment of these technologies - or at worse being a non-factor
>> to the adoption question - as those who want to do this in
>> non-standard ways will just continue to do so.
>> 
>> Oliver
>> 
>> ----------------------------------------------- Oliver Borchert,
>> Computer Scientist National Institute of Standards and Technology 
>> (Office) +1.301.975.4856 (GVoice) +1.240.668.4117
>> 
>> 
>> On 8/11/20, 4:59 PM, "Sidrops on behalf of Nick Hilliard"
>> <[email-masked] on behalf of [email-masked]> wrote:
>> 
>>> draft-sidrops-bgpsec-validation-signaling-03, “BGPsec Validation
>>> State signaling”. Please reply to the list with your comments.
>>> The WGLC will end on August 25, 2020.
>> 
>> In general, replicating validation functionality using BGP
>> communities is a poor idea and from an ops point of view, it seems
>> wiser as a long term objective to push vendors to support bgpsec
>> than to implement hacks like this.  For this reason I don't support
>> publication of the draft as an rfc.
>> 
>> Major issues:
>> 
>> 2. Previously there's been a good deal of discussion on sidrops
>> about RPKI validation state signalling.  Several problems were
>> listed here:
>> 
>> - crypto authentication is lost - different and incompatible set of
>> signalling hooks
>> 
>> In particular all the problems associated with RPKI validation
>> state signalling over eBGP also apply to bgpsec state signalling
>> over eBGP.
>> 
>> Defining this as non-transitive is a good start, but the language
>> needs to change to ensure that it cannot escape an ASN.  Can I
>> suggest the following text changes:
>> 
>> change:
>>> If the router supports the extension as defined in this document,
>>> it SHOULD attach the BGPsec path validation state extended
>>> community to BGPsec UPDATE messages sent to BGP peers by mapping
>>> the locally computed validation state into the last octet of the
>>> extended community.  This SHOULD be done automatically for iBGP
>>> peers and configurable for eBGP peers (see below).
>> 
>> to:
>>> If the router supports the extension as defined in this document,
>>> it SHOULD attach the BGPsec path validation state extended
>>> community to BGPsec UPDATE messages sent to iBGP peers by mapping
>>> the locally computed validation state into the last octet of the
>>> extended community.
>> 
>> and change:
>>> By default, routers SHOULD enable use of this community on all
>>> iBGP sessions and routers SHOULD disable the use of this
>>> community on all eBGP sessions.  Implementations MUST NOT send 
>>> validation state extended community if received over an External
>>> BGP (eBGP) peering session that has not be explicitly configured
>>> to enable processing.
>> 
>> to:
>>> By default, routers SHOULD enable use of this community on all
>>> iBGP sessions.  Implementations MUST NOT send more than one
>>> instance of the origin validation state extended community, MUST
>>> NOT attach the BGPsec path validation state extended community to
>>> BGPsec UPDATE messages sent to eBGP peers and MUST drop (without
>>> processing) the BGPsec path validation state extended community 
>> _______________________________________________ Sidrops mailing
>> list [email-masked] 
>> _______________________________________________ Sidrops mailing
>> list [email-masked] 
> _______________________________________________ Sidrops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/sidrops
>

---

From: Randy Bush <[email-masked]>
Date: Wed, 26 Aug 2020 10:07:15 -0700

> Signaling”. Please reply to the list with your comments. The WGLC will
> end on August 25, 2020.

i think this is as good as we will do in this area.  sad to say, among
other things, we are going to have rov incapable devices in our networks
for some years.

but yes nick, perhaps sec cons could be sterner about filtering the
community.  as you know, i am not fond of communities and leakage
thereof.  but we're not going over to idr and creating an attribute.

randy