Subject: [Simple] RE: [Sipping] draft-olson-sipping-content-indirect-00.txt

From: Sean Olson <[email-masked]>
Date: Tue, 9 Apr 2002 10:07:15 -0700 (PDT)

I absolutely appreciate your concern. Simply
put, any system must have an appropriately defined
security mechanism in place for any packets it
receives. Ignoring Content-Disposition: for now,
what dangers do you perceive for handling an INVITE,
or a SUBSCRIBE, or a REFER, or ... ? This is
roughly equivalent to the problem of handling CPL 
upload. How do you trust the CPL you receive to
know it is safe to execute? Assuming there is
an answer to that question, can you apply that
answer to an "execute" disposition?

I would like to solicit other people's comments
on this topic. If there is sufficient pushback,
I'll remove this item.

Thanks!
/sean

--- "Beck01, Wolfgang" <[email-masked]> wrote:
> Sean,
> 
> disposition "execute" in REQ-2 is very dangerous. A
> popular E-mail program
> used to have a similar function enabled by default,
> which resulted
> in a worldwide breakdown of many mail servers. Even
> "render" might be dangerous, if
> the document uses some language like PostScript or
> Word macros.
> 
> 
> --
> Wolfgang Beck
> T-Systems Nova GmbH 
> 
> 

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Tue, 9 Apr 2002 15:20:29 +0200

Sean,

disposition "execute" in REQ-2 is very dangerous. A popular E-mail program
used to have a similar function enabled by default, which resulted
in a worldwide breakdown of many mail servers. Even "render" might be dangerous, if
the document uses some language like PostScript or Word macros.

--
Wolfgang Beck
T-Systems Nova GmbH

---

From: Bobby Sardana <[email-masked]>
Date: Tue, 09 Apr 2002 18:57:04 -0700

I am sure that the appropriate UAC will implement a "security sandbox" for both the
"execute" and "render" feature set. A properly designed UAC will also allow such
features to be manually disabled.

Personally, I like the "execute" feature as it allows new services to be deployed on
the UAC.

regards,

Bobby Sardana.
[email-masked]