Subject: [Simple] Status summary

From: "Avshalom Houri" <[email-masked]>
Date: Sun, 14 Apr 2002 17:57:42 +0300

In the SIMPLE components adhoc meeting at IETF53, I have volunteered to 
summarize the various statuses used in various systems. The summary is 
below.

While going over the various statuses it occurred to me that we need a 
more 
precise definition of what we mean when we say status. The various status 
values 
in the various systems can be divided into:

* Mood - Happy, Sad etc.

* Hint - I am on the phone therefore I will probably not be able to 
respond 
  immediately. The way that the my client will display the message to me 
e.g.
  in Away mode some clients will display the message in a different way 
from
  the way they do in normal online mode. 

* Availability - Am I open or close to communication. The availability can 
be 
  simple just open or close or quite complex - I am open to communication 
  depending on who is calling and in which location am I.

While moods and hints can be localized to vendors and clients, it seems 
that 
availability is the part of the status that mostly needs standardization.

The summary:
===========

# AOL - No explicit status - only idle indication by sensing mouse and 
keyboard activity.

# MSN - Open and close statuses + hints
        * Online (OPEN)
        * Busy (CLOSED)
        * Be Right Back (OPEN)
        * Away (OPEN)
        * On the Phone (CLOSED)
        * Out to Lunch (OPEN)
        * Appear Offline (Lurking, CLOSED)

# YAHOO - Open and close + hints for open.
        * Offline (CLOSED)
        * Available (OPEN) 
        * Busy with various messages (configurable) e.g. Be Right Back, Busy 
          etc. (OPEN) 
        * Invisible (Lurking can be done only in login time) 

# ICQ - Open and close statuses. Open statuses are accompanied by hints. 
For 
  example if I am in DND, I will still get messages but the messages will 
not be 
  displayed on my screen.
        Simple Mode
                * Available
                * Away (OPEN, Messages are shown on the screen)
                * Offline
        Advanced Mode
                * Available
                * Free for chat
                * Away
                * N/A (Extended Away)
                * Occupied (Urgent messages)
                * DND (Do Not Disturb)
                * Privacy (Invisible) - Lurking
                * Offline

# Louts Sametime - Open and close + strong DND. Strong DND means that I am 
not 
  able to send a message to a person that is in DND mode
        * Active (OPEN)
        * DND (Online but closed)
        * Away (OPEN, an hint)

# Wireless Village - As defined by the spec status is composed from 
several 
  attributes as: availability, preferred contacts etc. Following is a 
complete 
  list. 
        * User availability
                - AVAILABLE
                - NOT_AVAILABLE
                - DISCREET (selectively available. Likd DND or busy in other systems)
         
        * Preferred Contacts (preferred contact method of the user + address of 
          contact)
                - CALL
                - SMS
                - MMS (Multi Media SMS)
                - IM
                - EMAIL
        * Preferred Language
        * Status Text (free text describing the status)
        * Status Mood (e.g. HAPPY, SAD, etc.)
        * Alias (alias name for the user)
        * Status Content - MMS content or URL to the MMS content that the user 
          has selected as personal status information.
        * Contact Info - Contact information (vCard)

# PAM Forum - As described in a previous message Jorge Lobo" 
  <[email-masked]>. PAM forum has separate layers of presence 
information and 
  availability. Availability can be computed by a very simple methods or 
by very 
  complex conditions as if the message is from X try to get me on any 
available 
  device that I am on if not, leave a message on my desktop.

Avshalom Houri
Presence and Instant Messaging Architect
Lotus Sametime, IBM Software Group
[email-masked]

---

From: "Ben Campbell" <[email-masked]>
Date: Sun, 14 Apr 2002 13:36:21 -0500

I cannot speak for the other systems, but Yahoo Messenger allows you to
select open or closed when you create a user configurable message. Also, you
can  become invisible (i.e. lurk) at any time, not just at login.
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Avshalom Houri
  Sent: Sunday, April 14, 2002 9:58 AM
  To: [email-masked]
  Subject: [Simple] Status summary

  * Mood - Happy, Sad etc.

  The summary:
  ===========

  # YAHOO - Open and close + hints for open.
          * Offline (CLOSED)
          * Available (OPEN)
          * Busy with various messages (configurable) e.g. Be Right Back,
Busy
            etc. (OPEN)
          * Invisible (Lurking can be done only in login time)

  # Wireless Village - As defined by the spec status is composed from
several
    attributes as: availability, preferred contacts etc. Following is a
complete
    list.
          * User availability
                  - AVAILABLE
                  - NOT_AVAILABLE
                  - DISCREET (selectively available. Likd DND or busy in
other systems)

          * Preferred Contacts (preferred contact method of the user +
address of
            contact)
                  - CALL
                  - SMS
                  - MMS (Multi Media SMS)
                  - IM
                  - EMAIL
          * Preferred Language
          * Status Text (free text describing the status)
          * Status Mood (e.g. HAPPY, SAD, etc.)
          * Alias (alias name for the user)
          * Status Content - MMS content or URL to the MMS content that the
user
            has selected as personal status information.
          * Contact Info - Contact information (vCard)

  Avshalom Houri

---

From: Tony Hansen <[email-masked]>
Date: Sun, 14 Apr 2002 16:45:45 -0400

AT&T's IM Anywhere provides:

     OPEN with hints:
	Available
	Away
	Be right back
	Do not disturb
	On the phone
	you can also create your own custom messages

     CLOSED
	Offline (invisible, lurking)

Any of the states (including Offline) can be chosen at any time.

	Tony Hansen
	[email-masked]

Ben Campbell wrote:

> select open or closed when you create a user configurable message. Also, 
> you can  become invisible (i.e. lurk) at any time, not just at login.
> 
>     summarize the various statuses used in various systems. The summary
>     is below.
> 
>     While going over the various statuses it occurred to me that we need
>     a more
>     precise definition of what we mean when we say status. The various
>     status values
>       immediately. The way that the my client will display the message
>     to me e.g.
>       in Away mode some clients will display the message in a different
>     way from
>     * Availability - Am I open or close to communication. The
>     availability can be
>     While moods and hints can be localized to vendors and clients, it
>     seems that
>     # AOL - No explicit status - only idle indication by sensing mouse
>     and keyboard activity.
> 
>     # ICQ - Open and close statuses. Open statuses are accompanied by
>     hints. For
>       example if I am in DND, I will still get messages but the messages
>     will not be
>       displayed on my screen.
>             Simple Mode
>                     * Available
>     # Louts Sametime - Open and close + strong DND. Strong DND means
>     that I am not
>       attributes as: availability, preferred contacts etc. Following is
>     a complete
>       list.  
>             * User availability
>                     - AVAILABLE
>                     - NOT_AVAILABLE
>       availability. Availability can be computed by a very simple
>     methods or by very
>       complex conditions as if the message is from X try to get me on
>     any available

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 15 Apr 2002 12:37:17 -0500 (CDT)

FWIW, we provide the following statuses (stati?) in Jabber:

1. Unavailable (maps to CLOSED)

2. Available (maps to OPEN) with sub-statuses:
   - away
   - extended away
   - do not disturb
   - free/desiring to chat

3. Invisible

Any status can be extended with a natural-language description of the
status.

More information at
http://www.jabber.org/ietf/draft-miller-jabber-00.html#common-presence

Peter

--
Peter Saint-Andre
email+jabber: [email-masked]
weblog: http://www.saint-andre.com/blog/

---

From: Sean Olson <[email-masked]>
Date: Mon, 15 Apr 2002 10:54:25 -0700 (PDT)

There seems to be a common thread here where
we can map communication status (presence) to
one of three states:

   open,
   closed,
   undisclosed (invisible)

Is there a fourth type of state I am missing?

/sean

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Ben Campbell" <[email-masked]>
Date: Mon, 15 Apr 2002 13:41:07 -0500

There may be some concept of Open, but unavailable, at least if you look at
the way Yahoo handles offline, vs. online but setting some unavailable
status. See the off-list conversation between Avshalom and myself that I am
forwarding separately.

> [mailto:[email-masked]]On Behalf Of Sean Olson
> Sent: Monday, April 15, 2002 12:54 PM
> To: [email-masked]; [email-masked]; Avshalom Houri
> Subject: Re: [Simple] Status summary
>
>

---

From: "Justin Uberti" <[email-masked]>
Date: Mon, 15 Apr 2002 15:37:14 -0400

AOL has open and closed statuses and hints.

* Online (OPEN)
* Offline (CLOSED)
* Away with various configurable messages (CLOSED)
* Idle (OPEN)

Justin Uberti
America Online

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 15 Apr 2002 17:26:27 -0400

I'm curious: Windows Messenger, supposedly using SIP and IMPP presence,
has a bunch of status indications, similar to the ones mentioned on the
list (lunch, do not disturb, etc.). How are they encoded?

---

From: Tony Hansen <[email-masked]>
Date: Tue, 16 Apr 2002 18:47:12 -0400

"Away with various configurable messages (CLOSED)" should really be
classified as OPEN, not closed. Although you are away, AOL still passes
messages through to you.

	Tony Hansen
	[email-masked]

---

From: "Justin Uberti" <[email-masked]>
Date: Wed, 17 Apr 2002 10:18:25 -0400

Agreed; I had misunderstood the meaning of CLOSED.

Note that being away can cause a message to be routed elsewhere, (e.g. to
your pager if you are away on your desktop), but I suppose this is still
OPEN, since the message is still delivered somewhere.

Justin Uberti
America Online

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Tuesday, April 16, 2002 6:47 PM
> To: Justin Uberti
> Cc: [email-masked]; [email-masked]
>   [reminder: [email-masked] for non-technical discussions, please]
>
>

---

From: Tony Hansen <[email-masked]>
Date: Wed, 17 Apr 2002 14:14:37 -0400

One aspect that hasn't come up yet in this conversation is something 
someone said at the ad-hoc mtg in MN: the temporal aspect of the various 
types of OPEN status messages. Why do you choose to use one message over 
another? Usually it's to give the others an idea of how quickly you'll 
respond.

Some of them mean "I'm doing stuff, but will probably respond to your 
message pretty quickly." (T = a couple minutes) Examples: Busy, On the 
Phone.

Some of them mean "I'm going to be gone for a while." (T = 1/2 - 1 hour) 
Example: Out to Lunch.

Some of them mean "Don't expect me to respond for hours." (T = 2-4 
hours) Example: Away, In Meetings.

Some of them mean "Don't expect me back for a long time." (T > 4 hours) 
Example: Out for the weekend.

When you go international, Out to Lunch doesn't mean a whole lot to 
anyone but English speakers. But specifying an expected time to be gone 
set at .5-1 hour certainly does translate well. Time is a pretty 
universal concept, and might be worth codifying as part of the status 
information.

	Tony Hansen
	[email-masked]

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 17 Apr 2002 13:50:18 -0500

It seems to me this concept is still more intended for _human_ consumption.
It would be dangerous to provide any protocol semantic or other automatic
processing based on the assumption that I will be back at a certain time,
unless we build in explicit expiration times for the piece of state.

So, all of the following can be handled by some sort of "away" status that
contains a human readable comment (or some other indicator for user display
purposes only).

> [mailto:[email-masked]]On Behalf Of Tony Hansen
> Sent: Wednesday, April 17, 2002 1:15 PM

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 17 Apr 2002 15:27:59 -0400

I see some parallels between open/away/closed and 200/202/4xx.

- "Open" means (sort of) that a MESSAGE should return a 200 - will be displayed and hopefully seen immediately.

- "Away" means (sort of) that a MESSAGE should return a 202 - will be accepted, but may not be displayed, or if displayed may not be seen immediately.

- "Closed" means (sort of) that a MESSAGE should fail because there is nobody willing or able to receive it.

The parallels aren't perfect by any means. E.g. 200 doesn't really mean that the message has been seen. Yet in some sense I think the purpose of the presence status is to
give a hint about what is likely to happen if communication is attempted. Maybe it would be helpful to make better parallels.

	Paul