Subject: Re: [Simple] RE: State labels (Was: notes from the SIMPLE components adhoc at IETF53)

From: "Li Hua Tang" <[email-masked]>
Date: Thu, 11 Apr 2002 09:47:15 +0800

Jorge,

Tell the truth I am little confused by the concepts you mentioned,
presence, availability and capability in PAM world. Could you please give
me a scenario in the real world?

And how to control the different access to presence and availability? Has
authorization and authentication been considered in PAM?

Best regards,

Tang Lihua

                    "Jorge Lobo"                                                                          
                    <[email-masked]>              To:     "Paul Kyzivat" <[email-masked]>          
                    Sent by:                         cc:     <[email-masked]>,                       
                    [email-masked]        <[email-masked]>                    
                    icsoft.com                       Subject:     [Simple] RE: State labels (Was: notes   
                                                      from the SIMPLE components adhoc at IETF53)         
                                                                                                          
                    2002-04-11 07:53                                                                      
                    Please respond to jorge                                                               

A quick mapping from some of the concepts of PAM to SIMPLE.

PAM is based on Identities, and Identities have Agents
associated with them.  Agents are electronic representations
                 --------
               >>Indentities here?
of (software or hardware) devices. Agents are the producers
of "raw" presence, and the presence of an Identity is derived
from the devices the Identity owns.

Identities  ---> Presentities
Agents      ---> Presence User Agent

Some applications may have direct access to presence but most
applications will be allowed only access to availability.

The basic API calls from PAM relevant to SIMPLE are

set and get presence

set and get preferences

get availability

One more thing.  There is a special class of presence data associated
with agents in PAM called capabilities - given that the capabilities of
an agent (Presence User Agent) can vary with time. For example, a
capability
can be J2ME-cable, an attribute of the capability can be
communicationAddress
which can be a dynamic IP address assigned to the agent for communication.

Best,

Jorge.

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 7:12 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: State labels (Was: notes from the SIMPLE components adhoc
at IETF53)

Jorge,

I just took a quick look at the PAM specification.

While it would take a much longer look to fully understand the mappings, I
agree that there does seem to be some commonality here.

           Paul

Jorge Lobo wrote:
>
> Paul and Henning,
>
> I have been following your discussion on call preferences and
> presence and I would like to offer an alternative view.
>
> I have been working with PAM, the presence and availability
> management standards being adopted by Parley and 3GPP,
> (http://www.PAMForum.org).
>
> In PAM there is a separation between "presence" and "availability".
> Presence, as mention by Henning, in the IM world is set by the
> user, but in many cases can be and will be automatically detected.
> The presence of your cellular phone in the network is detected
> automatically.
>
> What availability offers is a layer over presence where the subscriber
> describes preferences on how to expose presence. Preference rules to
> compute availability can be as simple as opt-in or out to publication of
> presence as in current IM systems to extremely to extremely sophisticated
> rules where the user can decide how to expose the information based on
> who is requesting the information, the time of the request,
> the location of the requester and the user, etc. - the bookie example is
> one this more complicated examples.
>
> In the case of PAM there is a minimal set of controls that a presence
> server should provide as an implementation of availability, but it is
> left open to the different implementations how sophisticated the
> computation of availability can be.
>
> A similar approach here may solve many of your problems.
>
> Regards,
>
> Jorge.
>
> ------------------------
> Jorge Lobo, Ph.D.
> Principal Architect
> Teltier Technologies
> 60 Walnut Avenue, #300
> Clark, NJ 07066
> mailto:[email-masked]
> ------------------------

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Jorge Lobo" <[email-masked]>
Date: Thu, 11 Apr 2002 18:04:48 -0400

Dear Tang Lihua,

authentication is done in a different place through a framework. PAM, as
specified by the PAMForum, has a simple authentication framework, but
inside Parley and 3GPP, the framework works across all the services
provided by them. Usually after authenticating with the framework a
token is returned to the requester and it is used in every API call.
The framework is also used to discover services such as PAM.  Other
services are call control, billing, etc.

Jorge.
-----Original Message-----
From: Li Hua Tang [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 9:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Simple] RE: State labels (Was: notes from the SIMPLE
components adhoc at IETF53)

Jorge,

Best regards,

Tang Lihua

                    "Jorge Lobo"
                    <[email-masked]>              To:     "Paul Kyzivat"
<[email-masked]>
                    Sent by:                         cc:
<[email-masked]>,
                    [email-masked]
<[email-masked]>
                    icsoft.com                       Subject:     [Simple]
RE: State labels (Was: notes
                                                      from the SIMPLE
components adhoc at IETF53)

                    2002-04-11 07:53
                    Please respond to jorge

set and get presence

set and get preferences

get availability

Best,

Jorge.

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 7:12 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: State labels (Was: notes from the SIMPLE components adhoc
at IETF53)

Jorge,

           Paul