Subject: RE: [Simple] Status summary

From: [email-masked]
Date: Thu, 18 Apr 2002 15:14:46 +0300

> I see some parallels between open/away/closed and 200/202/4xx.
> 
> - "Open" means (sort of) that a MESSAGE should return a 200 - 
> will be displayed and hopefully seen immediately.
> 
> - "Away" means (sort of) that a MESSAGE should return a 202 - 
> will be accepted, but may not be displayed, or if displayed 
> may not be seen immediately.

Correct me if I'm wrong, but reading draft-ietf-sip-message-02.txt, my understanding was that the 202 would *not* convey information on the handling of the message, i.e., whether it is displayed or not. 

It is sent back by a GW, or a message relay, and simply means that the message wasn't actually delivered to the recipient, but stored, gatewayed, etc, and may be delivered at a later time if at all.

Similarly, the 200 only states, that the message was received by the recipient, not necessarily displayed, seen, read, understood, etc.

Cheers,
Aki  
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 18 Apr 2002 08:03:38 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 18, 2002 7:15 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Simple] Status summary
>
>
> Correct me if I'm wrong, but reading
> draft-ietf-sip-message-02.txt, my understanding was that the 202
> would *not* convey information on the handling of the message,
> i.e., whether it is displayed or not.
>
> It is sent back by a GW, or a message relay, and simply means
> that the message wasn't actually delivered to the recipient, but
> stored, gatewayed, etc, and may be delivered at a later time if at all.
>
> Similarly, the 200 only states, that the message was received by
> the recipient, not necessarily displayed, seen, read, understood, etc.

Yes, this is correct. For example, a given service _might_ choose to return
202 all the time, if it perhaps did not want to indicate to the sender that
some messages go directly and others get store-and-forwarded. (I'm
not_suggesting_ this behavior, but it is legal).

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 18 Apr 2002 09:08:20 -0400

> Similarly, the 200 only states, that the message was received by the recipient, not necessarily displayed, seen, read, understood, etc.

You are not wrong - the meanings are not exactly the same,
which is why I qualified the statements above with 
"(sort of)", and in the next paragraph of my message...

Paul Kyzivat wrote:
> 
> The parallels aren't perfect by any means. E.g. 200 doesn't really mean
> that the message has been seen. Yet in some sense I think the purpose
> of the presence status is to give a hint about what is likely to happen
> if communication is attempted.
> Maybe it would be helpful to make better parallels.

	Paul