Subject: [Simple] Message Transport Protocol (SIP vs IMTP)

From: "James Undery" <[email-masked]>
Date: Tue, 23 Jul 2002 08:52:54 +0100

Hi,

At the SIMPLE meeting I believe the consensus was to go with a SIP based message transport, however, it was unclear if this should be SIP or IMTP. The argument for SIP is because of rfc3261 we can now use SIP as is, IMTP was complicated due to all the requirements of messaging that couldn't be addressed easily; I'd definitely agree with that, however, I believe that won't work, rfc2543 proxies may still do all the bad things IMTP was designed to avoid. The suggestion made by Rohan (that I strongly agree with) was to take  rfc3261 and just swap SIP/2.0 for IMTP/1.0 every time the protocol is mentioned in the spec. This has the advantage that you know older proxies aren't going to misbehave and the draft specifying it should be trivial modification to Jonathan's latest draft.

James
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 23 Jul 2002 09:09:10 -0400

> At the SIMPLE meeting I believe the consensus was to go with a SIP based message transport, however, it was unclear if this should be SIP or IMTP. The argument for SIP is because of rfc3261 we can…

To avoid misbehaving proxies, shouldn't it be sufficient to do something like

	Proxy-Require: message_session

or something to that effect? Changing the version requires much more mucking in the stack.

	Paul