Subject: RE: [Simple] Message session & associated dialog

From: [email-masked]
Date: Thu, 25 Jul 2002 10:14:38 +0300

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: Wednesday, July 24, 2002 8:29 PM
> To: Jonathan Rosenberg
> Cc: Khartabil Hisham (NMP/Helsinki); [email-masked]; Niemi Aki
> (NET/Espoo); [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [Simple] Message session & associated dialog
> 
> 
> 
> 
> Jonathan Rosenberg wrote:
> > 
> > I believe the CSeq numbering space is identified by the 
> local request
> > URI (i.e., the value in the r-uri seen by the UAS that receives the
> > message) combined with the From field, which would then identify the
> > sender. Since there is no dialog here, there is no 
> requirement that the
> >  From field be the same for each message, and it can 
> actually reflect
> > the originator of that specific message.
> 
> I don't think the From is necessarily unique here.
> 
> Suppose I initially made a call to you from my desktop pc 
> here, setting up a message session. Once we get chatting, I 
> have to go to a meeting, so I transfer my end of the
> call to my laptop pc.
> 
> Both pcs are registered as separate Contacts for my same 
> address of record, and typically the AoR is what would be 
> placed in the from address.
> 
> During the reinvite transition, you may be getting messages 
> from both pcs, using same From address.
> 
> As an alternative, the address in the first Via header might 
> be sufficiently unique.

I think Jonathan was talking about the From-header in the media (MESSAGE) and not the signalling (INVITE).

Hisham

> 	Paul
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 25 Jul 2002 12:50:11 -0400

> I think Jonathan was talking about the From-header in the media (MESSAGE) and not the signalling (INVITE).

So was I. The scenario is moving both the call leg and the media termination from on pc to the other. I would expect (but this is subject to discussion) that the MESSAGEs
sent in the media session would still list the Address of Record of the pc as the From address, rather than the pc-specific Contact address. To do otherwise could mess up
the UI for the IM session. It may be using the From address to identify the sender of each message. (If the messages are text rather than CPIM format.)

I don't think it is safe to assume that the From will be unique from source to source.

	Paul