Subject: RE: [Simple] Message session & associated dialog

From: Adam Roach <[email-masked]>
Date: Fri, 26 Jul 2002 13:34:19 -0500

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> 
> I don't think it is safe to assume that the From will be 
> unique from source to source.

Isn't this the exact reason the "tag" parameter was introduced?

/a
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Sean Olson <[email-masked]>
Date: Fri, 26 Jul 2002 12:17:01 -0700 (PDT)

Hmmm. Tag will work in this case (within a dialog),
but the tag doesn't really differentiate a source
outside of a dialog. Kinda ugly unless we have a
single dialog ID for this message session (at
the MESSAGE level)

Sean Olson
Microsoft

> Isn't this the exact reason the "tag" parameter was

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 26 Jul 2002 18:30:17 -0400

> Isn't this the exact reason the "tag" parameter was introduced?

I don't think so. For purposes of sip signalling, the MESSAGEs in a message session aren't part of the dialog of the INVITE that established the session. They aren't part
of any dialog. So either each MESSAGE gets a new tag in its From header, or else it gets no tag at all. It would definitely be wrong for them to get the tag from the dialog
of the INVITE.

(Do messages get a tag on the From if they don't establish a dialog and aren't part of a dialog?)

So the from tag is useless for this purpose.

	Paul

BTW - I'm going to be gone for a week or so, so you can finish this discussion without me.
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple