Subject: RE: [Simple] Message session & associated dialog

From: [email-masked]
Date: Wed, 24 Jul 2002 11:37:19 +0300

> -----Original Message-----
> From: ext Sean Olson [mailto:[email-masked]]
> Sent: Wednesday, July 24, 2002 1:12 AM
> To: Jonathan Rosenberg; Paul Kyzivat
> Cc: Niemi Aki (NET/Espoo); [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [Simple] Message session & associated dialog
> 
> 
> 
> > OK, let me know be very explicit.
> > 
> > Message sessions would be a sequence of pages. As
> > per 3261, each of 
> > those will have a call-id, a from tag, and no to
> > tag. The 200 OK 
> > response to each of those has a to tag filled in,
> > different for each 
> > message. The CSeq refers to the sequencing within
> > the URI seen by the 
> > UAS, as I have indicated in a previous mail, so I
> > have fully backed off 
> > that notion.
> > 
> > So, there is a dialog ID, but its different for each
> > message, as it 
> > would be for page mode.
> 
> If the dialog ID is different for each page, then
> how would the CSeq be used across these pages to
> do sequencing? Wouldn't there necessarily be a
> unique numbering space for each dialog ID? And if
> there is a possibility that these pages come from
> different sources, then we can't count on CSeq 
> ordering. I think I may be misunderstanding your
> proposal.

In an earlier I proposed using the local port and CSeq, but now there is the other dimension of receiving media from different sources. In this case, can we use local port, remote port and ip address, and CSeq (or whatever sequencing is supported by the media protocol) to identify groupings of media packets (MESSAGE)?

Regards,
Hisham

> 
> /sean
> 
> 
> 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Health - Feel better, live better
> http://health.yahoo.com
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 24 Jul 2002 08:58:39 -0400

inline.

[email-masked] wrote:
> In an earlier I proposed using the local port and CSeq, but now there is
> the other dimension of receiving media from different sources. In this
> case, can we use local port, remote port and ip address, and CSeq (or
> whatever sequencing is supported by the media protocol) to identify
> groupings of media packets (MESSAGE)?

Using a remote IP address or port is always a bad idea, for NAT reasons.

I believe the CSeq numbering space is identified by the local request 
URI (i.e., the value in the r-uri seen by the UAS that receives the 
message) combined with the From field, which would then identify the 
sender. Since there is no dialog here, there is no requirement that the 
 From field be the same for each message, and it can actually reflect 
the originator of that specific message.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 24 Jul 2002 13:17:57 -0400

> In an earlier I proposed using the local port and CSeq, but now there is the other dimension of receiving media from different sources. In this case, can we use local port, remote port and ip addre…

This only provides partial ordering - the recipient is still responsible for taking partially ordered sequences of messages and turning them into a total ordering for
display. So the ordering is only approximately "correct" in any case. 

How much improvement in accuracy do we get from ordering one of those sequences using CSeq vs just using the order in which they are received? If ordering is done this way,
what is the recipient to do if it receives a message with a CSeq value that is too large? Must it buffer it until the "missing" messages are received?

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 24 Jul 2002 13:29:11 -0400

> the originator of that specific message.

I don't think the From is necessarily unique here.

Suppose I initially made a call to you from my desktop pc here, setting up a message session. Once we get chatting, I have to go to a meeting, so I transfer my end of the
call to my laptop pc.

Both pcs are registered as separate Contacts for my same address of record, and typically the AoR is what would be placed in the from address.

During the reinvite transition, you may be getting messages from both pcs, using same From address.

As an alternative, the address in the first Via header might be sufficiently unique.

	Paul