Subject: [Simple] Presence support in Microsoft Messenger

From: [email-masked]
Date: Mon, 5 Aug 2002 08:45:52 -0400

Anybody have any information regarding what drafts Microsoft Messenger is
following with regard to Presence and Instant Messaging ?  I saw a post 

http://mailman.dynamicsoft.com/pipermail/simple/2002-April/001513.html

stating that it extends XPIDF.  So I am assuming it embraces the following two
drafts: draft-ietf-simple-presence-01, draft-rosenberg-impp-pidf-00. Am I
correct ?

I tried my own test with MSN Messenger, and I got a "488 Not Acceptable Here"
back from Messenger.  Any ideas ?  I have included the flow below.

Also, when I tried to capture some packet traces when I go to the .Net
service and not to a communication service, I do not get SIP messages. So Microsoft
only uses SIP when you are talking to a "Communication Service" as defined under
their "Tools...Options...Accounts" menu ??  Is it some proprietary protocol to
.Net ?  I am using MSN Messenger 4.6.0082.

Thanks,
  Jeff

------------------------------------------------------
> PresenceServer Received
SUBSCRIBE sip:90.30.214.202 SIP/2.0
Via: SIP/2.0/UDP 90.30.214.202:5060;branch=e037c25e293b413671df40be3716e038.cc66b4b80af2f8cc73a3f86b492f52de
Via: SIP/2.0/UDP 90.30.214.205:8460
From: "4043351643" <sip:4043351643>;tag=884a1ddc-5170-4482-864d-c6785d3f1d72
To: <sip:[email-masked]:5060>
Call-ID: [email-masked]
CSeq: 1 SUBSCRIBE
Contact:<sip:90.30.214.205:8460>
User-Agent:Windows RTC/1.0
Expires:1800
Content-Length: 0
Record-Route:<sip:90.30.214.202:5060;maddr=90.30.214.202>

< PresenceServer sent out
SIP/2.0 200 Ok
Via: SIP/2.0/UDP 90.30.214.202:5060;branch=e037c25e293b413671df40be3716e038.cc66b4b80af2f8cc73a3f86b492f52de
Via: SIP/2.0/UDP 90.30.214.205:8460
From: "4043351643" <sip:4043351643>;tag=884a1ddc-5170-4482-864d-c6785d3f1d72
To: <sip:[email-masked]:5060>;tag=540769738
Call-ID: [email-masked]
CSeq: 1 SUBSCRIBE
Record-Route: <sip:90.30.214.202:5060;maddr=90.30.214.202>
Content-Length: 0
Expires: 360

< PreseneceServer sent out
NOTIFY sip:90.30.214.202:5060 SIP/2.0
From: <sip:[email-masked]:5060>;tag=540769738
To: <sip:4043351643>;tag=884a1ddc-5170-4482-864d-c6785d3f1d72
Contact: sip:90.30.214.205:8460
Call-ID: [email-masked]
CSeq: 1 NOTIFY
Content-Length: 359
Event: presence
Subscription-State: active;expires="359"
Content-Type: application/xpidf+xml

</xml version="1.0"?>
<!DOCTYPE presence 
PUBLIC "-//IETF//DTD RFCxxxx XPIDF 1.0//EN" "xpidf.dtd">
<presence>
<presentity uri="sip:[email-masked]:5060;method=SUBSCRIBE" />
<atom id="1003">
<address uri="sip:90.30.214.202:11111;user=ip" priority="0.800000">
<status status="open" />
<msnsubstatus substatus="online" />
</address>
</atom>
</presence>

> PresenceServer received
SIP/2.0 488 Not Acceptable Here
Via: SIP/2.0/UDP 90.30.214.202:5050
From: <sip:[email-masked]:5060>;tag=540769738
To: "4043351643" <sip:4043351643>;tag=884a1ddc-5170-4482-864d-c6785d3f1d72
Call-ID: [email-masked]
CSeq: 1 NOTIFY
User-Agent:Windows RTC/1.0
Content-Length: 0

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Prince A.P." <[email-masked]>
Date: Mon, 5 Aug 2002 18:40:25 +0530

MSN Messenger is using SIP only when we select "communication service" in
accounts tab.For .net passport account it is not using SIP.
some links..
http://www.microsoft.com/windowsxp/pro/techinfo/planning/networking/windowsm
essenger.asp
http://www.microsoft.com/presspass/Features/2001/Jun01/06-04messenger.asp

thanks,
prince

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Monday, August 05, 2002 6:15 PM
Subject: [Simple] Presence support in Microsoft Messenger

> Via: SIP/2.0/UDP
90.30.214.202:5060;branch=e037c25e293b413671df40be3716e038.cc66b4b80af2f8cc7
3a3f86b492f52de
> From: "4043351643"
<sip:4043351643>;tag=884a1ddc-5170-4482-864d-c6785d3f1d72
> Via: SIP/2.0/UDP
90.30.214.202:5060;branch=e037c25e293b413671df40be3716e038.cc66b4b80af2f8cc7
3a3f86b492f52de
> From: "4043351643"
<sip:4043351643>;tag=884a1ddc-5170-4482-864d-c6785d3f1d72