Subject: RE: [Simple] who changes im: pres: to sip:

From: [email-masked]
Date: Thu, 21 Nov 2002 02:08:27 +0200

Hi,

Apologies for flooding the list by thinking aloud here. ;)

However, after thinking about this a little more, I did come up with a scenario for which the im/pres URI in the Request-URI would not work.

It's when a UA sits behind an outbound proxy that knows nothing about im/pres URIs. Then the UA itself will have to do tricks with the im URI so that the request can be routed by this outbound proxy.

I see two choices: 

1) Use a translation very much like a tel URI to SIP URI translation. The entire im URI would go into the user part of the SIP URI, and the target domain received in the SRV query would go into the hostport part. And again, the ';user=im' or ';user=pres' would indicate that such a translation was done.

2) Keep things as they are, and in most cases use the abstract im or pres URI in the Request-URI (if not in all cases). Use SRV normally, and if the UA doesn't send the request directly to the target server, the UA needs to use loose routing to guide it there.

Option 1 would force the target proxy to interpret the user-parameter to process the request correctly. Option 2 doesn't seem to require anything new, so it looks much better to me.

Thoughts?

Cheers,
Aki

> Hi Hisham,
> 
> [...]
> > > I think having the im URI in the Request-URI is even worse. 
> > > It would mean that all the proxies in the path of this 
> > > request would have to support the im URI scheme to be able to 
> > > route the message at all. With the user-parameter, at least 
> > > these intermediary proxies would still be able to route the 
> > > request normally to the owner domain.
> > 
> > When you do an SRV query on _im._sip.bar.com, you would 
> > expect the address returned to be for an entity that 
> > understands im scheme. So leaving the scheme as im is 
> > probably better. Or are there any scenarios where that is not 
> > the case?
> 
> Yeah, that actually defeats the whole purpose of the 
> translation. I agree, im URI in the Request-URI will do the trick.
> 
> Cheers,
> Aki 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 21 Nov 2002 02:54:48 -0500

inline.

[email-masked] wrote:
 > It's when a UA sits behind an outbound proxy that knows nothing about
 > im/pres URIs. Then the UA itself will have to do tricks with the im
 > URI so that the request can be routed by this outbound proxy.

Yes, this is definitely the problematic case.

 >
 > I see two choices:
 >
 > 1) Use a translation very much like a tel URI to SIP URI translation.
 > The entire im URI would go into the user part of the SIP URI, and the
 > target domain received in the SRV query would go into the hostport
 > part. And again, the ';user=im' or ';user=pres' would indicate that
 > such a translation was done.

Yuck.

 >
 > 2) Keep things as they are, and in most cases use the abstract im or
 > pres URI in the Request-URI (if not in all cases). Use SRV normally,
 > and if the UA doesn't send the request directly to the target server,
 > the UA needs to use loose routing to guide it there.

This is better, but it requires the UA to know that its outbound proxy 
doesn't support the im or pres URI.

 >
 > Option 1 would force the target proxy to interpret the user-parameter
 > to process the request correctly. Option 2 doesn't seem to require
 > anything new, so it looks much better to me.

There is a third option, which is do nothing. In this case, the proxy 
will fail the request. That is exactly what we do today for tel URI. If 
a UAC sends a request with a tel URI in the request URI to an outbound 
proxy (a common operation in sip networks), if the outbound proxy 
doesn't understand the tel URI, the request fails. Same with sips.

So, I don't believe we should be special casing the IM/Pres URIs. 
Generally speaking, the price you pay for using outbound proxies is that 
it knows how to process your request, new URIs, proxy-requires, and 
anything else.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com