Subject: Re: [Simple] Message Session IDs

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 02 Nov 2002 13:48:49 -0500

Agreed that msgID belongs inside the envelope. The issue, then, is what 
MIME header are we using in the outer envelope that would be used by the 
intermediary for routing? Is there an existing one that fits the job... 
suggestions anyone?

-Jonathan R.

Ben Campbell wrote:
> Paul Kyzivat wrote:
> 
>>
>> Ben Campbell wrote:
> 
> 
> [...]
> 
>>
>>> If we were to do this, does it also make sense to move MsgID to the
>>> outer envelope?
>>
>>
>>
>> I don't know about this. If it is only needed by the endpoints then it 
>> might as well be in the inner envelope. Protecting it should help 
>> protect against some kinds of attacks.
>>
> 
> On reflection, I agree with you. I had it in my head that an 
> intermediary might use it for ordering purposes, but now that I am more 
> awake I realize there is no need for that.
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Pekka Pessi <[email-masked]>
Date: 07 Nov 2002 15:41:08 +0200

Ben Campbell <[email-masked]> writes:
>draft-campbell-simple-im-sessions-00 discusses the use of the SDP
>offer/answer model for initiating message sessions, without talking much
>about the message sessions themselves.

	There are some things with SDP that might require modifications. 
	I would use the default mapping from SDP spec, according to it
	the message/cpim would be presented like m=message (port)
	(tport) cpim. I would also list the inner MIME types in fmtp or
	similar attribute line.

	So, instead of

m=message 8937 cpim/tls text/plain text/html

	I would write it like this:

m=message 8937 tls cpim
a=fmtp:cpim accept:text/plain,text/html

	As an added bonus, this would also work:

m=message 8937 tls/sctp cpim sip sipfrag
	
>draft-campbell-simple-cpimmsg-sessions-00 proposes a message session
>transport that involves transporting messages over TCP or TLS using the
>message/cpim format. This draft depends on the signaling methods described
>in the im-sessions draft.

	The comedia draft does not define how the application should
	behave when a connection is closed (except with direction:both,
	which states that the endpoint SHOULD close an idle connection). 
	An explicit message like RTCP BYE might be useful here.

					Pekka