Subject: Re: [Simple] Interdomain presence

From: deepankarb 70286 <[email-masked]>
Date: Sun, 03 Nov 2002 07:33:29 -0800

Yes, thats correct, but I would try to put my query this way.

say if my PA aka softswitch is responsible for abc.com administrative domain, and there's another PA taking care of xyz.com administrative domain. Both have their set of homing subscribers (PUAs). Here, I am taking PUAs as fixed IP phones, PSTN phones. Since both belong to different administrative domains, and in case of an example of presence based voice calling, a sip caller sip:[email-masked] is calling sip:[email-masked], and abc.com needs to find the presence first, and then route the call. In this case, how would xyz.com indicate the presence status/document of acallee to abc.com? 

Deeps

----- Original Message -----
From: Jonathan Rosenberg <[email-masked]>
Date: Saturday, November 2, 2002 9:03 am
Subject: Re: [Simple] Interdomain presence

> A PUA can publish presence to any PA using the SIP PUBLISH method. 
> You 
> can find the current I-D for this at:
> http://www.ietf.org/internet-drafts/draft-olson-simple-publish-01.txt
> 
> whether you call the PA a softswitch or not is irrelevant.
> 
> -Jonathan R.
> 
> Deepankar wrote:
> > Folks,
> >  
> > In case of a softswitch based presence solution, If the PA is co-
> located 
> > with the Proxy/Registrar with the Softswitch, then what 
> mechanisms are 
> > there for it, to know of the presence of users homed in a 
> different 
> > Softswitch.
> >  
> > Deeps
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 03 Nov 2002 22:05:33 -0500

deepankarb 70286 wrote:
 > say if my PA aka softswitch is responsible for abc.com administrative
 > domain, and there's another PA taking care of xyz.com administrative
 > domain. Both have their set of homing subscribers (PUAs). Here, I am
 > taking PUAs as fixed IP phones, PSTN phones. Since both belong to
 > different administrative domains, and in case of an example of
 > presence based voice calling, a sip caller sip:[email-masked] is
 > calling sip:[email-masked], and abc.com needs to find the presence
 > first, and then route the call. In this case, how would xyz.com
 > indicate the presence status/document of acallee to abc.com?

Thats what draft-ietf-simple-presence is for. The abc.com would 
SUBSCRIBE to the presence state at xyz.com.

-Jonathan R.