Subject: [Simple] who changes im: pres: to sip:

From: [email-masked]
Date: Wed, 20 Nov 2002 16:37:40 +0200

Hi,

Most of us heard the discussion at impp wg meeting about schemes, but there was no consensus on who changes the scheme.

There are 2 suggestions:

1. change it to sip as soon as possible, as instructed by presence-07
2. Leave it to the terminating domain. I.e. the domain responsible.

Which one of the above should we do? If we choose 2, should presence I-D be changed to reflect that?

I'm referring to the text:

"When subscribing to a presentity, the subscription can be addressed
   using the protocol independent form or the SIP or SIPS URI form. In
   the SIP context, "addressed" refers to the Request-URI. It is
   RECOMMENDED that if the entity sending a SUBSCRIBE is capable of
   resolving the protocol independent form to the SIP form, this
   resolution is done before sending the request"

Regards,
Hisham
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Sean Olson <[email-masked]>
Date: Wed, 20 Nov 2002 08:02:52 -0800 (PST)

It sounds like the text you reference answers 
the question. Do it as soon as possible, 
preferably before you send the request. Different
environments and clients may do this at different
times depending on your view of "as soon as possible".
I think (1) is the right answer, though that might
be identical to (2) is some rare cases.

The SRV resolution that was discussion in IMPP
solves the next hop problem. It did not directly
address translation of an im: *URI* to a sip: *URI*.
Shouldn't this be left to local policy/implementation?

/sean

--- [email-masked] wrote:
> Hi,
> 
> Most of us heard the discussion at impp wg meeting
> about schemes, but there was no consensus on who
> changes the scheme.
> 
> There are 2 suggestions:
> 
> Which one of the above should we do? If we choose 2,
> should presence I-D be changed to reflect that?
> 

__________________________________________________
Do you Yahoo!?
Yahoo! Web Hosting - Let the expert host your site
http://webhosting.yahoo.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple