Subject: [Simple] msgr

From: Sudipta Ghosh <[email-masked]>
Date: Mon, 09 Dec 2002 12:01:09 +0530

Hi,
MSN Messenger uses "msgr" tag in MESSAGE Request.
What is that?
sudipta

Example

MESSAGE sip:10.140.13.149:5060 SIP/2.0
Via: SIP/2.0/TCP 10.140.13.149:5060
Record-Route: <sip:10.140.13.149:5060;maddr=10.140.13.149;transport=tcp>

Via: SIP/2.0/TCP 10.140.13.96:11138
From: "Client_A"
<sip:[email-masked]>;tag=65056eff-f536-43dc-a795-947be959f714
To:
<sip:[email-masked]>;tag=f6dfc966-ad80-4cea-b8bd-ce3de259b79a
Call-ID: [email-masked]
CSeq: 4 MESSAGE
Route: <sip:10.140.13.178:12155;transport=tcp>
Contact: <sip:10.140.13.96:11138;transport=tcp>
User-Agent: Windows RTC/1.0
Content-Type: text/plain;
charset=UTF-8;msgr=WAAtAE0ATQBTAC0ASQBNAC0ARgBvAHIAbQBhAHQAOgAgAEYATgA9AE0AUwAlADIAMABTAGgAZQBsAGwAJQAyADAARABsAGcAOwAgAEUARgA9ADsAIABDAE8APQAwADsAIABDAFMAPQAwADsAIABQAEYAPQAwAA0ACgANAAoA

Content-Length: 18

--
***********************************************
System Executive
Scicom Infotech Pvt. Ltd. (Scicom)
A - 67, Sector - 57
Noida - 201 301
UP
**********************************************

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Hemant Kumar" <[email-masked]>
Date: Mon, 9 Dec 2002 12:48:10 +0530

If you'll look at the value of this tag in different messages, you'll find
out the value is

"WAAtAE0ATQBTAC0ASQBNAC0ARgBvAHIAbQBhAHQAOgAgAEYATgA9AE0AUwAlADIA
MABTAGgAZQBsAGwAJQAyADAARABsAGcAOwAgAEUARgA9ADsAIABDAE8APQAwADsA
IABDAFMAPQAwADsAIABQAEYAPQAwAA0ACgANAAoA"

and it is same always (well atleast all the messages I saw, it was same).

So, I think it is Unique String in charset, just make sure that this message
is from MSN Messenger.

rgds,
/hem

--
Hemant Kumar,
Project Manager,
SPG Solutions,LLC
B-372, Meera Bagh,
Paschim Vihar,
New Delhi - 110063,
Phone:+91.11.25271704
Fax:+91.11.25286949
Email:[email-masked]

----- Original Message -----
From: "Sudipta Ghosh" <[email-masked]>
To: "simple" <[email-masked]>; "sipforum"
<[email-masked]>
Sent: Monday, December 09, 2002 12:01 PM
Subject: [Simple] msgr

> Content-Type: text/plain;
charset=UTF-8;msgr=WAAtAE0ATQBTAC0ASQBNAC0ARgBvAHIAbQBhAHQAOgAgAEYATgA9AE0AU
wAlADIAMABTAGgAZQBsAGwAJQAyADAARABsAGcAOwAgAEUARgA9ADsAIABDAE8APQAwADsAIABDA
FMAPQAwADsAIABQAEYAPQAwAA0ACgANAAoA

---

From: "shanti" <[email-masked]>
Date: Mon, 9 Dec 2002 09:06:37 -0500

hi,

When I send a SIP MESSAGE request to MSN client, it responds with 200 ok but
doesnot display the message .

Following is the message am sending, and the response received from the MSN
client.

MESSAGE sip:[email-masked] SIP/2.0
CSeq: 1 MESSAGE
Call-Id: 1039218960404
From: <sip:[email-masked]>;tag=1093
To: <sip:[email-masked]>
Via: SIP/2.0/UDP 192.168.123.159:2000
Content-Type: application/text-plain
Contact: <sip:[email-masked]:2000>
Content-Length: 18

Hello

Thread-5:----------------------------------------
Thread-5:from = 127.0.0.1:3883
 to = 192.168.123.159:2000
 message = SIP/2.0 200 OK
Via: SIP/2.0/UDP
192.168.123.159:2000;branch=z9hG4bKad3693a4af1fd0c172f5a3cd2da61f43
From: <sip:sk_test@xyzcom>;tag=1093
To: <sip:[email-masked]>;tag=156b140c-b8bc-431c-8416-467ef5b4c6f8
Call-Id: 1039218960404
CSeq: 1 MESSAGE
Contact: <sip:192.168.123.159:9372>
User-Agent: Windows RTC/1.0
Content-Length: 0

Your help on this is much appreciated.

thanks,
shanti

---

From: Torrey Searle <[email-masked]>
Date: Mon, 09 Dec 2002 15:27:34 +0100

When MSN doesn't understand the content type, responds 200 OK w/o 
displaying the message.

Try sending a content type of Content-Type: text/plain instead

Torrey Searle
Indigo Software