Subject: [Simple] SUBSCRIBE with Accept-header for presence package (or any package)

From: [email-masked]
Date: Wed, 11 Dec 2002 17:00:06 +0200

presence-09 says:

"If the (accept) header field is present, it MUST
   include "application/cpim-pidf+xml", and MAY include any other types
   capable of representing user presence."

But it also says:

"All subscribers MUST support the
   "application/cpim-pidf+xml" presence data format described in [6]"

But it doesn't say all notifiers must support "application/cpim-pidf+xml" 

"As described in RFC 3265 [2], the NOTIFY message will contain bodies
   that describe the state of the subscribed resource. This body is in a
   format listed in the Accept header field of the SUBSCRIBE, or a
   package-specific default if the Accept header field was omitted from
   the SUBSCRIBE."

So, you would expect the Presence Server to reject the SUBSCRIBE if Accept header was present and did not include "application/cpim-pidf+xml", but no where in the document this is written.

/Hisham
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 11 Dec 2002 17:14:47 -0500

[email-masked] wrote:
 > presence-09 says:
 >
 > "If the (accept) header field is present, it MUST include
 > "application/cpim-pidf+xml", and MAY include any other types capable
 > of representing user presence."
 >
 > But it also says:
 >
 > "All subscribers MUST support the "application/cpim-pidf+xml"
 > presence data format described in [6]"
 >

Yeah, you are right. Thats a bug probably.

 >  that describe the state of the subscribed resource. This body is in
 > a format listed in the Accept header field of the SUBSCRIBE, or a
 > So, you would expect the Presence Server to reject the SUBSCRIBE if
 > Accept header was present and did not include
 > "application/cpim-pidf+xml", but no where in the document this is
 > written.

OK, we will get this fixed.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com