Subject: RE: [Simple] PUBLISH: a dialog?

From: [email-masked]
Date: Mon, 10 Feb 2003 13:16:01 +0200

I agree with what Aki's proposes. We purposefully rejected the use of MESSAGE within a dialog for various reasons including that; once you have established a dialog, a SIP message carries way too much information that it needs as a media protocol. The reasons apply here also.

I personally don't have any strong opinions regarding a PUBLISH having to do with dialogs. But if it does, then I prefer for the PUBLISH to establish the dialog rather than using SIP yet again as another form of media protocol.

If it will be INVITE to establish the publishing dialog, then, as Aki suggests, PIDF is the way to go, IMHO.

Regards,
Hisham

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Monday, February 10, 2003 11:06 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; Kiss Krisztian
> (NRC/Tampere); [email-masked]; [email-masked]
> Subject: RE: [Simple] PUBLISH: a dialog?
> 
> 
> Hi,
> 
> Inline.
> 
> > -----Original Message-----
> > From: ext Anders Kristensen [mailto:[email-masked]]
> > 
> > Paul Kyzivat wrote:
> > > I agree that this is a reasonable approach.
> > > 
> > > It does however open up some new issues that would need to 
> > be sorted out 
> > > - not a fundamental problem, just more work. Specifically, 
> > what should a 
> > > UAS do when receiving a "medialess" invitation? This 
> > probably depends on 
> > > the purpose of the invitation. In the case we are 
> > discussing the purpose 
> > > is simply to establish a dialog to carry PUBLISH messages, 
> > but it could 
> > > be preparatory to a reinvitation with media, or whatever. 
> > If the UAS 
> > > happens to be capable, should it alert?
> > 
> > The intent to send PUBLISH'es over a dialog could be "negotiated" 
> > through an m= line of the sdp in the INVITE similar to what 
> > we're doing 
> > for session-mode MESSAGEs.
> 
> We can also go down this path and forget PUBLISH altogether, 
> and use a PDIF-over-TCP media - just like we've done away 
> with MESSAGE in the message session work.
> 
> It seems to me we're going around in circles here. Where are 
> the requirements driving this discussion? 
> 
> Cheers,
> Aki
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Sean Olson <[email-masked]>
Date: Mon, 10 Feb 2003 08:32:59 -0800 (PST)

There is a disconnect here. You can rightfully
argue that MESSAGE is media in the context of
a IM "session" (INVITE dialog). However, what I
was proposing is something much different. I was
proposing a signaling session established by an
INVITE. In this case, what is being exchanged is
literally SIP messages -- there is no simpler 
canonical form that can be transferred here such
as CPIM/TCP. And unlike the CPIM case, what I
am suggesting is that the PUBLISH request have
all the same characteristics as the dialog within 
which it is established, including Call-ID, route
set, etc. This is definitely not media.

--- [email-masked] wrote:
> I agree with what Aki's proposes. We purposefully
> rejected the use of MESSAGE within a dialog for
> various reasons including that; once you have
> established a dialog, a SIP message carries way too
> much information that it needs as a media protocol.
> The reasons apply here also.
> 
> I personally don't have any strong opinions
> regarding a PUBLISH having to do with dialogs. But
> if it does, then I prefer for the PUBLISH to
> establish the dialog rather than using SIP yet again
> as another form of media protocol.
> 
> If it will be INVITE to establish the publishing
> dialog, then, as Aki suggests, PIDF is the way to
> go, IMHO.
> 
> Regards,
> Hisham
> 

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 11 Feb 2003 00:02:01 -0500

I still would propose to first define PUBLISH as a standalone method, 
like OPTIONS, which does its job.

We can separately investigate setting up a signaling session if people 
are interested. But, that is a bigger more conentious topic that should 
not hold up the more pressing, simpler work.

-Jonathan R>

Sean Olson wrote:
>>>From: ext [email-masked]
>>
>>[mailto:[email-masked]]
>>
>>>To: [email-masked];
>>
>>[email-masked]
>>
>>>Cc: [email-masked]; [email-masked];
>>
>>Kiss Krisztian
>>
>>>(NRC/Tampere); [email-masked];
>>
>>[email-masked]
>>
>>>>From: ext Anders Kristensen
>>>
>>[mailto:[email-masked]]
>>
>>>>Paul Kyzivat wrote:
>>>>
>>>>>It does however open up some new issues that
>>>>
>>would need to 
>>
>>>>be sorted out 
>>>>
>>>>>- not a fundamental problem, just more work.
>>>>
>>Specifically, 
>>
>>>>what should a 
>>>>
>>>>>UAS do when receiving a "medialess"
>>>>
>>invitation? This 
>>
>>>>probably depends on 
>>>>
>>>>>the purpose of the invitation. In the case we
>>>>
>>are 
>>
>>>>discussing the purpose 
>>>>
>>>>>is simply to establish a dialog to carry
>>>>
>>PUBLISH messages, 
>>
>>>>but it could 
>>>>
>>>>>be preparatory to a reinvitation with media,
>>>>
>>or whatever. 
>>
>>>>If the UAS 
>>>>
>>>>The intent to send PUBLISH'es over a dialog
>>>
>>could be "negotiated" 
>>
>>>>through an m= line of the sdp in the INVITE
>>>
>>similar to what 
>>
>>>>we're doing 
>>>We can also go down this path and forget PUBLISH
>>
>>altogether, 
>>
>>>and use a PDIF-over-TCP media - just like we've
>>
>>done away 
>>
>>>It seems to me we're going around in circles here.
>>
>>Where are 
>>

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com