Subject: RE: [Simple] Urgent: Event Lists Open Issue

From: Adam Roach <[email-masked]>
Date: Mon, 24 Mar 2003 18:11:47 -0600

After some further reflection, I think I see the disconnect
here.

When I say "applied to the root only", you're still thinking
of what I mean by "applied to everything".

The type of filter that would be "applied to the root only"
or "applied to non-leaves only" would be something along
the lines of "inform me only when the 'state' attribute of an
<instance> element transitions from 'active' to 'terminated'".
(Visual aid: example at the top of page 13 of
draft-ietf-simple-event-list-00)

The point of my "tell me when someone moves by more than 100
miles" example is that this is exactly the sort of filter
that CANNOT be applied to the root node, only to leaf nodes.

/a

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Monday, March 24, 2003 17:55
> To: Adam Roach
> Cc: Jonathan Rosenberg; [email-masked]'
> Subject: RE: [Simple] Urgent: Event Lists Open Issue
> 
> 
> On Mon, 2003-03-24 at 16:08, Adam Roach wrote:
> > Ben Campbell [mailto:[email-masked]] writes:
> > 
> > > I have a hard time
> > > understanding the distinction between applying a filter 
> to the list
> > > subscription and applying the subscription to the "conceptual"
> > > underlying subsriptions.
> > 
> > Thinking still of these conceptual underlying subscriptions,
> > a subscription to a list creates an arbitrarily deep tree
> > of subscriptions, in which all of the leaves are non-list
> > resources, and all other nodes are list resources.
> > 
> > Keeping this tree in mind, the question being posed fundamentally
> > boils down to this: When a filter document is included in a
> > SUBSCRIBE message to a list, which of these nodes does it apply to?
> > 
> > a) Only the root node?
> > b) Only the leaves?
> > c) Everything?
> > d) Everything but the leaves?
> > e) Some subset of nodes not listed above?
> > 
> > > For example, is it a question of saying "only tell me when 
> > > someone moves
> > > 100 miles" vs. "Tell me when Alice moves 50 mi or Bob 
> moves 75 mi"?
> > 
> > That's interesting, but not really what I had in mind. It also
> > indicates to me that the model you had in your mind was option
> > "b) Only the leaves".
> > 
> 
> No, actually what I had in mind was "a) Only the root.".
> 
> Maybe my disconnect is it still feels that the only rational model is
> "A) only the root", and options B and C are, among others, possible
> mechanisms the root can use to implement that. (Which, by the 
> way, seems
> to take us back to my first response.)
> 
> Since we seem to be talking _way_ past each other, let me extend your
> concrete example. If I only want to see notifies that involve a 100 mi
> or more change in geoloc, I express that on my SUBSCRIBE 
> request to the
> list. Now, the list server could go about that in a number of ways. It
> could delegate subscriptions for each list entry (with real or
> conceptual subscriptions), and only pass through 
> notifications when the
> threshold is reached. This seems like a clear case of option a).
> 
> Now, it could also do this by attaching a derived filter to each
> delegated subscription, so that _it_ only sees the changes that match
> the rule, and passes them all on to the watcher. That would 
> _seem_ like
> option B. But from the watcher's perspective, these two approaches
> should be indistinguishable.
> 
> I guess my point is, it seems to me this should be specified based on
> what goes into the root subscription, and what comes back out--which
> should be doable without explicitly dealing with filters in the list
> draft, just as it is without explicitly reving 3265.
> 
> 
> > /a
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 24 Mar 2003 18:22:41 -0600

Actually, the disconnect was a question of where the rule is executed
vs. expressing what a particular rule applies to. I originally thought
the latter, redirected myself to the former, and now have come full
circle in believing we are talking about the latter.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 24 Mar 2003 22:33:39 -0500

Question inline.

> draft-ietf-simple-event-list-00)

Why can't this be applied to everythign? The list server would pass such 
a filter on, and any leaves would process it. Those leaves which are not 
<instance> would send no notifications, and the one which is wuold send 
them only on state transitions.

Perhaps you had in mind that the list server would interpret this rule, 
and as a result, only subscribe to <instance>, and in that body, 
construct its own filter that applies to a single presentity, saying 
"inform me when the state changes from active to terminated"?

Note that I still believe this should not impact the list draft, which 
should still just say that filters appear in the bodies, which is under 
development.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com