Subject: RE: MSRP: Connection Sharing (was Re: [Simple] MSRP: Towards clos ure on HoL blocking issue)

From: [email-masked]
Date: Fri, 2 May 2003 10:58:42 +0300

Inline.

 > -----Original Message-----
 > From: ext Paul Kyzivat [mailto:[email-masked]]
 > Sent: 01 May, 2003 00:27
 > To: Adam Roach
 > Cc: Ben Campbell; Simple WG
 > Subject: Re: MSRP: Connection Sharing (was Re: [Simple] MSRP: Towards
 > clos ure on HoL blocking issue)
 > 
 > 
 > 
 > 
 > Adam Roach wrote:
 > > Ben Campbell writes:
 > > 
 > > 
 > >>Jonathan suggested we should handle flow control by simply dropping
 > >>messages. This is not as heinous as it first sounds, since 
 > MSRP does
 > >>have e2e acknowledgement of message delivery.
 > > 
 > > 
 > > The prospect of designing yet another protocol that needs to
 > > retransmit requests over a *reliable* transport layer if
 > > no response is received makes me more than a little queasy.
 > 
 > You beat me to it - my stomach has been bothering me for awhile too.
 > 
 > I'm trying to remember why we put the end-to-end acks in. 
 > I'm quite sure 
 > it wasn't so we could drop messages with the expectation 
 > that the sender 
 > would retry them. I think maybe it was so the sender can 
 > detect when the 
 > other end fails.

For testing endpoint liveliness, I think it is better to make it explicit rather than implicit. Defining new methods to do this (like PING/PONG in IRC) is better because an endpoint can then be tested even when there are no IMs to send. Another suggestion was to use the VISIT request to refresh the connection.

Cheers,
Aki

 > 
 > 	Paul
 > 
 > _______________________________________________
 > Simple mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/simple
 > 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 02 May 2003 10:29:39 -0500

> For testing endpoint liveliness, I think it is better to make it explicit rather than implicit. Defining new methods to do this (like PING/PONG in IRC) is better because an endpoint can then be tes…

Both VISIT and BIND will be soft state (i.e. refreshed) in the next
revision.