Subject: [Simple] Congestion Control

From: Colin Young <[email-masked]>
Date: Wed, 28 May 2003 11:38:22 -0400

Hi,

RFC 3428 says (section 8, page 8),

"At the time of this writing, there is no mechanism for a UAC to gain such knowledge outside of trivial network architectures, or networks that are wholly controlled by a single administrative domain.  But if a mechanism for ensuring congestion-control at each hop is created in the future, MESSAGE clients can relax the size limit without requiring a change to this specification.  The authors expect that such a mechanism or mechanism will be created in the near future."

I was just wondering if anyone has heard of any progress being made on this issue.

Thanks,

Colin Young
[email-masked]

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Thu, 29 May 2003 03:47:34 +0300

Inline.

 > -----Original Message-----
 > From: ext Dean Willis [mailto:[email-masked]]
 > Sent: 28 May, 2003 21:52
 > To: 'Colin Young'; [email-masked]
 > Subject: RE: [Simple] Congestion Control
 > 
 > 
 > 
 > Colin asked:
 > > -----Original Message-----
 > > From: [email-masked] [mailto:[email-masked]] On 
 > > Behalf Of Colin Young
 > > Sent: Wednesday, May 28, 2003 10:38 AM
 > > To: [email-masked]
 > > Subject: [Simple] Congestion Control
 > > 
 > > 
 > > Hi,
 > > 
 > > "At the time of this writing, there is no mechanism for a UAC 
 > > to gain such knowledge outside of trivial network 
 > > architectures, or networks that are wholly controlled by a 
 > > single administrative domain.  But if a mechanism for 
 > > ensuring congestion-control at each hop is created in the 
 > > future, MESSAGE clients can relax the size limit without 
 > > requiring a change to this specification.  The authors expect 
 > > that such a mechanism or mechanism will be created in the 
 > > near future."
 > > 
 > The latest is:
 > http://www.ietf.org/internet-drafts/draft-ietf-sip-congestsafe-01.txt
 > And
 > http://www.ietf.org/internet-drafts/draft-khartabil-sip-conge
 > stionsafe-ci-02
 > .txt
 > 
 > My thinking is that we agreed at the last IETF meeting that 
 > we couldn't
 > agreee on what congestion was or what it might mean to be 
 > "safe" from it, so
 > we're basically not working on it right now.

This probably was the general feeling in the meeting, but perhaps we weren't addressing the right issue there. As I remember the events that lead to MESSAGE having the size restriction in the first place, it was more due to a bug (or was it a feature?) of the SIP spec than IMs being universally congestion safe. I thought all we needed to do in congestsafe to correct this was, really, to have a way of telling proxies not to send the MESSAGE over UDP, no matter what.

So what if we drop the safety portion of congestion safe, and focus on ensuring congestion-controlled transport gets used at each hop instead?

Cheers,
Aki 

 > Have some ideas?
 > --
 > Dean

---

From: [email-masked]
Date: Thu, 29 May 2003 03:47:34 +0300

Inline.

Cheers,
Aki