Subject: [Simple] Congestion Control

From: Colin Young <[email-masked]>
Date: Wed, 28 May 2003 11:38:22 -0400

Hi,

RFC 3428 says (section 8, page 8),

"At the time of this writing, there is no mechanism for a UAC to gain such knowledge outside of trivial network architectures, or networks that are wholly controlled by a single administrative domain.  But if a mechanism for ensuring congestion-control at each hop is created in the future, MESSAGE clients can relax the size limit without requiring a change to this specification.  The authors expect that such a mechanism or mechanism will be created in the near future."

I was just wondering if anyone has heard of any progress being made on this issue.

Thanks,

Colin Young
[email-masked]

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 28 May 2003 13:52:17 -0500

Colin asked:
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Colin Young
> Sent: Wednesday, May 28, 2003 10:38 AM
> To: [email-masked]
> Subject: [Simple] Congestion Control
> 
> 
> Hi,
> 
> "At the time of this writing, there is no mechanism for a UAC 
> to gain such knowledge outside of trivial network 
> architectures, or networks that are wholly controlled by a 
> single administrative domain.  But if a mechanism for 
> ensuring congestion-control at each hop is created in the 
> future, MESSAGE clients can relax the size limit without 
> requiring a change to this specification.  The authors expect 
> that such a mechanism or mechanism will be created in the 
> near future."
> 

The latest is:

http://www.ietf.org/internet-drafts/draft-ietf-sip-congestsafe-01.txt
And
http://www.ietf.org/internet-drafts/draft-khartabil-sip-congestionsafe-ci-02
.txt

My thinking is that we agreed at the last IETF meeting that we couldn't
agreee on what congestion was or what it might mean to be "safe" from it, so
we're basically not working on it right now.

Have some ideas?

--
Dean

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 28 May 2003 13:52:17 -0500

The latest is:

Have some ideas?

--
Dean