Subject: Re: MSRP: Connection Sharing (was Re: [Simple] MSRP: Towards closure on HoL blocking issue)

From: Michael Hammer <[email-masked]>
Date: Thu, 01 May 2003 11:09:48 -0400

Ben,

Does it matter whether the "clients" are single-user versus multi-user?

I'm wondering where the first point of multiplexing is.

Mike

At 10:58 AM 4/29/2003 -0500, Ben Campbell wrote:
>OK, we now have several people coming out to say that they think sharing
>connections across multiple MSRP sessions should not be a requirement.
>But we previously had pretty strong support for it. Since this concept
>is the motivation for a number of other MSRP decisions that are proving
>controversial, I suggest we make a decision on it now.
>
>
>
>So, please respond to the following questions:
>
>1) Do we really need connection sharing between clients and relays?
>
>2) Do we really need connection sharing between relays?
>
>
>On Tue, 2003-04-29 at 10:13, David R. Oran wrote:
> > Sorry if I'm jumping in late. I much prefer to KISS and do nothing, as
> > proposed by Henning. If we want to multilex transport connections in the
> > future for relays, do it with SCTP and have one stream per client session.
> >
> > Dave.
> >
> >
> > --On Monday, April 28, 2003 2:18 PM -0500 Ben Campbell
> > <[email-masked]> wrote:
> >
> > > We have had lots of discussion on this, going off in several directions.
> > >
> > > I re-propose the following. If anyone has serious objections, please
> > > speak up. (Actually, I would appreciate it if anyone who has previously
> > > expressed an opinion on this matter to speak up one way or another.)
> > >
> > > 1. 64k-1 end-to-end size limit on MSRP requests, enforced by a fixed
> > > length message size field.
> > >
> > > 2. Chunking pushed to a future (but real soon) work. Chunking would be
> > > endpoint controlled, negotiated in SDP, and likely based on the existing
> > > MIME message/partial spec with some relaxation of the 7 bit rules, etc.,
> > > that Adam mentioned.
> > >
> > > _______________________________________________
> > > Simple mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/simple
> >
> >
> >
> > ------------------------
> > David R. Oran
> > Cisco Systems
> > 7 Ladyslipper Lane
> > Acton, MA 01720
> > Office: +1 978 264 2048
> > VoIP: +1 408 571 4576
> > Email: [email-masked]
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
>
>_______________________________________________
>Simple mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: 01 May 2003 10:21:12 -0500

The existing draft assumes connection sharing is possible at
client-client, client-relay, and relay-relay connections. So for a
multiuser client, the first point of multiplexing could be the client
itself.

If we do away with sharing at client-client and client-relay, then, at
least over TCP, a multi-user client would need to open a separate
connection for each session.

---

From: Michael Hammer <[email-masked]>
Date: Thu, 01 May 2003 13:21:37 -0400

At 12:36 AM 4/30/2003 -0400, Jonathan Rosenberg wrote:
>>4) Be effective in delivering messages of all sizes, up to and
>>including multi-gigabyte messages. (How much of a requirement is
>>this???)
>
>It is an important requirement.

At what point does one then declare FTP to be obsolete?  That is, what is 
the difference between FTPing and IMing?

>If this particular requirement is causing a serious problem with other 
>requirements - i.e., message size limits, DoS attacks, etc., I would dump 
>this in favor of others. After all, our preferred model is e2e 
>connections, where there would be no connection sharing at all between 
>endpoints.

Once you insert relays, can you still claim that it is e2e?

Mike