Subject: RE: [Simple] Sending 1 to n MESSAGEs

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Jun 2003 10:37:37 -0400

Was the salutation to your message a comment on the quality of
the discourse on this list?  ;)  

Good thought.  Interacts with conferencing (mass invite to a conference).
You don't want to have to have a complex interaction prior to sending
a list of recipients.  Smells like a kind of forking behavior, but 
clearly different (not all the same AOR).  Obviously creates multiple
dialogs if/when multiple responses are received.  The proxy can't be
the origination point; it's not a UA.  All the responses are going to
be forwarded to the UA.  The only way around that is B2BUA behavior.
Is that a better, or a worse idea?

Gotta think through what this means for Message Sessions.  You want the
proxy to replicate each message, but you don't really want to repeat
the list of recipients.  Does that argue for B2BUA more strongly?

With a B2BUA approach you send the message to the exploder.  It
sends individual messages to recipients, and handles all the dialogs.
That reminds me of a buddy list subscription without the prearranged 
buddy list.

Brian

> -----Original Message-----
> From: Mills, Duncan, D, CND Tech Dev, VF UK
> [mailto:[email-masked]]
> Sent: Tuesday, June 24, 2003 9:42 AM
> To: [email-masked]
> Subject: [Simple] Sending 1 to n MESSAGEs
> 
> 
> SIMPLE people,
> 
> I've just been thinking about how my e-mail works, and what I 
> like best about it.  It is really easy to type a long message 
> and then send it to a list of (more than one) people.  Better 
> still, I don't have to have pre-configured that list of 
> people.  I can just type in the addresses in the To: field 
> and the mail will be sent to each address.
> 
> As far as I know, I can't do this with the SIP MESSAGE 
> method.  Yes, I can create a resource URI in a server and 
> send one MESSAGE request to that resource-URI, and the server 
> may fork the MESSAGE to each URI in my pre-configured list.  
> But if I don't want to have to set up a new list of 
> recipients each time I send a MESSAGE then I have to send the 
> same MESSAGE several times.  Please correct me if I'm wrong.
> 
> Now... looking at this from a wireless operator perspective, 
> I immediately see warning signs about my £6 billion radio 
> interface ;-)  Currently, in GSM, if we want to send an SMS 
> to more 'n' recipients, we have the same situation- either 
> create a user group in the network or send the message 'n' 
> times.  However, a SIP MESSAGE request is likely to be about 
> ten times the size of an SMS.
> 
> Is this a problem?  If not, why not?  Maybe I'm missing some 
> background/historical information?
> 
> If it is a problem, might it be possible to extend SIP in 
> such a way as to state that the request-URI be set to the 
> address of my SIP proxy server in my home network and then 
> the To: field be filled with the list of intended recipients, 
> with the server then being responsible for sending the 
> MESSAGE to all the intended recipients?
> 
> Any comments/views?
> 
> Best Regards,
> 
> Duncan
> 
> 
> Duncan Mills
> Senior Engineer
> Network Standards & Technical Audit
> Technology Development (Network Systems)
> Vodafone (UK) Ltd
> Tel: +44 (0)1635 676074
> Mob: +44 7867 900955
> Fax: +44 (0)1635 234445
> mailto:[email-masked]
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 25 Jun 2003 14:30:20 -0400

It should at least be technically possible to do the explosion in a 
proxy rather than a B2BUA. If you address the message to an exploder, 
and include the actual list of intended recipients as another header, 
the exploder can act as a proxy, forking the message to each of the 
intended recipients.

Done this way, the sender will receive a response from each recipient, 
which may be good in some cases.

If you only want a single response, then the exploder can act as a 
B2BUA. It could even choose to act one way or the other depending on 
some parameter in the request.

Either way, the exploder can either leave the list of recipients in the 
message for the ultimate recipients to see, or remove it. That is 
another option or policy.

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 25 Jun 2003 14:30:20 -0400

Paul

---

From: Ben Campbell <[email-masked]>
Date: 26 Jun 2003 13:15:55 -0500

> which may be good in some cases.

You only get one final response from a forked non-invite transaction.

---

From: Ben Campbell <[email-masked]>
Date: 26 Jun 2003 13:15:55 -0500