Subject: RE: [Simple] comments on rpids-01 <activity>, <idlesince>

From: [email-masked]
Date: Fri, 27 Jun 2003 17:01:31 +0300

I think the current definition of <activity> is to represent my current interaction with a device (if I'm using the device currently or not). Something like <in-use>. I think this is the wrong definition. The examples in the I-D describing the element certainly elude to this.

Most of the time, my mobile phone sits by my side. It can be idle for hours and without any activity. This does not give a true representation of my ability to receive calls on it. This is different from me being away from my PC for hours without any activity. In this case, a true representation of my ability to receive calls on it is possible.

What I believe the <activity> element should represent is user's ability to answer calls (or receive any other media, or whatever) on that device. One could argue that OPEN and CLOSED are sufficient enough for this. Else, you need an element like <current-communication-ability> (a better name is needed here, but couldn't think of one from the top of my head).

Another issue with <activity> that I would like to bring up: It only talks about a device. I would like to know the meaning on this element when a tuple does not represent a device (a different <contact-type>.

Regards,
Hisham

> -----Original Message-----
> From: ext Henning Schulzrinne [mailto:[email-masked]]
> Sent: Friday, June 27, 2003 5:56 AM
> To: Peterson, Jon
> Cc: Simpletons (E-mail)
> Subject: Re: [Simple] comments on rpids-01 <activity>, <idlesince>
> 
> 
> Peterson, Jon wrote:
> 
> 
> > Though I like <idlesince>, I'm less sure about <activity>. 
> In response to
> > the motivation given in 6.2, if a computer doesn't have a 
> keyboard or mouse,
> > it should be publishing a state of CLOSED; we don't need 
> <activity> to
> > supplement this. Similarly, if I see the word 'active' in 
> presence, I would
> > assume that the presentity is around (and thus perhaps 
> ready to communicate)
> > - perhaps not what I should assume if they are on the 
> phone. If someone is
> > totally idle (at a threshold judged by the watcher), they 
> could derivately
> > be considered inactive - that's the quality that we really 
> need here; the
> > only difference that <activity> introduces, I think, is 
> that the presentity
> > rather than the watcher makes the judgment call of 
> activeness based on that
> > idleness timer. But then again, the presentity still always 
> gets to choose
> > the threshold at which it starts including an <idlesince> 
> element. Finally,
> > commercial instant messaging systems don't tell me, for 
> example, that a
> > presentity is currently conversing with two other IMers (which would
> > presumably be the corollary of <activity> for IM), so I'm 
> not sure I see
> > this sort of activity as being something we immediately need for our
> > short-term goals.
> 
> The idea is to provide additional, automatically derivable, 
> indication 
> of liveness. Current systems (like Windows Messenger) change the 
> activity indication to 'idle' if you don't use your keyboard 
> or mouse. 
> However, that's at best a guess (you might just be talking to a 
> colleague in your room, so you're hardly "idle"), and overloads an 
> indicator with two meanings that are not orthogonal.
> 
> A device that is 'idle' can be either OPEN or CLOSED - it 
> just provides 
> an additional hint to the watcher as to why nobody writes back when I 
> type. (MS Messenger puts up some kind of message saying that 
> the other 
> side may not respond, I think.)
> 
> If I recall the discussion correctly, <activity> was seen as a "less 
> revealing" form of <idlesince>. Thus, they share the same motivation, 
> but <activity> allows a presentity to indicate lack of 
> activity without 
> revealing how long I've not been using the device.
> 
> Maybe a simpler, less confusing, way of coding this is to simply allow
> <idlesince> to be empty, indicating that I am indeed 'idle', 
> but I won't 
> tell you for how long. Would that be clearer?
> 
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 27 Jun 2003 11:53:15 -0400

Not all elements will be appropriate for all types of services or 
devices. To pick on something outside RPIDS 01: it is unclear that 
geoloc or media would be appropriate for all kinds of tuples.

As noted earlier, the <idlesince> indication does not intend to provide 
a clue as to whether the device is OPEN or CLOSED - we have this 
already. It provides additional hints to the watcher as to which device 
is more likely to be "staffed". Combinations of <idlesince> with both 
OPEN and CLOSED are quite plausible, I think.

My current preference is to have only <idlesince>. For privacy, an empty 
element meaning indicates device has been idle (unused) for some 
unspecified time. I think this makes the logic a bit simpler.

[email-masked] wrote:

> I think the current definition of <activity> is to represent my
> current interaction with a device (if I'm using the device currently
> or not). Something like <in-use>. I think this is the wrong
> definition. The examples in the I-D describing the element certainly
> elude to this.
> 
> Most of the time, my mobile phone sits by my side. It can be idle for
> hours and without any activity. This does not give a true
> representation of my ability to receive calls on it. This is
> different from me being away from my PC for hours without any
> activity. In this case, a true representation of my ability to
> receive calls on it is possible.
> 
> What I believe the <activity> element should represent is user's
> ability to answer calls (or receive any other media, or whatever) on
> that device. One could argue that OPEN and CLOSED are sufficient
> enough for this. Else, you need an element like
> <current-communication-ability> (a better name is needed here, but
> couldn't think of one from the top of my head).
> 
> Another issue with <activity> that I would like to bring up: It only
> talks about a device. I would like to know the meaning on this
> element when a tuple does not represent a device (a different
> <contact-type>.
> 
> Regards, Hisham
>