Subject: RE: [Simple] XCAP issue: batching

From: [email-masked]
Date: Tue, 3 Jun 2003 18:54:33 +0300

I meant something like this:

POST http://xcap.example.com/services/presence-lists/users/joe/list 1.xml
   
<delete>/presence-lists/list[@name=friends]/entry[@name=bill]</delete>

/Hisham

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, June 03, 2003 6:47 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Simple] XCAP issue: batching
> 
> 
> 
> 
> [email-masked] wrote:
> > I don't yet have a preference, I have to think about the options a
> > little more. I do have a question about option II though:
> > 
> > Does going with option II potentially mean eliminating the need of
> > the DELETE method usage? and perhaps PUT as well? So we only have
> > POST and GET.
> 
> I suppose so, but at the cost of a lot of overhead. Basically, in the 
> case of buddy lists, to delete a buddy, you'd have to re-POST the 
> entire list, just without that buddy. Not what we want to do, I think.
> 
> Also, that would not work for deleting documents, where an explicit 
> DELETE is still needed.
> 
> -Jonathan R.
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Scientist                             Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 03 Jun 2003 12:02:38 -0400

I see. Yes, you could do that. I personally don't like it too much, 
since it devolves into using HTTP as a tunelling protocol for 
something that is more or less HTTP, but in XML format. I like the 
idea of preserving the HTTP semantics.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 03 Jun 2003 12:02:38 -0400

-Jonathan R.