Subject: [Simple] Question on draft-ietf-simple-winfo-package-05

From: "Mills, Duncan, D, CND Tech Dev, VF UK" <[email-masked]>
Date: Tue, 17 Jun 2003 10:20:18 +0100

Hi,

I have a question on the above internet-draft:

In section 5, "example usage," we see Joe subscribing to his own 'presence.winfo' event.  Then we see another user, [email-masked] trying to SUBSCRIBE to Joe's presence state.  Joe is sent a NOTIFY request to tell him that a subscription is pending.  Joe responds to this with a 200 OK.

The draft then says that "Joe then authorizes A's subscription through some means."

Can someone give me an example of how Joe authorises A's subscription?

Is there no possibility to allow the 200 OK to carry the authorisation, implicit or otherwise?

Regards,

Duncan

Duncan Mills
Senior Engineer
Network Standards & Technical Audit
Technology Development (Network Systems)
Vodafone (UK) Ltd
Tel: +44 (0)1635 676074
Mob: +44 7867 900955
Fax: +44 (0)1635 234445
mailto:[email-masked]

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Tue, 17 Jun 2003 17:07:40 +0300

This is an on going work in the SIMPLE WG.

Take a look at the requirements:
http://www.ietf.org/internet-drafts/draft-ietf-simple-data-req-02.txt

And the proposed solution:
http://www.jdrosen.net/papers/draft-rosenberg-simple-xcap-00.txt
http://www.jdrosen.net/papers/draft-rosenberg-simple-xcap-package-00.txt
http://www.jdrosen.net/papers/draft-rosenberg-simple-xcap-list-usage-00.txt 

Authorisation list usage should be published soon by Jonathan Rosenberg.

Regards,
Hisham

> -----Original Message-----
> From: ext Mills, Duncan, D, CND Tech Dev, VF UK
> [mailto:[email-masked]]
> Sent: Tuesday, June 17, 2003 12:20 PM
> To: [email-masked]
> Subject: [Simple] Question on draft-ietf-simple-winfo-package-05
> 
> 
> Hi,
> 
> In section 5, "example usage," we see Joe subscribing to his 
> own 'presence.winfo' event.  Then we see another user, 
> [email-masked] trying to SUBSCRIBE to Joe's presence state.  
> Joe is sent a NOTIFY request to tell him that a subscription 
> is pending.  Joe responds to this with a 200 OK.
>

---

From: [email-masked]
Date: Tue, 17 Jun 2003 17:07:40 +0300

Regards,
Hisham

---

From: [email-masked]
Date: Tue, 17 Jun 2003 15:38:40 -0400

Duncan,

My understanding is that the currently proposed means for modification of the authorization policy (including in response to a pending subscription) is XCAP (draft-rosenberg-simple-xcap). The XCAP proposal is for a set of conventions for using HTTP to read, write and modify the data stored on the server (including the authorization policy document).

The 200 OK to the Notify acknowledges that the Notify was received and processed by the UA. Authorization will likely require human intervention and may take place some minutes or even hours after the notification is received, if at all. The authorization policy may be considerably more complex than authorized or not authorized. There may be some data that is to be set to false indications (e.g. IF “at lunch” THEN show “in a meeting”) and other presence information that is to be completely hidden from the subscriber even though the subscription is accepted. Authorizing the subscriber requires a modification to the authorization policy document. For these reasons alone “piggy backing” the authorization on the 200 OK would not be suitable.

Regards
Andrew

---

From: [email-masked]
Date: Tue, 17 Jun 2003 15:38:40 -0400

Duncan,

Regards
Andrew