Subject: RE: [Simple] Sending 1 to n MESSAGEs

From: Michael Hammer <[email-masked]>
Date: Thu, 26 Jun 2003 10:14:35 -0400

At 07:01 PM 6/25/2003 -0500, Adam Roach wrote:
>As a related issue, you'll need to address the situation in which
>an IM is sent to a group, and one such member is offline. Imagine
>that this offline member has a message store that will play back
>missed messages when he comes back online (cf. current SMS usage).
>If the online recipients decide to respond to the message in such
>a way that the response is sent to all the original recipients,
>and a rather lengthy conversation ensues, the offline user is in
>for an annoying torrent of messages -- probably stale -- when he
>finally comes back online.

Maybe this is a philosophical point, but shouldn't there be a distinction 
between IM and email?  Or, put another way shouldn't IM be instant.  By 
definition, it they aren't online, they can't IM.  If someone is off-line, 
and you still want to send, use email.

Using sessions for messages probably prevents such stale-ness.  Perhaps, 
even without the session, a low value Expires header should be Recommended 
for group cases, rather than just a MAY.

Mike

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Thu, 26 Jun 2003 17:32:36 +0300

Inline.

Michael Hammer wrote:
> Maybe this is a philosophical point, but shouldn't there be a 
> distinction between IM and email?  Or, put another way shouldn't IM be 
> instant.  By definition, it they aren't online, they can't IM.  If 
> someone is off-line, and you still want to send, use email.

IM is instant by definition, something that e-mail is not (by definition). 
Email is store and forward, something taht IM is not.

You seem to mix presence availability with IM. Some IM systems allow 
senders to IM even when the recipient is not online. In that case the 
message is stored until the recipient becomes online.

> even without the session, a low value Expires header should be 
> Recommended for group cases, rather than just a MAY.

Low expires header values maybe something interesting to consider.

> Mike

/Miguel
-- 
Miguel-Angel Garcia                     Oy LM Ericsson AB
                                         Jorvas, Finland
mailto:[email-masked]     Phone:  +358 9 299 3553
mailto:[email-masked]        Mobile: +358 40 5140002

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Thu, 26 Jun 2003 17:32:36 +0300

Inline.

/Miguel