Subject: Re: Use of require header in SUBSCRIBE with a filter (was: RE: [Simple] RE: Comments on draft-khartabil-simple-filter-funct-00)

From: [email-masked]
Date: Tue, 03 Jun 2003 11:12:54 -0400

Hisham,

My responses below proceeded by [AA]

Regards
Andrew

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Thursday, May 29, 2003 6:32 PM
> To: Khartabil Hisham (NMP/Helsinki); [email-masked]
> Cc: [email-masked]
> Subject: Re: [Simple] RE: Comments on
> draft-khartabil-simple-filter-funct-00
> > 
> 
> 
> > I think we need a separate mechanism to indicate the 
> > difference between options 2 and 3. Also the UAC should be 
> > able to indicate whether option 2 is acceptable since option 
> > 2 could result in a large presence document being sent in a 
> > Notify, which may not be acceptable to the UAC.
> 
> I will remove references to the word "ignore" in the next 
> version. If a server does not like a filter, it rejects it. 
> When it comes to authorisation, the server can examine the 
> filter after its has applied the authorisation policy. I'll 
> clarify that also.
> 
> [AA] This is certainly one approach we could take however 
> this means that if I would like to use filtering but I am 
> willing to accept the subscription without filtering then I 
> may have to make two subscription attempts one with and one 
> without filtering. It seems to me that it would be more 
> efficient to use the SIP extension use negotiation 
> capabilities (Supported and Require) for a more efficient and 
> flexible mechanism. This is also along the lines of what is 
> currently proposed in draft-lonnfors-simple-partial-notify 
> where the option is there to indicate whether the use of the 
> extension is required or not. IMO it would make sense to be 
> consistent with subscription state handling for both partial 
> notifications and filtering.
> 

Firstly, I was just agreed in the interim meeting that this require-header in partial notification is not necessary and will be removed.

It is widely accepted that it is a server choice to honour filters. Do we need to change that? I need input from others on the list.

[AA] I think that the server should always have a choice whether to honour filters however the client needs to also be able to decide if it wants to subscribe without filters. I think that consistent behaviour of subscriptions with partial notification makes a lot of sense so lets just get rid of the possibility of the Server accepting the subscription while ignoring the filter as you proposed in your earlier email.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Tue, 03 Jun 2003 11:12:54 -0400

Hisham,

Regards
Andrew