Subject: Re: Scope of filter addressing (was: RE: [Simple] RE: Comments on draft-khartabil-simple-filter-funct-00)

From: [email-masked]
Date: Tue, 03 Jun 2003 11:14:13 -0400

Hisham,

My responses below proceeded by [AA]

Regards
Andrew

-----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Thursday, May 29, 2003 6:32 PM
> To: Khartabil Hisham (NMP/Helsinki); [email-masked]
> Cc: [email-masked]
> Subject: Re: [Simple] RE: Comments on
> draft-khartabil-simple-filter-funct-00
> [AA] The text at issue here is in clause 4.1 “If the URI 
> indicated by the filter criteria is for one resource who's 
> URI is NOT one of the URIs that result from a lookup, by the 
> RLS, on the Request-URI, the filter criteria are propagated 
> to all the fanned out subscriptions. This is to accommodate 
> the scenario where the
> subscriber knows that there are sub-lists in the list that 
> the original subscription was sent to, and the subscriber 
> wishes to set a filter criteria for a resource in that sub-list.”
> 
> [AA] The issue that I am identifying is when the filter 
> criteria corresponds to a resource that is a child of a sub 
> list of the list. For instance 3 lists A, B, and C, each in 
> different domains where A is a child of B and B is a child of 
> C:    CàBàA
> 
> [AA] Now in the subscription to C I want to be able to 
> include filter criteria that is targeted at a particular 
> member of list A (Amember1). In order to target the URI 
> member of A in the subscription to list C we need to specify 
> the path of the URI: C->B->A->Amember1. Maybe Xpath can also 
> be used for this purpose? For the reasons stated I think 
> simply propagating the filter criteria corresponding to a 
> resource unknown to the RLS to every descendent, (as I 
> understand from this text is proposed), is a bad idea. 
> Instead the filter criteria should only be propagated down 
> the specific branch that contains the target. In addition to 
> the issues raised earlier, I think also there may be privacy 
> concerns with broadcasting the filter criteria to other 
> branches of the tree that are possibly in different domains 
> from the target (i.e Do you want your company to know who all 
> your personal contacts are?)

As was discussed in the interim meeting, this URI approach might not be good enough to describe wild cards (this filter applies to all people in nokia.com, people is a georgraphic location (this filter applies to people in helsinki), etc.

This is certainly expanding the scope of this work and the question is do we need such scope.

[AA] Unfortunately I was not at the interim meeting and so I do not fully understand this comment, (I will read Robert’s report for details when it comes out). I assume what is meant is that there is maybe some cases when you want a filter to be propagated down multiple branches because the filter criteria have global applicability. I think that there are also cases when you don’t (as I have shown in some of my examples). My understanding was that if the URI was the URI of the list then the filter criteria applies to all the members of the list and is propagated down all the branches. I think we also need the ability to target filters at individual members as well though.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Tue, 03 Jun 2003 11:14:13 -0400

Hisham,

Regards
Andrew