Subject: RE: [Simple] comments on rpids-01 <activity>, <idlesince>

From: [email-masked]
Date: Mon, 30 Jun 2003 10:20:07 +0300

> -----Original Message-----
> From: ext Henning Schulzrinne [mailto:[email-masked]]
> Sent: Saturday, June 28, 2003 12:18 AM
> To: Trossen Dirk (NRC/Boston)
> Cc: [email-masked]
> Subject: Re: [Simple] comments on rpids-01 <activity>, <idlesince>
> 
> 
> 
> > In case I understood Hisham's comment correctly (correct me, Hisham,
> > if I'm wrong), it is more about the possible need for both or at
> > least the different meaning of both, i.e., <idlesince> and 
> <activity>
> > do not represent the same thing. This is because an <activity> that
> > is related to the communication ability of the user with the
> > particular device is not necessarily bound to the time the 
> particular
> > device has been in idle mode, since not necessarily all activities
> > that influence my communication ability are related to the device
> > directly.
> > 
> > The mobile phone, as pointed out by Hisham, is a very good example.
> > Most of the time (hopefully) in idle mode, the user is 
> still able and
> > willing to communicate. However, certain "activities" indeed may
> > influence my communication ability and, hence, might be 
> worthwhile to
> >  communicate to others through my (phone) presence.
> 
> I'm afraid I'm losing you here. For the cellphone case, the 
> <idlesince> 
> indicates when you last used the cellphone, providing a hint as to 
> whether you are likely to be near the phone, for example.

In the case of mobile phone (cellphone), <idlesince> does not provide any hint as to whether I am likely to be near the phone or not. This was exactly my point inthe earlier posting. If you use the <idlesince> value as an indication of the likelihood of me answering my mobile phone, then you may never call me on my mobile unless I just got off a phone call (its idle all other times). So we need something like OPEN and CLOSED.

> 
> The activity indication (sleeping, driving, etc.) is completely 
> separate. Just to avoid misunderstandings, what exactly are you 
> referring to as activity?

I am using the current definition of <activity> with values active and inactive. But I think we agreed that OPEN and CLOSED where a sufficient enough replacement. Did we?

/Hisham

> 
> > 
> > But even more, the source for <activity> and <idlesince> could be
> > different. <idlesince> is certainly bound to the phone, while the
> > <activity> element can be determined through other means 
> and devices.
> >  For instance, my current activity on the desktop could influence my
> > communication ability/willingness. Hence, it is the desktop which
> > could set (one) particular value for <activity>.
> > 
> > Do we want to cover something like this?
> 
> I'm confused; RPIDS already has an indication of what the 
> user is doing. 
>   This used to be called <category>; based on Jon's comment, I now 
> re-labeled this element as <activity>, since that's a more obvious 
> label. This element contains things like on-the-phone, away, 
> appointment, holiday, meal, meeting, steering, etc. as 
> 'reserved words', 
> plus additional indications. Can you give a concrete example what 
> indication you have in mind?
> 
> Note that there is a separate draft, 
> draft-rosenberg-peterson-simple-pidf-phone-00.txt, that describes the 
> detailed state of the phone as a device.
> 
> Henning
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 30 Jun 2003 21:24:52 -0400

[email-masked] wrote:

> In the case of mobile phone (cellphone), <idlesince> does not provide
> any hint as to whether I am likely to be near the phone or not. This
> was exactly my point inthe earlier posting. If you use the
> <idlesince> value as an indication of the likelihood of me answering
> my mobile phone, then you may never call me on my mobile unless I
> just got off a phone call (its idle all other times). So we need
> something like OPEN and CLOSED.

We must be talking past each other. There are three cases:

- You have your cell phone on and have used it recently (made a call or 
received a call). The <idle> indication might indicate "last used 5 
minutes ago". This is a good indication that you will answer that cell 
phone when I call.

- You have not used your cellphone for a long time, but it is on (= 
OPEN). This means that you're not making or receiving a lot of phone 
calls or that the phone is  silently draining its battery in your 
bedroom drawer and is too dumb to notice it. There is no way to tell one 
or the other, short of knowing your location and your cell phone location.

- The cell phone is off => Set status to CLOSED if you remember to do 
that or if the phone does it automatically. <idle> doesn't help one way 
or the other and is not relevant for CLOSED status.

Thus, for a cell phone, the useful bit of information is a *short* idle 
time. A long idle time says very little, unless I happen to know that 
you are a compulsive mobile phone user so that a long idle time might 
tell me something is amiss.

> I am using the current definition of <activity> with values active
> and inactive. But I think we agreed that OPEN and CLOSED where a
> sufficient enough replacement. Did we?

There was agreement that only <idle> (formerly known as <idletime>) is 
necessary. As I've tried to explain above, <idle> provides additional 
information that the basic OPEN and CLOSED status does not.

Henning

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 30 Jun 2003 21:24:52 -0400

[email-masked] wrote:

Henning