Subject: RE: [Simple] comments on rpids-01 <activity>, <idlesince>

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 27 Jun 2003 15:12:38 -0400

I am agreeing with you.

I agree we need several fields, and I agree that you having
them explicitly labeled and either numeric, or explicit
enumerated values.

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Friday, June 27, 2003 3:07 PM
> To: Rosen, Brian
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [Simple] comments on rpids-01 <activity>, <idlesince>
> 
> 
> 
> 
> Rosen, Brian wrote:
> 
> 
> > That means keeping several independently discoverable pieces of
> > information separate.
> 
> I'm not sure if you're agreeing with me or not, but I do want to 
> emphasize this general aspect: There is great value in having labeled 
> information as any attempt to extract information from 
> free-text fields 
> or from fields that combine multiple variables is prone to wrong 
> guesses, uncertainty and surprises. Just because some existing IM 
> systems have gotten this wrong should be no excuse to make the same 
> mistake again...
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 27 Jun 2003 15:12:38 -0400

I am agreeing with you.

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 27 Jun 2003 14:57:18 -0400

As you know, I advocate making most presence data represent the
state of a presentity (human).  However, in order to determine that,
you need to understand the state of (multiple) devices.
Then you aggregate them, filter the results by (watcher dependent)
policy, and publish the result as the presence of the human.

So, getting detailed information about a device is usefull, to
the aggregator.  You might publish the raw data to some watchers,
but I suspect you won't.  You do need the devices to be able to
provide the raw data so the aggregator can do it's job.  

Brian 

> Sent: Friday, June 27, 2003 11:53 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Not all elements will be appropriate for all types of services or 
> devices. To pick on something outside RPIDS 01: it is unclear that 
> geoloc or media would be appropriate for all kinds of tuples.
> 
> As noted earlier, the <idlesince> indication does not intend 
> to provide 
> a clue as to whether the device is OPEN or CLOSED - we have this 
> already. It provides additional hints to the watcher as to 
> which device 
> is more likely to be "staffed". Combinations of <idlesince> with both 
> OPEN and CLOSED are quite plausible, I think.
> 
> My current preference is to have only <idlesince>. For 
> privacy, an empty 
> element meaning indicates device has been idle (unused) for some 
> unspecified time. I think this makes the logic a bit simpler.
> 
> [email-masked] wrote:
> 
> > I think the current definition of <activity> is to represent my
> > current interaction with a device (if I'm using the device currently
> > or not). Something like <in-use>. I think this is the wrong
> > definition. The examples in the I-D describing the element certainly
> > elude to this.
> > 
> > Most of the time, my mobile phone sits by my side. It can 
> be idle for
> > hours and without any activity. This does not give a true
> > representation of my ability to receive calls on it. This is
> > different from me being away from my PC for hours without any
> > activity. In this case, a true representation of my ability to
> > receive calls on it is possible.
> > 
> > What I believe the <activity> element should represent is user's
> > ability to answer calls (or receive any other media, or whatever) on
> > that device. One could argue that OPEN and CLOSED are sufficient
> > enough for this. Else, you need an element like
> > <current-communication-ability> (a better name is needed here, but
> > couldn't think of one from the top of my head).
> > 
> > Another issue with <activity> that I would like to bring up: It only
> > talks about a device. I would like to know the meaning on this
> > element when a tuple does not represent a device (a different
> > <contact-type>.
> > 
> > Regards, Hisham
> > 
> 
> 
>

---

From: [email-masked]
Date: Fri, 27 Jun 2003 17:10:43 -0400

Hi Henning,

comment inline
>From: ext Henning Schulzrinne [mailto:[email-masked]]
>To: Khartabil Hisham (NMP/Helsinki)

In case I understood Hisham's comment correctly (correct me, Hisham, if I'm wrong),
it is more about the possible need for both or at least the different meaning of both, i.e., 
<idlesince> and <activity> do not represent the same thing. This is because an <activity> 
that is related to the communication ability of the user with the particular device is not 
necessarily bound to the time the particular device has been in idle mode, since not necessarily all 
activities that influence my communication ability are related to the device directly. 

The mobile phone, as pointed out by Hisham, is a very good example. Most
of the time (hopefully) in idle mode, the user is still able and willing to communicate. However, certain "activities" indeed may influence my communication ability and, hence, might be worthwhile to 
communicate to others through my (phone) presence.

But even more, the source for <activity> and <idlesince> could be different. <idlesince> is certainly
bound to the phone, while the <activity> element can be determined through other means and devices. 
For instance, my current activity on the desktop could influence my communication ability/willingness.
Hence, it is the desktop which could set (one) particular value for <activity>.

Do we want to cover something like this?

Dirk
>> Most of the time, my mobile phone sits by my side. It can be idle for

---

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 27 Jun 2003 23:23:48 -0400

[snip]
> 
> Maybe a simpler, less confusing, way of coding this is to simply allow
> <idlesince> to be empty, indicating that I am indeed 'idle', but I won't 
> tell you for how long. Would that be clearer?
> 

Yes, I think so - though perhaps <marked-idle> or something would then be a
better name for the parameter. So it could appear as
<marked-idle>(timestamp)</marked-idle> or just <marked-idle/>. An empty
<idlesince/> sounds a little ambiguous.

Jon Peterson
NeuStar, Inc.

---

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 27 Jun 2003 23:23:48 -0400

[snip]

Jon Peterson
NeuStar, Inc.

---

From: [email-masked]
Date: Mon, 30 Jun 2003 10:20:07 +0300

> Sent: Saturday, June 28, 2003 12:18 AM
> To: Trossen Dirk (NRC/Boston)
> Cc: [email-masked]
> > In case I understood Hisham's comment correctly (correct me, Hisham,
> > if I'm wrong), it is more about the possible need for both or at
> > least the different meaning of both, i.e., <idlesince> and 
> <activity>
> > do not represent the same thing. This is because an <activity> that
> > is related to the communication ability of the user with the
> > particular device is not necessarily bound to the time the 
> particular
> > device has been in idle mode, since not necessarily all activities
> > that influence my communication ability are related to the device
> > directly.
> > 
> > The mobile phone, as pointed out by Hisham, is a very good example.
> > Most of the time (hopefully) in idle mode, the user is 
> still able and
> > willing to communicate. However, certain "activities" indeed may
> > influence my communication ability and, hence, might be 
> worthwhile to
> I'm afraid I'm losing you here. For the cellphone case, the 
> <idlesince> 
> indicates when you last used the cellphone, providing a hint as to 
> whether you are likely to be near the phone, for example.

In the case of mobile phone (cellphone), <idlesince> does not provide any hint as to whether I am likely to be near the phone or not. This was exactly my point inthe earlier posting. If you use the <idlesince> value as an indication of the likelihood of me answering my mobile phone, then you may never call me on my mobile unless I just got off a phone call (its idle all other times). So we need something like OPEN and CLOSED.

> 
> The activity indication (sleeping, driving, etc.) is completely 
> separate. Just to avoid misunderstandings, what exactly are you 
> referring to as activity?

I am using the current definition of <activity> with values active and inactive. But I think we agreed that OPEN and CLOSED where a sufficient enough replacement. Did we?

/Hisham

> 
> > 
> > But even more, the source for <activity> and <idlesince> could be
> > different. <idlesince> is certainly bound to the phone, while the
> > <activity> element can be determined through other means 
> and devices.
> >  For instance, my current activity on the desktop could influence my
> > communication ability/willingness. Hence, it is the desktop which
> > could set (one) particular value for <activity>.
> > 
> I'm confused; RPIDS already has an indication of what the 
> user is doing. 
>   This used to be called <category>; based on Jon's comment, I now 
> re-labeled this element as <activity>, since that's a more obvious 
> label. This element contains things like on-the-phone, away, 
> appointment, holiday, meal, meeting, steering, etc. as 
> 'reserved words', 
> plus additional indications. Can you give a concrete example what 
> indication you have in mind?
> 
> Note that there is a separate draft, 
> draft-rosenberg-peterson-simple-pidf-phone-00.txt, that describes the 
> detailed state of the phone as a device.
> 
> Henning
> 
> 
>