Subject: RE: [Simple] Sending 1 to n MESSAGEs

From: "Mills, Duncan, D, CND Tech Dev, VF UK" <[email-masked]>
Date: Tue, 24 Jun 2003 16:46:50 +0100

Chris,

Yes, I think there are two cases here:

1.) The ability to 'explode' MESSAGES to a 'distribution list'

2.) The ability to send the same MESSAGE to several people NOT on a pre-configured distribution list (as Brian already pointed out, it would be complex to expect users to have to log onto a server in the network to set up a list every time)

I believe that 1.) can already be overcome in the way that you describe.  Basically, in this case, the user DOES have to set up the distribution list (a resource-URI) and send one MESSAGE to that list.

I am trying to solve case 2.)

Duncan

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]]
Sent: 24 June 2003 16:39
To: Mills, Duncan, D, CND Tech Dev, VF UK; [email-masked]
Subject: RE: [Simple] Sending 1 to n MESSAGEs

Duncan,

	I totally agree, I'm not saying that the latter is an option.  I was just thinking of scale e.g. you want to 'explode' to say 80 people. I guess your exploder would be able to group Sip URL's for this purpose e.g. sip:[email-masked] which has been configured to fork to 80 contact addresses.

Chris.

>-----Original Message-----
>From: Mills, Duncan, D, CND Tech Dev, VF UK
>[mailto:[email-masked]]
>Sent: 24 June 2003 16:27
>To: Chris Boulton; [email-masked]
>Subject: RE: [Simple] Sending 1 to n MESSAGEs
>
>Chris,
>
>For the sake of a few extra addresses in the MESSAGE headers, for a 1000
>byte MESSAGE request destined for 8 recipients, we can go from (for
>example) 8 * 1000 bytes to 1 * 1800 bytes (and that assumes each recipient
>address requires 100 bytes).
>
>I know which I'd prefer...
>
>Duncan
>
>-----Original Message-----
>From: Chris Boulton [mailto:[email-masked]]
>Sent: 24 June 2003 16:20
>To: Mills, Duncan, D, CND Tech Dev, VF UK; Chris Harris; Rosen, Brian;
>[email-masked]
>Subject: RE: [Simple] Sending 1 to n MESSAGEs
>
>
>Chris,
>
>	Wouldn't this be an expensive way of including a list of X-recipients
>(message size)?
>
>Chris B.
>
>
>>-----Original Message-----
>>From: Mills, Duncan, D, CND Tech Dev, VF UK
>>[mailto:[email-masked]]
>>Sent: 24 June 2003 16:13
>>To: Chris Harris; Rosen, Brian; [email-masked]
>>Subject: RE: [Simple] Sending 1 to n MESSAGEs
>>
>>Chris,
>>
>>Thanks for your thoughts.  I agree, that a custome header of some sort
>>would help.  I'd probably want to standardise that header with an RFC
>>though- what are thoughts on this?
>>
>>Duncan
>>
>>-----Original Message-----
>>From: Chris Harris [mailto:[email-masked]]
>>Sent: 24 June 2003 16:06
>>To: Mills, Duncan, D, CND Tech Dev, VF UK; Rosen, Brian; [email-masked]
>>Subject: RE: [Simple] Sending 1 to n MESSAGEs
>>
>>
>>Duncan,
>>
>>One possibility for this ad-hoc group messaging is to address the message
>>to
>>a message exploder application, and to use other custom headers for the
>>list
>>of actual recipients (say a list of X-Recipient: headers) that the
>exploder
>>understands. Once the exploder accepts the message it would presumably
>send
>>a 202 response to the sender and be responsible for the delivery of the
>>messages to the recipients.
>>
>>Regards,
>>Chris Harris
>>
>>> -----Original Message-----
>>> From: Mills, Duncan, D, CND Tech Dev, VF UK
>>> [mailto:[email-masked]]
>>> Sent: Tuesday, June 24, 2003 10:55 AM
>>> To: Rosen, Brian; [email-masked]
>>> Subject: RE: [Simple] Sending 1 to n MESSAGEs
>>>
>>>
>>> Dear CLEVER people (of the SIMPLE WG) ;-)
>>>
>>> Brian- yes, my thought was to allow a B2BUA function to fork
>>> the MESSAGE request.  This way, the user doesn't have to
>>> pre-configure the recipient list, but perhaps they do have to
>>> pre-configure the address of their MESSAGING server (the
>>> B2BUA). When I say pre-configure, I'm sure there are more
>>> dynamic ways to get the B2BUA address to the UA.
>>>
>>> I must admit, I am coming at this from the 3GPP perspective
>>> and so a SIP AS (acting in B2BUA mode) would seem to do the
>>> trick.  However, it would require- I believe- some extensions to SIP.
>>>
>>> However, 3GPP radio interface constraints aside, I think it
>>> would be a shame to design SIP messaging without the ability
>>> to fork a message to n recipients, in the same way you can
>>> with e-mail.
>>>
>>> Thanks for your initial thoughts- I'd be interested in
>>> progressing this issue, if you and others feel it worthwhile...
>>>
>>> Cheers,
>>>
>>> Duncan
>>>
>>>
>>> -----Original Message-----
>>> From: Rosen, Brian [mailto:[email-masked]]
>>> Sent: 24 June 2003 15:38
>>> To: Mills, Duncan, D, CND Tech Dev, VF UK; [email-masked]
>>> Subject: RE: [Simple] Sending 1 to n MESSAGEs
>>>
>>>
>>> Was the salutation to your message a comment on the quality of
>>> the discourse on this list?  ;)
>>>
>>> Good thought.  Interacts with conferencing (mass invite to a
>>> conference).
>>> You don't want to have to have a complex interaction prior to sending
>>> a list of recipients.  Smells like a kind of forking behavior, but
>>> clearly different (not all the same AOR).  Obviously creates multiple
>>> dialogs if/when multiple responses are received.  The proxy can't be
>>> the origination point; it's not a UA.  All the responses are going to
>>> be forwarded to the UA.  The only way around that is B2BUA behavior.
>>> Is that a better, or a worse idea?
>>>
>>> Gotta think through what this means for Message Sessions.
>>> You want the
>>> proxy to replicate each message, but you don't really want to repeat
>>> the list of recipients.  Does that argue for B2BUA more strongly?
>>>
>>> With a B2BUA approach you send the message to the exploder.  It
>>> sends individual messages to recipients, and handles all the dialogs.
>>> That reminds me of a buddy list subscription without the prearranged
>>> buddy list.
>>>
>>> Brian
>>>
>>> > -----Original Message-----
>>> > From: Mills, Duncan, D, CND Tech Dev, VF UK
>>> > [mailto:[email-masked]]
>>> > Sent: Tuesday, June 24, 2003 9:42 AM
>>> > To: [email-masked]
>>> > Subject: [Simple] Sending 1 to n MESSAGEs
>>> >
>>> >
>>> > SIMPLE people,
>>> >
>>> > I've just been thinking about how my e-mail works, and what I
>>> > like best about it.  It is really easy to type a long message
>>> > and then send it to a list of (more than one) people.  Better
>>> > still, I don't have to have pre-configured that list of
>>> > people.  I can just type in the addresses in the To: field
>>> > and the mail will be sent to each address.
>>> >
>>> > As far as I know, I can't do this with the SIP MESSAGE
>>> > method.  Yes, I can create a resource URI in a server and
>>> > send one MESSAGE request to that resource-URI, and the server
>>> > may fork the MESSAGE to each URI in my pre-configured list.
>>> > But if I don't want to have to set up a new list of
>>> > recipients each time I send a MESSAGE then I have to send the
>>> > same MESSAGE several times.  Please correct me if I'm wrong.
>>> >
>>> > Now... looking at this from a wireless operator perspective,
>>> > I immediately see warning signs about my £6 billion radio
>>> > interface ;-)  Currently, in GSM, if we want to send an SMS
>>> > to more 'n' recipients, we have the same situation- either
>>> > create a user group in the network or send the message 'n'
>>> > times.  However, a SIP MESSAGE request is likely to be about
>>> > ten times the size of an SMS.
>>> >
>>> > Is this a problem?  If not, why not?  Maybe I'm missing some
>>> > background/historical information?
>>> >
>>> > If it is a problem, might it be possible to extend SIP in
>>> > such a way as to state that the request-URI be set to the
>>> > address of my SIP proxy server in my home network and then
>>> > the To: field be filled with the list of intended recipients,
>>> > with the server then being responsible for sending the
>>> > MESSAGE to all the intended recipients?
>>> >
>>> > Any comments/views?
>>> >
>>> > Best Regards,
>>> >
>>> > Duncan
>>> >
>>> >
>>> > Duncan Mills
>>> > Senior Engineer
>>> > Network Standards & Technical Audit
>>> > Technology Development (Network Systems)
>>> > Vodafone (UK) Ltd
>>> > Tel: +44 (0)1635 676074
>>> > Mob: +44 7867 900955
>>> > Fax: +44 (0)1635 234445
>>> > mailto:[email-masked]
>>> >
>>> >
>>> >
>>> > _______________________________________________
>>> > Simple mailing list
>>> > [email-masked]
>>> > https://www1.ietf.org/mailman/listinfo/simple
>>> >
>>>
>>> _______________________________________________
>>> Simple mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/simple
>>>
>>
>>_______________________________________________
>>Simple mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 25 Jun 2003 11:09:53 +0300

Inline

> 1.) The ability to 'explode' MESSAGES to a 'distribution list'

I would say that this issue is solve with a resource list. I don't expect 
resource lists to be related to presence only. But taking a look at 
draft-ietf-simple-event-list-04 I see that it is considering only the 
presence case.

Does the WG think that there is space for generalization of the resource 
list, so that it is possible to use it not only for presence, but also for 
Instant Messaging?

> 2.) The ability to send the same MESSAGE to several people NOT on a pre-configured distribution list (as Brian already pointed out, it would be complex to expect users to have to log onto a server…

I believe SMTP and the Internet Message Format provides this capability, 
although SIP does not provide it today (probably because of the initial 
usage of SIP to establish point-to-point sessions).

But I believe that when we apply SIP for Instant Messaging there is a valid 
  use case that is worth investigating.

My first thought on a possible solution would be to relax the requirement 
of having a single To header field value, and a server providing the rest 
of the functionality. Nothing new, just following RFC 2822. Of course, we 
get the problem of how to populate the Request-URI...

> I am trying to solve case 2.)

/Miguel

-- 
Miguel-Angel Garcia                     Oy LM Ericsson AB
                                         Jorvas, Finland
mailto:[email-masked]     Phone:  +358 9 299 3553
mailto:[email-masked]        Mobile: +358 40 5140002

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 25 Jun 2003 11:09:53 +0300

Inline

/Miguel