Subject: [Simple] Date Formats

From: Adam Roach <[email-masked]>
Date: Mon, 14 Jul 2003 08:47:11 -0500

RPIDS uses dates like PIDF:

  <ep:until>2003-01-27T19:30:00Z</ep:until>

While the XCAP event package uses HTTP dates:

  version="Mon, 26 May 2003 19:43:31 GMT"

(presumably always expressed as GMT? It doesn't say
 as much, and specifically cites HTTP instead of
 SIP as its source; HTTP allows arbitrary time zones).

Frankly, I don't relish having to keep straight
which format to use where. Would it be possible for
us, as a working group, to pick one format that
we use for bodies of new protocols going forward
and stick with it?

/a

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 14 Jul 2003 20:10:42 -0400

Seems like it should be the SIP format.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 14 Jul 2003 20:10:42 -0400

-Jonathan R.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 15 Jul 2003 04:30:51 -0400

> Seems like it should be the SIP format.

Except in XML, where it really can't be, if you would like to use schemas.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 15 Jul 2003 04:30:51 -0400

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 15 Jul 2003 10:30:36 -0400

> Except in XML, where it really can't be, if you would like to use schemas.

Yeah, this occurred to me after I sent my response.

Well, there is no obvious win. I would tend to think that 
implementations would use third party XML libraries which would have 
their own code for date parsing, separate from the SIP code. As such, 
its not clear how much opportunity there is for code reuse really. Of 
course, thats based on assumptions, and perhaps some devices (i.e., 
wireless phones) don't use any standard libraries or anything.

So, maybe the answer is to have both?

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 15 Jul 2003 10:30:36 -0400

-Jonathan R.