Subject: RE: [Simple] Tuple design team discussion summary

From: [email-masked]
Date: Tue, 15 Jul 2003 13:41:37 +0300

I agree with Brian. I think we only ever discussed those 3: device, service and user. We don't need to be very explicit, information in the tuple give away the finer details about that thing that the tuple represents. 

Other than those 3, I haven't heard of other things that a tuple can represent, unless we allow a combination of the 3 above (which I believe we don't).

Regards,
Hisham

> -----Original Message-----
> From: ext Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, July 15, 2003 1:22 PM
> To: 'Henning Schulzrinne'; Ben Campbell
> Cc: Simple WG
> Subject: RE: [Simple] Tuple design team discussion summary
> 
> 
> frankly, I think all you need is a device called phone,
> the rest is capabilities.  It is the fact that the tuple is a phone
> that you can't deduce.  It may actually be possible to just
> label it "device".  I would not object to differentiating
> PC from phone, and text devices.  There is the PDA,
> the problem there is the TREO-like devices, are they
> phones or PDAs?
> 
> The others are
> "service" and I know we need a definition
> "user" (or "presentity, if you prefer)
> Both of these imply some sort of aggregation.
> 
> 
> 
> > -----Original Message-----
> > From: Henning Schulzrinne [mailto:[email-masked]]
> > Sent: Tuesday, July 15, 2003 4:38 AM
> > To: Ben Campbell
> > Cc: Simple WG
> > Subject: Re: [Simple] Tuple design team discussion summary
> > 
> > 
> > Almost none of the labels in RPIDS are exhaustive or claim to 
> > be, so a 
> > list is better than nothing. To make progress, I would like 
> > to call for 
> > nominations for such labels. The obvious ones are 
> device-oriented ones
> >    cell phone
> >    PC
> >    landline phone
> >    text device (BlackBerry, SMS, TTY, ...)
> > other suggestions?
> > 
> > Ben Campbell wrote:
> > 
> > > 
> > > I think even that can be handled cleanly. Such a device 
> > just displays 
> > > some default icon that indicates it does not know what type 
> > of tuple it
> > > has. That is no different from common usage in many other 
> > applications.
> > > For example, email attachments when your browser does not 
> > recognize the
> > > mime type, or gets something completely generic like
> > > application/octet-stream without any other qualifiers.
> > > 
> > 
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> > 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 15 Jul 2003 07:05:09 -0400

[email-masked] wrote:

> I agree with Brian. I think we only ever discussed those 3: device,
> service and user. We don't need to be very explicit, information in
> the tuple give away the finer details about that thing that the tuple
> represents.
> 
> Other than those 3, I haven't heard of other things that a tuple can
> represent, unless we allow a combination of the 3 above (which I
> believe we don't).

To beat a horse carcass: While device and 'user' has reasonable 
definitions, nobody, after a year+, has provided an operational 
definition of service. Since this label needs to be understandable by 
people who have not participated in the Tuple Theory 745 class (this is 
graduate-level stuff...), I don't think an elaborate definition helps.

'device', 'user' and 'other' seem to work ok, which seems to be close 
enough. (Earlier versions of RPIDS had an approximation to such an 
element, with the addition of 'group'.) For those, there are reasonable 
pictograms, too - phone, stick person and ?.

Henning

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 15 Jul 2003 07:05:09 -0400

Henning

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 15 Jul 2003 10:29:20 -0400

> pictograms, too - phone, stick person and ?.

Works for me. I have kept asking people who use the term "service" to 
define it for me, assuming I was just ignorant of the definition 
everyone was using. But I have yet to hear one. So I think the choice is 
either that there are only two reasonable views, or else "other" covers 
the rest.

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 15 Jul 2003 10:29:20 -0400

Paul