Subject: [Simple] asking for a specific view

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 13 Jul 2003 08:04:22 -0400

Folks,

One of the conclusions of the tuple design team was that we want to 
allow a PA the flexibility to have tuples represent anything they 
want. This means that a PA can compose, aggregate, and otherwise 
discard information as it sees fit.

However, in some cases, a watcher is interested in a specific type of 
information, and furthermore, a specific type of information within 
the context of a specific view. As an example, a watcher application 
that wants to send an SMS to a phone when it finds its not in a call, 
will want to see a device-centric view of a user, so that it can check 
the call state of the device.

It is possible that, by default, the PA would not provide information 
to the watcher in a device-centric view. Rather, its policy is to send 
a single tuple with summary information. If this happens, the watcher 
doesnt get the information they need, since its been aggregated away. 
To remedy this, I think we need to enhance the filter work to allow a 
watcher to ask for a specific view of the presence data. We have some 
work to do to define a view, but we have a couple of good candidates 
to work from.

Thanks,
Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 14 Jul 2003 11:43:47 +0300

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Sunday, July 13, 2003 3:04 PM
> To: Simple WG
> Subject: [Simple] asking for a specific view
> 
> 
> Folks,
> 

Is this possible with a generic filtering solution as we have today? In the last IETF meeting, we agreed that filtering will be a generic solution.

Regards,
Hisham

---

From: Adam Roach <[email-masked]>
Date: Mon, 14 Jul 2003 08:47:10 -0500

> work to do to define a view, but we have a couple of good candidates 

I'm pretty certain that you're going to run into a lot of
situations in which presence cannot be broken down along
specific lines (like device or service views). For example,
presence information may arrive at a PA already partially (or even
fully) composed of information about multiple devices. You'll
also often run into situations in which composition is performed
as a means of intentional obscurity.

I'm not saying that your suggestion is bad, but I suspect
that we'll discover that the cases in which requests
for certain types of views make sense will be the exception
rather than the norm.

/a

---

From: Adam Roach <[email-masked]>
Date: Mon, 14 Jul 2003 08:47:10 -0500

/a

---

From: [email-masked]
Date: Tue, 15 Jul 2003 13:14:36 +0300

> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, July 15, 2003 11:42 AM
> To: Jonathan Rosenberg
> Cc: Henning Schulzrinne; Simple WG
> Subject: Re: [Simple] asking for a specific view
> 
> 
> On Mon, 2003-07-14 at 19:23, Jonathan Rosenberg wrote:
> > Henning Schulzrinne wrote:
> > 
> > > Jonathan Rosenberg wrote:
> > > 
> > > Would this be as simple as being able to request certain 
> columns (in my 
> > > database view of the world)?
> > 
> > No. Its closer to what you were calling the pivot 
> operation. But more 
> > importantly, it means that the attributes have values (and indeed 
> > exist) which are relevant for that particular view. For 
> example, in a 
> > "device centric" view, things like whether the device is on or off, 
> > the placetype, geoloc, etc., make sense and have a well defined 
> > meaning. For other views, such as Brian's one-tuple view, 
> there could 
> > also be a placetype and geoloc, but they might represent where the 
> > user is (based, perhaps, on a device which is almost always on the 
> > body of the person in question), as opposed to one of his devices.
> > 
> > Adam writes:
> > Sure. You can't always deliver what the watcher wants. But 
> at least we 
> > should be able to know what they want, and deliver it if 
> possible, or 
> > we are permitted to.
> 
> I would state this more strongly, in that the PA has complete control
> over what it delivers. Such a request is at best a hint of watcher
> preference. But in general, the PA is an agent of the 
> presentity, and is
> not obligated to care about the preferences of a watcher. Anything
> beyond that is in conflict with one of the most useful attributes of
> SIP, that is, the owner of a resource has controls how and where calls
> are delivered.
> 
> Or in more practical terms, a watcher implementation MUST NOT 
> assume its
> preferences will be honored.

I sgree with Jonathan's "deliver it if possible", but I don't agree to deliver something in a view that the watcher does not want. The watcher needs to know how to render or automata needs to know how to react.

Regards,
Hisham

> > Well, that remains to be seen. We don't have a lot of deployment 
> > experience to see how these things will get used.
> > 
> > -Jonathan R.
> > 
> 
>

---

From: [email-masked]
Date: Tue, 15 Jul 2003 13:14:36 +0300

Regards,
Hisham