Subject: RE: [Simple] asking for a specific view

From: [email-masked]
Date: Mon, 14 Jul 2003 11:43:47 +0300

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Sunday, July 13, 2003 3:04 PM
> To: Simple WG
> Subject: [Simple] asking for a specific view
> 
> 
> Folks,
> 
> One of the conclusions of the tuple design team was that we want to 
> allow a PA the flexibility to have tuples represent anything they 
> want. This means that a PA can compose, aggregate, and otherwise 
> discard information as it sees fit.
> 
> However, in some cases, a watcher is interested in a specific type of 
> information, and furthermore, a specific type of information within 
> the context of a specific view. As an example, a watcher application 
> that wants to send an SMS to a phone when it finds its not in a call, 
> will want to see a device-centric view of a user, so that it 
> can check 
> the call state of the device.
> 
> It is possible that, by default, the PA would not provide information 
> to the watcher in a device-centric view. Rather, its policy 
> is to send 
> a single tuple with summary information. If this happens, the watcher 
> doesnt get the information they need, since its been aggregated away. 
> To remedy this, I think we need to enhance the filter work to allow a 
> watcher to ask for a specific view of the presence data. We have some 
> work to do to define a view, but we have a couple of good candidates 
> to work from.

Is this possible with a generic filtering solution as we have today? In the last IETF meeting, we agreed that filtering will be a generic solution.

Regards,
Hisham

> 
> Thanks,
> Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 14 Jul 2003 04:48:15 -0400

> Is this possible with a generic filtering solution as we have today? In the last IETF meeting, we agreed that filtering will be a generic solution.

That's why I suggested that expressing this as a list of fields 
("columns") to be included and non-merged, presumably as XPath statements.

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 14 Jul 2003 04:48:15 -0400