Subject: RE: [Simple] Tuple design team discussion summary

From: [email-masked]
Date: Tue, 15 Jul 2003 15:36:11 +0300

I think I mentioned something like this before: Service to me means something that an operator can offer (as part of a package) and charge for. IM, presence and geoloc are some examples.

This is probably not the definition you are looking for since its not technical, but probably its good enough to warrant the inclusion of the term 'service' in the list of what a tuple represents. I don't think having the term 'other' is a good idea since it might confuse implementers in the sense that they would not know what goes into such a tuple.

Brian started some discussion about service definition, perhaps we need to discuss further a technical definition of what a service is. I believe this is better than just saying that we have a 'other' tuple that represents things that are not devices or are not users.

Regards,
Hisham

> -----Original Message-----
> From: ext Henning Schulzrinne [mailto:[email-masked]]
> Sent: Tuesday, July 15, 2003 2:05 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Re: [Simple] Tuple design team discussion summary
> 
> 
> [email-masked] wrote:
> 
> > I agree with Brian. I think we only ever discussed those 3: device,
> > service and user. We don't need to be very explicit, information in
> > the tuple give away the finer details about that thing that 
> the tuple
> > represents.
> > 
> > Other than those 3, I haven't heard of other things that a tuple can
> > represent, unless we allow a combination of the 3 above (which I
> > believe we don't).
> 
> To beat a horse carcass: While device and 'user' has reasonable 
> definitions, nobody, after a year+, has provided an operational 
> definition of service. Since this label needs to be understandable by 
> people who have not participated in the Tuple Theory 745 
> class (this is 
> graduate-level stuff...), I don't think an elaborate definition helps.
> 
> 'device', 'user' and 'other' seem to work ok, which seems to be close 
> enough. (Earlier versions of RPIDS had an approximation to such an 
> element, with the addition of 'group'.) For those, there are 
> reasonable 
> pictograms, too - phone, stick person and ?.
> 
> Henning
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 15 Jul 2003 16:32:23 -0400

This is very different from the definition Brian is homing in on. We 
can't have both definitions using the same name. If we need both 
definitions then we need separate names for them. I'm still not 
convinced we need either defintion.

	paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 15 Jul 2003 16:32:23 -0400

paul