Subject: RE: [Simple] Re: rpids-01 - security and <relationship>

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 24 Jul 2003 07:53:24 -0400

We've had some customer demand for this kind of thing.
One aspect that has not been mentioned is that S is not
one person.  Either there are M B's and N S's, or
at the very least, there is one or more B's and one S, 
but S has backups.

Thus, S is not an actual person, but a role.

Brian

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, July 23, 2003 9:49 PM
> To: Vijay K. Gurbani
> Cc: Jonathan Rosenberg; [email-masked]
> Subject: Re: [Simple] Re: rpids-01 - security and <relationship>
> 
> 
> Vijay K. Gurbani wrote:
> 
> 
> 
> > 
> > I believe that the <relationship> attribute is important enough
> > that some manner of convergence around how to implement and
> > understand its semantics will be advantageous down the line.
> 
> Agreed; it would be nice to support all three models:
> - plain 'pres' reference; let S and B work it out behind the scenes; 
> does not appear to work well in terms of authorization
> 
> - ticket, but we would need to standardize the token to have 
> any hope of 
> being usable in practice; requires a shared secret between S 
> and B and 
> needs special support in S and B
> 
> - inclusion; requires extra effort only by B, but raises 
> philosophical 
> concerns
> 
> > 
> > - vijay
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 24 Jul 2003 09:50:25 -0400

I think it only affects security issues.
Addressing and presence aggregation is easy.

Brian

> Sent: Thursday, July 24, 2003 9:37 AM
> To: Rosen, Brian
> Cc: [email-masked]
> This seems similar to AORs like [email-masked], with some kind of 
> aggregate presence. Here, it would presumably be something like 
> "[email-masked]". Does this change any of the 
> mechanisms, 
> besides maybe complicating any secret management?
> 
> Rosen, Brian wrote:
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 24 Jul 2003 09:50:25 -0400

Brian