Subject: [Simple] Question about the Waiting state

From: Orly Rosenberg <[email-masked]>
Date: Sun, 3 Aug 2003 12:05:40 +0300

Hi.

According to winfo-package-05: 
"If, while in the waiting state, the subscription is refreshed through
another Subscribe, it moves back into the pending state".

Also in the Subscription state-machine as defined in section 4.7.1, there is
a transition from state waiting to state pending in case of an incoming
Subscribe.

My question is:
How is it possible to handle a refresh request in the Waiting state, after
we already sent a Notify(terminated)? (when the state changed from Pending
to Terminated).
From what I understand, the Waiting state is an internal state, but the real
subscription has terminated.
If so, how can we change its state back to pending?

Thanks,
Orly Rosenberg.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Stephen Gryphon" <[email-masked]>
Date: Mon, 4 Aug 2003 14:25:55 +1000

Test message 1

> -----Original Message-----
> From: Orly Rosenberg [mailto:[email-masked]]
> Sent: Sunday, August 03, 2003 7:06 PM
> To: [email-masked]'
> Subject: [Simple] Question about the Waiting state
> 
> 
> Hi.
>

---

From: "Stephen Gryphon" <[email-masked]>
Date: Mon, 4 Aug 2003 14:25:55 +1000

Test message 1