Subject: [Simple] general questions on presence information format

From: youngsun song <[email-masked]>
Date: Mon, 15 Sep 2003 02:14:06 -0700 (PDT)

Hi,
I just started looking at documents related to presence information and have a few questions.
 
The draft-ietf-impp-cpim-pidf document seems to define a baseline presence format that is to be extended for use by various presence applications. The documents that extend the pidf seem to be: draft-ietf-simple-rpids-01.txt, draft-rosenberg-peterson-simple-pidf-phone-00.txt, draft-lonnfors-simple-prescaps-ext-01.txt, etc.
Are these extensions considered fairly stable? If not, are there any timeframes by when these are expected to become stable?
Also, for the SIP-based presence applications currently implemented, are they then using private extensions of the pidf (or private presence formats)?
 
Thanks for any help you can provide.
YoungSun

---------------------------------
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software

---

From: [email-masked]
Date: Wed, 17 Sep 2003 20:28:40 +0300

Hi,

> youngsun song wrote:
> 
> > Hi,
> > I just started looking at documents related to presence information
> > and
> > have a few questions.
> >  
> > The draft-ietf-impp-cpim-pidf document seems to define a baseline 
> > presence format that is to be extended for use by various presence 
> > applications. The documents that extend the pidf seem to be: 
> > draft-ietf-simple-rpids-01.txt, 
> > draft-rosenberg-peterson-simple-pidf-phone-00.txt,
> > draft-lonnfors-simple-prescaps-ext-01.txt, etc.
> > Are these extensions considered fairly stable?
> 
> rpids is somewhat stable; I expect some more changes but its been
> through the ringer quite a bit already.
> 
> pidf-phone is very unstable - that was just the first proposal, and
> the scope will be substantially reduced in the next rev.
> 
> I think prescaps-ext also has some work to do, hasn't gotten a lot of
> air time yet really.

Yes, draft is currently being rewritten and there will be some changes.
At least XML schema will look very different compared to what is
currently in the draft. Hopefully -02 draft will be more stable.

- Mikko

> 
> > If not, are there any
> > timeframes by when these are expected to become stable?
> 
> I'll let the chairs comment on that...
> 
> > Also, for the SIP-based presence applications currently
> implemented,
> > are
> > they then using private extensions of the pidf (or private presence
> > formats)?
> 
> I think there are some private extensions. I know of deployments that
> use the baseline pidf though.
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 17 Sep 2003 20:28:40 +0300

Hi,

- Mikko