Subject: RE: [Simple] Re: [Geopriv] Individuals, hats and spheres

From: [email-masked]
Date: Tue, 9 Sep 2003 10:06:24 +0300

> -----Original Message-----
> From: ext Henning Schulzrinne [mailto:[email-masked]]
> Sent: Tuesday, September 09, 2003 6:53 AM
> To: Trossen Dirk (NRC/Boston)
> Cc: [email-masked]; [email-masked]
> Subject: [Simple] Re: [Geopriv] Individuals, hats and spheres
> 
> 
> [email-masked] wrote:
> 
> 
> > I like the idea of enabling a certain set of rules (as 
> opposed to have conditional single
> > rules, the condition being e.g., the identity of the 
> watcher) based on a certain condition. 
> > However, I was wondering whether this is intended to be 
> bound to the <sphere> element? 
> > Let me try to describe the underlying, general method that 
> I understood from your proposal:
> >    Allow for enabling a defined set of rules based on a 
> certain condition, in which the
> > condition would be a certain value/range of an RPID element. 
> 
> That is indeed the general problem. However, here, my 
> objective is far 
> narrower. I'm trying to capture one aspect of the 
> condition/context/state of the presentity, namely its role-based 
> interaction with other humans. There are many other 
> variables, such as 
> time, space, other physical measurements ("it's hot, so don't bother 
> me") - all of which may be combined to select a certain set of 
> permissions. Indeed, the core ruleset discussed in GEOPRIV 
> contains some 
> of these conditions (time, space).
> 
> I just happen to believe that for access to information about human 
> activities, our relationship to humans and how we divide our 
> life is one 
> of the more important items.
> 
> > 
> > Hence, with this understanding of your proposal in mind, 
> would it be possible/desirable to
> > use other RPID elements? In this, I could define a set of 
> rules that is enabled when 
> > <placetype> is "work" or <activity> is "meeting". 
> 
> That is certainly possible and useful, in my view. I wanted to start 
> small, with a broad brush. It might again be helpful to 
> enumerate some 
> plausible examples of privacy policies that real people are likely to 
> use. I found that in many cases, the <placetype> or 
> <activity> is really 
> just a stand-in for "a part of my world that has distinct 
> assumptions, 
> expectations, obligations and conventions". I'm not a sociologist, so 
> maybe there's a better term for this than sphere.

Dimension, perhaps.

Just a few questions:

- Why is a sphere different than a group?

- Why this type of analogy is limited to geoloc? 

- How this is different from the stream-header we had in PUBLISH?

/Hisham

> 
> 
> > 
> > Dirk
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 09 Sep 2003 10:40:10 -0400

> - Why is a sphere different than a group?

This is not a group as it defines a matching parameter that is (or could 
be) used alongside other context information, such as the person, a time 
range and a place.

In many cases, this will correspond to "allow {group of people} access 
to me when I'm working/at home", but the semantics is slightly 
different. The model is

"I have declared myself to be in state/sphere X. Please apply the rules 
that apply to that state."

In the end, all rules boil down to {set of people} can do {set of 
things}, but the number of such sets may be very large.

> - Why this type of analogy is limited to geoloc? 

It isn't. It's just that some of the discussion on privacy-related 
issues has taken place there and that many of those involving location 
tended to be of the "I'm at work" vs. "I'm off work" flavor. (Mistresses 
also seem to be popular in that working group :-))

I have argued before that I see no principal difference in most cases 
(stalkers excepted) between the privacy considerations for what I'm 
currently doing and where I am, particularly since they are often 
derivable from each other with high probability. In some cases, activity 
information is more sensitive (knowing that I'm in state 'sleeping' 
during work hours is more revealing than that I'm not moving in my 
office), in others it's not ("driving" vs. "vectored to the drug 
treatment center").

> - How this is different from the stream-header we had in PUBLISH?

I fail to see the connection. This is much closer to <placetype> and 
<activity> and in some cases, there will be a high correlation between 
(<placetype>,<activity>) and <sphere>, but since the correlation is less 
than perfect, it seemed better to make the real intent explicit.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 09 Sep 2003 10:40:10 -0400

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 09 Sep 2003 11:14:39 -0400

I myself am less than happy with the term sphere. "Role" has been 
suggested and may be less overloaded, however, it doesn't quite work.

I would say that I play the role of 'father' or 'teacher', but I 
wouldn't say that I'm in a work role or private role.

Amateur and professional sociologists may want to step in here...

John Schnizlein wrote:
> My impression is that the spherical shape of the earth's geography
> is an unintended analogy to the "spheres of interest" Henning meant.
> This might be sufficient reason to change the word, but the concept
> of many-to-many categories of individuals is important. Allowing
> watchers in the same category to get my location is the concept.
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 09 Sep 2003 11:14:39 -0400

---

From: John Schnizlein <[email-masked]>
Date: Tue, 09 Sep 2003 10:57:37 -0400

John

At 10:40 AM 9/9/2003, Henning Schulzrinne wrote:

>It isn't. It's just that some of the discussion on privacy-related issues has taken place there and that many of those involving location tended to be of the "I'm at work" vs. "I'm off work" flavor. (Mistresses also seem to be popular in that working group :-))

---

From: John Schnizlein <[email-masked]>
Date: Tue, 09 Sep 2003 10:57:37 -0400

John