Subject: RE: [Simple] Discovery of an MSRP relay

From: [email-masked]
Date: Thu, 9 Oct 2003 16:34:35 +0300

How about UA configuration from SIPPING (or any other configuration protocol)?

/Hisham

> -----Original Message-----
> From: ext Miguel A. Garcia [mailto:[email-masked]]
> Sent: Thursday, October 09, 2003 2:03 AM
> To: Adam Roach
> Cc: Jonathan Rosenberg; [email-masked]
> Subject: Re: [Simple] Discovery of an MSRP relay
> 
> 
> Adam:
> 
> Your proposal works if I am in my home network. But if I am 
> roaming, the 
> DHCP server will be located in the roaming network, and will be 
> provisioned with information about the MSRP relay in the roaming 
> network. If this is the case, fine, it will work, but if by policy, I 
> have to use the MSRP provided in my home network, and I am 
> roaming, it 
> won't work. Further more, if the roaming network does not 
> offer an MSRP 
> relay service, but my home network does, I won't be able to 
> discover the 
> MSRP relay server.
> 
> I am not sure, at this stage, which of the above cases would 
> be the case 
> for MSRP relays... I just want to be prepared with solutions 
> that solve 
> any of the possible requirements.
> 
> /Miguel
> 
> Adam Roach wrote:
> 
> > Miguel A. Garcia [mailto:[email-masked]] writes:
> > 
> > 
> >>In another case, an MSRP relay is provided in a home network, 
> >>and that MSRP relay is used no matter whether the user is
> >>attached directly to such network or indirectly through other
> >>networks. In this case DHCP won't obviously solve the problem.
> > 
> > 
> > For this case, I suggest we borrow a page from the well-understood,
> > time-tested, universally deployed, and demonstrably workable
> > mechanism that HTTP clients use to solve the problem of finding
> > HTTP proxies.
> > 
> > /a
> 
> -- 
> Miguel-Angel Garcia                     Oy LM Ericsson AB
>                                          Jorvas, Finland
> mailto:[email-masked]     Phone:  +358 9 299 3553
> mailto:[email-masked]        Mobile: +358 40 514 0002
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Sat, 11 Oct 2003 10:41:53 +0300

I am pretty sure that the final solution would be based on the work on 
the configuration/policies that is taking place in SIPPING.

/Miguel

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Sat, 11 Oct 2003 10:41:53 +0300

/Miguel