Subject: RE: [Simple] Comments on MSRP - multiparty message session support

From: [email-masked]
Date: Mon, 20 Oct 2003 13:37:14 +0300

> -----Original Message-----
 > From: ext Ben Campbell [mailto:[email-masked]]
 > Sent: 17 October, 2003 20:36
 > To: Niemi Aki (NMP/Helsinki)
 > Cc: [email-masked]
 > Subject: Re: [Simple] Comments on MSRP - multiparty message session
 > support
 > 
 > 
 > We talked about how this could be done in a couple of ways. 
 > One was by 
 > simply having the mixer remember the identity associated with each 
 > connection.

This would still not work, since there isn't a vehicle in the protocol to transport this "asserted-identity" to the recipient endpoints.
 
 > The mixer could also insist that all content be wrapped in 
 > message/cpim 
 > using our extension to the SDP format list negotiation.

Which is fine, if all MSRP endpoints are required to support it. Currently they aren't which potentially leaves a lot of MSRP clients incapable of participating in message session conferences.

Regards,
Aki

 > Aki Niemi wrote:
 > 
 > > Hi All,
 > > 
 > > Since MSGFMT is no longer mandated (or is but only for 
 > CPIM gateways), 
 > > how would a participant know where a message is coming from in a 
 > > multiparty message session?
 > > 
 > > Also, when using MSRP in a conferencing system, the lack 
 > of To/From 
 > > prevents sending private messages efficiently within a multiparty 
 > > session using an MSRP mixer as a "router" for them.
 > > 
 > > So my question is this: what is the extensibility model 
 > for MSRP? For 
 > > example, would it be possible to later on add this multiparty 
 > > functionality as an extension, or would it be wise to think ahead 
 > > already now?
 > > 
 > > The draft includes some extensibility, e.g., for authentication 
 > > algorithms, but I didn't immediately find much about 
 > adding methods and 
 > > headers, and what to do with unknown headers.
 > > 
 > > Regards,
 > > Aki
 > > 
 > > 
 > > _______________________________________________
 > > Simple mailing list
 > > [email-masked]
 > > https://www1.ietf.org/mailman/listinfo/simple
 > 
 > 
 > 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Mon, 20 Oct 2003 08:31:26 -0500

> Which is fine, if all MSRP endpoints are required to support it. Currently they aren't which potentially leaves a lot of MSRP clients incapable of participating in message session conferences.

I am not opposed to requiring support for this. In retrospect, I think 
we intended to do that and it just didn't make it in.

---

From: Ben Campbell <[email-masked]>
Date: Mon, 20 Oct 2003 08:31:26 -0500