Subject: [Simple] Chair call for group opinion (was MSRP: Administrative shutdown of relays)

From: Robert Sparks <[email-masked]>
Date: Mon, 13 Oct 2003 18:31:19 -0500

If you have not been  reading the Administrative shutdown of relays
thread, the following provides a summary of the possible paths the
thread has explored:

In interests of progress _before_ Minnesota, I would like to get input
from people other than the 3 primary participants in the tread as to
what they believe is important for us to work on.

So, I am calling an electronic hum. Respond to list or privately to
me if you prefer. The questions called are:

One: Do you believe it is important for the document to discuss
    administrative shutdown of relays.

Two: (answer only if you answer Yes to question One). 
    How much scope creep are we willing to take on?
    The options below are listed in increasing scope creep order.
    Please respond with which option you would like to see pursued.

Please respond to this call no later than Wed 10/15.

RjS

-----Forwarded Message-----
> From: Ben Campbell <[email-masked]>
>
> It seems to me we have 4 choices:
> 
> 1) Live with the potential for duplicate deliveries when a logical 
> conversation transitions from one session to another in a short time 
> period. Note that this can happen without relays being involved at all.
This potential can be bounded by shorter than inactivity timeout delays
(specifically watiting for transactions already in progress to
complete).

>
> 2) Require any hosting device that wishes to end a session wait either 
> until connected devices send a request, so that we can send a response 
> indicating that we are shutting down, or until an inactivity timeout occurs.
>
> 3) Allow relays to originate a message saying the session is going down.
> 
> 4) Create a cross-session duplicate supression mechanism.
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Alex Audu <[email-masked]>
Date: Tue, 14 Oct 2003 09:46:46 -0500

Hello Robert,

1) I think it is important for the document to discuss administrative shutdown
    of relays.
2) For the sake of a positive user experience, I'd make the shutdown as
    graceful as possible. Hence, I'd go for option 3 (Allow relays to originate
    a message saying the session is going down).

Regards,
Alex.

---

From: Alex Audu <[email-masked]>
Date: Tue, 14 Oct 2003 09:46:46 -0500

Hello Robert,

Regards,
Alex.