Subject: [Simple] What can you do with a list?

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 17 Oct 2003 15:03:06 -0400

Folks,

I'll be submitting a rev shortly to the xcap list draft:
http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-list-usage-00.txt

There have been few comments on this document; its pretty straightforward.

One issue was raised to me privately by Markus, which I think merits 
broader discussion, is whether the scope of this draft is just 
presence lists, or whether it is broader than that. In a broader 
model, each URI representing a list has a set of permissible actions 
that can be taken against the list. We have "subscribable", which 
means you can subscribe to the list, but we could allow other things. 
For example, we could add "messageable", which means a MESSAGE request 
to that group we be exploded (using Gonzalo's terminology) to those 
members. "Invitable" would mean that an INVITE to that group would 
cause creation of a conference call to that group. Clearly this 
intersects with the conferencing work.

So, there are two questions:

(1) Do we want the draft to be broader than presence lists, and 
mention that these are lists to which different operations can be applied,

(2) Assuming (1), do we want to add explicit support for a 
"messageable" boolean?

I think we should definitely do (1), I have mixed feelings on (2), but 
am inclined to add it.

Comments?

THanks,
Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 20 Oct 2003 08:52:37 +0100

Jonathan,
	I agree with Ted on this one - I certainly think it would be
beneficial to open up lists for other operations BUT these should be
extensions from the base draft. So (1) and not (2).

Chris.

>-----Original Message-----
>From: Jonathan Rosenberg [mailto:[email-masked]]
>Sent: 19 October 2003 22:04
>To: [email-masked]
>Cc: Simple WG
>Subject: Re: [Simple] What can you do with a list?
>
>Ted,
>
>What you are talking about would correspond to saying yes to option
>(1) below, and no to option (2). Scope creep and immaturity were some
>of the reasons for my mixed feelings on (2). Does anyone strongly
>believe it should be added?
>
>Thanks,
>Jonathan R.
>
>[email-masked] wrote:
>
>> Hi Jonathan, I would suggest that if you decide to expand the scope
>> of the work to include other permissible actions, that those
>> actions be taken forward in separate drafts.  That might require
>> some re-writing of this draft (to make clear that the other drafts
>> and actions may exist later), but it would allow the more mature
>> work to proceed without blocking on the semantics of the other
>> actions. Purely  a personal commentary, regards, Ted Hardie
>>
>>
>>
>> At 3:03 PM -0400 10/17/2003, Jonathan Rosenberg wrote:
>>
>>> Folks,
>>>
http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-list-usage-
>00.txt
>>> One issue was raised to me privately by Markus, which I think
>>> merits broader discussion, is whether the scope of this draft is
>>> just presence lists, or whether it is broader than that. In a
>>> broader model, each URI representing a list has a set of
>>> permissible actions that can be taken against the list. We have
>>> "subscribable", which means you can subscribe to the list, but we
>>> could allow other things. For example, we could add
>>> "messageable", which means a MESSAGE request to that group we be
>>> exploded (using Gonzalo's terminology) to those members.
>>> "Invitable" would mean that an INVITE to that group would cause
>>> creation of a conference call to that group. Clearly this
>>> I think we should definitely do (1), I have mixed feelings on
>>> (2), but am inclined to add it.
>>>
>>> Comments?
>>>
>>> THanks, Jonathan R. -- Jonathan D. Rosenberg, Ph.D.
>>> 600 Lanidex Plaza Chief Technology Officer
>>> Parsippany, NJ 07054-2711 dynamicsoft [email-masked]
>>> FAX:   (973) 952-5050 http://www.jdrosen.net
>>> PHONE: (973) 952-5000 http://www.dynamicsoft.com
>>>
>>>
>>>
>>> _______________________________________________ Simple mailing
>>> list [email-masked]

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 20 Oct 2003 08:52:37 +0100

Jonathan,

Chris.

---

From: [email-masked]
Date: Mon, 20 Oct 2003 19:56:56 +0300

Hi,

I'm also happy to go for option (1) now, and leave (2) for an extension.

Having said that, I think we should do the support for MESSAGE request to the list urgently too, since there are many products around doing such things already, and it would be nice to get some interoperability too. XCAP part is rather obvious, but I belive some discussion is needed about the requirements on the SIP side. At least this comes to mind:
- Do we want to support the reporting on success/failure of the "exploder" to deliver the request to each destination on the list? 

About <invitable> and conferencing: From the user's point of view I think it is clear that the same list should be usable for initiating conferences too. But this could be done by issuing a CPCP command (based on eventual XCON WG output) that is able to reference the HTTP URI of the list too. I think the assumption in XCON is that CPCP would have this kind of functionality (i.e. mass-invitation).

Markus

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Jonathan Rosenberg
> Sent: 20 October, 2003 00:04
> To: [email-masked]
> Cc: Simple WG

---

From: [email-masked]
Date: Mon, 20 Oct 2003 20:29:40 +0300

I think (2) is needed. If you would like to pursue option 1 for now, but delay 2, then I suggest removing any text referring to the list as a presence list.

There is nothing in the draft that tells what package is the list "subscrible" for. It is assumed that it is the presence event package. If you want to extract those service specifics, again, I suggest not referring to presence in this draft.

We could then would write a draft for "subscribe to presence", "messagable", etc.

Regards,
Hisham

> ext Chris Boulton
> Sent: Monday, October 20, 2003 10:53 AM
> To: Jonathan Rosenberg; [email-masked]
> Cc: Simple WG
> Subject: RE: [Simple] What can you do with a list?
> 
> 
> Jonathan,