Subject: RE: [Simple] Comments on MSRP - multiparty message session support

From: [email-masked]
Date: Fri, 17 Oct 2003 17:34:32 +0300

Hi,

I think Aki has a very important point here. I would say that one of the essential drivers for having messaging sessions in the first place is the ability to use them as "media" in the SIP conferencing framework (or in the centralized conferencing a la XCON). In these kind of "chats" it is obviously mandatory that the recipients sees who the originator is. (BTW, this is one of the SIP services that also 3GPP is working on.)

I see three ways forward:
1. Fix this in MSRP base spec (I see that many people woudn't want this anymore at this stage, but still...)
2. Define how MSRP can be extended and do this ASAP as the first extension
3. Use MSGFMT somehow to support this feature

My strong opinion is that MSRP should not allowed to proceed to IESG before there is some conclusion on this. At least to me MSRP without a simple way to support the conference scenario is worthless. There are already have plenty of solutions to send messages between two end-points and imitate a "session" (even SMS can do this), but SIP/MSRP solution's strenght should be really the multi-party case.

Markus 

> -----Original Message-----
> From: ext Aki Niemi [mailto:[email-masked]]
> Sent: 16 October, 2003 19:02
> To: [email-masked]
> Subject: [Simple] Comments on MSRP - multiparty message 
> session support
> 
> 
> Hi All,
> 
> Since MSGFMT is no longer mandated (or is but only for CPIM 
> gateways), 
> how would a participant know where a message is coming from in a 
> multiparty message session?
> 
> Also, when using MSRP in a conferencing system, the lack of To/From 
> prevents sending private messages efficiently within a multiparty 
> session using an MSRP mixer as a "router" for them.
> 
> So my question is this: what is the extensibility model for MSRP? For 
> example, would it be possible to later on add this multiparty 
> functionality as an extension, or would it be wise to think ahead 
> already now?
> 
> The draft includes some extensibility, e.g., for authentication 
> algorithms, but I didn't immediately find much about adding 
> methods and 
> headers, and what to do with unknown headers.
> 
> Regards,
> Aki
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Fri, 17 Oct 2003 12:51:56 -0500

Markus,

As I mentioned to Aki in a separate email, it is possible for the mixer 
device to require all content be wrapped in message/cpim (or any other 
wrapper, for that matter). It seems to me that this at least meets your 
item number 2. Is this not sufficient somehow?

---

From: Ben Campbell <[email-masked]>
Date: Fri, 17 Oct 2003 12:51:56 -0500

Markus,