Subject: RE: [Simple] What can you do with a list?

From: [email-masked]
Date: Mon, 20 Oct 2003 19:56:56 +0300

Hi,

I'm also happy to go for option (1) now, and leave (2) for an extension.

Having said that, I think we should do the support for MESSAGE request to the list urgently too, since there are many products around doing such things already, and it would be nice to get some interoperability too. XCAP part is rather obvious, but I belive some discussion is needed about the requirements on the SIP side. At least this comes to mind:
- Do we want to support the reporting on success/failure of the "exploder" to deliver the request to each destination on the list? 

About <invitable> and conferencing: From the user's point of view I think it is clear that the same list should be usable for initiating conferences too. But this could be done by issuing a CPCP command (based on eventual XCON WG output) that is able to reference the HTTP URI of the list too. I think the assumption in XCON is that CPCP would have this kind of functionality (i.e. mass-invitation).

Markus

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Jonathan Rosenberg
> Sent: 20 October, 2003 00:04
> To: [email-masked]
> Cc: Simple WG
> Subject: Re: [Simple] What can you do with a list?
> 
> 
> Ted,
> 
> What you are talking about would correspond to saying yes to option
> (1) below, and no to option (2). Scope creep and immaturity were some 
> of the reasons for my mixed feelings on (2). Does anyone strongly 
> believe it should be added?
> 
> Thanks,
> Jonathan R.
> 
> [email-masked] wrote:
> 
> > Hi Jonathan, I would suggest that if you decide to expand the scope
> > of the work to include other permissible actions, that those
> > actions be taken forward in separate drafts.  That might require
> > some re-writing of this draft (to make clear that the other drafts
> > and actions may exist later), but it would allow the more mature 
> > work to proceed without blocking on the semantics of the other 
> > actions. Purely  a personal commentary, regards, Ted Hardie
> > 
> > 
> > 
> > At 3:03 PM -0400 10/17/2003, Jonathan Rosenberg wrote:
> > 
> >> Folks,
> >> 
> >> I'll be submitting a rev shortly to the xcap list draft: 
> >> 
> http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-lis
> t-usage-00.txt
> >> 
> >> 
> >> There have been few comments on this document; its pretty
> >> straightforward.
> >> 
> >> One issue was raised to me privately by Markus, which I think
> >> merits broader discussion, is whether the scope of this draft is
> >> just presence lists, or whether it is broader than that. In a
> >> broader model, each URI representing a list has a set of
> >> permissible actions that can be taken against the list. We have
> >> "subscribable", which means you can subscribe to the list, but we
> >> could allow other things. For example, we could add
> >> "messageable", which means a MESSAGE request to that group we be
> >> exploded (using Gonzalo's terminology) to those members.
> >> "Invitable" would mean that an INVITE to that group would cause
> >> creation of a conference call to that group. Clearly this
> >> intersects with the conferencing work.
> >> 
> >> So, there are two questions:
> >> 
> >> (1) Do we want the draft to be broader than presence lists, and
> >> mention that these are lists to which different operations can be
> >> applied,
> >> 
> >> (2) Assuming (1), do we want to add explicit support for a
> >> "messageable" boolean?
> >> 
> >> I think we should definitely do (1), I have mixed feelings on
> >> (2), but am inclined to add it.
> >> 
> >> Comments?
> >> 
> >> THanks, Jonathan R. -- Jonathan D. Rosenberg, Ph.D.
> >> 600 Lanidex Plaza Chief Technology Officer
> >> Parsippany, NJ 07054-2711 dynamicsoft [email-masked]
> >> FAX:   (973) 952-5050 http://www.jdrosen.net
> >> PHONE: (973) 952-5000 http://www.dynamicsoft.com
> >> 
> >> 
> >> 
> >> _______________________________________________ Simple mailing
> >> list [email-masked] 
> >> https://www1.ietf.org/mailman/listinfo/simple
> > 
> > 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 21 Oct 2003 11:17:23 +0300

Folks,

> I'm also happy to go for option (1) now, and leave (2) for an extension.

Yes, that would be OK.

Regarding (2), we can agree on the requirements in SIPPING (they are 
only a few of them) and have an ad-hoc (bar BOF) in Minneapolis about 
potential solutions. Reporting to the initiator is one of the issues we 
need to talk about.

I agree that the more important cases are MESSAGE and INVITE... it is 
clear that the INVITE case could be addressed with CPCP as well, but I 
see value in having a simpler way of doing that in addition to CPCP.

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 21 Oct 2003 11:17:23 +0300

Folks,

Yes, that would be OK.

Gonzalo