Subject: [Simple] Discovery of an MSRP relay

From: "Miguel A. Garcia" <[email-masked]>
Date: Fri, 03 Oct 2003 08:31:59 +0300

Hi:

I would like to understand possible mechanisms to discover an MSRP relay 
in a network. Is this something that have been discussed before?

When reading the MSRP draft, section 7.1.2, I found a discussion on the 
usage of DNS SRV when the MSRP client already knows the host name of the 
  MSRP relay. Fair enough. But in most situations this requires either 
provisioning or some out of band configuration. In a roaming scenario, 
when the network changes oftenly, the address of the MSRP relay may 
change as well. So I believe there is a need for a discovery mechanism 
of the MSRP relay.

If we compare with SIP, SIP uses DNS SRV records to solve this problem. 
The input to the DNS SRV query is a network name, and the answer is a 
host name. I was wondering if is this something that we can mimic in 
MSRP, as I believe the problem are pretty similar.

Thanks a lot,

         Miguel
-- 
Miguel-Angel Garcia                     Oy LM Ericsson AB
                                         Jorvas, Finland
mailto:[email-masked]     Phone:  +358 9 299 3553
mailto:[email-masked]        Mobile: +358 40 514 0002

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Adam Roach <[email-masked]>
Date: Wed, 8 Oct 2003 17:54:24 -0500

Miguel A. Garcia [mailto:[email-masked]] writes:

> In another case, an MSRP relay is provided in a home network, 
> and that MSRP relay is used no matter whether the user is
> attached directly to such network or indirectly through other
> networks. In this case DHCP won't obviously solve the problem.

For this case, I suggest we borrow a page from the well-understood,
time-tested, universally deployed, and demonstrably workable
mechanism that HTTP clients use to solve the problem of finding
HTTP proxies.

/a

---

From: [email-masked]
Date: Thu, 9 Oct 2003 16:34:35 +0300

How about UA configuration from SIPPING (or any other configuration protocol)?

/Hisham

> -----Original Message-----
> From: ext Miguel A. Garcia [mailto:[email-masked]]
> Sent: Thursday, October 09, 2003 2:03 AM
> To: Adam Roach
> Cc: Jonathan Rosenberg; [email-masked]
> Subject: Re: [Simple] Discovery of an MSRP relay
> 
> 
> Adam:
> 
> Your proposal works if I am in my home network. But if I am 
> roaming, the 
> DHCP server will be located in the roaming network, and will be 
> provisioned with information about the MSRP relay in the roaming 
> network. If this is the case, fine, it will work, but if by policy, I 
> have to use the MSRP provided in my home network, and I am 
> roaming, it 
> won't work. Further more, if the roaming network does not 
> offer an MSRP 
> relay service, but my home network does, I won't be able to 
> discover the 
> MSRP relay server.
> 
> I am not sure, at this stage, which of the above cases would 
> be the case 
> for MSRP relays... I just want to be prepared with solutions 
> that solve 
> any of the possible requirements.
> 
> /Miguel
> 
> Adam Roach wrote:
>

---

From: Adam Roach <[email-masked]>
Date: Thu, 9 Oct 2003 10:56:06 -0500

Miguel A. Garcia [mailto:[email-masked]] writes:

> ...but if by policy, I 
> won't work.

I don't see why not. Your home MSRP relay would be provisioned
in your terminal, so it would know to go there.

As an aside: what are you trying to do? The purpose of MSRP
relays is to solve issues with firewalls and/or NATs. Why would
you be tromboning back to your home network to find an MSRP
relay? I mean, if you can get to your home network, it's a
pretty good bet that you can hit the Internet as well, which
should give you a clear shot to the other participant (or
at least his relay).

/a