Subject: RE: [Simple] What can you do with a list?

From: [email-masked]
Date: Mon, 20 Oct 2003 20:29:40 +0300

I think (2) is needed. If you would like to pursue option 1 for now, but delay 2, then I suggest removing any text referring to the list as a presence list.

There is nothing in the draft that tells what package is the list "subscrible" for. It is assumed that it is the presence event package. If you want to extract those service specifics, again, I suggest not referring to presence in this draft.

We could then would write a draft for "subscribe to presence", "messagable", etc.

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Chris Boulton
> Sent: Monday, October 20, 2003 10:53 AM
> To: Jonathan Rosenberg; [email-masked]
> Cc: Simple WG
> Subject: RE: [Simple] What can you do with a list?
> 
> 
> Jonathan,
> 	I agree with Ted on this one - I certainly think it would be
> beneficial to open up lists for other operations BUT these should be
> extensions from the base draft. So (1) and not (2).
> 
> Chris.
> 
> 
> >-----Original Message-----
> >From: Jonathan Rosenberg [mailto:[email-masked]]
> >Sent: 19 October 2003 22:04
> >To: [email-masked]
> >Cc: Simple WG
> >Subject: Re: [Simple] What can you do with a list?
> >
> >Ted,
> >
> >What you are talking about would correspond to saying yes to option
> >(1) below, and no to option (2). Scope creep and immaturity were some
> >of the reasons for my mixed feelings on (2). Does anyone strongly
> >believe it should be added?
> >
> >Thanks,
> >Jonathan R.
> >
> >[email-masked] wrote:
> >
> >> Hi Jonathan, I would suggest that if you decide to expand the scope
> >> of the work to include other permissible actions, that those
> >> actions be taken forward in separate drafts.  That might require
> >> some re-writing of this draft (to make clear that the other drafts
> >> and actions may exist later), but it would allow the more mature
> >> work to proceed without blocking on the semantics of the other
> >> actions. Purely  a personal commentary, regards, Ted Hardie
> >>
> >>
> >>
> >> At 3:03 PM -0400 10/17/2003, Jonathan Rosenberg wrote:
> >>
> >>> Folks,
> >>>
> >>> I'll be submitting a rev shortly to the xcap list draft:
> >>>
> http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-list-usage-
> >00.txt
> >>>
> >>>
> >>> There have been few comments on this document; its pretty
> >>> straightforward.
> >>>
> >>> One issue was raised to me privately by Markus, which I think
> >>> merits broader discussion, is whether the scope of this draft is
> >>> just presence lists, or whether it is broader than that. In a
> >>> broader model, each URI representing a list has a set of
> >>> permissible actions that can be taken against the list. We have
> >>> "subscribable", which means you can subscribe to the list, but we
> >>> could allow other things. For example, we could add
> >>> "messageable", which means a MESSAGE request to that group we be
> >>> exploded (using Gonzalo's terminology) to those members.
> >>> "Invitable" would mean that an INVITE to that group would cause
> >>> creation of a conference call to that group. Clearly this
> >>> intersects with the conferencing work.
> >>>
> >>> So, there are two questions:
> >>>
> >>> (1) Do we want the draft to be broader than presence lists, and
> >>> mention that these are lists to which different operations can be
> >>> applied,
> >>>
> >>> (2) Assuming (1), do we want to add explicit support for a
> >>> "messageable" boolean?
> >>>
> >>> I think we should definitely do (1), I have mixed feelings on
> >>> (2), but am inclined to add it.
> >>>
> >>> Comments?
> >>>
> >>> THanks, Jonathan R. -- Jonathan D. Rosenberg, Ph.D.
> >>> 600 Lanidex Plaza Chief Technology Officer
> >>> Parsippany, NJ 07054-2711 dynamicsoft [email-masked]
> >>> FAX:   (973) 952-5050 http://www.jdrosen.net
> >>> PHONE: (973) 952-5000 http://www.dynamicsoft.com
> >>>
> >>>
> >>>
> >>> _______________________________________________ Simple mailing
> >>> list [email-masked]
> >>> https://www1.ietf.org/mailman/listinfo/simple
> >>
> >>
> >
> >--
> >Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> >Chief Technology Officer                    Parsippany, NJ 07054-2711
> >dynamicsoft
> >[email-masked]                     FAX:   (973) 952-5050
> >http://www.jdrosen.net                      PHONE: (973) 952-5000
> >http://www.dynamicsoft.com
> >
> >
> >_______________________________________________
> >Simple mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/simple
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 21 Oct 2003 01:10:20 -0400

[email-masked] wrote:

> I think (2) is needed. If you would like to pursue option 1 for
> now, but delay 2, then I suggest removing any text referring to the
> list as a presence list.
> 
> There is nothing in the draft that tells what package is the list
> "subscrible" for. It is assumed that it is the presence event
> package. If you want to extract those service specifics, again, I
> suggest not referring to presence in this draft.
> 

I think it would be OK to make the list descriptions generic, and also 
include in the draft the information on how to subscribe to presence.

Anyway, it seems there is consensus to do (1), and to pursue (2) 
separately.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 21 Oct 2003 01:10:20 -0400

-Jonathan R.