Subject: RE: [Simple] Comments on message-sessions-02 - message retry

From: [email-masked]
Date: Thu, 6 Nov 2003 11:31:48 +0200

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: Wednesday, November 05, 2003 9:22 PM
> To: Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Simple] Comments on message-sessions-02 - message retry
> 
> 
> [email-masked] wrote:
> > 
> > - Section 7.4.3:
> >    - In step 5 "The endpoint MAY attempt to send the 
> message content again"
>  >      Should we remove this text? If the message sending 
> fails, so be it.
>  >      The user can choose to send it again. This avoids the 
> very large 
> message
>  >      being sent again (long messages have the potential to falsely 
> timing out
>  >      and the sender gets a 500 response).
> 
> I agree this should go. We may want to discuss possibility of 
> establishing a replacement media session and then retrying 
> the message 
> there. In that case I think we perhaps should make it permissible for 
> the retry to use the same TR-ID. It is then optional whether the 
> recipient detects the duplicate or not.

If I understand you correctly, you are suggesting that if a message fails with a 500 or a timeout, then we create a new session and try resending it there? If so, then I think I disagree. I think there should not be any retransmission at all. The end user can choose to send the message again, after he learns that the message did not really get there.

Also, you really want to tie TR-IDs across sessions?

Regards,
Hisham

> 
> This addresses the case where a relay crashes in an ungraceful way.
> 
> >    - Open issue: NO.
> 
> I guess what I am proposing is YES, but with a weak mechanism 
> - neither 
> side is *required* to enable duplicate suppression, but the 
> mechanism is 
> there if both sides choose to use it.
> 
> 	Paul
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Nov 2003 09:30:23 -0500

[email-masked] wrote:
> If I understand you correctly, you are suggesting that if a message
 > fails with a 500 or a timeout, then we create a new session and try
 > resending it there?

Yes, depending on the definition of "we". :-)

I am suggesting that an IM *application* that wants to provide the best 
possible user experience might do this.

 > If so, then I think I disagree. I think there
 > should not be any retransmission at all. The end user can choose to
 > send the message again, after he learns that the message did not
 > really get there.

If your application doesn't support the retransmission then of course 
you can choose to do that. I'm not suggesting that this be mandatory.

> Also, you really want to tie TR-IDs across sessions?

If the application chooses to use them that way.

The main significant point here would be that *if* a TR-ID is reused on 
a "related" session then a recipient would be permitted to ignore the 
message. To avoid any confusion, it would probably be best to define an 
error response that indicates the message was recognized as a duplicate.

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Nov 2003 09:30:23 -0500

Paul