Subject: [Simple] Questions about SIMPLE

From: Nadezhda Fedorova <[email-masked]>
Date: Sat, 22 Nov 2003 15:28:24 +0200

Hello all,

     Could you please answer some questions about SIMPLE?
     I need to make IM System based on SIP and SIMPLE, so I've read a lot of
     documents about SIMPLE and didn't find answers to them.
     Please answer me if you can.

     Here are the questions:

     1. Is it possible to use resource lists (RL) not only for defining list of my
        buddies and subscribing to events from them, but e.g.
        for inviting many people to a dialog,
        or for sending a message to all of them simultaneously?
        
        If it is, then what must be the behaviour of UAC and UAS when
        UAC sends a message to all buddies from his RL and some of
        buddies are offline and some online?
         
     2. Are there any common mechanisms (rules) for sending offline messages
        (I mean rules for sending a message to a user when he is
         offline)?

     3. How can I SUBSCRIBE to all events from a resource?

-- 
Best regards,
 Nadezhda                          mailto:[email-masked]
                                   mailto:[email-masked]

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 25 Nov 2003 14:28:56 -0500

inline.

>         or for sending a message to all of them simultaneously?

That is just now under consideration. The xcap-list spec was recently 
updated to allow for this possibility:

http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-list-usage-01.txt

although there is no specifics for message or invite. This is also 
intimately related to the recent exploders work:

http://www.ietf.org/internet-drafts/draft-camarillo-sipping-exploders-01.txt
http://www.ietf.org/internet-drafts/draft-camarillo-sipping-explode-method-00.txt
http://www.ietf.org/internet-drafts/draft-camarillo-sipping-exploders-solution-00.txt

>         buddies are offline and some online?

Unless the server explicitly supports the notion of messaging to a 
group, the server would return a 405 indicating that this method is 
not allowed on that resource.

>         (I mean rules for sending a message to a user when he is

No standards work has been done in this area at this time. We do have 
some requirements that were written about it some time ago:

http://www.jdrosen.net/papers/draft-rosenberg-simple-messaging-requirements-00.txt

>      3. How can I SUBSCRIBE to all events from a resource?

That is not supported.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 25 Nov 2003 14:28:56 -0500

inline.

That is not supported.

-Jonathan R.