Subject: RE: [Simple] I-D ACTION:draft-ietf-simple-xcap-01.txt -> comments

From: [email-masked]
Date: Wed, 5 Nov 2003 16:10:24 +0200

Hi,

Thanks for the new version of the XCAP draft! It was nice to see that it was still improved,
and more "exact" than the previous version. I have only a couple of comments for the draft.

I think that there could be more exact definition on what is exactly the "real" content to be handled by the following three operations:
- 6.5. "Creating a new element"
This chapter says that "The content in the request MUST be an XML element." However, shouldn't it state that 
"the content is an XML element and associated content (including children elements)" OR "the content is the portion of the XML document starding with the left bracket of the begin tag of the element, ending with the right bracket of the end tag of the element." as said in the later chapters concerning the PUT and/or GET operations?

- 6.6. "Replacing an element in the document
The same comment as for the "creating a new element" applies also to this chapter.

- 6.7. "Delete an Element
* The chapter says "...containing the elements to be deleted": is it possible to delete elements from several parts of the document using one "delete an element" operation or should the node selector point to only one element? This could be clarified in the chapter.
* the same comments as for the chapter 6.5 also applies here: shouldn't the "delete" remove the element plus its sub-tree?

BR, Eva Leppanen

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 13 Nov 2003 03:33:06 -0500

Thanks for your comments. Responses inline.

[email-masked] wrote:

> Hi,
> 
> Thanks for the new version of the XCAP draft! It was nice to see
> that it was still improved, and more "exact" than the previous
> version. I have only a couple of comments for the draft.
> 
> I think that there could be more exact definition on what is
> exactly the "real" content to be handled by the following three
> operations: - 6.5. "Creating a new element" This chapter says that
> "The content in the request MUST be an XML element." However,
> shouldn't it state that "the content is an XML element and
> associated content (including children elements)" OR "the content
> is the portion of the XML document starding with the left bracket
> of the begin tag of the element, ending with the right bracket of
> the end tag of the element." as said in the later chapters
> concerning the PUT and/or GET operations?

Yes, good idea. I will use the latter text. As you say, I have already 
used that elsewhere.

> 
> - 6.6. "Replacing an element in the document The same comment as
> for the "creating a new element" applies also to this chapter.

Sure, but this section refers to 6.5 for most of the details. So, I 
think a discussion in 6.5 alone is sufficient.

> 
> - 6.7. "Delete an Element * The chapter says "...containing the
> elements to be deleted": is it possible to delete elements from
> several parts of the document using one "delete an element"
> operation or should the node selector point to only one element?
> This could be clarified in the chapter.

One element.

I will clarify.
 >
 >
> * the same comments as for
> the chapter 6.5 also applies here: shouldn't the "delete" remove
> the element plus its sub-tree?

Yes, I will clarify.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 13 Nov 2003 03:33:06 -0500

One element.

I will clarify.

Yes, I will clarify.

Thanks,
Jonathan R.