Subject: RE: [Simple] Objects to NATs kill TCP connection

From: [email-masked]
Date: Thu, 20 Nov 2003 09:28:38 +0200

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: 19.November.2003 16:23
> To: Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [Simple] Objects to NATs kill TCP connection
> 
> 
> [email-masked] wrote:
> 
> > 
> >>-----Original Message-----
> >>From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> >>ext Paul Kyzivat
> >>Sent: 18.November.2003 21:13
> >>To: Ben Campbell
> >>Cc: Jonathan Rosenberg; Cullen Jennings; [email-masked]
> >>Subject: Re: [Simple] Objects to NATs kill TCP connection
> >>
> >>
> >>
> >>
> >>Ben Campbell wrote:
> >>
> >>>Can we reasonably assume that all connection failures are 
> >>
> >>due to NATs? 
> >>
> >>>What happens if endpoints do this when the failure is caused by 
> >>>something else?
> >>
> >>Good point. That could be ugly - I don't see any easy way to 
> >>know when 
> >>the connection fails because of NAT. Lacking that it seems 
> >>infeasible to 
> >>test for the NAT timeout interval.
> >>
> >>Are there any standard practices in this regard? In other words, is 
> >>there a keepalive time we could use that would be sufficient 
> >>most of the 
> >>time and still not be too impractical to keep up?
> > 
> > 
> > To be safe, you need a keepalive message every 30 seconds. 
> You can always send empty TCP packets.
> > 
> > Shouldn't this anyway be a relay problem? maybe a BIND is 
> sent to the relay every x seconds.
> 
> It can occur without any relays. For example, what if one 
> (the active) 
> endpoint is natted and the other is not? This scenario works 
> with no relays.

We had relays in the protocol to solve such problems of NAT and firewall traversal. Lets not try to solve the problems introduced by NATS and firewalls without relays.

MS(R)P does not support NAT and firewall traversal without relays. Am I missing something?

/Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Thu, 20 Nov 2003 08:16:49 -0600

> MS(R)P does not support NAT and firewall traversal without relays. Am I missing something?

Relays were primarily needed for when both endpoints were behind NATs. 
If only one is behind a NAT, you can work without a relay. Relays also 
helped with firewall policy that only allows connections to and/or from 
a particuclar address. But this is not always the case.

If everyone things we can ignore NAT entirely in the base spec, then I 
will be happy to do so.

There are some gray areas in the current draft that may or may not need 
to stay when relays are removed. I will follow up shortly with a list 
for discussion purposes.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 20 Nov 2003 08:16:49 -0600