Subject: RE: [Simple] I-D ACTION:draft-ietf-simple-xcap-auth-usage-01.txt -> comments

From: [email-masked]
Date: Wed, 5 Nov 2003 16:19:39 +0200

Hi,

Thanks for the new version! Please find below a couple of comments.

- The draft mentions still in a couple of places the "when" (~rule permissions) issue even if it has been removed from the 
current version. The chapters are: 
	* the first sub-chapter of the "1. introduction" ("...but also includes decisions about when the watcher should receive notifications...") and 
	* the first sub-chapter of the chapter 2 ("...a condition under which a notification is sent or is not sent...")

- 4.2.2.2. Content permissions
	* The "show-element" does not clearly indicate whether e.g. the sub-tree of the indicated element will be delivered or not.

- 4.4. Naming Conventions
	* Just for clarification: is it possible to use the definitions of the "global" sub-tree or is the presence authorisation limited to the "users" sub-tree?

- 4.6. XML Schema
	* the schema is missing

- 5. Supported permissions
	* The "compound permissions" is mentioned in the introduction and the example (5.6) but shouldn't they be removed?
	* Is the purpose of the example (5.6) to show an example of primitive types or "combound permissions" (see the description of the example)?
	* the <show-element> in the example document (5.6) has the value "example": is the purpose to list all the supported elements or just to indicate that the <show-element> content permission is supported by the server?

BR, Eva

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 5 Nov 2003 16:19:39 +0200

Hi,

- 4.6. XML Schema
	* the schema is missing

BR, Eva