Subject: RE: [Simple] BIND and relays documentation

From: [email-masked]
Date: Tue, 25 Nov 2003 11:52:13 +0200

We will support relays for NAT traversal, in a separate document. But having half the solution documented is a separate I-D is not appropriate, IMO.

/Hisham

> -----Original Message-----
> From: ext Miguel A. Garcia [mailto:[email-masked]]
> Sent: 25.November.2003 11:43
> To: Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] BIND and relays documentation
> 
> 
> This proposal is an incomplete specification. Precluding support for 
> proxies and NAT these days seems a bad idea. If you allow to have a 
> collection of endpoints deployed that do not support relays, we will 
> definitely get problems.
> 
> /Miguel
> 
> [email-masked] wrote:
> 
> > Hi Miguel,
> > 
> > I don't agree with you. The relay case will be seen as an 
> extension of MS(R)P and therefore all methods to support 
> relays should be defined in that document.
> > 
> > If endpoint implementers want to support relays for NAT 
> traversal, then they better implement whatever is documented 
> in the relay document.
> > 
> > Regards,
> > Hisham
> > 
> > 
> >>-----Original Message-----
> >>From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> >>ext Miguel A. Garcia
> >>Sent: 24.November.2003 20:48
> >>To: Ben Campbell
> >>Cc: Simple WG
> >>Subject: [Simple] BIND and relays documentation
> >>
> >>
> >>Hi:
> >>
> >>A question about the recent decision to split the MSRP 
> >>protocol into a 
> >>relay-less document and a document that details the use of relays.
> >>
> >>I would like to understand if the idea is to document the 
> >>BIND primitive 
> >>in the relay-less document or in the relayful document.
> >>
> >>Some folks may argue that the BIND primitive is only used 
> in the case 
> >>there are relays in the path, and as such, it should be 
> documented in 
> >>the relays document. However, in doing so, we may risk that 
> >>end points 
> >>will not implement the BIND primitive ever, and therefore will not 
> >>support the operation through relays.
> >>
> >>I am in favour of documenting the BIND primitive in the core MSRP 
> >>document, in spite that the relay operation will be 
> described in the 
> >>relays document.
> >>
> >>Is this something that the working group is thinking?
> >>
> >>/Miguel
> >>-- 
> >>Miguel-Angel Garcia                     Oy LM Ericsson AB
> >>                                         Jorvas, Finland
> >>mailto:[email-masked]     Phone:  +358 9 299 3553
> >>mailto:[email-masked]        Mobile: +358 40 514 0002
> >>
> >>
> >>
> >>_______________________________________________
> >>Simple mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/simple
> > 
> > 
> 
> -- 
> Miguel-Angel Garcia                     Oy LM Ericsson AB
>                                          Jorvas, Finland
> mailto:[email-masked]     Phone:  +358 9 299 3553
> mailto:[email-masked]        Mobile: +358 40 514 0002
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Tue, 25 Nov 2003 13:46:18 +0200

To me the "half" solution is to document the interaction between the 
endpoint and the relays in a different document. This sounds a lame 
solution comparable to not supporting proxies in RFC 3261 or RFC 2616.

/Miguel

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Tue, 25 Nov 2003 13:46:18 +0200

/Miguel

---

From: Ben Campbell <[email-masked]>
Date: Tue, 25 Nov 2003 09:37:30 -0600

> We will support relays for NAT traversal, in a separate document. But having half the solution documented is a separate I-D is not appropriate, IMO.

I am not sure I follow your meaning. Do you mean (1) having the relay 
specification spread between drafts (BIND in one, the rest in the other) 
is not appropriate, or (2) Splitting the total solution into two drafts, 
one specifying a point-to-point solution, and the other specifying a 
relay extension is inappropriate?

---

From: Ben Campbell <[email-masked]>
Date: Tue, 25 Nov 2003 09:37:30 -0600