Subject: RE: [Simple] Question on draft-ietf-simple-presence-10 and Allow- Events

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 26 Nov 2003 14:38:44 -0000

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: 25 November 2003 19:19
> To: Drage, Keith (Keith)
> Cc: Adam Roach; [email-masked]
> Subject: Re: [Simple] Question on draft-ietf-simple-presence-10 and
> Allow- Events
> 
<snipped>

> 
> > Is it
> > not the case that presence servers supporting the "presence" event,
> > probably (i.e. SHOULD strength) also support the "presence.winfo"
> > event template.
> 
> We have never made that a requirement anywhere. I'm not sure its 
> IETF's job to do that.

I understood the following text from section 4.6 of draft-ietf-simple-winfo-package-05 specified this requirement. Have I misread this.

   "It is RECOMMENDED that user A be allowed to subscribe to their own
   watcher information for any package. This is true recursively, so
   that it is RECOMMENDED that a user be able to subscribe to the
   watcher information for their watcher information for any package."
> 
> 
>   Would it be useful to indicate this support, given
> > that the support of one package is only a SHOULD, given the support
> > of the other, or do you have some other way of determining this
> > information? Thus user A subscribing for the presence of user B
> > would get an indication of whether user A could see other users,
> > e.g. user B, watching him.
> 
> I agree that learning other packages that are supported would 
> be useful.
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 26 Nov 2003 16:24:34 -0500

Drage, Keith (Keith) wrote:

>>> Is it not the case that presence servers supporting the
>>> "presence" event, probably (i.e. SHOULD strength) also support
>>> the "presence.winfo" event template.
>> 
> I understood the following text from section 4.6 of
> draft-ietf-simple-winfo-package-05 specified this requirement. Have
> I misread this.
> 

This text does not mean that, if you support presence, you need to 
support winfo. It means that, for any package that the server might 
support, it should allow a user to subscribe to winfo for that package 
(assuming of course winfo is supported).

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 26 Nov 2003 16:24:34 -0500

Drage, Keith (Keith) wrote:

-Jonathan R.