Subject: RE: [Simple] xcap/geopriv alignment issue 4: authentication

From: [email-masked]
Date: Tue, 25 Nov 2003 10:19:57 +0200

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: 24.November.2003 23:00
> To: Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] xcap/geopriv alignment issue 4: authentication
> 
> 
> [email-masked] wrote:
> 
> > Can the user at least have a say in accepting or rejecting 
> the subscription based on the availability of any 
> authentication type. Eg: A user can reject subscriptions that 
> are not authenticated in any way and accept subscriptions 
> that are authenticated, regardless of authentication type.
> 
> In the absence of _some_ authentication, what is the value of having 
> authorization policies in the first place? They have no 
> meaning if you 
> cannot put some degree of trust in the requestor identity.
> 
> I think the email world has proven to us how useful it is to 
> authorize 
> on un-authenticated headers. How useful is a spam filter that 
> relies on 
> the From header?

Either I'm missing your point, or you missed mine. All I said was that the user should be able to reject subscriptions if they are not authenticated (authentication method is irrelevant).

/Hisham

> 
> > 
> > Regards,
> > Hisham
> > 
> > 
> >>-----Original Message-----
> >>From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> >>ext Jonathan Rosenberg
> >>Sent: 24.November.2003 08:13
> >>To: Simple WG
> >>Subject: [Simple] xcap/geopriv alignment issue 4: authentication
> >>
> >>
> >>Folks,
> >>
> >>Currently, xcap-auth defines an authentication condition. 
> This allows 
> >>you to decide whether to accept or reject a subscription 
> based on the 
> >>type of authentication used in the SUBSCRIBE request.
> >>
> >>The geopriv policy specification currently has no such mechanism.
> >>
> >>This was discussed during the geopriv meeting in 
> Minneapolis. If you 
> >>think about it for a bit, its not clear how this would actually get 
> >>used. Remember, it is end users that will set these policies. What 
> >>kind of meaningful information can be provided to a user about the 
> >>differences between p-asserted-id and sip-identity and digest 
> >>authentication? What would make a user give permission for 
> >>one type or 
> >>authentication, and not another? Practically speaking, it 
> doesnt seem 
> >>like its easy to use at all.
> >>
> >>As a result, I would propose to remove the authentication condition 
> >>from xcap-auth.
> >>
> >>Comments?
> >>
> >>-Jonathan R.
> >>-- 
> >>Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> >>Chief Technology Officer                    Parsippany, NJ 
> 07054-2711
> >>dynamicsoft
> >>[email-masked]                     FAX:   (973) 952-5050
> >>http://www.jdrosen.net                      PHONE: (973) 952-5000
> >>http://www.dynamicsoft.com
> >>
> >>
> >>
> >>_______________________________________________
> >>Simple mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/simple
> >>
> > 
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> 
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 25 Nov 2003 09:23:27 -0600

> Either I'm missing your point, or you missed mine. All I said was that the user should be able to reject subscriptions if they are not authenticated (authentication method is irrelevant).

Ah, well, I can't disagree with that :-)

Ben.

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 25 Nov 2003 21:21:58 +0100

Hi ben, 

This issue is not about the absence of authentication. It is only about a
specific mechanism. An example: 

Would you like to indicate policies stating that you show information X to
henning if he authenticated himself using tls but not using http digest. 

If an identity is provided then it is always assumed that you performed
authentication (otherwise it is anonymous). Without cryptographic
authentication you could provide any identity (i.e., identity spoofing is
very simple). 

btw, a small note. Stating tls as authentication mechanism is actually wrong
since you have to indicate which protocol was used within the tls handshake,
e.g., 
- Kerberos
- Unilateral pk-based authentication
- Mutual pk-based authentication
- Shared secret authentication
- strong-password based authentication using srp

ciao
hannes

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Dienstag, 25. November 2003 09:20
> To: [email-masked]
> Subject: RE: [Simple] xcap/geopriv alignment issue 4: authentication
> 
> 
> 
> 
> Either I'm missing your point, or you missed mine. All I said 
> was that the user should be able to reject subscriptions if 
> they are not authenticated (authentication method is irrelevant).
> 
> /Hisham
> 
> > 
> > > 
> > > Regards,
> > > Hisham
> > > 
> > > 
> > >>[email-masked] https://www1.ietf.org/mailman/listinfo/simple
> > >>
> > > 
> > > 
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/simple
> > 
> > 
> > 
>

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 25 Nov 2003 21:21:58 +0100

Hi ben, 

ciao
hannes