Subject: RE: [Simple] ad-hoc list subscriptions

From: [email-masked]
Date: Thu, 13 Nov 2003 05:09:31 +0200

Hi,

Would you consider the decision whether the list contents are included in the request sent by the application server as application logic, or should this be explicitely signaled by the original sender? 

In general it is not clear to me what kind of behaviours should be standardized/signaled, and which are just left to each application to decide. In fact I'm inclined to think that this kind of very basic cases, i.e. conference establishment or B2BUA forking, should be made explicit. More advanced/niche features, such as if the app. server sends e-mail to people not reached, can be left to the imagination of the developers. One of the reasons is that I would like the basic features to work uniformly accross service providers. I believe this to be the advantage of the "ordinary" users.

Markus 

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: 13 November, 2003 00:20
> To: Adam Roach
> Cc: 'Paul Kyzivat'; Isomaki Markus (NRC/Helsinki);
> [email-masked]; Jonathan Rosenberg; [email-masked]
> Subject: Re: [Simple] ad-hoc list subscriptions
> 
> 
> I concur with Adam. The basic URI (not counting the list parameter) 
> identifies an application that knows to do something with the list 
> parameter. Some other application might just ignore the list 
> parameter.
> 
> Adam Roach wrote:
> 
> > I would argue that, as with every other request you send,
> > the application behavior depends on the request URI.
> > 
> > So, for example, I could deploy an application server in
> > the middle of the network that treats:
> > 
> > INVITE 
> sip:[email-masked];list=cid:[email-masked]
> > SIP/2.0
> > 
> > ...very differently than...
> > 
> > INVITE 
> sip:[email-masked];list=cid:[email-masked] SIP/2.0
> > 
> > /a
> > 
> > 
> >>-----Original Message-----
> >>From: Paul Kyzivat [mailto:[email-masked]]
> >>Sent: Wednesday, November 12, 2003 12:39
> >>To: [email-masked]
> >>Cc: [email-masked]; [email-masked]; 
> >>[email-masked]
> >>Subject: Re: [Simple] ad-hoc list subscriptions
> >>
> >>
> >>There seems to be an assumption here that sending an INVITE 
> >>to an ad hoc 
> >>list should create a conference. That is certainly one 
> >>interpretation, 
> >>but not the only possible one. If the ad hoc list server is 
> a simple 
> >>message exploder then you probably aren't going to get a conference.
> >>
> >>If you have a list of people and want to set up a conference 
> >>there are 
> >>other ways to do it, so trying to bend ad hoc list to do this 
> >>may not be 
> >>justified.
> >>
> >>	Paul
> >>
> >>[email-masked] wrote:
> >>
> >>>Hi,
> >>>
> >>>I believe the best way would be for them to subscribe to 
> >>
> >>conference-state event package, if that is available. But I 
> >>guess there is a bigger issue here: What is the relationship 
> >>between a conference started through an exploder and a 
> >>conference setup for with CPCP a la XCON. Is it possible to 
> >>migrate from an exploder conference to CPCP-controllable one 
> >>(given that the server supports CPCP, conference notification 
> >>service etc.)?
> >>
> >>>I have yet another requirement for this ad hoc list / 
> >>
> >>exploder solution. Especially in the case of MESSAGE to a 
> >>list, it would be nice to be able to convey to the recipients 
> >>the list of other recipients. It should be possible for the 
> >>original sender to indicate this. It shouldn't be too hard to 
> >>map the headers/payload from incoming to outgoing side for 
> >>this purpose within the "exploder server".
> >>
> >>>Markus 
> >>>
> >>>
> >>>
> >>>>-----Original Message-----
> >>>>From: [email-masked] 
> >>
> >>[mailto:[email-masked]]On Behalf Of
> >>
> >>>>ext Dean Willis
> >>>>Sent: 12 November, 2003 16:56
> >>>>To: Jonathan Rosenberg
> >>>>Cc: Simple WG
> >>>>Subject: Re: [Simple] ad-hoc list subscriptions
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>>I dont get this. I thought that an ad-hoc list would be 
> >>>>
> >>>>scoped to the 
> >>>>
> >>>>
> >>>>>subscription, in which case, there wouldnt be any other 
> >>>>
> >>>>subscribers. Am 
> >>>>
> >>>>
> >>>>>I missing something?
> >>>>
> >>>>Ok, assume I send an INVITE to an ad-hoc list, forming an ad-hoc 
> >>>>conference. Would "members" of the list (i.e., 
> participants in the 
> >>>>conference) subscribe to the list, or to the conference 
> in order to 
> >>>>learn about changes to the participant set?
> >>>>
> >>>>--
> >>>>Dean
> >>>>
> >>>>
> >>>>
> >>>>_______________________________________________
> >>>>Simple mailing list
> >>>>[email-masked]
> >>>>https://www1.ietf.org/mailman/listinfo/simple
> >>>>
> >>>
> >>>
> >>>_______________________________________________
> >>>Simple mailing list
> >>>[email-masked]
> >>>https://www1.ietf.org/mailman/listinfo/simple
> >>>
> >>
> >>
> >>_______________________________________________
> >>Simple mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/simple
> >>
> > 
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> 
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Wed, 12 Nov 2003 21:22:09 -0600

First, just for clarity's sake, I did not intend for the word 
"application" to indicate any value judgement about whether it should be 
standardized or not.

More inline:

> Would you consider the decision whether the list contents are included in the request sent by the application server as application logic, or should this be explicitely signaled by the original sen…

Assuming you actually mean should we standardize whether the app server 
copies the list into the resulting "exploded" requests, I think it has 
to be taken on a case by case basis based on the semantics of the 
"exploder" application. For example, it may make sense to signal the 
choice if exploding MESSAGE, but I can't think of any use for doing that 
for SUBSCRIBE.

That does not mean that we cannot standardize specific applications.

---

From: Ben Campbell <[email-masked]>
Date: Wed, 12 Nov 2003 21:22:09 -0600

More inline: