Subject: RE: [Simple] Comments on message-sessions-02

From: [email-masked]
Date: Wed, 12 Nov 2003 07:22:50 +0200

> -----Original Message-----
> From: ext Adam Roach [mailto:[email-masked]]
> Sent: Wednesday, November 12, 2003 12:12 AM
> To: Niemi Aki (NMP/Helsinki); Ben Campbell
> Cc: Adam Roach; Khartabil Hisham (NMP-MSW/Helsinki); [email-masked]
> Subject: RE: [Simple] Comments on message-sessions-02
> 
> 
> At the risk of beating a dead horse even more: I wasn't trying
> to make the point that MSRP should never be used for file
> transfer (although the purist in me still believes this to be
> "correct").
> 
> My point was that if you were going to initiate "a specific
> session" for file transfer and file transfer only (that is,
> no instant messages, just file transfer) as your mail seemed
> to be advocating, then you *are* using the wrong protocol.
> 
> More succinctly: there is no valid use case for labeling a
> session "file transfer only."

First, we agreed that in order not to block a conversation, a long message should be sent on a separate session. Then there was the concern that the other endpoint will start using that second session to send normal short messages. Hence I suggested that an endpoint can restrict what a session was used for using mime-types (accept-types).

Ben pointed to the problem that a message with mime type text/plain could still carry a very long text file. This is how the content-disposition discussion started. So, should content disposition be used in SDP to restrict the type of "things" that can be sent in an MSRP session? I think it's useful.

Regards,
Hisham

> 
> /a
> 
> > -----Original Message-----
> > From: Aki Niemi [mailto:[email-masked]]
> > Sent: Tuesday, November 11, 2003 13:22
> > To: ext Ben Campbell
> > Cc: ext Adam Roach; [email-masked]'; [email-masked]
> > Subject: Re: [Simple] Comments on message-sessions-02
> > 
> > 
> > Hi,
> > 
> > Perhaps I should also clarify my position. Clearly, if you 
> > are going to 
> > just do file transfer, there is no sense at all to start to develop 
> > something else but to use FTP.
> > 
> > But this is not the case here. We are developing MSRP to 
> > enable sending 
> > messages in a session, negotiating this in SIP/SDP, and 
> have tools to 
> > invoke relays for these sessions.
> > 
> > Now, it is also possible *and* useful to send files, or 
> things other 
> > than text/plain, in this session - at which point it becomes "file 
> > transfer". Please explain why this is bad practice just 
> because IETF 
> > already has another protocol to do "file transfer"?
> > 
> > It's not like we are re-developing TCP here. If we were, I'd 
> > share your 
> > concerns. As I understand it, in the hour-glass model of Internet, 
> > multiple application layer protocols that may even overlap in 
> > functionality is not a bad thing.
> > 
> > Cheers,
> > Aki
> > 
> > ext Ben Campbell wrote:
> > >  From section 5.1:
> > > 
> > > "An analysis of whether it makes sense to do this [file 
> transfer or 
> > > sending very large content], rather than sending such 
> > content over FTP, 
> > > HTTP, or some other such protocol, is beyond the scope of 
> > this document."
> > > 
> > > I originally took (and still agree with) Adam's position, 
> > but that is 
> > > clearly not the consensus of this group. (If I am 
> incorrect in that 
> > > belief, I would love to hear it as I could remove quite a 
> > bit of text.)
> > > 
> > > 
> > > Aki Niemi wrote:
> > > 
> > >>
> > >>
> > >> ext Adam Roach wrote:
> > >>
> > >>> Aki Niemi [mailto:[email-masked]] writes:
> > >>>
> > >>>
> > >>>> These are somewhat orthogonal aspects of a message 
> > session. It is 
> > >>>> probably useful to label a specific session as e.g., 
> > file-transfer
> > >>>
> > >>>
> > >>>
> > >>>
> > >>> Yes. You do this by using port 21. If you know a priori that all
> > >>> you are going to do is transfer files, the IETF has already
> > >>> defined a file transfer protocol.
> > >>
> > >>
> > >>
> > >> Right. And if you know a priori that all you are going to 
> > do is chat 
> > >> with the other party, then just use IRC. Great, we're done.
> > >>
> > >> Thanks,
> > >> Aki
> > >>
> > >>
> > >>> /a
> > > 
> > > 
> > > 
> > 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Wed, 12 Nov 2003 08:49:33 -0600

> Ben pointed to the problem that a message with mime type text/plain could still carry a very long text file. This is how the content-disposition discussion started. So, should content disposition b…

I think it could be useful, but it doesn't feel like the best semantic. 
Content-disposition really gives hints on what the receiver endpoint 
should do with a piece of content. It doesn't say anything about what an 
endpoint should send. Also, if we used the standard MIME syntax, it can 
be pretty complex to put into an sdp document. If we were to decide to 
label in the first place, I suspect we would have to invent something 
for it.

[...]

---

From: Ben Campbell <[email-masked]>
Date: Wed, 12 Nov 2003 08:49:33 -0600

[...]