Subject: RE: [Simple] Comments on message-sessions-02 - message retry

From: [email-masked]
Date: Wed, 10 Dec 2003 14:36:05 +0200

What was the outcome of this discussion? Are we supporting message retransmission?

Regards,
Hisham

> -----Original Message-----
> From: ext Chris Boulton [mailto:[email-masked]]
> Sent: 28.November.2003 18:56
> To: Ben Campbell; Paul Kyzivat
> Cc: Khartabil Hisham (NMP-MSW/Helsinki); [email-masked]
> Subject: RE: [Simple] Comments on message-sessions-02 - message retry
> 
> 
> 
> 
> >-----Original Message-----
> >From: Ben Campbell [mailto:[email-masked]]
> >Sent: 10 November 2003 17:09
> >To: Paul Kyzivat
> >Cc: [email-masked]; [email-masked]
> >Subject: Re: [Simple] Comments on message-sessions-02 - message retry
> >
> >Paul Kyzivat wrote:
> >
> >[...]
> >
> >>
> >> I'm not certain a time period is really necessary. I think this can
> be
> >> local option.
> >>
> >> Even uniqueness across streams isn't *required*, though it would be
> >> helpful. Instead, we can simply introduce an error response to be
> used
> >> when a duplicate is detected and supressed. If it was supressed in
> error
> >> because the sender duplicated a TR-ID from another stream, 
> the sender
> >> would then know to recover.
> >>
> >> But I agree that some further clarification on TR-ID 
> uniqueness could
> be
> >> helpful.
> >>
> >
> >If TR-ID is not required to be unique across sessions, and you allow
> >clients to attempt to find duplicate messages using TR-ID across
> >sessions, then you introduce the possibility of false 
> detection caused
> >by TR-ID collisions. This seems bad to me.
> >
> [Chris Boulton] I totally agree.
> 
> >
> >
> >_______________________________________________
> >Simple mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/simple
> >
> >_____________________________________________________________
> __________
> _
> >This email has been scanned for all viruses by the MessageLabs Email
> >Security System. For more information on a proactive email security
> >service working around the clock, around the globe, visit
> >http://www.messagelabs.com
> >_____________________________________________________________
> __________
> _
> 
> ______________________________________________________________
> __________
> This email has been scanned for all viruses by the MessageLabs Email
> Security System. For more information on a proactive email security
> service working around the clock, around the globe, visit
> http://www.messagelabs.com
> ______________________________________________________________
> __________
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Thu, 11 Dec 2003 11:05:07 -0600

> What was the outcome of this discussion? Are we supporting message retransmission?

I think we are agreed to not attempt retransmission on the same 
connection. We are also agreed that, when a connection fails, we must 
re-signal to create a new one.

I think we still need discussion on how to associate a new connection 
with the old, when both are associated with the same dialog, and how to 
deal with retrying any messages that may have failed on the old 
connection on an associated new connection.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 11 Dec 2003 11:05:07 -0600