Subject: RE: [Simple] MSRP: Some thoughts on session updates

From: [email-masked]
Date: Tue, 16 Dec 2003 18:14:21 +0200

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: 16.December.2003 18:05
> To: Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Simple] MSRP: Some thoughts on session updates
> 
> 
> [email-masked] wrote:
> [...]It can send an update without
> >>the passive 
> >>party first supplying a new URL. Basically, it works like this:
> >>
> >>Active                   Passive
> >>    new offer (no url)------->
> >>    <-----resp (may have URL)-
> >>
> >>So, when the active party sends an update, without a URL, 
> the passive 
> >>party may or may not send a new URL back. The active party cannot 
> >>prevent the passive party from doing so.
> > 
> > 
> > What would the active party do with this URL if it came in 
> the SDP answer from the passive party?
> > 
> 
> I think it would visit the new URL. (i.e. resolve the URL, connect, 
> visit, etc.) The interesting question to me is, if it thinks the old 
> connection is still good, does it disconnect from it? And if 
> so, does it 
> need to wait for the new visit to succeed first?

As I said in the previous email (I'm not sure if you read down that far :) The new offer sent by the active party will contain a new media line (m-line), the old m-line would have the port set to 0 disabling it. This is how the passive party knows that it needs to disconnect from the old one.

/Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Dec 2003 10:19:07 -0600

> As I said in the previous email (I'm not sure if you read down that far :) The new offer sent by the active party will contain a new media line (m-line), the old m-line would have the port set to 0…

Oops, sorry. My mail reader (thunderbird) seems to forget to put in the 
vertical scroll bar sometimes. And even when it does, sometimes I forget 
to notice :-)

---

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Dec 2003 10:19:07 -0600