Subject: RE: [Simple] MSRP: Some thoughts on session updates

From: [email-masked]
Date: Tue, 16 Dec 2003 17:36:47 +0200

Hi Ben,

I agree with what you state below.

Just to make sure I understand it correctly though, the restrictions for the active party to stay active and the passive to stay passive when updating do indeed also apply to adding another MSRP media component to an existing session?

Because, it makes little sense to repeat a "offer both-> try active and fail -> answer passive" sequence for each new MSRP component added to a session. This is an additional benefit we would get by the below restrictions, which is a good thing. Of course, this would not allow negotiating 'direction' per MSRP session inside a SIP dialog, but I don't see much use for that anyway.

Cheers,
Aki

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On 
 > Behalf Of
 > ext Ben Campbell
 > Sent: 15 December, 2003 23:20
 > To: Simple WG
 > Subject: [Simple] MSRP: Some thoughts on session updates
 > 
 > 
 > We have had a lot of discussion on how we deal with 
 > connection failures, 
 > session continuance across a failure, duplicate supression, 
 > etc. Much of 
 > that depends on how we handle session updates. Here are some 
 > thoughts 
 > for discussion.
 > 
 > Although the sense of the room at IETF58 indicated we needed 
 > a way to 
 > re-establish TCP connections without resignaling, subsequent list 
 > discussion has indicated consensus that this will not work, 
 > and we will 
 > indeed have to re-signal. I am slightly concerned that many 
 > of those who 
 > favored reconnection without resignaling at the meeting have not 
 > participated in the email thread. I must assume that means 
 > they agree ;-)
 > 
 > Obviously resignaling means a new SDP exchange. For SIP, 
 > that would mean 
 > a re-INVITE or an UPDATE. Since the MSRP spec only tangentally talks 
 > about sip, I think the re-INVITE vs UPDATE question is out 
 > of scope, and 
 > is treated sufficiently well in the UPDATE rfc.
 > 
 > So, here are some assumptions and observations about how an updated 
 > offer/answer would work.
 > 
 > 0) We don't have to worry about early media. (I expect this to be 
 > controversial, but I can always hope. The following are 
 > based on that 
 > assumption.)
 > 
 > 1) The active party must remain the active party. If the 
 > active party 
 > initiates an updated offer, it MUST NOT contain a session URL.
 > 
 > 2) The passive party must remain the passive party. If the 
 > passive party 
 > initates an updated offer, it MUST contain a session URL. 
 > This updated 
 > URL may be the same as before, or may be completely different, even 
 > pointing to a completely different location.
 > 
 > 3)If the passive party sends an updated offer with a semantically 
 > identical URL as the original, this indicates no change. (I 
 > don't know 
 > why you would do this, but Paul asked for an example of an 
 > update that 
 > changes nothing.) Interestingly, the active party _cannot_ send an 
 > updated without giving the active party a chance to provide a new 
 > session URL.
 > 
 > 4) A corrolary of 1) and 2) is that direction=both would not be 
 > permitted for an update.
 > 
 > 5) Updated offers can occur for both healthy sessions and as 
 > a result of 
 > connection failures, etc.
 > 
 > Thoughts?
 > 
 > Ben.
 > 
 > 
 > _______________________________________________
 > Simple mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/simple
 > 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Dec 2003 09:40:24 -0600

> Because, it makes little sense to repeat a "offer both-> try active and fail -> answer passive" sequence for each new MSRP component added to a session. This is an additional benefit we would get b…

I think I agree, as long as we are only talking about MSRP sessions. I 
don't think the direction of some other kind connection oriented media 
session would necessarily imply the direction for MSRP, but I think one 
MSRP session can definitely imply a direction for a second MSRP session.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Dec 2003 09:40:24 -0600