Subject: [Simple] SIMPLE implementations

From: "Toni Heinonen" <[email-masked]>
Date: Mon, 15 Dec 2003 18:51:54 +0200

Hello,

I saw a nice listing of general SIP implementations at http://www.sipcenter.com/vsts/vsts_clientsoft.html. However, I did not see any free instant messaging clients like ICQ or ms messenger. Can anyone point me to any PC desktop instant messaging software that uses SIMPLE or uses a proprietary protocol but is moving to SIMPLE? Preferably open source, but commercial products would be nice too.

Can anyone shed the light on why all the instant messaging clients are still using their own proprietary protocols instead of SIMPLE?

Regards,

-- 
Toni Heinonen
Teleware Oy
[email-masked]
+358 40 836 1815

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 17 Dec 2003 22:01:32 +0200

Hi Toni,

I think one reason is that SIMPLE currently does not offer a good enough interoperable feature set as completed standarsds (RFCs). For instance Nokia has implemented IM & presence in some of its phones based on Wireless Village technology, and that includes features such as private/block list settings for presence, sending IMs to multiple recipients etc. At the moment you can't do this kind of things with SIMPLE, unless you have proprietary parts in place for some of the core functionality.

SIMPLE is however working on most of these fronts: XCAP to take care of list and authorization policy maintenance, MSRP for sending messages/files within a session etc. (Even presence publishing is still unfinished but currently belongs to SIP WG). One important thing to fix also is more clear semantics for presence documents. With the current SIMPLE/IMPP specs good interoperability cannot be guaranteed.

Once these issues have been solved - which will still take at least 6 months - it is probable that more products will be switching to SIP/SIMPLE based protocols. The main reason is probably not that SIP is better than the others in IM & presence area, but that it can combine even other methods of communication, such as voice and video, to the service mix. The discussions ongoing on this list on how cumbersome it is to map user IDs from one protocol to another provide yet another reason why VoIP with SIP + IM/Presence with SIP is nicer than VoIP with SIP + IM/Presence with WV, XMPP etc.

Markus 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Toni Heinonen
> Sent: 15 December, 2003 18:52
> To: [email-masked]
> Subject: [Simple] SIMPLE implementations
> 
> 
> Hello,
> 
> I saw a nice listing of general SIP implementations at 
> http://www.sipcenter.com/vsts/vsts_clientsoft.html. However, 
> I did not see any free instant messaging clients like ICQ or 
> ms messenger. Can anyone point me to any PC desktop instant 
> messaging software that uses SIMPLE or uses a proprietary 
> protocol but is moving to SIMPLE? Preferably open source, but 
> commercial products would be nice too.
> 
> Can anyone shed the light on why all the instant messaging 
> clients are still using their own proprietary protocols 
> instead of SIMPLE?
> 
> Regards,
> 
> -- 
> Toni Heinonen
> Teleware Oy

---

From: [email-masked]
Date: Wed, 17 Dec 2003 22:01:32 +0200

Hi Toni,

Markus