Subject: [Simple] Question on XCAP-auth - multi-device use case

From: [email-masked]
Date: Thu, 4 Dec 2003 01:02:27 +0200

Hi,

I have a question on xcap-auth usage in case that the presentity has multiple devices that publish presence information. 

Here's the use case:
User has two devices that publish presence tuples related to the same application or communication mean (e.g. MMS). The user would like to give this information (from both devices) only to a group of watchers. 

In the current xcap-auth there is only one content permission element that can be used to select tuples, i.e. show-tuple which is based on RPID class element:
---
   show-tuple: This permission specifies that the identified tuples can
      be sent to the watcher. The element has no attributes. Its content
      is a string that matches the "class" element present within the
      tuple [12].
---
RPID defines class as an opaque identifier without any semantics.

If the user is using one of his devices to make this configuration, he can basically use the right class values regarding the tuples in _that_ device. However, as the other device may use whatever classes, the user can't determine the correct settings for xcap-auth.

If both devices came from the same vendor the class names for MMS could be fixed, but if they come from different vendors, there's no specification about that. Also, some tuples could come from entities that the presentity has no control over, such as the MMS server.

So, my question is that is it possible at all to authorize tuples coming from another device than the one updating xcap-auth doc?

Wouldn't it make sense to be able to authorize tuples based on something else than class too, e.g. contact? Actually the contact URI scheme based authorization would work in the use case given above. Would it be possible to extend show-tuple with limited regexp matching with contact, i.e. something like:
Show tuple if "contact" matches to "mmsto:*"

Another possibility would be to define some application labels to RPID, even though it is not sure how this would work for more complex apps than SMS, MMS or e-mail, which are readily identifiable from the contact URI scheme.

Markus  

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Thu, 4 Dec 2003 13:29:57 +0200

Markus,

I basically agree with you. In filtering, we use conditions using xpath like expressions. So for xcap-auth, it would look something like:

<show-tuple>//class=MMS</show-tuple>

This enables any kind of conditional inclusion of a tuple, not limited to class.

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext [email-masked]
> Sent: 04.December.2003 01:02
> To: [email-masked]
> Subject: [Simple] Question on XCAP-auth - multi-device use case
> 
> 
> Hi,
> 
> I have a question on xcap-auth usage in case that the 
> presentity has multiple devices that publish presence information. 
> 
> Here's the use case:
> User has two devices that publish presence tuples related to 
> the same application or communication mean (e.g. MMS). The 
> user would like to give this information (from both devices) 
> only to a group of watchers. 
> 
> In the current xcap-auth there is only one content permission 
> element that can be used to select tuples, i.e. show-tuple 
> which is based on RPID class element:
> ---
> If the user is using one of his devices to make this 
> configuration, he can basically use the right class values 
> regarding the tuples in _that_ device. However, as the other 
> device may use whatever classes, the user can't determine the 
> correct settings for xcap-auth.
> 
> If both devices came from the same vendor the class names for 
> MMS could be fixed, but if they come from different vendors, 
> there's no specification about that. Also, some tuples could 
> come from entities that the presentity has no control over, 
> such as the MMS server.
> 
> So, my question is that is it possible at all to authorize 
> tuples coming from another device than the one updating xcap-auth doc?
> 
> Wouldn't it make sense to be able to authorize tuples based 
> on something else than class too, e.g. contact? Actually the 
> contact URI scheme based authorization would work in the use 
> case given above. Would it be possible to extend show-tuple 
> with limited regexp matching with contact, i.e. something like:
> Another possibility would be to define some application 
> labels to RPID, even though it is not sure how this would 
> work for more complex apps than SMS, MMS or e-mail, which are 
> readily identifiable from the contact URI scheme.
> 
> Markus  
>

---

From: [email-masked]
Date: Thu, 4 Dec 2003 13:29:57 +0200

Markus,

Regards,
Hisham