Subject: RE: [Simple] RE: [xmppwg] RE: Action Item: character mappings for interoperabi lity

From: Joe Hildebrand <[email-masked]>
Date: Wed, 17 Dec 2003 12:20:33 -0700

Do you feel the same way about im: as sip:?

-- 
Joe Hildebrand

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]] 
> Sent: Wednesday, December 17, 2003 12:03 PM
> To: Joe Hildebrand
> Cc: [email-masked]'; [email-masked]'
> Subject: Re: [Simple] RE: [xmppwg] RE: Action Item: character 
> mappings for interoperabi lity
> 
> Joe Hildebrand wrote:
> 
> > You're right, that's our disconnect.  I hadn't even considered that.
> > 
> > Can you give me a concrete use case where I might want 
> > sip:[email-masked] and im:[email-masked] to point to 
> > different entities?  I can see the messages and presences 
> addressed to 
> > the two following different paths, perhaps using different 
> protocols, 
> > but I can't imagine a non-contrived reason for them going to 
> > completely different endpoints, or being for completely 
> different system entities.
> > 
> > In other words, it might be nice for completeness, but if 
> it adds mad 
> > complexity, and no one will ever use it, is it worth the effort?
> > 
> 
> Let me take another angle at this. JIDs and and the "sip:" 
> scheme designate  two different name spaces, even if they are 
> resolved at the same domain. One domain _might_ choose to 
> synchronize them. But another domain might have two 
> completely distinct user sets between the two namespaces. 
> There is no requirement the two services be related in any 
> way. For example, an ISP might have some SIP users and some 
> XMPP users, where the sets are not identical. Furthermore, 
> the same user part could exist in both sets, but refer to 
> different people.
> 
> For example, HypotheticalISP.com might let its users sign up 
> for an xmpp service and/or a simple service. Furthermore, it 
> might let those users choose their user id for that service 
> on a first come first serve basis. 
> So, I might sign up for the jid of 
> [email-masked]. I later sign up for simple, 
> and find out some other person with the same name already has 
> "sip:[email-masked]" So, instead, I get 
> "sip:[email-masked]"
> 
> I don't think the standards can assume that services are synchronized.
> 
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Alan Johnston <[email-masked]>
Date: Wed, 17 Dec 2003 18:46:12 -0600

>Do you feel the same way about im: as sip:?

Of course - they are different URI schemes.

This is why SIP uses URIs and why even H.323 has moved towards the use of 
URIs instead of just identifiers.  As a result, the interworking of SIP and 
H.323 is quite straightforward - a SIP request can be sent with an H.323 
URI as the target - a proxy receiving such a request would locate a 
SIP/H.323 interworking function and forward.  The same thing in the H.323 
domain - if the resource was a SIP URI, the gatekeeper would attempt to 
locate a suitable gateway.

SIP also has responses to indicate that a particular URI scheme is not 
understood, allowing extensibility in the definition of new URI schemes in 
the future.

Most Internet protocols use URIs for these reasons.  Completely avoids all 
the ugly issues of namespace/character mappings and conventions.

Thanks,
Alan Johnston
MCI
sip:[email-masked]

---

From: Alan Johnston <[email-masked]>
Date: Wed, 17 Dec 2003 18:46:12 -0600

Thanks,
Alan Johnston
MCI
sip:[email-masked]

---

From: Ben Campbell <[email-masked]>
Date: Thu, 18 Dec 2003 12:55:15 -0600

> Do you feel the same way about im: as sip:?

If the question is, do I think that the im: scheme and the JID space are 
separate namespaces, where you cannot assume a simple string mapping 
between them, then yes.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 18 Dec 2003 12:55:15 -0600