Subject: RE: [Simple] RE: [xmppwg] Action Item: character mappings for int eroperability

From: Adam Roach <[email-masked]>
Date: Mon, 15 Dec 2003 16:28:07 -0600

Ben Campbell [mailto:[email-masked]] wrote:

> > We've already discussed how the first would work; that's easy.
> > The scheme to use in translation is a matter of the destination
> > server configuration, potentially selected on a user-by-user
> > basis.
> 
> I'm not sure I agree on this. As you mention above, even if 
> dynamicsoft.com maintains an xmpp to simple gateway, there is 
> no reason to expect that you can infer an identifier that makes
> sense to the xmpp side of the gateway from a SIP URI. If
> dynamicsoft maintains such a gateway, then it would make more
> sense to advertise an xmpp identity in addition to the SIP
> identity...

That was what I was assuming, and what I meant by the mapping being
at the gateway's discretion (because it "owns" the namespace). For
example, such a gateway could certainly decide to translate the JID
"[email-masked]" to "sip:[email-masked]" if it so
chose.

The objection you're raising -- that you couldn't then pass out
a single identifier -- is one reason I called it an incomplete
solution. (The other objection is that it *requires* the destination
domain to run an XMPP server in order to work).

I described this model primarily because it was the *only* model
that was supported by Joe's proposed mappings.

The larger point I was trying to raise is that you can't really
come up with a syntactic mapping from JIDs to external systems
unless you have a context in which to evaluate the mapping.

/a

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Adam Roach <[email-masked]>
Date: Mon, 15 Dec 2003 16:28:07 -0600

/a

---

From: Adam Roach <[email-masked]>
Date: Mon, 15 Dec 2003 16:48:13 -0600

Ben Campbell wrote:

> I wonder (vaguely) if draft-daigle-napstr-03.txt is applicable here. 

It's part of the solution space, but only one of the three
configurations I mentioned. It's more elegant than what I
described, but it is still a solution to the easy part of the
problem -- that is, the cast in which the destination determines
how translation occurs.

/a

---

From: Adam Roach <[email-masked]>
Date: Mon, 15 Dec 2003 16:48:13 -0600

/a

---

From: Joe Hildebrand <[email-masked]>
Date: Mon, 15 Dec 2003 17:27:16 -0700

> The objection you're raising -- that you couldn't then pass 
> out a single identifier -- is one reason I called it an 
> incomplete solution. (The other objection is that it 
> *requires* the destination domain to run an XMPP server in 
> order to work).

I'm hoping my other mail addressed this.  I'm not sure why I'd have to have
the destination domain running an XMPP server.

If the originating XMPP server can do the SRV dance, and finds out that the
destination server supports SIMPLE but not XMPP, that's when the jid->im:
translation takes place.

If you want to pass out a single identifer, feel free to pass out
im:foo@bar, if that's your thing, and you're an English speaker.  XMPP folks
(or their UAs) will learn to strip of the im:, just like people strip off
the mailto: today.  I'm not sure what to suggest to you if your username
isn't US-ASCII.  You could give out either the unencoded version (which
should be easier to type, as long as you only deal with people in your
language camp), or the encoded version, which would be really ugly, or both,
which seems like overkill.

-- 
Joe Hildebrand

---

From: Joe Hildebrand <[email-masked]>
Date: Mon, 15 Dec 2003 17:27:16 -0700

-- 
Joe Hildebrand