Subject: RE: [Simple] filter attribute question

From: [email-masked]
Date: Mon, 22 Dec 2003 17:12:14 +0200

If the element in question is measurable in units (eg: seconds), then the subscriber can filter using changed-by without needing to know the previous value. eg: send me a notification if the value of element x has changed by m.

Changed-from and changed-to can also be used for elements whose value is measurable in units. eg: send me a notification if the value of element x has changed from m to n. In this case, you are explicitly stating the value before and after. With changed-by, you are stating the delta.

Changed-to is also usable for elements that are not measured in units. eg: send me notification if the value of element x has changed to xyz (from abc).

Hope this helps.
Hisham

> -----Original Message-----
> From: ext Ashir Ahmed [mailto:[email-masked]]
> Sent: 22.December.2003 14:57
> To: Ashir Ahmed; Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Simple] filter attribute question
> 
> 
> Sorry the question was:
> what is the difference between "changed-to" and "changed-by" 
> attribute?
> 
> ----- Original Message ----- 
> From: "Ashir Ahmed" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, December 22, 2003 9:50 PM
> Subject: [Simple] filter attribute question
> 
> 
> > what is the difference between "changed-from" and 
> "changed-to" attribute
> in
> > the <changed> element in 
> draft-khartabil-simple-filter-format-00.txt doc?
> > Can someone provide an example?
> >
> > Ashir
> >
> >
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 22 Dec 2003 17:12:14 +0200

Hope this helps.
Hisham