Subject: [Simple] XCAP: what does in the 200 of a PUT request

From: [email-masked]
Date: Thu, 11 Dec 2003 11:42:18 +0200

This is not clear in XCAP. I also check RFC2616 to find out some sort of answer, but it is not clear there either.

Should the 200 (or 201 for that matter) contain the contents the were PUT? If so, does it include the resource interdependencies (like the resource list URI in the list case)?

If no, does that mean the client needs to follow the PUT with a GET to learn of the resource interdependencies?

Thanks,
Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ted Hardie <[email-masked]>
Date: Thu, 11 Dec 2003 10:49:31 -0800

>This is not clear in XCAP. I also check RFC2616 to find out some sort of answer, but it is not clear there either.

The 200 response doesn't require a response body for HTTP.  You can define
a response body appropriate for a specific method  (Julian Reschke has
a webdav-related example in his draft for checkin; a uri for that is:
http://www.greenbytes.de/tech/webdav/draft-reschke-deltav-compute-checkin-uri-01.html)
For PUT, though, you should probably be able to handle getting a bare 200 response (see
section 9.6 of RFC 2616.)

Or am I misunderstanding your question?
				regards,	
					Ted Hardie

---

From: Ted Hardie <[email-masked]>
Date: Thu, 11 Dec 2003 10:49:31 -0800