Subject: RE: [Simple] RE: [xmppwg] RE: Action Item: character mappings for interoperabi lity

From: [email-masked]
Date: Thu, 18 Dec 2003 10:54:38 +0200

Although I agree with Adam and others, I would like to point out that people usually try to make guesses about other people's sip addresses using their email addresses. So, if my email is [email-masked], people using SIP would assume that my sip address is the same [email-masked]. People using XMPP would assume that my JID looks the same, and so on.

Therefore I think it is in the service providers' interest that they don't allow different people to have the same URI but with different scheme. I see some security and confidentiality concenrs here. Some one might wronly assume that I have a JID that looks the same as my sip address and end up sending someone else a message that says "Nokia is planning on ...".

So, having said that, is it really worth spending the time on trying to get this working when it will not be used?

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Ben Campbell
> Sent: 17.December.2003 21:03
> To: Joe Hildebrand
> Cc: [email-masked]'; [email-masked]'
> Subject: Re: [Simple] RE: [xmppwg] RE: Action Item: character mappings
> for interoperabi lity
> 
> 
> Joe Hildebrand wrote:
> 
> > You're right, that's our disconnect.  I hadn't even considered that.
> > 
> > Can you give me a concrete use case where I might want
> > sip:[email-masked] and im:[email-masked] to 
> point to different
> > entities?  I can see the messages and presences addressed to the two
> > following different paths, perhaps using different 
> protocols, but I can't
> > imagine a non-contrived reason for them going to completely 
> different
> > endpoints, or being for completely different system entities.
> > 
> > In other words, it might be nice for completeness, but if 
> it adds mad
> > complexity, and no one will ever use it, is it worth the effort?
> > 
> 
> Let me take another angle at this. JIDs and and the "sip:" scheme 
> designate  two different name spaces, even if they are 
> resolved at the 
> same domain. One domain _might_ choose to synchronize them. 
> But another 
> domain might have two completely distinct user sets between the two 
> namespaces. There is no requirement the two services be 
> related in any 
> way. For example, an ISP might have some SIP users and some 
> XMPP users, 
> where the sets are not identical. Furthermore, the same user 
> part could 
> exist in both sets, but refer to different people.
> 
> For example, HypotheticalISP.com might let its users sign up 
> for an xmpp 
> service and/or a simple service. Furthermore, it might let 
> those users 
> choose their user id for that service on a first come first 
> serve basis. 
> So, I might sign up for the jid of 
> [email-masked]. I 
> later sign up for simple, and find out some other person with 
> the same 
> name already has "sip:[email-masked]" So, 
> instead, I 
> get "sip:[email-masked]"
> 
> I don't think the standards can assume that services are synchronized.
> 
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Thu, 18 Dec 2003 09:52:13 -0600

> So, having said that, is it really worth spending the time on trying to get this working when it will not be used?

It is not our place to specify provider namespace policy. At best, one 
might have a bcp for this sort of thing, but _never_ a standard. And if 
we were to make such namespace assumption, where do you stop? Would we 
also want to say that if I have a JID of [email-masked], and 
a SIP URI of sip:[email-masked] I must also have a web page 
at HTTP://www.dynamicsoft.com/~bcampbell?

So, we have a mechanism to map from an abstract scheme (pres: or im:) to 
a concrete one. I think we need to either further specify how two 
interoperable concrete systems should use the abstract schema, or we 
need to specify how to map between the two concrete systems, without 
making assumptions about synchronized identifiers.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 18 Dec 2003 09:52:13 -0600

---

From: "Ashir Ahmed" <[email-masked]>
Date: Mon, 22 Dec 2003 21:50:56 +0900

what is the difference between "changed-from" and "changed-to" attribute in
the <changed> element in draft-khartabil-simple-filter-format-00.txt doc?
Can someone provide an example?

Ashir

---

From: "Ashir Ahmed" <[email-masked]>
Date: Mon, 22 Dec 2003 21:50:56 +0900

Ashir

---

From: "Ashir Ahmed" <[email-masked]>
Date: Mon, 22 Dec 2003 21:56:57 +0900

Sorry the question was:
what is the difference between "changed-to" and "changed-by" attribute?

---

From: "Ashir Ahmed" <[email-masked]>
Date: Mon, 22 Dec 2003 21:56:57 +0900

Sorry the question was: