Subject: RE: [Simple] XCAP: what does in the 200 of a PUT request

From: [email-masked]
Date: Thu, 11 Dec 2003 11:56:38 +0200

of course the question was: What goes in the body of a 200 response of a PUT request? 

Apologies for the lack of clarity in the first post.

/Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext [email-masked]
> Sent: 11.December.2003 11:42
> To: [email-masked]
> Subject: [Simple] XCAP: what does in the 200 of a PUT request
> 
> 
> This is not clear in XCAP. I also check RFC2616 to find out 
> some sort of answer, but it is not clear there either.
> 
> Should the 200 (or 201 for that matter) contain the contents 
> the were PUT? If so, does it include the resource 
> interdependencies (like the resource list URI in the list case)?
> 
> If no, does that mean the client needs to follow the PUT with 
> a GET to learn of the resource interdependencies?
> 
> Thanks,
> Hisham
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Dec 2003 08:55:58 -0500

I was also unable to find any text on this subject in RFC2616. It was 
always my underestanding that the PUT 200 OK response had no body. If 
any of our http experts could provide a more authoritative answer, it 
would be welcome.

Thanks,
Jonathan R.

[email-masked] wrote:

>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]]On Behalf Of ext
>> [email-masked] Sent: 11.December.2003 11:42 To:
>> [email-masked] Subject: [Simple] XCAP: what does in the 200 of a
>> PUT request
>> 
>> 
>> This is not clear in XCAP. I also check RFC2616 to find out some
>> sort of answer, but it is not clear there either.
>> 
>> Should the 200 (or 201 for that matter) contain the contents the
>> were PUT? If so, does it include the resource interdependencies
>> (like the resource list URI in the list case)?
>> 
>> If no, does that mean the client needs to follow the PUT with a
>> GET to learn of the resource interdependencies?
>> 
>> Thanks, Hisham
>> 
>> _______________________________________________ Simple mailing
>> list [email-masked] 
> _______________________________________________ Simple mailing list
>  [email-masked] https://www1.ietf.org/mailman/listinfo/simple
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Dec 2003 08:55:58 -0500

Thanks,
Jonathan R.