Subject: Re: [Simple] xcap/geopriv alignment issue 7: actions and transformations

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 02 Dec 2003 15:06:36 -0500

I will go ahead and add this to the next rev of the spec.

Thanks,
Jonathan R.

Ben Campbell wrote:

> Jonathan Rosenberg wrote:
> 
>> Folks,
>>
>> In the current xcap-auth document, the spec describes two different 
>> types of permissions. These are "acceptance" permissions and "content" 
>> permissions. The former are permissions about who can or cannot 
>> subscribe in the first place. The latter are permissions about what 
>> they will see when they do subscribe.
>>
>> In geopriv, they instead have "actions" and "transformations". The 
>> actions are things to do  - accept a subscription, confirm a 
>> subscription. Other possible actions in the future might be to log the 
>> event, send an IM, etc. Then "transformations" specify operations on 
>> the data that the watcher will receive. This is equivalent to what we 
>> call content permissions.
>>
>> The geopriv document separates these types of elements within the 
>> document through an enclosing "actions" and "transformations" tag. In 
>> xcap-auth, its flat, and no syntactic distinction is made between the 
>> two types.
>>
>> I would propose we adopt the geopriv terminology and xml syntax. Using 
>> the syntax has the benefit that, with the xcap protocol, you could 
>> change all of the actions or all of the transformations in one 
>> operation. The terminology is apparently more consistent with other 
>> policy languages that exist.
>>
>> As an example of what this change would mean, here is a document in 
>> the current xcap-auth format:
>>
>> <applies-to>
>>   <uri>sip:[email-masked]</uri>
>> </applies-to>
>>
>> <accept/>
>> <show-namespace>rpid</show-namespace>
>>
>>
>> and with this change, would look like:
>>
>> <applies-to>
>>   <uri>sip:[email-masked]</uri>
>> </applies-to>
>>
>> <actions>
>>   <accept/>
>> </actions>
>>
>> <transformations>
>>   <show-namespace>rpid</show-namespace>
>> </transformations>
> 
> 
> This sounds reasonable to me. It seems to future-proof things a little 
> better than the original xcap-auth syntax.
> 
>>
>>
>> Thanks,
>> Jonathan R.
>>
>>
> 
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 02 Dec 2003 15:06:36 -0500

Thanks,
Jonathan R.