Subject: RE: [Simple] Update to xcap package

From: [email-masked]
Date: Tue, 17 Feb 2004 11:56:22 +0200

I'm not sure if this is the most efficient though. I would go for a combination of all three: The first NOTIFY returns the full document with an etag, subsequent NOTIFYs return changes along with the new etag.

Filters can be used to get etags only.

/Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Chris Boulton
> Sent: 17.February.2004 10:49
> To: Jonathan Rosenberg; Simple WG
> Subject: RE: [Simple] Update to xcap package
> 
> 
> Jonathan - just so I've got a clear picture ;-)  With option 
> 3, you are
> proposing that a user is only notified that a document has changed But
> NOT what has changed - this would then be retrieved as required using
> XCAP operations(GET).  If this is the case, it certainly seems the
> cleanest and less problematic solution.
> 
> Chris.
> 
> >-----Original Message-----
> >From: Jonathan Rosenberg [mailto:[email-masked]]
> >Sent: 16 February 2004 22:32
> >To: Simple WG
> >Subject: [Simple] Update to xcap package
> >
> >Folks,
> >
> >I've submitted a revision to the xcap event package. Until it appears
> in
> >the archives, you can pick it up at:
> >
> >http://www.jdrosen.net/papers/draft-ietf-simple-xcap-package-01.txt
> >
> >The changes from the last version:
> >
> >1. Notifications contain the before and after etags
> >
> >2. Inclusion of the schema
> >
> >3. defined a mechanism for subscribing to documents in the 
> global tree
> >- define a well known user name to subscribe to.
> >
> >4. changed MIME type of change documents to use +xml 
> convention in rfc
> >3023.
> >
> >
> >There are really two major open issues.
> >
> >The first is alignment with the config framework. Indeed, there has
> been
> >some attempt at some alignment, and this will be reflected in the
> config
> >framework revision that is pending. With documents in place, 
> we will be
> >able to have a look at how it might look so a decision can be made
> >shortly. I am personally on the fence on this topic.
> >
> >The second open issue is, what is the scope of this event 
> package. That
> >is, what is it that you are subscribing to? There are three possible
> >things:
> >
> >The first is that subscription is to the document itself, in 
> which case
> >a full state update in a NOTIFY contains the current document. The
> >second is a subscription to the revision history, which gives you
> >changes, but not the full state of the document. The third 
> option is to
> >just subscribe to the etag, so that you know that something changed,
> but
> >the notifications don't tell you anything about what 
> changed. Which do
> >we need? The latter is the simplest, good for the case where third
> >party modification of documents is rare. If xcap is utilized in the
> >scope for which it was proposed - management of a user's provisioned
> >data, I do believe these events would be rare, and that this would be
> >the ideal design choice. As such, my own preference would be to do
> that.
> >
> >Thoughts?
> >
> >-Jonathan R.
> >--
> >Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> >Chief Technology Officer                    Parsippany, NJ 07054-2711
> >dynamicsoft
> >[email-masked]                     FAX:   (973) 952-5050
> >http://www.jdrosen.net                      PHONE: (973) 952-5000
> >http://www.dynamicsoft.com
> >
> >_______________________________________________
> >Simple mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/simple
> 
> 
> This message has been scanned for viruses by MailControl - 
www.mailcontrol.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 17 Feb 2004 16:50:31 -0500

[email-masked] wrote:

> I'm not sure if this is the most efficient though. I would go for a
> combination of all three: The first NOTIFY returns the full document
> with an etag, subsequent NOTIFYs return changes along with the new
> etag.
> 

Sorry to not be clear; this is exactly proposal 1. I wasnt saying
that proposal one DOESNT include etag, it would also include it.

I think the choice is driven largely by use case. If we expect that it 
is infrequent for anyone else but a user to update their own content, 
then option 3 is the right choice. Hisham - can you comment on the use 
cases that you think will make this efficiency important?

Thanks,
Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 17 Feb 2004 16:50:31 -0500

Thanks,
Jonathan R.