Subject: [Simple] I-D ACTION:draft-ietf-simple-prescaps-ext-00.txt

From: [email-masked]
Date: Mon, 09 Feb 2004 16:22:15 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the SIP for Instant Messaging and Presence Leveraging Extensions Working Group of the IETF.

	Title		: User agent capability presence status extension
	Author(s)	: M. Lonnfors, K. Kiss
	Filename	: draft-ietf-simple-prescaps-ext-00.txt
	Pages		: 28
	Date		: 2004-2-9
	
Interoperation of Instant Messaging and Presence systems has been
defined in IMPP working group. IMPP WG has come up with baseline
interoperable operations and formats for presence and instant   messaging systems. However, these base formats might need standardized extensions in order to enable building rational applications using presence and instant messaging. This memo proposes an extension to PIDF presence document format to represent

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-simple-prescaps-ext-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-simple-prescaps-ext-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-simple-prescaps-ext-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: [email-masked]
Date: Mon, 16 Feb 2004 12:58:06 +0200

Hi,

Here is the list of changes that have been made to prescaps:

- Added negated attribute to all elements where it makes sense.
Current version has a bug is sections where it describes how 'negated'
attribute is used. So when reading current text: 
"Value 'true' indicates that device supports audio media type and value
'false' indicates that device does not support audio media type as
defined in [6]" 
please replace 'true' with false and 'false' with true.

Example:
<prescaps>
	<text negated="true"/>
</prescaps>

- <type> elements can now be used inside media feature tags (<audio>,
<video>, ...) to list all supported media types. Current draft does not
allow use of <type> outside these elements but I think it makes sense to
also allow that.

Example:
<prescaps>
	<audio>
		<type>audio/gsm</type>
   	      <type>audio/amr-wb</type>		
	<text negated="true"/>
</prescaps>

- Added 'list' elements to <methods>, <extensions>, <schemas>, and
<languages> elements.

Example:
<prescaps>
	<ext:methods>
   		<method>INVITE</method>
   	      <method>MESSAGE</method>
   	      <method>ACK</method>
   	      <method>BYE</method>
   	      <method>CANCEL</method>
   	      <method negated="true">REFER</method>
   	</methods>
</prescaps>

- Added extension elements: <string>, <token>, <numeric>, and <boolean>.

Example:
<prescaps>
	<string name="myString" negated="false">myvalue</string>
</prescaps>

- Mikko

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of ext [email-masked]
> Sent: Monday, February 09, 2004 11:22 PM
> Cc: [email-masked]
> Subject: [Simple] I-D ACTION:draft-ietf-simple-prescaps-ext-00.txt
> 
> 
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories. This draft is a work item of the 
> SIP for Instant Messaging and Presence Leveraging Extensions 
> Working Group of the IETF.
> 
> Interoperation of Instant Messaging and Presence systems has
> been defined in IMPP working group. IMPP WG has come up with baseline
> interoperable operations and formats for presence and instant 
>   messaging systems. However, these base formats might need 
> standardized extensions in order to enable building rational 
> applications using presence and instant messaging. This memo 
> proposes an extension to PIDF presence document format to represent
> 

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the
message.

Internet-Drafts are also available by anonymous FTP. Login with the
username "anonymous" and a password of your e-mail address. After
logging in, type "cd internet-drafts" and then
	"get draft-ietf-simple-prescaps-ext-00.txt".

Send a message to:
	[email-masked].
In the body type:
	
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 16 Feb 2004 12:58:06 +0200

Hi,

Example:
<prescaps>
	<text negated="true"/>
</prescaps>

Example:
<prescaps>
	<audio>
		<type>audio/gsm</type>

Example:
<prescaps>
	<ext:methods>
   		<method>INVITE</method>
   	      <method>MESSAGE</method>
   	      <method>ACK</method>
   	      <method>BYE</method>
   	      <method>CANCEL</method>

Example:
<prescaps>

- Mikko

Send a message to:
	[email-masked].
In the body type: