Subject: RE: [Simple] RE: Advanced IM requirements

From: "Chris Boulton" <[email-masked]>
Date: Wed, 25 Feb 2004 16:09:37 -0000

1. it placed the URI for sending the delivery notification as a CPIM
header, not a SIP header

<<CJB>> Out of interest, what was the driving force for this design choice?

2. It used the existing email delivery status notification.

<<CJB>> A new XML schema was chosen as it allowed extensibility.  As mentioned before this is an early version of this 
work and the plan is to make it as generic as possible - This will be discussed in Korea.  That way implementors could use
it as a framework and extend if required.

These, I think, represent the main design choices for such an extension.

-Jonathan R.

--
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

This message has been scanned for viruses by MailControl - www.mailcontrol.com
¢š™^™¨¥Šx%ŠËRŠjez'~Šà†Ûi³ÿðÃ
bz×è®æj)fjåŠËb�ú?²)©•

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 26 Feb 2004 01:50:46 -0500

> <<CJB>> Out of interest, what was the driving force for this design choice?

I believe the document talks a bit about this. It would make the 
mechanism applicable to any system that uses cpim, which would include 
IM sessions and in theory any other IMPP compliant IM protocol, though 
since XMPP is not using it there are practically none others.

Of course, Eric is the author of this and is better suited to answer the 
question.

-Jonathan R.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 26 Feb 2004 01:50:46 -0500

-Jonathan R.

---

From: Aki Niemi <[email-masked]>
Date: Thu, 26 Feb 2004 14:43:57 +0200

> since XMPP is not using it there are practically none others.

Perhaps that's a good sign that we should up a notch the place where 
MDNs are defined. In other words perhaps we should define the MDNs for 
SIP MESSAGE instead of message/cpim.

This would enable us to request/receive delivery reports without having 
to wrap content in message/cpim.

Cheers,
AKi

---

From: Aki Niemi <[email-masked]>
Date: Thu, 26 Feb 2004 14:43:57 +0200

Cheers,
AKi

---

From: Ben Campbell <[email-masked]>
Date: Fri, 27 Feb 2004 15:16:15 -0600

> to wrap content in message/cpim.

And it would make it harder to request delivery reports across gateways. 
Are CPIM routers all that expensive?

> 
> Cheers,
> AKi
> 
>> Of course, Eric is the author of this and is better suited to answer 
>> the question.
>>
>> -Jonathan R.
> 
>

---

From: Ben Campbell <[email-masked]>
Date: Fri, 27 Feb 2004 15:16:15 -0600

---

From: Ben Campbell <[email-masked]>
Date: Fri, 27 Feb 2004 16:02:07 -0600

Ben Campbell wrote:
>>> mechanism applicable to any system that uses cpim, which would 
>>> include IM sessions and in theory any other IMPP compliant IM 
>>> protocol, though since XMPP is not using it there are practically 
>>> none others.
>>
>>
>>
>> This would enable us to request/receive delivery reports without 
>> having to wrap content in message/cpim.
> 
> 

Uhm, I meant CPIM wrappers. Not routers. I am willing to believe that 
CPIM routers may be expensive.