Subject: RE: [Simple] XCAP questions

From: [email-masked]
Date: Tue, 10 Feb 2004 18:03:01 +0200

Hi,

For practical use of XCAP I think case 1. below is very important, without it XCAP falls short from the practical requirements. The requirement is basically that the user should be able to determine which XCAP-manipulateable resources he has under which application usage. Without this, there will be difficulties when the client looses state or the user switches to some other client device. 

I think it would be sufficient to be able to do this per application usage. Is it possible to define a (XML) response payload for HTTP GET done for the application usage directory URI, which would include the resources under that directory/usage?

Markus

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Jari Urpalainen
> Sent: 29 January, 2004 12:22
> To: [email-masked]
> Subject: [Simple] XCAP questions
> 
> 
> Hi !
> 
> I have been developing a reference implementation for XCAP server 
> (standalone and an Apache module).  There are some 
> open/unclear issues 
> (to me at least),  so here's the list of questions.
> 
> 1. XCAP directory list
> In XCAP presence auth draft chapter 4.4, there's a requirement to get 
> all documents from the server. However, in the base XCAP draft it is 
> unspecified how the server should send this directory list. While 
> http-servers can/will provide this information in many ways, IMO the 
> base XCAP draft should specify this format (xml?). 
> Furhermore, it would 
> be nice if ETags were included in the response in order to help to 
> synchonize documents between the client and the server.
> 
> 2. XCAP ETags
> In order to ease the synchronizing within resources between 
> client and 
> server the base XCAP draft could specify the secure hash method e.g. 
> SHA-1 or whatever that is used to calculate the ETag. This is already 
> proposed in xcap-package but IMHO could be in the base spec.
> 
> 3. XCAP attributes
> When updating/querying attributes is it necessary to include 
> attribute 
> name in payload as attribute name is already provided in XPATH-query ?
> 
> e.g. you could get /resource-lists/list[@name="friends"]/@uri
> so you already know that you receive response for attribute uri. IMHO 
> when putting/getting attributes, payload could include only 
> attribute value.
> 
> 4. XCAP namespace declarations
> As namespace handling resemble "standard" XML attributes is it also 
> allowed to change namespace declarations with similar semantics ?
> 
> BR,
> Jari Urpalainen
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Ashir Ahmed" <[email-masked]>
Date: Fri, 20 Feb 2004 20:37:50 +0900

Folks,

I submitted a draft entitled "draft-ashir-simple-message-guideline-00.txt".
However, I have extensively revised it and therefore, ask you to refer to
this updated version which can be found at

http://www.softfront.co.jp/tech/ietfdoc/draft/draft-ashir-simple-message-guideline-01.txt

You will also find it attached to the email.

Thanks.
Ashir

---------------------

a.. To: IETF-Announce: ;
a.. Subject: I-D ACTION:draft-ashir-simple-message-guideline-00.txt
a.. From: Internet-Drafts at ietf.org
a.. Date: Wed, 11 Feb 2004 15:46:45 -0500
a.. Reply-to: Internet-Drafts at ietf.org
a.. Sender: owner-ietf-announce at ietf.org
A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: A guideline on message headers and URI in SIP/SIMPLE framework
	Author(s)	: A. Ahmed
	Filename	: draft-ashir-simple-message-guideline-00.txt
	Pages		: 14
	Date		: 2004-2-11

SUBSCRIBE, NOTIFY and PUBLISH methods in SIP are responsible for
carrying presence information to a target destination. Message headers
(Request-line, To, From, Contact etc.) indicate SIP entities that are
identified by a URI.  This document clarifies the indication of the
message headers and provides a guideline on URI usage in the header
fields. The authors hope that this document will be useful for
SIP/SIMPLE implementers, interoperability testers, designers, and
protocol researchers.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ashir-simple-message-guideline-00.txt

To remove yourself from the IETF Announcement list, send a message to
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ashir-simple-message-guideline-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ashir-simple-message-guideline-00.txt".

NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
<ftp://ftp.ietf.org/internet-drafts/draft-ashir-simple-message-guideline-00.
txt>

---

From: "Ashir Ahmed" <[email-masked]>
Date: Fri, 20 Feb 2004 20:37:50 +0900

Folks,

Thanks.
Ashir

---------------------

a.. To: IETF-Announce: ;

Send a message to:
	[email-masked].
In the body type: