Subject: RE: [Simple] Advanced IM Reqs: Delivery status reporting

From: "Chris Boulton" <[email-masked]>
Date: Wed, 25 Feb 2004 09:27:07 -0000

Comments in-line - <<CJB>>.

	-----Original Message----- 
	From: Vikas Tandon [mailto:[email-masked]] 
	Sent: Wed 25/02/2004 04:33 
	To: 'Vijay K. Gurbani'; [email-masked] 
	Cc: [email-masked]; Chris Boulton; [email-masked] 
	Subject: RE: [Simple] Advanced IM Reqs: Delivery status reporting

	Agree with Vijay on the storm of notifications. The delivery in case of
	page mode is ensured by the 200OK and in case of session is ensured by
	the session being valid.

	<<CJB>> The 200 OK indicates the completion of a transaction.  I don't see how this indicates the delviery

	of the MESSAGE to the required destination (e.g. your handset is turned off - the transaction would complete but the message would be delivered at a later date).

	 Identifying the case where the user has read
	the message or not is a debatable issue in case of IM as IM is typical
	useful in case where you are expecting instant communication,

	<<CJB>> This draft is initially refering to pager-mode, one off massaging.  I wouldn't expect an

	instance response to an SMS-style message. 

	 so u can
	very well assume that if the message has reached the target (ensured by
	the 200OK) and there is no response from the target, then either the
	target is away from the interface or is unwilling to respond at that
	time.

	<<CJB>> I disagree - based on previous comments.

	In case of group IM, this will become more complex.
	
	Regards,
	Vikas Tandon
	Arciis Software Technologies
	www.arciis.com

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] On Behalf Of
	Vijay K. Gurbani
	Sent: mercredi 25 février 2004 03:48
	To: [email-masked]
	Cc: [email-masked]; [email-masked]; [email-masked]
	Subject: Re: [Simple] Advanced IM Reqs: Delivery status reporting

	[email-masked] wrote:
	
	> I see use cases for both: report-on-failure and report-on-delivery.
	
	Problem with affirmitive delivery notification is that it
	may cause notification storms when an IM is sent to a large list.  Not
	all users will remember to turn delivery notification _off_ when sending
	the IM to a large audience.
	
	> Some people rely on the latter to learn when a recipient actually
	> received (not necessarily read) the IM. 
	
	I can't argue with that, to be sure; but is that the norm?
	
	It appears that there are two cases to consider: a) where
	the IM system is tied to a presence system, and b) where
	it is not.  In (a), a sender can be reasonably sure when
	he sends the message that the recipient got it.  A
	confirmation for each message would simply be too awkward, given the
	volume of IMs that can be potentially exchanged.
	(b) is more akin to email; the sender sends a message
	not expecting an immediate response.  If the undelying
	network fails to deliver the message, it should let the
	sender know.  Otherwise, no further communications are
	needed.
	
	> An natural extension to that is to learn when the IM was actually
	> read.
	
	I can see this as providing a utility in case (b) above.
	
	> BTW, I don't see IM and SMTP as a fair comparison.
	
	For store-and-forward IM, I think SMTP is a good comparison. For real
	time interactive IM, I agree, it is not.
	
	> IM and SMS is a better comparison.
	
	I think we can -- and must -- do better than SMS.  AFAIK,
	if a SMS message is not delivered, the sender is not
	notified (correct me if I am wrong).  Once a sender sends
	a SMS, they generally assume that it will be delivered.
	We can do one better than SMS by notifying the sender if
	the IM could NOT be delivered.  If it is delivered (which
	will be a majority of the case), no notification needed.
	
	Thanks.
	
	- vijay
	--
	Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
	Wireless Networks Group/Internet Software and Services
	Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
	Naperville, Illinois 60566     Voice: +1 630 224 0216
	
	_______________________________________________
	Simple mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/simple

This message has been scanned for viruses by MailControl - www.mailcontrol.com
�jezf��)��+-J)��螵�+�m����5��_��?�������+-�w��Ȧ�W

---

From: "Vikas Tandon" <[email-masked]>
Date: Wed, 25 Feb 2004 15:32:42 +0530

Hi Chris,

In case your handset is off, the message delivered will be "202Accepted"
which can be used to tell the source that the message was not delivered
to the target. In case the message is not delivered (which means the
target is "open" according to the notifier/presence server and still
there is no response ("200OK") from the target, the presence server can
generate 480 Temporarily Unavailable - which tell the source that the
target did not get the message and it wasn't delivered.

Please let me know if I'm going on the wrong track.

Regards,
Vikas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Chris Boulton
Sent: mercredi 25 février 2004 14:57
To: Vikas Tandon; Vijay K. Gurbani; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Simple] Advanced IM Reqs: Delivery status reporting

	-----Original Message----- 
	From: Vikas Tandon [mailto:[email-masked]] 
	Sent: Wed 25/02/2004 04:33 
	To: 'Vijay K. Gurbani'; [email-masked] 
	Cc: [email-masked]; Chris Boulton; [email-masked] 
	Subject: RE: [Simple] Advanced IM Reqs: Delivery status
reporting

	Agree with Vijay on the storm of notifications. The delivery in
case of
	page mode is ensured by the 200OK and in case of session is
ensured by
	the session being valid.

	<<CJB>> The 200 OK indicates the completion of a transaction.  I
don't see how this indicates the delviery

	of the MESSAGE to the required destination (e.g. your handset is
turned off - the transaction would complete but the message would be
delivered at a later date).

	 Identifying the case where the user has read
	the message or not is a debatable issue in case of IM as IM is
typical
	useful in case where you are expecting instant communication,

	<<CJB>> This draft is initially refering to pager-mode, one off
massaging.  I wouldn't expect an

	 so u can
	very well assume that if the message has reached the target
(ensured by
	the 200OK) and there is no response from the target, then either
the
	target is away from the interface or is unwilling to respond at
that
	time.

	
	Regards,
	Vikas Tandon

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] On
Behalf Of
	Vijay K. Gurbani
	Sent: mercredi 25 février 2004 03:48
	To: [email-masked]
	Cc: [email-masked]; [email-masked];
[email-masked]
	Subject: Re: [Simple] Advanced IM Reqs: Delivery status
reporting

	
	Problem with affirmitive delivery notification is that it
	may cause notification storms when an IM is sent to a large
list.  Not
	all users will remember to turn delivery notification _off_ when
sending
	the IM to a large audience.

	
	confirmation for each message would simply be too awkward, given
the

	
	> BTW, I don't see IM and SMTP as a fair comparison.
	
	For store-and-forward IM, I think SMTP is a good comparison. For
real
	time interactive IM, I agree, it is not.

	
	Thanks.
	
	- vijay
	--
	Vijay K. Gurbani
vkg@{lucent.com,research.bell-labs.com,acm.org}
	Wireless Networks Group/Internet Software and Services
	Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm
6G-440
	Naperville, Illinois 60566     Voice: +1 630 224 0216

	

This message has been scanned for viruses by MailControl -
www.mailcontrol.com J)X?X(Wz? '~ff X)