Subject: RE: [Simple] Comments on draft-ietf-simple-rpid-01

From: [email-masked]
Date: Mon, 23 Feb 2004 12:33:09 +0200

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Henning Schulzrinne
> Sent: 22.February.2004 00:45
> To: Anders Kristensen
> Cc: [email-masked]
> Subject: Re: [Simple] Comments on draft-ietf-simple-rpid-01
> 
>
> 
> > 
> >  From 4.2:
> > 
> >    The <activity> element MAY be qualified with the 'from' 
> and 'until'
> >    attributes to describe the time when the element assumed 
> this value
> >    and the time until which is element is expected to be valid.
> > 
> > The schema def seems to require 'from' and doesn't define 'until'.
> 
> I don't see why the schema would indicate that the attribute is 
> required; there is no 'use="required"' declaration on the attribute.

In the absence of use="required", the default is required.

/Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 23 Feb 2004 08:19:00 -0500

> In the absence of use="required", the default is required.

Unfortunately, "global declarations cannot contain the attributes 
minOccurs,  maxOccurs, or use." (see 
http://www.w3.org/TR/xmlschema-0/#DefnDeclars)

Also, according to the same document,

"... instance document is optional (the default value of  use is 
optional), ..."

Thus, I wonder if you can cite the source of your sentence quoted above.

Henning

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 23 Feb 2004 08:19:00 -0500

Henning