Subject: [Simple] comments on draft-ietf-simple-xcap-list-usage-00

From: [email-masked]
Date: Sun, 29 Feb 2004 08:43:09 +0200

- Section 3 mentions the <entry-ref> and <external> elements. Is it possible that they reference an entry or list that is in a foreign administrative domain? If so, then this might cause problems or access. If not, they the text should make that clear.

- Section 3: and <entry> element has 2 attributes, name and uri. For xcap specific reasons, I understand why name needs to be an attribute, but I think it is much cleaner to have the uri as an element. It fits in better with the display-name element and other extensions that will go there.

- Section 3: about the name attribute in <entry>. It is required to be unique. The text should spell out the behaviour of the server if that name was not unique (409 with body).

- Section 5: Example is missing.

Regards,
Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Adam Roach <[email-masked]>
Date: Sun, 29 Feb 2004 19:48:29 -0600

[email-masked] [mailto:[email-masked]] writes:

> - Section 3: and <entry> element has 2 attributes, name and 
> uri. For xcap specific reasons, I understand why name needs 
> to be an attribute

Yes, I agree that it does, and that the reasons are rather
specific to XCAP.

> but I think it is much cleaner to have 
> the uri as an element. It fits in better with the 
> display-name element and other extensions that will go there.

So... are you proposing a change or not?

/a

---

From: Adam Roach <[email-masked]>
Date: Sun, 29 Feb 2004 19:48:29 -0600

/a

---

From: [email-masked]
Date: Mon, 1 Mar 2004 04:35:29 +0200

Yes.

Instead of 

<entry name="hisham" uri="sip:[email-masked]">
  <display-name>Hisham Khartabil</display-name>
</entry>

I'm proposing:

<entry name="hisham">
  <uri>sip:[email-masked]</uri>
  <display-name>Hisham Khartabil</display-name>
</entry>

/Hisham

> -----Original Message-----
> From: ext Adam Roach [mailto:[email-masked]]
> Sent: 01.March.2004 03:48
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> Cc: Jonathan Rosenberg
> Subject: RE: [Simple] comments on draft-ietf-simple-xcap-list-usage-00
> 
> 
>

---

From: [email-masked]
Date: Mon, 1 Mar 2004 04:35:29 +0200

Yes.

Instead of 

I'm proposing:

<entry name="hisham">

/Hisham

---

From: Adam Roach <[email-masked]>
Date: Sun, 29 Feb 2004 22:27:59 -0600

One problem with this approach is that "name" is an
optional attribute in the latest draft. If you remove
URI to be an element, then it becomes difficult (if
not impossible; I'm not an XPATH expert) to identify
an entry.

There is strong motivation to have a very small notation
for minimal list, along the lines of:

  <entry uri="sip:[email-masked]" />
  <entry uri="sip:[email-masked]" />
  <entry uri="sip:[email-masked]" />

/a

> From: [email-masked] [mailto:[email-masked]]
> Sent: Sunday, February 29, 2004 20:34
> To: [email-masked]
> > [email-masked] 
> [mailto:[email-masked]] writes:
> >

---

From: Adam Roach <[email-masked]>
Date: Sun, 29 Feb 2004 22:27:59 -0600

/a