Subject: [Simple] WGLC on Partial Notification

From: [email-masked]
Date: Tue, 17 Feb 2004 09:28:42 +0200

The WG chairs would like to start a Working Group Last Call on the following drafts:

http://www.ietf.org/internet-drafts/draft-ietf-simple-partial-pidf-format-00.txt
http://www.ietf.org/internet-drafts/draft-ietf-simple-partial-notify-01.txt

This WGLC will end on March 9th.

Please send your comments to this mailing list and to the authors.

Thanks,
Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Thu, 19 Feb 2004 13:32:22 +0200

Hi,

Thanks for comments. See below:
> 
> Hi,
> 
> I wanted to make some comments on these 2 internet drafts.
> 
> 1. It is mentioned (in
> http://www.3gpp.org/ftp/Specs/html-info/23-series.htm
> section 3.1 and 
> section 4.4) that the version MUST start from 0.
> Though in the example included in the 
> in the F3 NOTIFY message the
> version starts from 1.
> 
> This should be corrected to 0 and also in the next NOTIY (F5)
> the version should be changed from 2 to 1.

Yes, will be fixed in next version

> 2. What happens if a tuple appears in a partial notification
> both to be deleted and updated? How should the subscriber 
> process such a notification? Is there any order in the way 
> the subscriber processes the information inside the 
> notification? e.g. first the updated and then the deleted? I 
> believe there should some text explaining what happens in 
> this scenario.

This scenario should never happen and it probably indicates that
something has gone wrong in notifier side. I can add text stating that
_all_ tuple Ids used in partial PIDF document MUST be unique (tuple ids
in <tuple> and in <removed>). If this still happens watcher has two
options:
- terminate the subscription
- refresh the subscription
I can add text about this into next version.

> 3. In the case of a refresh in the dialog (if the versions go
> out of synch) are there any guidelines for the notifier 
> regarding the selection of the version in the notification 
> that will contain full presence? Is it incremented by 1(from 
> the latest one), starts again from 0 or the notifier picks a 
> new random number as a starting point?

It should start again from 0. This is not well documented in the draft
so I will add text about this to section 4.4.

> 4. In the
> sometimes the word dialog is used instead of subscription. I 
> think we should use subscription as a dialog may have more 
> than one subscriptions (with different ids) and notifications 
> pertain to subscriptions. Examples can be found in:
>  - "The watcher MUST discard all previously received presence 
> information from that particular presentity in the context of 
> current dialog"
>     Instead of dialog it should say subscription
> 
>  - "In case the PS changes the content type used in
> notifications within the existing dialog the watcher must 
> discard all previously received presence information from 
> that particular presentity and process the new content as 
> specified for that content type".
>     Instead of dialog it should say subscription

Yes, use of subscription instead of dialog is better. I will make
changes.

> 5. Finally, it is not mentioned what happens when the
> subscription expires or when the subscriber unsubscribes. My 
> guess is that a notification with full state will be generated.

Right. Behavior should be same as in presence event package (full
state). I will clarify this in next version. 

- Mikko

> Regards,
> 
> Yannis Pavlidis
> Openwave Systems
> [email-masked]
> +1-303 385 6695
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of [email-masked]
> Sent: Tuesday, February 17, 2004 12:29 AM
> To: [email-masked]
> Subject: [Simple] WGLC on Partial Notification
> 
> 
> The WG chairs would like to start a Working Group Last Call
> on the following
> drafts:
> 
http://www.ietf.org/internet-drafts/draft-ietf-simple-partial-pidf-forma
t-00
.txt
http://www.ietf.org/internet-drafts/draft-ietf-simple-partial-notify-01.
txt

Thanks,
Hisham

---

From: [email-masked]
Date: Thu, 19 Feb 2004 13:32:22 +0200

Hi,

- Mikko

Thanks,
Hisham