Subject: RE: [Simple] Update to xcap package

From: [email-masked]
Date: Wed, 25 Feb 2004 17:13:30 +0200

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: 25.February.2004 06:37
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] Update to xcap package
> 
> 
> 
> Yes, something like this would work. No doubt fuller xpath 
> would enable
> us to more concretely specify insertion points. Its not clear whether
> these are needed in xpath per se, but rather in the "diff" sent in the
> notifications for the package.
> 
> A few more comments inline:
> 
> [email-masked] wrote:
> 
> > You can probably indicate the position of the insertion using the
> > xpath like expression. Something like:
> > 
> > PUT http://document/foo/bar[@id="3 and 3"]
> 
> This is not legal, I don't think.

It is legal in xpath, but not xcap.

/Hisham

> 
> > 
> > <bar id="3"/>
> > 
> > or
> > 
> > PUT http://document/foo/bar[@id="3 and position()=3"]
> 
> I believe its http://example.com/document/foo/bar[@id="3" and 
> position()="3"]
> 
> 
> > 
> > <bar id="3"/>
> > 
> > Valid xpath expressions, but not sure if they are valid http URIs.
> 
> As Ted points out, they would need to be escaped.
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 25 Feb 2004 11:19:30 -0500

> It is legal in xpath, but not xcap.

I dont think its legal xpath; or at least, it doesnt do what you want. 
Its saying to choose the element bar whose id attribute is equal to "3 
and 3". So, it would select an element in a document like this:

<foo>
   <bar id="3 and 3"/>
</foo>

If you want the element whose id attribute is 3 and whose position is 3, 
the and cannot be in quotations.

Note that it doesnt seem to work in XML spy either.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 25 Feb 2004 11:19:30 -0500

<foo>
   <bar id="3 and 3"/>
</foo>

-Jonathan R.