Subject: RE: [Simple] Update to xcap package

From: [email-masked]
Date: Wed, 18 Feb 2004 09:37:16 +0200

I had the use case in my mind that if we have a list that is shared amongst 100 or even 10000 employees and one modifies it, then this will result in 100 NOTIFYs. Each then might generate a GET.

Also for a conference using XCAP, it might be true that there is one creator, but there could be many privileged users who have read rights and can subscribe to the changes in the conference policy.

I'm not sure if the cost of sending the changes in a NOTIFY as opposed to just sending the etag is so great.

/Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Jonathan Rosenberg
> Sent: 17.February.2004 23:51
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] Update to xcap package
> 
> 
> 
> 
> 
> [email-masked] wrote:
> 
> > I'm not sure if this is the most efficient though. I would go for a
> > combination of all three: The first NOTIFY returns the full document
> > with an etag, subsequent NOTIFYs return changes along with the new
> > etag.
> > 
> > Filters can be used to get etags only.
> 
> Sorry to not be clear; this is exactly proposal 1. I wasnt saying
> that proposal one DOESNT include etag, it would also include it.
> 
> I think the choice is driven largely by use case. If we 
> expect that it 
> is infrequent for anyone else but a user to update their own content, 
> then option 3 is the right choice. Hisham - can you comment 
> on the use 
> cases that you think will make this efficiency important?
> 
> Thanks,
> Jonathan R.
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 18 Feb 2004 23:47:32 -0500

[email-masked] wrote:

> I had the use case in my mind that if we have a list that is shared
> amongst 100 or even 10000 employees and one modifies it, then this
> will result in 100 NOTIFYs. Each then might generate a GET.

OK.

> 
> Also for a conference using XCAP, it might be true that there is one
> creator, but there could be many privileged users who have read
> rights and can subscribe to the changes in the conference policy.
> 
> I'm not sure if the cost of sending the changes in a NOTIFY as
> opposed to just sending the etag is so great.

One thing we need to figure out is the format for the NOTIFY. WHats in 
the event package at the moment won't work, because there are many valid 
results that can be obtained from applying the xcap operations to a 
document. You need a proper "diff" format, I think. If you want a pure 
XML diff, XSLT is a choice, though you may not want to process that on a 
phone. A standard patch file format is another choice. I welcome other 
ideas.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 18 Feb 2004 23:47:32 -0500

OK.

-Jonathan R.