Subject: RE: [Simple] XCAP questions

From: [email-masked]
Date: Mon, 16 Feb 2004 17:55:45 +0200

Hi Jonathan,

My idea was this:
There is currently no feasible way for a client to track the changes in the documents owned by the particular user. To my understanding XCAP-change currently does not solve this, as there is no way to subscribe to all the documents in the directories of a particular user. The directory on the other hand, as discussed, would indeed contain references to all the documents owned by the user. So, if that directory contained something like Etags for each document, the client would be able to see with a simple subscription or fetch _which_ documents have changed e.g. since the last time it was turned off. Obviously there would be no way knowing exactly _what_ has been changed, but at least there would be a start.

Or do you think that this kind of functionality would be suitable for XCAP-change, i.e. being able to SUBSCRIBE to changes for all the documents of a single user with one shot?

Markus

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: 13 February, 2004 18:41
> To: Isomaki Markus (Nokia-NRC/Helsinki)
> Cc: Urpalainen Jari (Nokia-NRC/Helsinki); [email-masked]
> Subject: Re: [Simple] XCAP questions
> 
> 
> 
> 
> [email-masked] wrote:
> 
> > Hi,
> > 
> > Regarding the XCAP directory application usage:
> > 
> > I also like approach 3, as this would make things easiest for the
> > client. A follow-up issue to this: Would it be possible to include
> > also the Etags (or similar version identifiers) for each resource
> > listed in that directory file? In this way the user could only be
> > subscribed to the changes in the directory file (via XCAP-change
> > event), and still learn about all the changes that have occured in
> > any of the resources that he/she owns.
> 
> I dont think having the etags in there helps. Changes in the 
> directory 
> file would not contain the changes in the actual documents. 
> As such, the 
> client would know about the change, but knowing the new etag 
> doesnt help 
> - it would still have to do a get of the document to find out 
> what changed.
> 
> There IS value, however, in including etags in the xcap-event 
> package, 
> so that the client can apply the diff, verify it, know the 
> new etag, and 
> any PUTs it would do would be against that new etag.
> 
> 
> > 
> > If we agree that this is the way, I think specifying this new usage
> > would be straightforward, and I can volunteer to provide the first
> > version for it after IETF 59.
> 
> Great!
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 16 Feb 2004 17:34:07 -0500

Responding to my own note..

Jonathan Rosenberg wrote:

>> My idea was this: There is currently no feasible way for a client to
>> track the changes in the documents owned by the particular user. To
>> my understanding XCAP-change currently does not solve this, as there
>> is no way to subscribe to all the documents in the directories of a
>> particular user. 
> 
> 
> Right. Thats because the directories are structured as <root services 
> uri>/<auid>/users/<username>.
> 
> It would be easy enough to define an alias directory structured as <root 
> services URI>/users/<username>/<auid>. ACAP does this; both directories 
> exist. If this were done, you could use the xcap package to subscribe to 
> all documents for a user.

Of course, I just realized that the xcap-package does, in fact, 
explicitly say that you can only subscribe to a single document or a 
document sub-component. I can't think of a particular reason why this 
constraint has to be true. The notifications contain a reference to the 
specific document which changed, so it seems like you should be able to 
subscribe to a sub-tree. In that case, all you need to do is make sure 
the trees are structured in a way that makes such a subscription doable, 
and that is my proposal above.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 16 Feb 2004 17:34:07 -0500

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 16 Feb 2004 17:22:00 -0500

> The directory on the other hand, as discussed, would
> indeed contain references to all the documents owned by the user. So,
> if that directory contained something like Etags for each document,
> the client would be able to see with a simple subscription or fetch
> _which_ documents have changed e.g. since the last time it was turned
> off. Obviously there would be no way knowing exactly _what_ has been
> changed, but at least there would be a start.

Ah, I see. OK, in the case of a *fetch*, yes, the etags will be useful. 
For change notifications I dont think they would be useful. For a client 
with lots of documents, this would seem to help reduce startup time.

> 
> Or do you think that this kind of functionality would be suitable for
> XCAP-change, i.e. being able to SUBSCRIBE to changes for all the
> documents of a single user with one shot?

See above, yes it can be done. Indeed, I just recently submitted an 
update to xcap-package, and have now included etags in the 
notifications. I'll be sending a separate note on that topic.

Thanks,
Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 16 Feb 2004 17:22:00 -0500

Thanks,
Jonathan R.