Subject: Re: [Simple] Comments on xcap-list-usage

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 12 Feb 2004 16:41:13 -0500

I wish it were true that display names were enough, and that a URI 
itself was invisible to users, so that its structure was unimportant.

But historically, this has not been the case.

I beleive there will be a strong desire for vanity URIs, and that we 
need to be able to support that.

I would propose adding the ability of the user to select the URI. If it 
cannot be assigned, the error response (409) will contain some xml-meta 
data. We'll define, in base xcap, a meta-data specifically for the case 
of "URI cannot be assigned", as I expect this to be a very common case 
for server assigned data.

OK?

-Jonathan R.

[email-masked] wrote:

> Well, you can always have a display name that the user can set. If the list usage, you have the name attribute.
> 
> In CPCP usage, we defined the Display-name element. I think that should do it.
> 
> /Hisham
> 
> 
>>-----Original Message-----
>>From: ext Jonathan Rosenberg [mailto:[email-masked]]
>>Sent: 29.January.2004 00:29
>>To: Khartabil Hisham (Nokia-TP/Helsinki)
>>Cc: [email-masked]
>>Subject: Re: [Simple] Comments on xcap-list-usage
>>
>>
>>Certainly that tactic is simpler. However, it makes it hard to have 
>>"vanity URIs" for specific lists, for example - 
>>[email-masked]. Do we think that this function 
>>is needed?
>>
>>-Jonathan R.
>>
>>[email-masked] wrote:
>>
>>
>>>I would like to follow up on this issue since I faced the 
>>
>>same problem while updating the XCAP usage for CPCP.
>>
>>>
>>>>-----Original Message-----
>>>>From: [email-masked] 
>>
>>[mailto:[email-masked]]On Behalf Of
>>
>>>>ext Jonathan Rosenberg
>>>>Sent: 13.November.2003 11:14
>>>>To: Khartabil Hisham (NMP-MSW/Helsinki)
>>>>Cc: [email-masked]
>>>>Subject: Re: [Simple] Comments on xcap-list-usage
>>>>
>>>>[email-masked] wrote:
>>>>
>>>>
>>>>>- If the "uri" attribute is absent in a document, but the
>>>>>"subscribeable" flag is set to true. the XCAP server must allocate
>>>>>a URI. But what if the URI is present but conflicts with an already
>>>>>existing URI? How does the server react? Does it reject the request
>>>>>or does it just rewrite the URI?
>>>>
>>>>Great question.
>>>>
>>>>I think it should return an error. The reason is that the document 
>>>>would be in violation of one of the non-schema data constraints.
>>>>
>>>>The real question is, how does the client know that it should retry 
>>>>with a different URI?
>>>>
>>>>I see no obvious answer. There are a few possibilities:
>>>>
>>>>  * disallow clients from setting the URI
>>>>  * invent a new error resposne code
>>>>  * add a body to the 409 that describes the condition
>>>>
>>>
>>>
>>>I think the easiest and fastest thing to do is disallow the 
>>
>>client from setting the URI. Any other opinions?
>>
>>>Regards,
>>>Hisham
>>>
>>
>>-- 
>>Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
>>Chief Technology Officer                    Parsippany, NJ 07054-2711
>>dynamicsoft
>>[email-masked]                     FAX:   (973) 952-5050
>>http://www.jdrosen.net                      PHONE: (973) 952-5000
>>http://www.dynamicsoft.com
>>
>>
> 
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 12 Feb 2004 16:41:13 -0500

OK?

-Jonathan R.