Subject: [Simple] Comments on draft-ietf-simple-rpid-01

From: Anders Kristensen <[email-masked]>
Date: Fri, 20 Feb 2004 10:18:50 -0500

The draft doesn't spell out how many times the various extension 
elements can appear in a particular <tuple> or <status> element. For 
example, <activity> can perhaps appear more than once in a <status> but 
<idle> probably can't. These constraints aren't expressed in the schema 
so should be in the text.

 From 4.2:

    The <activity> element MAY be qualified with the 'from' and 'until'
    attributes to describe the time when the element assumed this value
    and the time until which is element is expected to be valid.

The schema def seems to require 'from' and doesn't define 'until'.

4.4: The <contact-type> element apparently is supposed to be extensible 
but AFAIK (and this may be wrong) the schema definition of this as a 
restriction of xs:token will not allow subsequent "widening" of the 
value space.

4.7: last paragraph seems to be a cut and paste error.

4.8 The <relationship> element seems to me to be a qualification of a 
tuple rather than a status. Shouldn't <relationship> be a tuple rather 
than a status extension?

5.1 The example has a bunch of errors:
- first <note> element appears in illegal place (according to the PIDF 
schema)
- Bad namespace prefix on <relationship> element.
- Within <tuple> elements, extensions must come immediately after the 
<status> element.
- The <contact> element is not a child of <status> (1st tuple)

In the schema section, the definition of activityToken and sphereToken 
looks odd. I'm not sure what it means or whether it's legal.

The 'from' and 'until' attributes of <sphere> aren't mentioned in the text.

Anders

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 23 Feb 2004 12:33:09 +0200

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Henning Schulzrinne
> Sent: 22.February.2004 00:45
> To: Anders Kristensen
> Cc: [email-masked]
> Subject: Re: [Simple] Comments on draft-ietf-simple-rpid-01
> 
>
> 
> > 
> >  From 4.2:
> > 
> I don't see why the schema would indicate that the attribute is 
> required; there is no 'use="required"' declaration on the attribute.

In the absence of use="required", the default is required.

/Hisham

---

From: [email-masked]
Date: Mon, 23 Feb 2004 15:44:47 +0200

You are right. I had myself confused.

/Hisham

> From: ext Henning Schulzrinne [mailto:[email-masked]]
> Sent: 23.February.2004 15:19
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Unfortunately, "global declarations cannot contain the attributes 
> minOccurs,  maxOccurs, or use." (see 
> http://www.w3.org/TR/xmlschema-0/#DefnDeclars)
> 
> Also, according to the same document,
> 
> "... instance document is optional (the default value of  use is 
> optional), ..."
> 
> Thus, I wonder if you can cite the source of your sentence 
> quoted above.
> 
> Henning
>

---

From: [email-masked]
Date: Mon, 23 Feb 2004 15:44:47 +0200

/Hisham