Subject: [Simple] BIND and Chat sessions

From: Marjou Xavier <[email-masked]>
Date: Wed, 3 Mar 2004 11:24:17 +0100

Hi,

I think one must not forget that the BIND method of MSRP could be a potential problem for Chat sessions. This is because the "media" BIND request would happen before "control" SIP request of the session establishment.

Best Regards,
Xavier Marjou

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: vendredi 20 février 2004 07:45
To: [email-masked]
Cc: [email-masked]
Subject: [Simple] Chat sessions

Hi:

I would like to draw your attention to a draft that Aki and me submitted a few days ago. We are addressing those missing components in a multiparty session based messaging (aka chat room). The draft is:

http://www.ietf.org/internet-drafts/draft-niemi-simple-chat-00.txt

We are focusing on two aspects at the moment: setting and displaying a nickname; and sending private messages to a subset of the participants (sidebar messaging conferences).

We have defined a convention to transport nicknames in message/cpim. Messages can be addressed to the whole chat room or just a subset of the participants. We have also provided an XML document that allows a participant to set her nickname and the chat room server to accept it.

Comments are welcome.

/Miguel
---
Miguel A. Garcia           tel:+358-50-4804586    
Nokia Research Center      Helsinki, Finland

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Thu, 04 Mar 2004 09:21:27 +0900

Just to be clear, the current MSRP draft removed the BIND method. (As 
well as anything else related to relays.)

However, the relay extension proposed in the wg meeting would most 
likely have something analogous.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 04 Mar 2004 09:21:27 +0900