Subject: RE: [Simple] MSRP: Wrapped types

From: [email-masked]
Date: Mon, 1 Mar 2004 18:52:56 +0200

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: 01.March.2004 10:42
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] MSRP: Wrapped types
> 
> 
> If we are to do more than leave as is, then I think we need 
> to revisit 
> requirements. I have the impression that the people raising 
> issues may 
> have different notions of what the requirements are.
> 
> For instance, if there is a requirement to have messages wrapped in 
> cpim, and then the cpim wrapper must be signed, and using 
> just signed, 
> or just cpim isn't ok, then we can't meet the requirement.

You can do that with the current solution. accept-types can have both message/cpim and signed. This means that they can both appear as wrapped types.

/Hisham

> 
> 	Paul
> 
> [email-masked] wrote:
> > My vote is to leave it as is. This is a solution that we 
> were comfortable with after a long debate. The new proposals 
> add no benefit.
> > 
> > /Hisham
> > 
> > 
> >>-----Original Message-----
> >>From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> >>ext Ben Campbell
> >>Sent: 27.February.2004 22:53
> >>To: [email-masked]
> >>Subject: [Simple] MSRP: Wrapped types
> >>
> >>
> >>Another issue came up during the discussions several of us 
> >>had a SIPIT. 
> >>I am separating this out from the MSRP/SIMS harmonization 
> >>email, as it 
> >>is orthagonal to that.
> >>
> >>Several people commented that the existing "accept-types" and 
> >>"accept-wrapped-types" were overly confusing and error prone. 
> >>To recap, 
> >>the point of this mechanism is to allow an MSRP device to accept a 
> >>number of formats, but require them to be wrapped in an 
> >>envelope of some 
> >>sort. The motivation behind this is that a CPIM gateway may 
> allow any 
> >>number of content-types, but insist that everything be wrapped in a 
> >>message/cpim envelope.
> >>
> >>The existing mechanism says that any format listed in 
> >>"accept-types" can 
> >>occur anywhere in a body, including at the root. Formats listed in 
> >>"accept-wrapped-types" cannot occur at the root; that is, 
> >>they must be 
> >>wrapped inside of some format listed in "accept-types". This 
> >>solves the 
> >>problem, but it is pretty complicated and difficult to understand.
> >>
> >>Two possible alternatives were offered:
> >>
> >>1) Get rid of the "accept-wrapped-types" attribute, and 
> >>instead add an 
> >>attribute that means "I require CPIM". This would mean that 
> >>all content 
> >>must be wrapped in message/cpim envelopes.
> >>
> >>2) Generalize option 1 a little bit by adding an "envelope" 
> >>attribute. 
> >>This attribute would contain a single format entry. All 
> >>content must be 
> >>wrapped in that format.
> >>
> >>And of course, there is an implied item 3: Leave it as is.
> >>
> >>Thoughts?
> >>
> >>Thanks!
> >>
> >>Ben.
> >>
> >>_______________________________________________
> >>Simple mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/simple
> >>
> > 
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> > 
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Niemi Aki (Nokia-M/Espoo)" <[email-masked]>
Date: Mon, 01 Mar 2004 19:53:21 +0200

ext [email-masked] wrote:
> 
>> -----Original Message----- From: ext Paul Kyzivat
>> [mailto:[email-masked]] Sent: 01.March.2004 10:42 To: Khartabil
>> Hisham (Nokia-TP-MSW/Helsinki) Cc: [email-masked];
>> [email-masked] Subject: Re: [Simple] MSRP: Wrapped types
>> 
>> 
>> If we are to do more than leave as is, then I think we need to
>> revisit requirements. I have the impression that the people raising
>>  issues may have different notions of what the requirements are.
>> 
>>  cpim, and then the cpim wrapper must be signed, and using just
>> signed, or just cpim isn't ok, then we can't meet the requirement.
> 
> 
> You can do that with the current solution. accept-types can have both
> message/cpim and signed. This means that they can both appear as
> wrapped types.

Yes, they can both appear there, but you can't mandate special ordering, 
i.e., that the message needs to first be wrapped in CPIM, then to 
multipart/signed and not the other way around, or using only one of them.

This may be feature creep, but I think it's important to see whether 
there are valid usages for this sort of thing because it's not really 
something that can be added easily afterwards.

Cheers,
Aki

>> were comfortable with after a long debate. The new proposals add no
>> benefit.
>> 
>>> /Hisham
>>> 
>>> 
>>> 
>>>> -----Original Message----- From: [email-masked]
>> 
>>>> ext Ben Campbell Sent: 27.February.2004 22:53 To:
>>>> [email-masked] Subject: [Simple] MSRP: Wrapped types
>>>> 
>>>> 
>>>> Another issue came up during the discussions several of us had
>>>> a SIPIT. I am separating this out from the MSRP/SIMS
>>>> harmonization email, as it is orthagonal to that.
>>>> 
>>>> To recap, the point of this mechanism is to allow an MSRP
>>>> device to accept a number of formats, but require them to be
>>>> wrapped in an envelope of some sort. The motivation behind this
>>>> is that a CPIM gateway may
>> 
>> allow any
>> 
>>>> number of content-types, but insist that everything be wrapped
>>>> in a message/cpim envelope.
>>>> 
>>>> "accept-types" can occur anywhere in a body, including at the
>>>> root. Formats listed in "accept-wrapped-types" cannot occur at
>>>> the root; that is, they must be wrapped inside of some format
>>>> listed in "accept-types". This solves the problem, but it is
>>>> pretty complicated and difficult to understand.
>>>> 
>>>> 1) Get rid of the "accept-wrapped-types" attribute, and instead
>>>> add an attribute that means "I require CPIM". This would mean
>>>> that all content must be wrapped in message/cpim envelopes.
>>>> 
>>>> attribute. This attribute would contain a single format entry.
>>>> All content must be wrapped in that format.
>>>> 
>>>> _______________________________________________ Simple mailing
>>>> list [email-masked] 
>>> _______________________________________________ Simple mailing
>>> list [email-masked] 
> _______________________________________________ Simple mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/simple

---

From: "Niemi Aki (Nokia-M/Espoo)" <[email-masked]>
Date: Mon, 01 Mar 2004 19:53:21 +0200

Cheers,
Aki

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Mar 2004 00:15:14 -0500

Aki,

I agree entirely. Note that I have no interest in complicating this 
further. I am just trying to flush out specific requirements, since I 
have had hallway conversations where such requirements were implied.

	Paul

Niemi Aki (Nokia-M/Espoo) wrote:
>>>>> "accept-wrapped-types" were overly confusing and error prone. To 
>>>>> recap, the point of this mechanism is to allow an MSRP
>>>>> list [email-masked] https://www1.ietf.org/mailman/listinfo/simple
>>>>>
>>>>
>>>>
>>>> list [email-masked] https://www1.ietf.org/mailman/listinfo/simple
>>>>
>>>
>>>
>>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Mar 2004 00:15:14 -0500

Aki,

	Paul