Subject: Re: [Simple] xcap/geopriv alignment issue 4: authentication

From: Ben Campbell <[email-masked]>
Date: Tue, 25 Nov 2003 09:23:27 -0600

[email-masked] wrote:

> 
>>-----Original Message-----
>>From: ext Ben Campbell [mailto:[email-masked]]
>>Sent: 24.November.2003 23:00
>>To: Khartabil Hisham (NMP-MSW/Helsinki)
>>Cc: [email-masked]; [email-masked]
>>Subject: Re: [Simple] xcap/geopriv alignment issue 4: authentication
>>
>>
>>[email-masked] wrote:
>>
>>
>>>Can the user at least have a say in accepting or rejecting 
>>
>>the subscription based on the availability of any 
>>authentication type. Eg: A user can reject subscriptions that 
>>are not authenticated in any way and accept subscriptions 
>>that are authenticated, regardless of authentication type.
>>
>>In the absence of _some_ authentication, what is the value of having 
>>authorization policies in the first place? They have no 
>>meaning if you 
>>cannot put some degree of trust in the requestor identity.
>>
>>I think the email world has proven to us how useful it is to 
>>authorize 
>>on un-authenticated headers. How useful is a spam filter that 
>>relies on 
>>the From header?
> 
> 
> Either I'm missing your point, or you missed mine. All I said was that the user should be able to reject subscriptions if they are not authenticated (authentication method is irrelevant).
> 

Ah, well, I can't disagree with that :-)

Ben.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Vesa Torvinen (JO/LMF)" <[email-masked]>
Date: Wed, 26 Nov 2003 09:48:23 +0100

Hi, 

I think this mechanism goes back to a use case where a policy would define that "anyone that knows this password is allowed to subscribe". The user wouldn't exactly be interested in identities - just to be sure that the watcher knows the password. This use case is similar to the policies currently used in phone conferencing systems where the caller just needs to know the conference id, and related password - and not really to authenticate itself. 

I agree with you that forcing the use of S/MIME, TLS or P-Asserted-Identity may not be meaningful. However, having policies that mandates the use of HTTP Digest (or some other password based mechanism) may still be useful. 

Vesa

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Jonathan Rosenberg
Sent: 24. marraskuuta 2003 8:13
To: Simple WG
Subject: [Simple] xcap/geopriv alignment issue 4: authentication

Folks,

Currently, xcap-auth defines an authentication condition. This allows 
you to decide whether to accept or reject a subscription based on the 
type of authentication used in the SUBSCRIBE request.

The geopriv policy specification currently has no such mechanism.

This was discussed during the geopriv meeting in Minneapolis. If you 
think about it for a bit, its not clear how this would actually get 
used. Remember, it is end users that will set these policies. What 
kind of meaningful information can be provided to a user about the 
differences between p-asserted-id and sip-identity and digest 
authentication? What would make a user give permission for one type or 
authentication, and not another? Practically speaking, it doesnt seem 
like its easy to use at all.

As a result, I would propose to remove the authentication condition 
from xcap-auth.

Comments?

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com