Subject: RE: external lists, was: Re: [Simple] Comments on: First draft of text on semantic-based authorization policies [external lists]

From: [email-masked]
Date: Wed, 24 Mar 2004 23:20:51 +0200

Hi,

Jonathan Rosenberg wrote:
> 
> I also think that the external list is, as the name implies, 
> a reference 
> to a list of URI that resides elsewhere. 

This is what I was meaning, sorry that I didn't explain it clearly. And in practice I don't think there is (at least initially) any need to support references to lists "anywhere in the Internet", just within a single administrative domain (for instance under the common XCAP root). In that case keeping in synch is more realistic. I don't see any need to normatively limit it like that, though.

> It is not a reference to an 
> external ruleset, as I think Henning has suggested. In one 
> iteration of 
> the xcap authorization rules, the URI was an xcap resource 
> that resolved 
> to a list of URI in the resource-lists application usage.
> 
> Does anyone see problems with this?
>

I don't think there would be any problem if the use is limited to privacy-safe scenarios, as Jonathan suggested. On the other hand, we would gain the possibility of managing a single resource list and using it for more than one application.
 
> I would therefore suggest that we pursue extternal lists as a 
> separate 
> document, which can follow shortly after the baseline specification.
> 

That's OK, if you think that adding this directly to the baseline spec would be too much at this point.

> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 

Markus

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 24 Mar 2004 23:20:51 +0200

Hi,

 

Markus