Subject: RE: [Simple] comments on prescaps

From: [email-masked]
Date: Tue, 2 Mar 2004 09:34:25 +0200

> 
> inline; we didnt cover this during the meeting.

True, there really wasn't time for everything. Inline:

> [email-masked] wrote:
> 
> > Hi,
> > 
> 
> >>>5. Generating SIP request based on 'prescaps' extension
> >>>
> >>>   UA receiving PIDF documents with 'prescaps' extension 
> may wish to
> >>>   generate SIP request which would route to UA having capabilities
> >>>   described by 'prescaps' extension. UA MAY add
> >>
> >>Accept-Contact: header
> >>
> >>>   based on 'prescaps' extension elements. However, as discussed in
> >>>   Section 4 device capabilities described by this
> >>
> >>extension may not be
> >>
> >>>   consistent what UA has indicated in its registration. 
> Due to this
> >>>   request may not route to correct UA.
> >>
> >>It should not be necessary, in fact, to do this at all. The contact 
> >>URI should route you to a UA that has these capabilities.
> > 
> > 
> > Are you saying that adding Accept-Contact: doesn't make any 
> difference 
> > in proxies in case there exists multiple UAs for a single 
> AoR? But in 
> > any case you are right that contact URI should route to correct UA.
> 
> My point is that its redundant. The definition, I think, of 
> the contact 
> URI is that it routes to something with the advertised 
> capabilities. I 
> should not have to use caller prefs to route to a device described by 
> the tuple.

I agree that contact URI should route to correct UA without any callee
prefs. So if nobody thinks this is useful I will remove the section.

- Mikko   

> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Tue, 2 Mar 2004 09:34:25 +0200

- Mikko