Subject: RE: [Simple] is-composing: has-focus?

From: "Eric Burger" <[email-masked]>
Date: Tue, 9 Mar 2004 16:46:18 -0500

How is this different from AIM's "Typing..." notification?

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, March 09, 2004 1:41 AM
> To: Henning Schulzrinne
> Cc: Simple WG
> Subject: Re: [Simple] is-composing: has-focus?
> 
> 
> Firstly, "has-focus" is probably a bad name, since its 
> dangerously close 
> to "is-focus" which means something entirely different in the SIP 
> specifications...
> 
> Secondly, does this really provide useful information? Just 
> because the 
> window doesnt have focus doesnt mean I'm not paying 
> attention. Indeed, I 
> frequently look at another window while a user is typing to me (often 
> another IM conversation). Or, to ask more concretely, how 
> would a user 
> change their behavior in knowing that my IM window didnt have focus?
> 
> -Jonathan R.
> 
> Henning Schulzrinne wrote:
> 
> > The AT&T Hubbubb IM/presence client 
> (http://www.hubbubme.com/) has an 
> > interesting feature that fits nicely into the is-composing draft: a 
> > 'has-focus' indication that shows if the IM application has 
> the user's 
> > window focus, i.e., the user is paying attention to what's 
> being sent 
> > from the other side or is likely to respond soon. Any opinions of 
> > including this as an optional state, i.e., a user MUST be 
> able to choose 
> > whether this gets sent and it MUST be off by default?
> > 
> > Henning
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> > 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 09 Mar 2004 16:48:36 -0500

Typing presumably refers to composing a message for the IM client. Focus 
describes whether the IM window has input focus. Typing implies focus, 
but not vice versa.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 09 Mar 2004 16:48:36 -0500