Subject: [Simple] Chat sessions

From: [email-masked]
Date: Fri, 20 Feb 2004 08:44:47 +0200

Hi:

I would like to draw your attention to a draft that Aki and me submitted a few days ago. We are addressing those missing components in a multiparty session based messaging (aka chat room). The draft is:

http://www.ietf.org/internet-drafts/draft-niemi-simple-chat-00.txt

We are focusing on two aspects at the moment: setting and displaying a nickname; and sending private messages to a subset of the participants (sidebar messaging conferences).

We have defined a convention to transport nicknames in message/cpim. Messages can be addressed to the whole chat room or just a subset of the participants. We have also provided an XML document that allows a participant to set her nickname and the chat room server to accept it.

Comments are welcome.

/Miguel
---
Miguel A. Garcia           tel:+358-50-4804586    
Nokia Research Center      Helsinki, Finland

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Alan Johnston <[email-masked]>
Date: Fri, 19 Mar 2004 12:21:18 -0600

As a result of this thread, in Korea, a group of us (roughly myself, Brian, 
Hisham, Aki, Paul, Markus - apologies to others who I might have forgotten) 
met to discuss "chat rooms" and text conferencing.

Here is what the consensus of the participants was:

There is a need to document aspects of "chat rooms" or text
conferencing.

There seems to be a need to have a request/response kind of
subset of conferencing (sidebar) AS WELL AS an immediate
no request/response subset of conferencing (private message /
whisper).  This need is not specific to media, although the
exact mechanism to establish it might be media dependent.
Media Policy is a media independent mechanism, but others
may be more appropriate, especially for IM.  This work
will at least begin in XCON.

In addition, the absence of an ability to express a nickname
in SIP was identified as an area for future SIP work.

Thanks,
Alan Johnston
MCI
sip:[email-masked]

At 08:07 PM 3/2/2004 -0500, Rosen, Brian wrote:
>How are we going to resolve this?
>
>Most of us are here.  Can we get together?
>
>Brian
>
> > -----Original Message-----
> > From: Paul Kyzivat [mailto:[email-masked]]
> > Sent: Tuesday, March 02, 2004 6:44 PM
> > To: Niemi Aki (Nokia-M/Espoo)
> > Cc: ext Rosen, Brian; ext Jonathan Rosenberg;
> > [email-masked];
> > [email-masked]; [email-masked];
> > [email-masked]
> > Subject: Re: [Simple] Chat sessions
> >
> >
> >
> >
> > Niemi Aki (Nokia-M/Espoo) wrote:
> > >
> > >>> Of course you can't do private messages with voice. Voice
> > and IM are
> > >>> inherently different. You can't send private voice
> > packets to another
> > >>> participant of a conference, simply because there isn't a way to
> > >>> single out a participant in a conference by directly addressing
> > >>> packets there. It also makes mixing really complicated, because a
> > >>> private voice stream might overlap with the rest of the
> > conference.
> > >>> These don't present a problem for IM; the sender can
> > single out the
> > >>> recipient using the cpim To header field and the recipient UA can
> > >>> simply mark a message as private and render it to the
> > same UI as the
> > >>> rest of the IMs in that conference.
> > >>
> > >> I protest.  There is no logical difference.  There is no protocol
> > >> difference.  In most cases, there is no practical difference.  You
> > >> send media to some address, you get media from some address.  You
> > >> render it.  IM or voice or video is all just media, and its handled
> > >> the same way.  You might have "centralized" or
> > "distributed" mixers.
> > >> Most IM systems, as implemented, are centralized mixers.  You send
> > >> all media to the mixer, it sends media to you.  There is nothing
> > >> special with IM.  You need some signaling for a private message.
> > >> You can use the same signaling for a sidebar or a whisper.
> > >
> > > Hmm.. which systems are these? The ones I've used have both private
> > > messages *and* sidebars.
> >
> > It seems that in principle the difference between sidebars
> > and private
> > messages is simply one of UI design. A particular client
> > could support
> > one or the other, or both.
> >
> > But you also seem to require that the initiator be able to
> > choose which
> > user experience the recipients will have. That turns it into
> > a protocol
> > issue. In general I would consider this a bad idea. But it is
> > largely a
> > human factors issue, and I don't feel qualified to comment on
> > it except
> > from the perspective of personal preference. But it seems that whole
> > discussion hinges on whether there is a valid requirement for giving
> > senders that degree of control over recipients.
> >
> >       Paul
> >
>