Subject: RE: [Simple] RE: Advanced IM requirements

From: "Eric Burger" <[email-masked]>
Date: Tue, 2 Mar 2004 22:54:15 -0500

Common scenario:
You send me an IM.  My device receives the message, forwards it to me, I read it.  Is my device going to send you two messages, a provisional MDN saying I got the message and a final MDN saying I read the message?  Doesn't SIP tell you if my device got the message?

Likely Scenario:
You send me an IM.  My device receives the message, creates a provisional MDN, because my device is online.  The MDN says the relay has received the message, but has not delivered it.

Unfortunately, I've turned off my device, because I am going to Korea for a week.

Are you suggesting the IM relay should open a session mode connection and leave it up for a week until I get back?

> -----Original Message-----
> From: Chris Boulton [mailto:[email-masked]]
> Sent: Monday, March 01, 2004 2:01 AM
> To: Paul Kyzivat; Eric Burger
> Cc: [email-masked]
> Subject: RE: [Simple] RE: Advanced IM requirements
> 
> 
>  
> 
> 	-----Original Message----- 
> 	From: Paul Kyzivat [mailto:[email-masked]] 
> 	Sent: Mon 01/03/2004 06:44 
> 	To: Eric Burger 
> 	Cc: [email-masked] 
> 	Subject: Re: [Simple] RE: Advanced IM requirements
> 	
> 	
> 
> 
> 
> 	Eric Burger wrote:
> 	> I agree.  Again, this highlights why IMDN is at the 
> CPIM, and not SIP, level.
> 	>
> 	> Further, what is the use case for MDN in session 
> mode?  Would anyone EVER use it?  I doubt it: if you are in a 
> session, presumably you are interactive, which means you have 
> OOB methods for knowing the message wasn't read (e.g., no 
> response from the other person).
> 	
> 	I agree it doesn't seem like something that normally 
> would be used. But
> 	there may be some cases. I may want explicit confirmation that a
> 	particular message has not only been delivered, but 
> read. (This might
> 	require the UAS to demand some explicit confirmation 
> from the end user
> 	before sending the confirmation.)
> 
> 	<<CJB>> This is ceratainly the reason I allowed for 
> more than one receipt per transaction.  The notion of 
> delievery + read receipts is something that is quite 
> beneficial + copies current SMS. 
> 
> 	
> 	
> 	Another case is with an IM conference. If I send a 
> message to the mixer,
> 	requesting confirmation, ideally that would be an 
> end-to-all-ends
> 	confirmation. The mixer would have to request and 
> receive confirmation
> 	from all recipients before confirming to sender.
> 	
> 	> Given that assertion, can we say IMDN's are page mode 
> messages.
> 	
> 	Based on above, I say NO.
> 
> 	<<CJB>> Sorry Paul, I'm with Eric and still just don't 
> see when this would be used.
> 	
> 	        Paul
> 	
> 	
> 	_______________________________________________
> 	Simple mailing list
> 	[email-masked]
> 	https://www1.ietf.org/mailman/listinfo/simple 
> <https://www1.ietf.org/mailman/listinfo/simple> 
> 	
> 
> 
> 
> This message has been scanned for viruses by MailControl - 
www.mailcontrol.com
J)隊XX(Wzm?0'~ffX)ߣ"^
���^����x%��R�jez'�~����i����
bz���j)fj��b��?�)��

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 04 Mar 2004 10:37:23 -0500

> You send me an IM.  My device receives the message, forwards it to me, I read it.  Is my device going to send you two messages, a provisional MDN saying I got the message and a final MDN saying I r…

Doesn't sip tell me you got the message? Not necessarily. It might with 
page mode and not with session mode. Or it might just tell me that it 
was received and stored, so maybe it didn't even get to your device, 
much less your eyes.

Could the messages that are required to make the protocol work also be 
used to carry some of the delivery confirmations? Probably. Perhaps we 
should change the specification of MESSAGE so that it can optionally 
carry a delivery confirmation body in the 2xx response.

> Likely Scenario:
> You send me an IM.  My device receives the message, creates a provisional MDN, because my device is online.
 > The MDN says the relay has received the message, but has not 
delivered it.

I don't follow the above. You say your device received the message, but 
MDN says the *relay* received the message but hasn't delivered it.
I think maybe the MDN says the *device* has received the message but 
hasn't delivered it.

> Unfortunately, I've turned off my device, because I am going to Korea for a week.

Well, if you have turned off your device I don't see how it could have 
done the above.

What I can imagine is something entirely analogous to voicemail: you 
have two devices registered to your AoR - your pc or whatever you 
usually receive IMs on, and an IM recording device. (It could make sense 
for a single device to be recorder for both VM and IM.)

So you have turned off your pc and are in transit to Korea. Your 
recording device accepts the message and returns an indication that it 
has been recorded but not read.

In case of page mode, the 202 response to MESSAGE may be sufficient to 
tell you that. In case of session mode something else is required.

> Are you suggesting the IM relay should open a session mode connection and leave it up for a week until I get back?

No, of course not. When you get around to firing up your IM client, it 
will presumably go out to your recording device and retrieve whatever 
has been recorded. How it does that is not standardized. It could be via 
sip or msrp, or otherwise. But when it does, if those messages requested 
notification that the message had been read, then your client would 
presumably send that notification once it confirms that you have read 
it. It could do that via page mode, or it could establish an msrp 
session and deliver confirmations that way.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 04 Mar 2004 10:37:23 -0500

delivered it.

	Thanks,
	Paul