Subject: RE: [Simple] Chat sessions

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 2 Mar 2004 20:07:01 -0500

How are we going to resolve this?

Most of us are here.  Can we get together?

Brian

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Tuesday, March 02, 2004 6:44 PM
> To: Niemi Aki (Nokia-M/Espoo)
> Cc: ext Rosen, Brian; ext Jonathan Rosenberg; 
> [email-masked];
> [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Re: [Simple] Chat sessions
> 
> 
> 
> 
> Niemi Aki (Nokia-M/Espoo) wrote:
> > 
> >>> Of course you can't do private messages with voice. Voice 
> and IM are 
> >>> inherently different. You can't send private voice 
> packets to another 
> >>> participant of a conference, simply because there isn't a way to 
> >>> single out a participant in a conference by directly addressing 
> >>> packets there. It also makes mixing really complicated, because a 
> >>> private voice stream might overlap with the rest of the 
> conference. 
> >>> These don't present a problem for IM; the sender can 
> single out the 
> >>> recipient using the cpim To header field and the recipient UA can 
> >>> simply mark a message as private and render it to the 
> same UI as the 
> >>> rest of the IMs in that conference.
> >>
> >> I protest.  There is no logical difference.  There is no protocol
> >> difference.  In most cases, there is no practical difference.  You
> >> send media to some address, you get media from some address.  You
> >> render it.  IM or voice or video is all just media, and its handled
> >> the same way.  You might have "centralized" or 
> "distributed" mixers.
> >> Most IM systems, as implemented, are centralized mixers.  You send
> >> all media to the mixer, it sends media to you.  There is nothing
> >> special with IM.  You need some signaling for a private message.
> >> You can use the same signaling for a sidebar or a whisper.
> > 
> > Hmm.. which systems are these? The ones I've used have both private 
> > messages *and* sidebars.
> 
> It seems that in principle the difference between sidebars 
> and private 
> messages is simply one of UI design. A particular client 
> could support 
> one or the other, or both.
> 
> But you also seem to require that the initiator be able to 
> choose which 
> user experience the recipients will have. That turns it into 
> a protocol 
> issue. In general I would consider this a bad idea. But it is 
> largely a 
> human factors issue, and I don't feel qualified to comment on 
> it except 
> from the perspective of personal preference. But it seems that whole 
> discussion hinges on whether there is a valid requirement for giving 
> senders that degree of control over recipients.
> 
> 	Paul
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Mar 2004 20:58:26 -0500

I'm game. Who cares? This is in the overlap area between simple and xcon 
I think. How about lunch tomorrow, after xcon?

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Mar 2004 20:58:26 -0500

Paul

---

From: "Niemi Aki (Nokia-M/Espoo)" <[email-masked]>
Date: Wed, 03 Mar 2004 04:12:07 +0200

Yeah, me too. Lunch tomorrow sounds good.

Cheers,
Aki

ext Paul Kyzivat wrote:
>>> Cc: ext Rosen, Brian; ext Jonathan Rosenberg; [email-masked];
>>> [email-masked]; [email-masked]; [email-masked]
>>> It seems that in principle the difference between sidebars and 
>>> private messages is simply one of UI design. A particular client 
>>> could support one or the other, or both.
>>>
>>> But you also seem to require that the initiator be able to choose 
>>> which user experience the recipients will have. That turns it into a 
>>> protocol issue. In general I would consider this a bad idea. But it 
>>> is largely a human factors issue, and I don't feel qualified to 
>>> comment on it except from the perspective of personal preference. But 
>>> it seems that whole discussion hinges on whether there is a valid 
>>> requirement for giving senders that degree of control over recipients.
>>>
>>>     Paul
>>>
>>
>>

---

From: "Niemi Aki (Nokia-M/Espoo)" <[email-masked]>
Date: Wed, 03 Mar 2004 04:12:07 +0200

Cheers,
Aki