Subject: RE: [Simple] return receipt and delivery status notification for MSRP

From: [email-masked]
Date: Thu, 4 Mar 2004 12:24:15 +0200

It is optional. If it is annoying to you, then you don't request a delivery notification. It is not every time and it is not mandatory.
 
/Hisham

-----Original Message-----
From: ext vikas [mailto:[email-masked]]
Sent: 04.March.2004 07:31
To: Vijay K. Gurbani; ; Rohan Mahy; Niemi Aki (Nokia-M/Espoo); Khartabil Hisham (Nokia-TP-MSW/Helsinki); 
Subject: Re: [Simple] return receipt and delivery status notification for MSRP

Hi,

Adding to what Vijay just mentioned, it would be annoying for the user to get a notification everytime that the message has been read by the target. 

Typically the number of messages exchanged in IM will be greater than that in email (if you would like to compare for read notification purpose). 

To me - "no news is good news" sounds okay for delivery notifications.

Regards,
Vikas Tandon
Arciis Software Technologies
www.arciis.com

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 04 Mar 2004 08:53:15 -0600

[email-masked] wrote:

> It is optional. If it is annoying to you, then you don't 
> request a delivery notification. It is not every time and it is 
> not mandatory.

So, just to be pedantic, please correct me if my summary below
is wrong:

   1/ We are interested in DSNs at the _user_ level, not the
      _protocol_ level (i.e. the transactional model at the
      protocol level is sufficient for protocol state
      machines to figure out if an IM was delivered to the
      next hop successfully or not).
   2/ We should design protocol provisions such that a positive
      acknowledgement DSN model is supported (let me know
      the current state of the IM: queued, delivered, read,
      being responded to, ...).
   3/ We should design protocol provisions such that a negative
      acknowledgement DSN model is supported (send it and
      forget it unless something drastic happens, then
      let me know).
   4/ Both 2 and 3 should apply to page mode and session
      mode IMs.
   5/ Both 2 and 3 should be configurable by the sending
      user.

Is this accurate?

Thanks,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 04 Mar 2004 08:53:15 -0600

Is this accurate?

Thanks,

- vijay