Subject: Re: [Simple] return receipt and delivery status notification for MSRP

From: "vikas" <[email-masked]>
Date: Thu, 04 Mar 2004 05:30:49 +0000

Hi,

Adding to what Vijay just mentioned, it would be annoying for the user to get a notification everytime that the message has been read by the target. 

Typically the number of messages exchanged in IM will be greater than that in email (if you would like to compare for read notification purpose). 

To me - "no news is good news" sounds okay for delivery notifications.

Regards,
Vikas Tandon
Arciis Software Technologies
www.arciis.com

   -------Original Message-------
   > From: Vijay K. Gurbani <[email-masked]>
   > Subject: Re: [Simple] return receipt and delivery status notification for MSRP
   > Sent: 03 Mar 2004 16:36:43
   >
   >  [email-masked] wrote:
   >  
   >  > Yes, in chunking, I think it is useful to get
   >  > delivery reports of chunks. Not for every chunk, but
   >  > for x number of them.
   >  
   >  Receipt of X chunks is a protocol-level status notification.
   >  I am confused -- what kind of DSNs are we talking about?
   >  Protocol level or user level?
   >  
   >  Opening a dialog box to the user and telling him or her
   >  that "The 9th chunk has been successfully delivered" will
   >  probably not impart too much information to the user.  But
   >  opening a dialog box that says "Message could not be
   >  delivered -- receiver exceeds disk quota to store the message"
   >  is more meaningful to the sender.
   >  
   >  User level DSNs may be influenced by presence (I agree with
   >  others who point out that presence is not a pre-requisite
   >  for guaranteed delivery) and by the type of IM session:
   >  page or session mode.
   >  
   >  For page mode, Hisham wants to be notified not only
   >  when the IM was delivered but also when it was read.
   >  On the other hand, I want to be only notified if the
   >  message could not be delivered (i.e. I would consider
   >  an intermediary accepting the IM on behalf of an offline
   >  receiver as successful delivery but would like to know if
   >  the receiver has run out of disk space or no longer has
   >  a login in that domain).
   >  
   >  - vijay
   >  
   >  
   >  _______________________________________________
   >  Simple mailing list
   >  [email-masked]
   >  https://www1.ietf.org/mailman/listinfo/simple
   -------Original Message-------

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 5 Mar 2004 07:40:52 +0900

On Mar 4, 2004, at 2:30 PM, vikas wrote:

> Hi,
>
>  Adding to what Vijay just mentioned, it would be annoying for the 
> user to get a notification

these can and probably will be consumed by automatons on behalf of the 
user without rendering the confirmation directly.

thx,
-rohan

> everytime that the message has been read by the target.
>
>  Typically the number of messages exchanged in IM will be greater than 
> that in email (if you would like to compare for read notification 
> purpose).
>

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 5 Mar 2004 07:40:52 +0900

thx,
-rohan