Subject: RE: [Simple] Inter-domain Requirements for SIMPLE

From: "Orit Levin" <[email-masked]>
Date: Sun, 29 Feb 2004 21:18:33 -0800

Inline.

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]] 
Sent: Sunday, February 29, 2004 8:33 PM
To: Orit Levin
Cc: Robert Sparks; IETF SIMPLE WG; Avshalom Houri
Subject: Re: [Simple] Inter-domain Requirements for SIMPLE

OK, now I understand.

I think that this is not really the requirement; this is once again 
really the main requirement here - optimizing message transfer between 
domains. 

OL: you are right that this specific new feature (7.1.2) is introduced
in order to build a mechanism to meet requirement 7.3 . That being said,
the draft identifies a number of orthogonal optimization approaches:
7.1.2, 7.2, and 7.3.

What you are proposing is one mechanism for achieving that, but 
not the only one.

OL: Are you saying that other optimization approaches can be introduced
(I would love to hear and explore each one of them) or are you saying
that a different mechanism for achieving 7.3 can be introduced? (Again,
let's hear/see it.)

-Jonathan R.

Orit Levin wrote:

> The requirement is for the case where a subscription to a group exists
> (i.e. the present information is available at the watchers' domain
> already). Upon getting the permission, a new watcher is added to the
> group and the presence information is delivered to it from its PS
> locally.
> 
> Hope it clarifies the case,
> Orit.
> 
> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: Saturday, February 28, 2004 7:11 AM
> To: Orit Levin
> Cc: Robert Sparks; IETF SIMPLE WG; Avshalom Houri
> Subject: Re: [Simple] Inter-domain Requirements for SIMPLE
> 
> Orit,
> 
> I am still confused on this requirement.
> 
> It sounds like what you want is for the watcher to find out if he has 
> permission to subscribe or fetch presence from the presentity, without

> actually subscribing or fetching? In other words, it would be a
request 
> from the watcher to the presentity to ask the presentity to set an 
> authorization policy for the watcher, in absence of any specific 
> subscription. Is that right?
> 
> If so, what is the motivating use case here?
> 
> THanks,
> Jonathan R.
> 
> Orit Levin wrote:
> 
> 
>>This requirement attempts to say:
>>
>>A potential watcher asks a presentity to grant access to presentity's
>>presence information, but the watcher (or more precisely, its PS) is
> 
> not
> 
>>interested in the presence information being pushed on individual
> 
> basis
> 
>>from this point on. In other words, it can be implemented by just
> 
> adding
> 
>>the watcher to presentity's ACL. Or in case of groups, adding the
>>requesting watcher to a specific group.
>>
>>Orit.
>>
>>-----Original Message-----
>>From: Robert Sparks [mailto:[email-masked]] 
>>Sent: Wednesday, February 25, 2004 8:48 AM
>>To: Orit Levin
>>Cc: IETF SIMPLE WG; Avshalom Houri
>>Subject: Re: [Simple] Inter-domain Requirements for SIMPLE
>>
>>Orit, Avshalom -
>>
>>Thanks for submitting this draft. You've captured some
>>important thoughts around deploying presence systems that
>>deserve attention. I particularly look forward to the
>>discussions we'll have around section 7.3 (Grouping of
>>Watchers for SHARING of Presence Info).
>>
>>One quick question: I don't understand what you're looking
>>for with the first requirement of 7.1:
>>
>>   o  Presence access: It MUST be possible to request continuous
>>      access to the status of a remote presentity without
>>      "subscribing" to it.
>>
>>Could you explain this a little more?
>>
>>RjS
>>
>>On Mon, 2004-02-23 at 17:33, Orit Levin wrote:
>>
>>
>>>Guys!
>>>We have submitted a requirements document for secure and efficient
>>>transfer of presence information over inter-domain links.
>>>Please, take a look at our thoughts and suggestions:
>>>
>>>
>>
>>
>
http://www.ietf.org/internet-drafts/draft-levin-simple-interdomain-reqs-
> 
>>00.txt
>>
>>
>>>We look forward to your feedbacks on how we can enhance SIMPLE to
>>>support these directions.
>>>
>>>Thanks,
>>>Orit.
>>
>>
>>
>>_______________________________________________
>>Simple mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/simple
>>
> 
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 01 Mar 2004 10:58:57 -0500

> that a different mechanism for achieving 7.3 can be introduced? (Again,

I am saying that we are early in this work, and I think it is good to 
start with the really main requirement here, "optimize message volume 
and bandwidth", and then let everything after that be an implementation 
approach.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 01 Mar 2004 10:58:57 -0500

-Jonathan R.