Subject: RE: [Simple] comments on draft-ietf-simple-xcap-list-usage-00

From: [email-masked]
Date: Mon, 1 Mar 2004 07:56:13 +0200

> -----Original Message-----
> From: ext Adam Roach [mailto:[email-masked]]
> Sent: 01.March.2004 06:28
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]'
> Subject: RE: [Simple] comments on draft-ietf-simple-xcap-list-usage-00
> 
> 
> 
> 
> One problem with this approach is that "name" is an
> optional attribute in the latest draft. If you remove
> URI to be an element, then it becomes difficult (if
> not impossible; I'm not an XPATH expert) to identify
> an entry.

That's not a problem. You can still identify an entry by its position, which xcap allows, btw.
> 
> There is strong motivation to have a very small notation
> for minimal list, along the lines of:
> 
>   <entry uri="sip:[email-masked]" />
>   <entry uri="sip:[email-masked]" />
>   <entry uri="sip:[email-masked]" />

Yes, I was thinking the same. If the uri in unique, why do we need name?

/Hisham

> 
> /a
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Sunday, February 29, 2004 20:34
> > To: [email-masked]
> > Subject: RE: [Simple] comments on 
> draft-ietf-simple-xcap-list-usage-00
> > 
> > 
> > Yes.
> > 
> > Instead of 
> > 
> > <entry name="hisham" uri="sip:[email-masked]">
> >   <display-name>Hisham Khartabil</display-name>
> > </entry>
> > 
> > I'm proposing:
> > 
> > <entry name="hisham">
> >   <uri>sip:[email-masked]</uri>
> >   <display-name>Hisham Khartabil</display-name>
> > </entry>
> > 
> > /Hisham
> > 
> > > -----Original Message-----
> > > From: ext Adam Roach [mailto:[email-masked]]
> > > Sent: 01.March.2004 03:48
> > > To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> > > Cc: Jonathan Rosenberg
> > > Subject: RE: [Simple] comments on 
> > draft-ietf-simple-xcap-list-usage-00
> > > 
> > > 
> > > 
> > > [email-masked] 
> > [mailto:[email-masked]] writes:
> > > 
> > > > - Section 3: and <entry> element has 2 attributes, name and 
> > > > uri. For xcap specific reasons, I understand why name needs 
> > > > to be an attribute
> > > 
> > > Yes, I agree that it does, and that the reasons are rather
> > > specific to XCAP.
> > > 
> > > > but I think it is much cleaner to have 
> > > > the uri as an element. It fits in better with the 
> > > > display-name element and other extensions that will go there.
> > > 
> > > So... are you proposing a change or not?
> > > 
> > > /a
> > > 
> > 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 1 Mar 2004 07:56:13 +0200

/Hisham

---

From: Adam Roach <[email-masked]>
Date: Mon, 1 Mar 2004 04:21:47 -0600

> Yes, I was thinking the same. If the uri in unique, why do we 

The stated motivation has been that SIP URI comparision rules
can be inefficient.

/a

---

From: [email-masked]
Date: Mon, 1 Mar 2004 18:55:17 +0200

So, you need name to be mandatory and then push URI into an element like I suggested.

/Hisham

> Sent: 01.March.2004 12:22
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); Adam Roach
> Cc: [email-masked]

---

From: [email-masked]
Date: Mon, 1 Mar 2004 18:55:17 +0200

/Hisham