Subject: [Simple] I-D ACTION:draft-ietf-simple-rpid-03.txt

From: [email-masked]
Date: Mon, 22 Mar 2004 15:44:32 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the SIP for Instant Messaging and Presence Leveraging Extensions Working Group of the IETF.

	Title		: RPID: Rich Presence: Extensions to the Presence Information Data Format (PIDF)
	Author(s)	: H. Schulzrinne, V. Gurbani, P. Kyzivat, J. Rosenberg
	Filename	: draft-ietf-simple-rpid-03.txt
	Pages		: 19
	Date		: 2004-3-22
	
The Rich Presence Information Data Format (RPID) adds elements to the
   Presence Information Data Format (PIDF) that provide additional
   information about the presentity and its contacts.  The information
   is designed so that much of it can be derived automatically, e.g.,
   from calendar files or user activity.

   This extension includes information about what the presentity is
   doing (the activity element), a grouping identifier for a tuple (the
   class element), the type of tuple (the contact-type element), whether
   a contact is idle (the idle element), the typle of place a presentity
   is in (the placetype element), whether the presentity is in a public
   or private space (the privacy element), the relationship of a tuple
   to another presentity (the relationship element), and the overall
   role of the presentity (the sphere element).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-simple-rpid-03.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-simple-rpid-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-simple-rpid-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: [email-masked]
Date: Thu, 25 Mar 2004 13:18:53 +0200

Hi,

I have the following comments (mainly just typos):

- Abstract: "typle" -> "type"
- 4.1: "urn:ietf:params:xml:ns:pidf:status:rpid-tuple" -> "status" to be removed
- 4.2: the sentence after the list of pre-defined activities states that "The <activity> element
MAY be qualified with the 'since' and 'until'..." -> I did not find support for this from XML Schema.
- 4.3 (Class): Also the authorisation use could be mentioned because the class element has quite a central
role in presence authorization.
- 4.4 "<contacttype>" -> "<contact-type>"
- 4.5 (Idle): the 'since' attribute could be mentioned in the text.
- 4.7 (Privacy): The example talks still about the "quiet" value.
- 4.7 (the last sentence): "The placetype element MAY be qualified with ..." -> "The <privacy> element MAY..."
- 5.1 (XML example / tuple having id="x765"):
	- outermost <ep:activity> </ep:activity> should be <ep:activities> and </ep:activities> 
	- <ep:privacy> has the value "quiet" which is no more supported by the <privacy> element
	- according to XML Schema the 'since' information should be provided by XML attribute instead of <idle> element's value 	as <ep:idle since="2003..."/>
- 5.1 (XML example / tuple having id="bs9r"):
	- <ep:privacy> has the value "quiet" which is no more supported by the <privacy> element
- 5.1 (XML example / tuple having id="eg92n"): 
	- namespace definition for 'nn' is missing (<nn:blah>)
- 6.1 and 6.2 (XML schemas): I did not find any reason to define the pidf namespace in the schema (see xmlns:pidf="urn...")

BR, Eva

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Henning Schulzrinne
> Sent: 23 March, 2004 01:23
> To: [email-masked]
> Subject: Re: [Simple] I-D ACTION:draft-ietf-simple-rpid-03.txt
> 
> 
> I believe that this draft incorporates all comments received 
> so far and 
> is ready for WGLC.
> 
> [email-masked] wrote:
> 
> > This draft is a work item of the SIP for Instant Messaging 
> and Presence Leveraging Extensions Working Group of the IETF.
> > 
> > 	Title		: RPID: Rich Presence: Extensions to 
> the Presence Information Data Format (PIDF)
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Thu, 25 Mar 2004 13:18:53 +0200

Hi,

BR, Eva