Subject: RE: [Simple] return receipt and delivery status notification for MSRP

From: "Eric Burger" <[email-masked]>
Date: Tue, 6 Apr 2004 14:29:39 -0400

And if the receiver is sensible, she will set her UAS options to never offer positive DSN, making it useless.

I could see putting it in the protocol if one was looking to deploy such a system where there were legal implications of a message being delivered (financial services?).  However, wouldn't e-mail be better for that?

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, April 06, 2004 3:02 AM
> To: Eric Burger; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Simple] return receipt and delivery status notification
> for MSRP
> 
> 
> 
> 
> > -----Original Message-----
> > From: ext Eric Burger [mailto:[email-masked]]
> > Sent: 05.April.2004 16:38
> > To: Ben Campbell
> > Cc: Chris Boulton; Khartabil Hisham (Nokia-TP-MSW/Helsinki);
> > [email-masked]
> > Subject: RE: [Simple] return receipt and delivery status 
> notification
> > for MSRP
> > 
> > 
> > 
> > Ben gets it in one...
> > 
> > As the sender of the message, there is no difference between 
> > any of the following scenarios:
> > 
> > 1. The message is delivered, but the user does not read it.
> > 2. The message is delivered, but the user ignores it.
> > 3. The message is delivered, the user reads it, but the user 
> > blocks receipt generation.
> > 4. The message is not delivered.
> > 
> > All of those scenarios, including #3, fall into the 
> > "Recipient did not get the message".
> 
> "Message is delivered" is not the same as "message is not 
> delivered". In cases 1-3, the sender knows that it was a 
> receiver action that stopped the MDN since he will get a DSN 
> saying that message is delivered.
> 
> /Hisham
> 
> > 
> > The security implications of #3 are more then enough to 
> > suggest that generating a Positive DSN on message receipt at 
> > a UAS is a bad idea.
> > 
> > On a separate thought, is the plan to have SIMPLE replace 
> > SMTP for messaging?  I thought SIMPLE was for real-time 
> > communications, while ESMTP, with its myriad of non-real-time 
> > certification facilities, would be the place for things like 
> > "Registered Delivery With Return Receipt Delivery With 
> > Signatures from Every Person That Handled the Message".
[snip]

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 06 Apr 2004 13:40:23 -0500

> I could see putting it in the protocol if one was looking to deploy such a system where there were legal implications of a message being delivered (financial services?).  However, wouldn't e-mail b…

The financial services market is really interested in IM, as some 
aspects of the industry tend to be highly time sensitive. (And, no, I am 
not arguing that IM is necessarily any faster than mail...)

---

From: Ben Campbell <[email-masked]>
Date: Tue, 06 Apr 2004 13:40:23 -0500