Subject: RE: [Simple] MSRP Details

From: [email-masked]
Date: Wed, 21 Apr 2004 09:36:47 +0300

Is the REPORT method part of MSRP? If yes, then what is wrong with using the status-code as is currently defined in MSRP draft?

Status-Code  = 200    ;Success
                    / 400    ;Bad Request
                    / 403    ;Forbidden
                    / 415    ;Unsupported Content Type
                    / 426    ;Upgrade Required
                    / 481    ;No session
                    / 506    ;duplicate session

I don't think you need to define your own for DSN here.

Thanks,
Hisham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Chris Boulton
Sent: 20.April.2004 17:41
To: [email-masked]
Cc: Ben Campbell
Subject: [Simple] MSRP Details

Hi to all on the list,

                        I've got a question that I wouldn't mind some input + closure on.  I am currently completing the DSN details for MSRP reports and in RFC 1894 - It specifies that the format for 'status' code in a DSN message is:-

status-code = DIGIT "." 1*3DIGIT "." 1*3DIGIT

This does not map exactly to an MSRP status code and I was trying to look at the best solution - does anyone have any input?

Should we spread the status code e.g. 200 = 2.0.0

OR

Use the last 3 digit field e.g. 0.0.200

I would appreciate some input.

Best Regards,

Chris Boulton.

------------------------------------------------
Chris Boulton
Ubiquity Software

Tel : +44 (0) 1633765600
Fax : +44 (0) 1633765601 
------------------------------------------------

This message has been scanned for viruses by MailControl, a service from BlackSpider Technologies.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Wed, 21 Apr 2004 08:35:24 -0500

The RFC1894 syntax for status-code is something like (from memory)

So our HTTP style codes do not naturally fit.

---

From: Ben Campbell <[email-masked]>
Date: Wed, 21 Apr 2004 08:35:24 -0500