Subject: RE: [Simple] WGLC: partial notification

From: [email-masked]
Date: Fri, 30 Apr 2004 09:27:19 +0300

Ok, I also agree that overlapping partial NOTIFYs complicate things without benefit. I also would like to propose explicitly disallowing overlapping full state and partial. I.e. A notifier must not issue a partial state NOTIFY without first receiving the 200 for a full state NOTIFY. I believe the converse is also required: the notifier must not issue a full state NOTIFY before it receives a 200 for a partial state NOTIFY.

With all there restrictions, we can do without the version attribute.

Regards,
Hisham

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: 29.April.2004 21:47
> To: Robert Sparks
> Cc: Khartabil Hisham (Nokia-TP-MSW/Helsinki); Lonnfors Mikko
> (Nokia-NRC/Helsinki); [email-masked]
> Subject: Re: [Simple] WGLC: partial notification
> 
> 
> 
> 
> Robert Sparks wrote:
> > Aside from that I'd like for you to think through this again
> > from viewpoints besides active attack (use a transient malfunction
> > of the application (above the layer that would screw up basic SIP)),
> > I'm ready to let this go as long as we have _a_ solid solution to
> > dealing with reordered/missing notifies.
> 
> I'm not going to start down the path to speculation about how 
> to recover 
> from arbitrary malfunctions of an application. That is just plain 
> impossible without some characterization of the kinds of malfunctions 
> that are to be recovered from.
> 
> > So, backing out a layer, lets look at my original question of
> > whether or not we allow overlapping ->partial<- NOTIFYs at all
> > in this case.
> 
> I don't see any compelling need to support overlapping 
> partial notifies. 
> It is very difficult to see how to make them work.
> 
> I can imagine a case where there might be some motivation: I sent one 
> notification and have had no response. But I already have a bunch of 
> additional changes that you should know about. It might be 
> advantageous 
> to start sending them as soon as possible. But until you know 
> the prior 
> one has been handled it isn't safe to send the new one.
> 
> > Why would you want to? What value would doing that bring? 
> > 
> > 3261 and even presence-10 left sending full-state presence
> > NOTIFYs open. We wouldn't be changing that. If an application
> > for some reason decided it needed to send a new full-state
> > notify while a partial-state notify was pending, it could.
> > So any of the arguments for allowing it from the 3261/presence-10
> > are still satisfied. Can you see any use case where allowing
> > a server to send overlapping partial NOTIFYs is a good idea?
> > If not, disallowing it seems a powerful simplification.
> >
> 
> I agree.
> 
> 	Paul
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Apr 2004 09:05:16 -0500

We need to have a call about this I guess. Are you still in today?
I'm available for the next hour, then out until Tuesday.

Assuming we don't get to talk until then:

 Chair comment: This is in danger of going off the rails. The comments
   (Christians) are of a nature you'd expect for the first or second
   drop of an individual submission - fundamental assumptions are
   being questioned. 

RjS

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Apr 2004 09:05:16 -0500

RjS

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Apr 2004 09:34:47 -0500

well - twice in one week - Guess its time to change email
programs.

My deep apologies to the list contributors, and particularly
to Mikko and Christian. 

My statement below was to my co-chair. Treat it as if you
overheard me speaking with him in the hallway. I was _NOT_
making an administrative statement to the group, and am 
chagrined to have sent it such that it could be misinterpreted
as such.

RjS

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Apr 2004 09:34:47 -0500

RjS