Subject: RE: [Simple] return receipt and delivery status notification for MSRP

From: "Eric Burger" <[email-masked]>
Date: Mon, 5 Apr 2004 09:37:36 -0400

Ben gets it in one...

As the sender of the message, there is no difference between any of the following scenarios:

1. The message is delivered, but the user does not read it.
2. The message is delivered, but the user ignores it.
3. The message is delivered, the user reads it, but the user blocks receipt generation.
4. The message is not delivered.

All of those scenarios, including #3, fall into the "Recipient did not get the message".

The security implications of #3 are more then enough to suggest that generating a Positive DSN on message receipt at a UAS is a bad idea.

On a separate thought, is the plan to have SIMPLE replace SMTP for messaging?  I thought SIMPLE was for real-time communications, while ESMTP, with its myriad of non-real-time certification facilities, would be the place for things like "Registered Delivery With Return Receipt Delivery With Signatures from Every Person That Handled the Message".

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Friday, April 02, 2004 2:55 PM
> To: Eric Burger
> Cc: Chris Boulton; [email-masked]; [email-masked]
> Subject: Re: [Simple] return receipt and delivery status notification
> for MSRP
> 
> 
> 
> 
> 
> 
> Eric Burger wrote:
> > nononononononono.
> > 
> > We are confusing two, different concepts here.  A DSN lets 
> the sender know that a relay attempt failed.  IMHO, a 
> positive DSN has not practical value (other than generating 
> information that "might be useful", but of no use).  
> ["Useful" information is how long it takes a message to 
> traverse the relays.  What user cares?]
> > 
> 
> I had not confused the concepts. I was arguing that it was 
> useful to get 
> a report saying that an IM was successfully delivered to the 
> endpoint. 
> That seems to me to fit the definition of DSN more than MDN. 
> But I might 
> be able to be convived otherwise (see below.)
> 
> > A MDN lets the sender know that the recipient received the message.
> > 
> > If you are a *user*, and you want to *know* if someone 
> received a message, you are going to request a MDN.
> 
> If I understand correctly, you are arguing that the useful 
> information 
> is not whether it was delivered to the endpoint, but whether the user 
> actually saw it. (Or consumer consumed it, to be more 
> generic.) Is that 
> the point?
> 
> If so, I do not have strong feelings one way or another. I am 
> willing to 
> accept that, for critical delivery, the thing I care about is 
> that the 
> message was consumed, rather than merely delivered.
> 
> But I continue to hold the opinion, that you need some form 
> of positive 
> acknowledgement for sufficiently important messages, whether it be 
> positive DSN or MDN. Negative DSN by themselves are 
> insufficent, because 
> they can also fail. Positive acknowledgement gives us a 
> fail-safe mode.
> 
> 
> > 
> > 
> > Let's look at two cases from the example again:
> > 
> > A --> R1 --> R2 --> B
> > 
> > First case:
> > A sends to R1
> > R1 tries to send to R2, but nobody is home.
> > R1 sends Failure DSN to A
> > A knows message was not delivered.  Why?  Because A 
> receives the DSN.
> > 
> > 
> > Second case:
> > A sends to R1
> > R1 sends to R2 (successfully - no DSN)
> > R2 disappears (no DSN)
> > A *knows* B did not get the message.
> > How does A know this?  Because A requested a MDN, and it 
> never got it.
> 
> To be pedantic, you do not know it was _not_ delivered. You just have 
> reason to believe it might not have been delivered. Close, 
> but not the 
> same. B may have ignored the MDN request, or the MDN itself may have 
> failed in transit.
> 
> > 
> > One might say that A cannot tell the difference between a 
> delivery failure and the user ignoring the message.  One 
> might say that one would be correct in that assertion, and 
> that is by design.
> > 
> 
> [...]
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Mon, 05 Apr 2004 09:57:02 -0500

> On a separate thought, is the plan to have SIMPLE replace SMTP for messaging?  I thought SIMPLE was for real-time communications, while ESMTP, with its myriad of non-real-time certification facilit…

I certainly hope we are not planning to replace mail. But does this 
absolve us from needing positive acknowledgement of delivery? I am not 
sure on this point.

---

From: Ben Campbell <[email-masked]>
Date: Mon, 05 Apr 2004 09:57:02 -0500