Subject: RE: [Simple] return receipt and delivery status notification for MSRP

From: "Vikas Tandon" <[email-masked]>
Date: Thu, 1 Apr 2004 10:51:14 +0530

Vijay, 
Thanks for summarizing this rather pending issue. Agree with Hisham on
session mode delivery notification on every message. One of the reasons
for session mode was to keep the notification traffic minimal. Also
would be interesting to know "being responded to" status as i might send
you "Hello Vijay " and at the same time you might be typing "Hey did you
get my email" unaware of what I'm going to say, in effect i don't know
if you are responding to "My Message" or writing your own. This surely
is a debatable issue, would be good to have more thoughts on this.
Regards,
Vikas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: mercredi 31 mars 2004 22:56
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Simple] return receipt and delivery status notification
for MSRP

This is a good summary, although point 4 can be debatable: How useful is
it to request receive notification in session mode?

/Hisham

> -----Original Message-----
> From: ext Vijay K. Gurbani [mailto:[email-masked]]
> Sent: 04.March.2004 16:53
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]; [email-masked]; Niemi Aki
> (Nokia-M/Espoo)
> Subject: Re: [Simple] return receipt and delivery status notification 
> for MSRP
> 
> 
> 
> [email-masked] wrote:
> 
> > It is optional. If it is annoying to you, then you don't
> > request a delivery notification. It is not every time and it is 
> > not mandatory.
> 
> So, just to be pedantic, please correct me if my summary below is 
> wrong:
> 
>    1/ We are interested in DSNs at the _user_ level, not the
>       _protocol_ level (i.e. the transactional model at the
>       protocol level is sufficient for protocol state
>       machines to figure out if an IM was delivered to the
>       next hop successfully or not).
>    2/ We should design protocol provisions such that a positive
>       acknowledgement DSN model is supported (let me know
>       the current state of the IM: queued, delivered, read,
>       being responded to, ...).
>    3/ We should design protocol provisions such that a negative
>       acknowledgement DSN model is supported (send it and
>       forget it unless something drastic happens, then
>       let me know).
>    4/ Both 2 and 3 should apply to page mode and session
>       mode IMs.
>    5/ Both 2 and 3 should be configurable by the sending
>       user.
> 
> Is this accurate?
> 
> Thanks,
> 
> - vijay
> --
> Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
> Wireless Networks Group/Internet Software and Services
> Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
> Naperville, Illinois 60566     Voice: +1 630 224 0216
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Vikas Tandon" <[email-masked]>
Date: Thu, 1 Apr 2004 10:51:14 +0530

Vijay, 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: mercredi 31 mars 2004 22:56
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]

/Hisham