Subject: AW: AW: [Simple] WGLC: partial notification

From: Schmidt Christian <[email-masked]>
Date: Fri, 30 Apr 2004 14:58:22 +0200

Hi Paul,

thank you for the comment. Concerning the tunnel case, it is a question, how often this would
happen. If it is a rare case, perhaps we can ignore it. If not, we can add a repetition option.

Modified proposal:
The notifier must not issue a NOTIFY (full or partial), before it receives a 200 for the last issued NOTIFY (full or partial). After experation of a timer t, the notifier should repeat the last message and if the timer t expires a second time, send a full NOTIFY.

Regards,
Christian

-----Ursprüngliche Nachricht-----
Von: Paul Kyzivat [mailto:[email-masked]] 
Gesendet: Freitag, 30. April 2004 14:48
An: Schmidt Christian
Cc: [email-masked]'; [email-masked]; [email-masked]; [email-masked]
Betreff: Re: AW: [Simple] WGLC: partial notification

Schmidt Christian wrote:
> Hi Hisham,
> 
> this proposal would not solve the problem with a missing NOTIFY (full or partial). 
> 
> What´s about the following proposal:
> The notifier must not issue a NOTIFY (full or partial), before it receives a 200 for the last issued NOTIFY (full or partial). After experation of a timer t, the notifier should send a full NOTIFY.
> 
> This would also work without version number and would cover reordering and packet loss cases.

This would work. I guess it is obvious that if the full notify also 
times out then further retries, if any, should also send full state. And 
that this should continue until there is success. A notify with partial 
state could only happen after receiving a 2xx for the prior notify.

OTOH, this might be a bad choice for a bandwidth constrained device, 
like a cell phone. If you are driving thru a tunnel and can't receive 
for a few minutes, are going to be happy to get a full update when you 
emerge?

	Paul

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 30 Apr 2004 09:24:41 -0400

I'd like to hear what the cellular guys think of this. (Are you one of 
them?)

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 30 Apr 2004 09:24:41 -0400

Paul