Subject: [Simple] MSRP Details

From: "Chris Boulton" <[email-masked]>
Date: Tue, 20 Apr 2004 15:41:10 +0100

Hi to all on the list,

                        I've got a question that I wouldn't mind some
input + closure on.  I am currently completing the DSN details for MSRP
reports and in RFC 1894 - It specifies that the format for 'status' code
in a DSN message is:-

status-code = DIGIT "." 1*3DIGIT "." 1*3DIGIT

This does not map exactly to an MSRP status code and I was trying to
look at the best solution - does anyone have any input?

Should we spread the status code e.g. 200 = 2.0.0

OR

Use the last 3 digit field e.g. 0.0.200

I would appreciate some input.

Best Regards,

Chris Boulton.

------------------------------------------------
Chris Boulton
Ubiquity Software

Tel : +44 (0) 1633765600
Fax : +44 (0) 1633765601 
------------------------------------------------

This message has been scanned for viruses by MailControl - www.mailcontrol.com

---

From: [email-masked]
Date: Wed, 21 Apr 2004 09:36:47 +0300

Is the REPORT method part of MSRP? If yes, then what is wrong with using the status-code as is currently defined in MSRP draft?

Status-Code  = 200    ;Success
                    / 400    ;Bad Request
                    / 403    ;Forbidden
                    / 415    ;Unsupported Content Type
                    / 426    ;Upgrade Required
                    / 481    ;No session
                    / 506    ;duplicate session

I don't think you need to define your own for DSN here.

Thanks,
Hisham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Chris Boulton
Sent: 20.April.2004 17:41
To: [email-masked]
Cc: Ben Campbell
Subject: [Simple] MSRP Details

Hi to all on the list,

                        I've got a question that I wouldn't mind some input + closure on.  I am currently completing the DSN details for MSRP reports and in RFC 1894 - It specifies that the format for 'status' code in a DSN message is:-

This does not map exactly to an MSRP status code and I was trying to look at the best solution - does anyone have any input?

OR

Best Regards,

Chris Boulton.

Tel : +44 (0) 1633765600
Fax : +44 (0) 1633765601 

This message has been scanned for viruses by MailControl, a service from BlackSpider Technologies.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Chris Boulton" <[email-masked]>
Date: Wed, 21 Apr 2004 08:10:22 +0100

Hisham - these are the codes that I want to represent in the DSN payload
of a REPORT method.  But the format of the status field in RFC 1894 is:-

e.g. 2.1.2

So the question was - How is best to represent this code in the DSN
payload, as per RFC 1894.

OR

OR 

Some other suggestion.

Regards,

Chris.

>From: [email-masked] [mailto:[email-masked]]
>Sent: 21 April 2004 07:37
>To: Chris Boulton; [email-masked]
>Cc: [email-masked]
>Subject: RE: [Simple] MSRP Details
>
>Is the REPORT method part of MSRP? If yes, then what is wrong with
using
>the status-code as is currently defined in MSRP draft?
>
>From: [email-masked] [mailto:[email-masked]]On Behalf Of
ext
>                        I've got a question that I wouldn't mind some
input
>+ closure on.  I am currently completing the DSN details for MSRP
reports
>and in RFC 1894 - It specifies that the format for 'status' code in a
DSN
>message is:-
look
>at the best solution - does anyone have any input?
>
>This message has been scanned for viruses by MailControl, a service
from
>BlackSpider Technologies.

---

From: "Chris Boulton" <[email-masked]>
Date: Wed, 21 Apr 2004 08:10:22 +0100

e.g. 2.1.2

OR

OR 

Some other suggestion.

Regards,

Chris.

using
ext
input
reports
DSN
look
from

---

From: [email-masked]
Date: Wed, 21 Apr 2004 10:27:14 +0300

Ok, sorry I misinterpreted what you were asking.

I would vote for 2.0.0 style. It is more appropriate and fits what RFC 1894 is trying to do, IMHO.

Thanks,
Hisham

> From: ext Chris Boulton [mailto:[email-masked]]
> Sent: 21.April.2004 10:10
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]

---

From: [email-masked]
Date: Wed, 21 Apr 2004 10:27:14 +0300

Thanks,
Hisham