Subject: RE: [Simple] WGLC: partial notification

From: [email-masked]
Date: Fri, 23 Apr 2004 20:23:55 +0300

Hi,

Your proposal sounds good. Probably the sentence "When one tuple
changes, a new document containing the full set of tuples is delivered."
should read something like -> "When any number of tuples change, a new
document containing the full set of tuples is delivered"

- Mikko

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of ext Robert Sparks
> Sent: Friday, April 23, 2004 6:33 PM
> To: [email-masked]
> Subject: Re: [Simple] WGLC: partial notification
> 
> 
> The abstract for -partial-notification needs to focus 
> more on what the document is defining. I suggest this
> as a replacement for the current text:
>                                                               
>                  Abstract
> 
>    By default, presence delivered using the Presence Event
>    Package for the Session Initiation Protocol is represented
>    in the Presence Information Data Format (PIDF). A PIDF
>    document contains a set of tuples, each representing
>    a different aspect of the presence being reported. When
>    one tuple changes, a new document containing the full set
>    of tuples is delivered. This memo defines an extension
>    allowing delivery of a new document type that contains
>    information about only those tuples that have actually
>    changed.
> 
> On Wed, 2004-04-21 at 09:55, Robert Sparks wrote:
> > This is a Working Group Last call on the following drafts:
> > 
> > 
> http://www.ietf.org/internet-drafts/draft->
ietf-simple-partial-notify-0
> > 2.txt
> > 
> http://www.ietf.org/internet-drafts/draft-ietf-simple-partial-
pidf-format-01.txt
> 
> This abbreviated WGLC will end on Wednesday, April 28.
> 
> These drafts went through a previous last call at the beginning of 
> March. These versions reflect changes due to comments received during 
> that period. See 
> https://www1.ietf.org/mail-archive/working-groups/simple/current/msg02
> 519.html
> for details.
> 
> Please send comments to the list, copying the editor. If you reviewed 
> the draft and found no issues, please indicate so on the list.
> 
> RjS
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Robert Sparks <[email-masked]>
Date: Fri, 23 Apr 2004 12:31:57 -0500

That's more correct, but to emphasize the extent of the optimization
being defined, maybe:

"When any subset of the tuples change, even a just a single tuple,
a new document containing the full set of tuples is delivered."

RjS

---

From: Robert Sparks <[email-masked]>
Date: Fri, 23 Apr 2004 12:31:57 -0500

RjS