Subject: RE: [Simple] WGLC on RPID, CIPID and future status [Future]

From: [email-masked]
Date: Wed, 12 May 2004 09:20:05 +0300

Hi,

> > - 4. Schema: shouldn't the PIDF namespace be imported in the XML
> > Schema?
> 
> They are.
> xmlns:pidf="urn:ietf:params:xml:ns:pidf"

What I actually ment was that in addition to the namespace definition the XML Schema of PIDF 
should be imported as <xs:import namespace="urn:ietf:params:xml:ns:pidf"/>, shouldn't it?

BR, Eva

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Thu, 13 May 2004 14:39:54 +0300

Hi,

> should be imported as <xs:import 
> namespace="urn:ietf:params:xml:ns:pidf"/>, shouldn't it?
> 
> BR, Eva

Yes, that should be added. 
Also, schema is missing target namespace attribute. Schema has defined
"urn:ietf:params:xml:ns:pidf:timed-status" as default namespace but this
is not enough. I believe
targetNamespace="urn:ietf:params:xml:ns:pidf:timed-status" attribute
should be included.

- Mikko

---

From: [email-masked]
Date: Thu, 13 May 2004 14:39:54 +0300

Hi,

- Mikko

---

From: [email-masked]
Date: Sun, 16 May 2004 21:04:07 +0300

> 
> 
> > What I actually ment was that in addition to the namespace 
> definition 
> > the XML Schema of PIDF
> I looked at my local schema documentation, but couldn't find why this 
> declaration would be needed both in the schema element itself 
> and as an 
> import. After all, the other namespaces (e.g., xmlns:xs) are not 
> imported separately. Just curious...

I don't fully understand these XML details but I think 
xmlns:pidf="urn:ietf:params:xml:ns:pidf" 
Declaration only defines the addressing of "urn:ietf:params:xml:ns:pidf"
namespace in the target namespace. Separate import is needed to tell the
schema processor that a schema document contains such a reference. More
details can be found from:
http://www.w3.org/TR/2001/REC-xmlschema-1-20010502/#element-import

And my XMLSpy doesn't validate the schema without 
<xs:import> namespace="urn:ietf:params:xml:ns:pidf"/>

- Mikko

---

From: [email-masked]
Date: Sun, 16 May 2004 21:04:07 +0300

- Mikko