Subject: RE: [Simple] WGLC on RPID, CIPID and future status [CIPID]

From: [email-masked]
Date: Wed, 12 May 2004 16:51:53 +0300

I think this is more useful than having an icon representing the tuple. I want to visually represent my status (Sick in bed image for my boss and on a beach bed for my friends).

/Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Henning Schulzrinne
> Sent: 12.May.2004 16:14
> To: Anders Kristensen
> Cc: [email-masked]
> Subject: Re: [Simple] WGLC on RPID, CIPID and future status [CIPID]
> 
> 
> > IMHO this is not needed and may well lead to confusion 
> about where to 
> > place these elements.
> 
> I think the only case where this makes some sense is for the 
> icon, but 
> the meaning of the icon in <status> is a bit different, as it would 
> reflect the state of the presentity (sleeping, mowing the 
> lawn, etc.), 
> rather than the presentity itself. The revised (02) text 
> restricts all 
> CIPID elements to the root or tuple level.
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 May 2004 10:09:43 -0400

I think this should be a separate element, as the two uses are rather 
different. I do think that state icons are useful (we had discussed this 
in the what's-a-tuple discussion, I think).

[email-masked] wrote:

> I think this is more useful than having an icon representing the
> tuple. I want to visually represent my status (Sick in bed image for
> my boss and on a beach bed for my friends).
> 
> /Hisham

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 May 2004 10:09:43 -0400

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 15 May 2004 17:41:12 -0400

> my boss and on a beach bed for my friends).

I think this fits better with RPID, since it's not really contact 
information. This also avoids commingling presence and status elements 
in CIPID, with all the additional namespace registration complexity that 
this entails. (I'd have to add a whole new namespace for this one 
element in CIPID.)

Henning

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 15 May 2004 17:41:12 -0400

Henning