Subject: RE: [Simple] Presence Rules Issue 1: Provide Contact URI defaults

From: [email-masked]
Date: Wed, 12 May 2004 22:24:24 +0300

Hi,

I also support the original proposal to have "provide-contact-uri" as a permission. It is true that if the user by default has no rules the contact is then not provided at all, but for instance the service provider could have some default rules pre-provisioned for new users, if the starting point seen by the user seems otherwise too restrictive.

Markus 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Ben Campbell
> Sent: 07 May, 2004 00:54
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] Presence Rules Issue 1: Provide Contact URI
> defaults
> 
> 
> I concur.
> 
> 
> [email-masked] wrote:
> 
> > I vote for 1.
> > 
> > /Hisham
> > 
> > 
> >>-----Original Message-----
> >>From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> >>ext Jonathan Rosenberg
> >>Sent: 30.April.2004 22:30
> >>To: Simple WG
> >>Subject: [Simple] Presence Rules Issue 1: Provide Contact 
> URI defaults
> >>
> >>
> >>There is currently a permission called provide-contact-uri that 
> >>specifies which tuples the contact-uri should be provided in. 
> >>Like many 
> >>of the other permissions, you can specify which tuples to 
> >>include it in 
> >>  based on the values of a few other rpid parameters.
> >>
> >>The problem is that, for privacy safety, the default of all 
> of these 
> >>sets needs to be the empty set. As a result, the default 
> will be that 
> >>you never include a contact URI. If you want one in every 
> >>tuple, you'd 
> >>have to add this:
> >>
> >><provide-contact-uri>
> >>   <all-tuples/>
> >></provide-contact-uri>
> >>
> >>in every permission statement. Or, you could turn it on 
> "globally" by 
> >>specifying a rule that applied to everyone (i.e., all domains you 
> >>communicate with), which granted just this specific permission.
> >>
> >>There is also no way to say that the contact URI is to be 
> provided in 
> >>"barebones" tuples that have no other RPID information in them.
> >>
> >>My concern is that I think that, in practice, it will be 
> >>expected that 
> >>contact is nearly always provided, and so you'll have to have this 
> >>permission pretty much all the time. The "real" default - 
> in terms of 
> >>what a user might expect - is not the same as the default of the 
> >>permission itself.
> >>
> >>Our options are:
> >>
> >>1. who cares, its fine, just add the permission
> >>2. remove the provide-contact-uri permission, and always include a 
> >>contact uri
> >>
> >>My proposal is (1). Thoughts?
> >>
> >>-Jonathan R.
> >>-- 
> >>Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> >>Chief Technology Officer                    Parsippany, NJ 
> 07054-2711
> >>dynamicsoft
> >>[email-masked]                     FAX:   (973) 952-5050
> >>http://www.jdrosen.net                      PHONE: (973) 952-5000
> >>http://www.dynamicsoft.com
> >>
> >>
> >>_______________________________________________
> >>Simple mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/simple
> >>
> > 
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 17 May 2004 04:15:40 -0400

[email-masked] wrote:

> Hi,
> 
> I also support the original proposal to have "provide-contact-uri" as
> a permission. It is true that if the user by default has no rules the
> contact is then not provided at all, but for instance the service
> provider could have some default rules pre-provisioned for new users,
> if the starting point seen by the user seems otherwise too
> restrictive.

Yes, thats possible. But, if the provider sets such a default, then 
there would be no way for the user to restrict its distribution, because 
permissions are additive.

I think that, in any case, we have consensus around this point, to keep 
the permission as it stands now.

Thanks,
Jonathan R.

Chief Technology Officer                    Parsippany, NJ 07054-2711

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 17 May 2004 04:15:40 -0400

Thanks,
Jonathan R.