Subject: RE: [Simple] WGLC: prescaps

From: [email-masked]
Date: Wed, 19 May 2004 16:02:37 +0300

Hi,

> > I think this only applies to <mobility>, <class>, <duplex>, and 
> > <actor>. These are defines as enumerated types. All the 
> other ones are 
> > strings.
> > 
> 
> So you are saying that <event-package>, <methods>, <extension> and 
> <scheme> do not need that treatment because they are 
> currently defined 
> as strings, which is the current situation, but wrong in my opinion.
> 
> If you take a look at the Callee capabilities, all these 
> media fetures 
> refer to their respective IANA registry for the list of 
> possible values 
> that can be used. This, translated into XML, sounds like usage of 
> tokens. But since we concluded that tokens are not extensible 
> in XML, we 
> should user elements are Jonathan proposed. What I disagree 
> is to allow 
> a free string rather than "a value out of a collection". I think this 
> will kill the purpose of the XML structured information.

With currect schema this would look like:

<methods>
	<method>INVITE</method>
	<method>MESSAGE</method>
</methods>

If I understand your proposal this would be:

<methods>
	<INVITE/>
	<MESSAGE/>
<methods>

Advantage in your proposal is that you can use XML parser to validate
that only valid method names are being used. Also it would allow method
specific extensions. However, I have at least one issue which should be
solved before taking this approach. Correctly we have the 'negated'
attribute which can be used with any <method> element (and <scheme>,
etc). Now, I think we want that this same attribute is also usable for
all future methods as well. If we take your approach there should be
mechanism which would enable/force usage of this attribute also in
extensions. For time being I am not sure how to do this.
 
> Then we have <priority>. I am confused with this one. Callee 
> Caps defins 
> it as an integer, but the fact that there is a mapping 
> between possible 
> values of the integer and human-readable values makes me doubt.

I am not sure I get this. Can you provide an example?
 
- Mikko 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Thu, 20 May 2004 21:12:26 +0300

> extensions. For time being I am not sure how to do this.

I understand your concern. My preference is (if possible) to define the 
suppported attribute in the "template". I don't know if the schema is 
valid, but something like this:

<xs:element name="activity" minOccurs="0">
            <xs:complexType>
              <xs:sequence>
                <xs:element ref="ts:methods"
                  minOccurs="1" maxOccurs="1">
                    <attribute name="supported" type="xs:boolean"/>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>

And then each method will inherit the attribute (I guess).

<xs:element name="INVITE" substitutionGroup="ts:methods"/>

And an example:

<methods>
    <INVITE/>
    <REFER supported="no"/>
</methods>

But as I said, I haven't checked if the syntax is legal in XML.

> I am not sure I get this. Can you provide an example?

Yes. The problem is that callee capabilities defines the sip.priority as 
a media feature tag whose value is an integer. Therefore, we have a 
continuous value. However, callee capabilities also maps some values 
into discrete values, and this sounds more like a token kind of thing. 
According to callee caps:

       Each
       integral value corresponds to one of the possible values of the
       Priority header field as specified in SIP [1]. The mapping is
       defined as:

       non-urgent: Integral value of 10. The device supports non-urgent
          calls.

       normal: Integral value of 20. The device supports normal calls.

       urgent: Integral value of 30. The device supports urgent calls.

       emergency: Integral value of 40. The device supports calls in the
          case of an emergency situation.

I was just saying that it is not clear to me whether this is an integer 
or a token. Perhaps it should be an integer like callee caps.

- Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Research Center      Helsinki, Finland

---

From: Miguel Garcia <[email-masked]>
Date: Thu, 20 May 2004 21:12:26 +0300

And an example:

<methods>
    <INVITE/>
    <REFER supported="no"/>
</methods>

       Each

- Miguel