Subject: Re: [Simple] WGLC on RPID, CIPID and future status [CIPID]

From: Schmidt Christian <[email-masked]>
Date: Fri, 14 May 2004 15:08:31 +0200

Hi Henning,

we are quite happy with the current RPID draft (draft-ietf-simple-rpid-04). Nevertheless we propose the following changes:

(1) Addition of a very helpful new RPID Element:

MOOD Element

The <mood> element describes the current mood of the presentity, for example angry, tired, happy and aggressive. This information could be very helpful to a watcher, especially if he want to achieve something from the presentity. 

The <mood> element could be handled according to the <sphere> element. There are allready good experiences with mood in the IM area.

(2) Separate namespace:

With the current RPID version, the argument for doing this (4.1.Introdution):
"This document uses a separate namespace for extending the PIDF ´status´ namespace, in accordance with Section 4.2.5 of [7]."

In [7], I found:
"Although the existing PIDF definition allows arbitrary elements to appear in the <status> element, it may be sometimes desirable to standardize extension status elements and their semantics (the meanings of particular statuses, how they should be interpreted)."

It would be helpful for the reader, to explain the cause for the usage of two URIs in this special case in few sentences.

Best regards,
Christian Schmidt

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 16 May 2004 19:52:29 -0400

[Changing subject to be more meaningful.]

Schmidt Christian wrote:

> The <mood> element describes the current mood of the presentity, for
> example angry, tired, happy and aggressive. This information could be
> very helpful to a watcher, especially if he want to achieve something
> from the presentity.
> 
> The <mood> element could be handled according to the <sphere>
> element. There are allready good experiences with mood in the IM
> area.

This is something I've always talked about in jest...  The problem I 
have is that I can't see a good automated way of determining moods, so 
we'd have to exclusively rely on people's self-assessment.

I did find

http://www.jabber.org/jeps/jep-0107.html

which proposes something like that for Jabber and references a listing 
of mood values in Wireless Village.

I'm happy to include it, but I'm worried and anxious that this will lead 
to extended discussions whether the list is sufficiently complete.

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 16 May 2004 19:52:29 -0400

I did find

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 16 May 2004 20:20:42 -0400

> 
> (2) Separate namespace:
> 
> With the current RPID version, the argument for doing this
> (4.1.Introdution): "This document uses a separate namespace for
> extending the PIDF ´status´ namespace, in accordance with Section
> 4.2.5 of [7]."
> 
> In [7], I found: "Although the existing PIDF definition allows
> arbitrary elements to appear in the <status> element, it may be
> sometimes desirable to standardize extension status elements and
> their semantics (the meanings of particular statuses, how they should
> be interpreted)."
> 
> It would be helpful for the reader, to explain the cause for the
> usage of two URIs in this special case in few sentences.

This should probably say that this follows 4.2.5 and 4.3.2. I don't see 
the document mentioning much about this, but since there are two 
subspace registrations for ns:pidf and ns:pidf:status, it makes sense to 
keep them separate for the extensions.

However, I believe we had decided that unlike the example in PIDF 
Section 4.2.5, that this is a separate namespace, not just extending 
targetNamespace="urn:ietf:params:xml:ns:pidf:status"

Better ways of expressing this are welcome.

> 
> Best regards, Christian Schmidt
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 16 May 2004 20:20:42 -0400

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 17 May 2004 11:14:21 -0500

> we'd have to exclusively rely on people's self-assessment.

Unfortunately, self-assessment seems necessary here, unless someone has
invented an introspection machine.

> to extended discussions whether the list is sufficiently complete.

That protocol attempted to be complete but, naturally, someone will
always claim that some important and essential mood was excluded. I'm
of the opinion that getting 80% or 90% coverage is sufficient in this
context.

Peter

-- 
Peter Saint-Andre
Jabber Software Foundation
http://www.jabber.org/people/stpeter.php

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 17 May 2004 11:14:21 -0500

Peter