Subject: RE: [Simple] XML schema validation

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 18 May 2004 13:07:13 +0300

Miguel,

There is an XML Directorate within the IETF that could help - http://www.apps.ietf.org/xml-directorate.html

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Miguel Garcia
> Sent: 18 May, 2004 12:50 PM
> To: SIMPLE mailing list
> Subject: [Simple] XML schema validation
> 
> 
> Hi:
> 
> As you know the SIMPLE WG is specifying a bunch of documents 
> that define 
> some kind of XML schema. We have seen in the last days that documents 
> which almost concluded WGLC include schemas that do not validate with 
> common validation tools.
> 
> I have the feeling that there might be a few of these WG 
> documents where 
> the XML schema contain some errors. I am really worried with the 
> potential publication of an RFC where the schema is not valid.
> 
> I would like to propose some procedure to guarantee that the 
> documents 
> that we send to the IESG for review contain a well-formed and valid 
> schema definition. As a minimum I propose that the authors of 
> the draft 
> are responsible for validating the schema before the document is 
> published as an I-D.
> 
> I also proposed that the chairs get confirmation from the 
> authors about 
> the validity of the schema prior to submitting the document 
> to the IESG.
> 
> I also encourage folks with validating tools to provide 
> feedback to the 
> mailing list and authors about XML schemas defined in WG documents. I 
> think this feedback should be both positive (yeah, Tool Foo says is a 
> valid schema) and negative.
> 
> How about it?
> 
> Regards,
> 
>          Miguel
> 
> 
> -- 
> Miguel A. Garcia           tel:+358-50-4804586
> Nokia Research Center      Helsinki, Finland
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Tue, 18 May 2004 13:35:12 +0300

Dan,

Thanks for the pointer. It complements my proposal. But in a way, I 
don't see how the XML directorate has been involved so far in the SIMPLE WG.

 From the XML directory web page:

    "WG Chairs and individuals responsible for I-Ds that employ XML are
     urged to request review early in the review process of an I-D."

Have we missed the above?

- Miguel

---

From: Miguel Garcia <[email-masked]>
Date: Tue, 18 May 2004 13:35:12 +0300

Dan,

- Miguel