Subject: RE: [Simple] XCAP issue 5: selecting multiple elements

From: [email-masked]
Date: Fri, 21 May 2004 09:39:46 +0300

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Jonathan Rosenberg
> Sent: 20.May.2004 18:15
> To: Urpalainen Jari (Nokia-NRC/Helsinki)
> Cc: ext Joel M. Halpern; Simple WG
> Subject: Re: [Simple] XCAP issue 5: selecting multiple elements
> 
> 
> Folks,
> 
> Joel sent me a note pointing out a problem in nesting:
> 
> > It is actually possible (but presumably accidental) for 
> there to be nesting in a replacement case.
> > Given a starting document fragment
> > <a id="1">
> >    <b id="2">
> >        <c id="3"> V </c>
> >    </b>
> >    <b id="4">
> >         <c id="5"> X </c>
> >    </b>
> > </a>
> > 
> > And given a put expression that days doc//a[@id="1"] | 
> a[@id="1"]/b[@id="2"]
> > And as the content
> > <a id="1">
> >    <b id="2">
> >        <c id="3"> Y </c>
> >    </b>
> >    <b id="4">
> >         <c id="5"> Z </c>
> >    </b>
> > </a>
> > <b id="2">
> >    <c id="3"> W </c>
> > </b>
> > 
> > We need to define the order of application, and note that 
> there is no order such 
>  > that a get will produce the same thing as the put.  I am not sure 
> what you think
>  > should happen in this case, from your text.
> 
> This is a good point.
> 
> My conclusion was that there was never really a point in doing a PUT 
> that was nested; you would only repeat data twice. As such, my 
> preference would be to just not allow this.

I don't see why someone would do that and therefore don't see any reason to explicitly disallow it. A warning or a note will suffice, IMO.

/Hisham

> 
> The implication is, that when the server got the PUT, it 
> would have to 
> verify that none of the URI components were children of any of the 
> others. This undoubtedly adds to the complexity of the server side 
> processing.
> 
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 21 May 2004 07:20:49 -0400

inline.

> I don't see why someone would do that and therefore don't see any reason to explicitly disallow it. A warning or a note will suffice, IMO.

Sorry for not being clear on this.

As Joel points out, there is no way to process the PUT such that a GET 
of the document returns what was in the PUT. Thus, allowing this at all 
will fundamentally break the xcap model. Since there is no reason for it 
anyway, I believe it must be disallowed.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 21 May 2004 07:20:49 -0400

inline.

-Jonathan R.