Subject: RE: [Simple] WGLC Extension for RPID, CIPID and future status [RPID]

From: [email-masked]
Date: Thu, 13 May 2004 15:02:55 +0300

Hi,

Rpid-status schema seems to miss targetnamespace attribute. At least my
XMLSpy refuses to validate it without:
targetNamespace="urn:ietf:params:xml:ns:pidf:status:rpid-status"

- Mikko

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of ext [email-masked]
> Sent: Wednesday, May 12, 2004 4:07 PM
> To: [email-masked]
> Subject: RE: [Simple] WGLC Extension for RPID, CIPID and future status
> 
> 
> Henning has made available new versions. If you have not 
> looked at the versions that were WGLCed but plan to review, 
> please use those.
> 
http://www.cs.columbia.edu/sip/draft/rpid/draft-ietf-simple-rpid-04.txt
http://www.cs.columbia.edu/sip/draft/cipid/draft-ietf-simple-cipid-02.tx
t
http://www.cs.columbia.edu/sip/draft/timed-status/draft-ietf-simple-futu
re-02.txt

Thanks,
Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Thu, 13 May 2004 15:02:55 +0300

Hi,

- Mikko

Thanks,
Hisham

---

From: [email-masked]
Date: Mon, 17 May 2004 09:47:40 +0300

Hi,

I think 
xmnls:ts="urn:ietf:params:xml:ns:pidf:status:rpid-status"
^^^^^^
Should be ->
xmlns:ts="urn:ietf:params:xml:ns:pidf:status:rpid-status"

Then it seems that definition of ts:foo is missing.

- Mikko

> Behalf Of ext Henning Schulzrinne
> Sent: Monday, May 17, 2004 4:49 AM
> To: Jonathan Rosenberg
> Cc: Garcia Miguel.An (Nokia-NRC/Helsinki); [email-masked]
> Subject: Re: [Simple] WGLC Extension for RPID, CIPID and 
> future status [RPID]
> 
> 
> I can't make the schema validate; any schema hints are most welcome:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <xs:schema 
> xmlns:xs="http://www.w3.org/2001/XMLSchema" 
> xmnls:ts="urn:ietf:params:xml:ns:pidf:status:rpid-status" 
> elementFormDefault="qualified" attributeFormDefault="unqualified">
>    <xs:import namespace="http://www.w3.org/XML/1998/namespace" 
> schemaLocation="http://www.w3.org/2001/xml.xsd"/>
>    <xs:annotation>
>      <xs:documentation xml:lang="en">
>      Describes RPID status extensions for PIDF.
>      </xs:documentation>
>    </xs:annotation>
>    <xs:element name="activity">
>      <xs:complexType>
>        <xs:sequence>
>          <xs:element ref="ts:foo"/>
>        </xs:sequence>
>      </xs:complexType>
>    </xs:element>
>    <xs:element name="phone" substitutionGroup="ts:foo"/> </xs:schema>
> 
> 
>

---

From: [email-masked]
Date: Mon, 17 May 2004 09:47:40 +0300

Hi,

I think 

- Mikko