Subject: RE: [Simple] WGLC: prescaps

From: [email-masked]
Date: Wed, 19 May 2004 10:02:29 +0300

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext [email-masked]
> Sent: 18.May.2004 20:15
> To: Garcia Miguel.An (Nokia-NRC/Helsinki); [email-masked]
> Cc: [email-masked]
> Subject: RE: [Simple] WGLC: prescaps
> 
> 
> > 
> > - In all the boolean elements you have a "negated" attribute that 
> > puzzles me. Its name is really obscure. For instance:
> > 
> >       <event-package negated="false">presence.winfo</event-package>
> > 
> > So this is a double negation, and its not clear enough. I 
> > would propose 
> > to replace the negative logic by a positive logic. Perhaps you are 
> > looking for a "supported" attribute rather than "negated". 
> > The example 
> > would be rewritten as:
> > 
> >       <event-package supported="true">presence.winfo</event-package>
> > 
> > The meaning in both examples is the same, but supported is 
> > clearer (IMHO).
> 
> This might be an issue if you think that these documents are processed
> by humans. I am not sure it this matters for automates. But if others
> think that this change makes sense I can do it.
> 

I think "negated" is that is used in callee caps. But would it make more sense to use ! in the element values instead?

/Hisham 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 19 May 2004 10:17:11 +0300

Calle caps uses an exclamation mark to indicate the negation. For instance:

    events="!presence,winfo"

I don't think we want to use exclamation marks in XML. So the options 
are either keep the "negated" attribute that perhaps reassembles callee 
caps or go for something more human readable, such as "supported".

- Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Research Center      Helsinki, Finland

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 19 May 2004 10:17:11 +0300

events="!presence,winfo"

- Miguel

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 19 May 2004 08:50:36 -0400

Yes, the negated was intended as a literal replacement for the !.
And I agree that it often (maybe always) seems awkward and unnatural in use.

Chaning the word from 'negated' to 'supported' would alter nothing 
semantically, but I think it would be an improvement for readability.

	Paul

Miguel Garcia wrote:
>>>> So this is a double negation, and its not clear enough. I would 
>>>> propose to replace the negative logic by a positive logic. Perhaps 
>>>> you are looking for a "supported" attribute rather than "negated". 
>>>> The example would be rewritten as:
>>>>
>>>> The meaning in both examples is the same, but supported is clearer 
>>>> (IMHO).
>>>
>>>
>> I think "negated" is that is used in callee caps. But would it make 
>> more sense to use ! in the element values instead?
>>
>> /Hisham 
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 19 May 2004 08:50:36 -0400

Paul