Subject: RE: [Simple] WGLC on RPID, CIPID and future status [CIPID]

From: [email-masked]
Date: Wed, 12 May 2004 12:28:43 +0300

Hi,

One use case would be that there is an icon (or a sound) describing especially the status element (and its value), and
another CIPID element describing (or related to) information inside a tuple in general. Or there could be even two icon elements: one inside the status element (closely related to status value) and another inside the tuple.

I was also thinking if there are some reasons not to allow CIPID elements inside the status? Anyway, it'd be good to 
clearly mention if CIPID elements are not supported inside the status element.

BR, Eva 

> -----Original Message-----
> From: ext Henning Schulzrinne [mailto:[email-masked]]
> Sent: 12 May, 2004 05:33
> To: Leppanen Eva-Maria (Nokia-NET/Tampere)
> Cc: [email-masked]; Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Subject: Re: [Simple] WGLC on RPID, CIPID and future status [CIPID]
> 
> 
> Thanks, Eva, for your comments.
> 
> Same drill: new draft at
> http://www.cs.columbia.edu/sip/draft/cipid/draft-ietf-simple-c
> ipid-02.html
> 
> Last-minute comments most welcome.
> 
> [email-masked] wrote:
> 
> > I was also thinking whether is should be mentioned that the CIPID 
> > elements can be placed also inside the <status> element.
> 
> Good question. Does it make sense to allow this as a status extension?
> What would be the advantage?
> 
> Henning
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 12 May 2004 12:28:43 +0300

Hi,

BR, Eva

---

From: [email-masked]
Date: Wed, 12 May 2004 16:51:53 +0300

I think this is more useful than having an icon representing the tuple. I want to visually represent my status (Sick in bed image for my boss and on a beach bed for my friends).

/Hisham

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Henning Schulzrinne
> Sent: 12.May.2004 16:14
> To: Anders Kristensen
> Cc: [email-masked]
> > IMHO this is not needed and may well lead to confusion 
> about where to 
> > place these elements.
> 
> I think the only case where this makes some sense is for the 
> icon, but 
> the meaning of the icon in <status> is a bit different, as it would 
> reflect the state of the presentity (sleeping, mowing the 
> lawn, etc.), 
> rather than the presentity itself. The revised (02) text 
> restricts all 
> CIPID elements to the root or tuple level.
>

---

From: Schmidt Christian <[email-masked]>
Date: Fri, 14 May 2004 15:08:31 +0200

Hi Henning,

we are quite happy with the current RPID draft (draft-ietf-simple-rpid-04). Nevertheless we propose the following changes:

(1) Addition of a very helpful new RPID Element:

MOOD Element

The <mood> element describes the current mood of the presentity, for example angry, tired, happy and aggressive. This information could be very helpful to a watcher, especially if he want to achieve something from the presentity. 

The <mood> element could be handled according to the <sphere> element. There are allready good experiences with mood in the IM area.

(2) Separate namespace:

With the current RPID version, the argument for doing this (4.1.Introdution):
"This document uses a separate namespace for extending the PIDF ´status´ namespace, in accordance with Section 4.2.5 of [7]."

In [7], I found:
"Although the existing PIDF definition allows arbitrary elements to appear in the <status> element, it may be sometimes desirable to standardize extension status elements and their semantics (the meanings of particular statuses, how they should be interpreted)."

It would be helpful for the reader, to explain the cause for the usage of two URIs in this special case in few sentences.

Best regards,
Christian Schmidt