Subject: RE: [Simple] WGLC on isComposing draft

From: [email-masked]
Date: Tue, 4 May 2004 10:31:19 +0300

> -----Original Message-----
> From: ext Henning Schulzrinne [mailto:[email-masked]]
> Sent: 22.April.2004 20:18
> To: Paul Kyzivat
> Cc: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> Subject: Re: [Simple] WGLC on isComposing draft
> 
> 
> 
> 
> 
> Paul Kyzivat wrote:
> 
> > I like it. I see one new thing that I consider small:
> > 
> > - I'm a little concerned about the idle timeout being as 
> small as 10 
> > seconds. Personally, I am often inclined to stop and think 
> in the middle 
> > of composing an IM, which could trigger the idle transition fairly 
> > often. This might generate more traffic than we might like.
> 
> I'm happy to raise it to 30 seconds. It is a configured 
> interval, so you 
> could have a philosopher mode that triggers messages less 
> frequently and 
> an ADD mode that indicates idle sooner...
> 

It is a SHOULD in the draft, so that claiming it is configurable is not really true. I think 30 seconds is way too long. I felt 10 seconds was more appropriate. Are you composing if you are sitting and thinking what you want to type for more than 10 seconds? I don't know. Perhaps 15 seconds does it.

/Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 04 May 2004 22:25:09 -0400

> It is a SHOULD in the draft, so that claiming it is configurable is
> not really true. I think 30 seconds is way too long. I felt 10

Actually, it says that the default value (out of the box) SHOULD be X 
seconds, but that the value may be configurable by the user. I did not 
specify an automatic teenager vs. John Kerry detector.

> seconds was more appropriate. Are you composing if you are sitting
> and thinking what you want to type for more than 10 seconds? I don't
> know. Perhaps 15 seconds does it.

I don't know if there's a way to scientifically pick this. Since I 
can't, I'll take your compromise.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 04 May 2004 22:25:09 -0400