Subject: [Simple] Question on Partial Publish

From: "George Foti (QA/EMC)" <[email-masked]>
Date: Tue, 18 May 2004 10:38:23 -0500

Hi Eva-Maria,

Can you please clarify in section 4.2  on generation of PUBLISH request what you mean by the PUA MUST NOT change the content type between the full and partial event state publications.

Thxn/gf

---

From: [email-masked]
Date: Wed, 19 May 2004 09:52:11 +0300

Hi George and others,

I copy the whole chapter here first: 
"The PUA MUST publish a full event state to form a basis for an event state and version information before publishing one or more partial event states.  Additionally, the PUA MUST NOT change the content type between the full and partial event state publications."

With the sentence you asked the draft tries to clarify more the previous sentence so that the content type cannot be changed between a "sequence" of partial publications (always starting with the full state publication using the pidf-partial content type). E.g., it's not possible for a PUA to publish a full event state using the PIDF content type and continue publishing partial event states after that. Or it is not allowed to publish as follows: 

1. full event state (pidf-partial content type)
2. partial event state (pidf-partial content type)
3. full event state (pidf content type)
4. partial event state (pidf-partial content type)

However, the following would be possible:

1. full event state (pidf-partial content type)
2. partial event state (pidf-partial content type)
3. full event state (pidf content type)
4. full event state (pidf-partial content type)
5. partial event state...

I admit that the sentence should be either rephrased or removed.

BR, Eva
-----Original Message-----
From: ext George Foti (QA/EMC) [mailto:[email-masked]]
Sent: 18 May, 2004 18:38
To: Leppanen Eva-Maria (Nokia-NET/Tampere); [email-masked]
Subject: [Simple] Question on Partial Publish 

Hi Eva-Maria, 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 19 May 2004 09:52:11 +0300

Hi George and others,

BR, Eva
-----Original Message-----
From: ext George Foti (QA/EMC) [mailto:[email-masked]]
Sent: 18 May, 2004 18:38
To: Leppanen Eva-Maria (Nokia-NET/Tampere); [email-masked]
Subject: [Simple] Question on Partial Publish 

Hi Eva-Maria,

---

From: "George Foti (QA/EMC)" <[email-masked]>
Date: Wed, 19 May 2004 09:36:25 -0500

I am now even more confused.
Let me try and say it differently.
If a PUA  intentds to use Partial PUBLISH, then it must always use the content type pidf-partial from the outset.

Is that what you are trying to say?
Thnx/gf

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Wednesday, May 19, 2004 2:52 AM
> To: George Foti (QA/EMC); [email-masked]
> Subject: RE: [Simple] Question on Partial Publish 
> 
> 
> Hi George and others,
> 
> "The PUA MUST publish a full event state to form a basis for 
> an event state and version information before publishing one 
> or more partial event states.  Additionally, the PUA MUST NOT 
> change the content type between the full and partial event 
> state publications."
> 
> With the sentence you asked the draft tries to clarify more 
> the previous sentence so that the content type cannot be 
> changed between a "sequence" of partial publications (always 
> starting with the full state publication using the 
> pidf-partial content type). E.g., it's not possible for a PUA 
> to publish a full event state using the PIDF content type and 
> continue publishing partial event states after that. Or it is 
> not allowed to publish as follows: 
> 
> Can you please clarify in section 4.2  on generation of 
> PUBLISH request what you mean by the PUA MUST NOT change the 
> content type between the full and partial event state publications.
> Thxn/gf 
>

---

From: "George Foti (QA/EMC)" <[email-masked]>
Date: Wed, 19 May 2004 09:36:25 -0500