Subject: RE: [Simple] Update to xcap authorization rules

From: [email-masked]
Date: Mon, 17 May 2004 11:30:32 +0300

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Jonathan Rosenberg
> Sent: 17.May.2004 10:57
> To: Isomaki Markus (Nokia-NRC/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Simple] Update to xcap authorization rules
> 
> 
> 
> > 
> > Another thing that currently there seems to be no way of controlling
> > child elements of <presence>, e.g. <note>, which is not within any
> > tuple. This is allowed by PIDF, so maybe there should be a
> > "provide-..." element explicitely for it.
> 
> I think the only thing is actually note, since basic status has to be 
> included I think. I can add a provide-note.

Note: There can appear more than one <note> element. Would <provide-note> provide all notes?

/Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Aki Niemi <[email-masked]>
Date: Wed, 19 May 2004 14:20:21 +0300

ext [email-masked] wrote:
>>> Another thing that currently there seems to be no way of
>>> controlling child elements of <presence>, e.g. <note>, which is
>>> not within any tuple. This is allowed by PIDF, so maybe there
>>> should be a "provide-..." element explicitely for it.
>> 
>> I think the only thing is actually note, since basic status has to
>> be included I think. I can add a provide-note.
> 
> 

I at least think it should, since I think the only reason for having 
multiple notes would be to give each one their own 'xml:lang' attribute 
value.

Cheers,
Aki

> /Hisham
> 
> _______________________________________________ Simple mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 20 May 2004 06:25:33 -0400

> multiple notes would be to give each one their own 'xml:lang' attribute 

Yes, I also agree. Please take a look at the email I just sent on 
presence rules issue 4, where I think these "provide-X" things should 
not support complicated selection rules which allow you to say for which 
tuples you were talking about.

I think what we'll find is that, if I really want to control information 
differently in different tuples, this manifests itself by me simply 
providing you with some tuples and not others, in which case you'll get 
the <note> that was in the tuples you get.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 20 May 2004 06:25:33 -0400

-Jonathan R.