Subject: RE: [Simple] WGLC: Event Filtering

From: [email-masked]
Date: Thu, 8 Jul 2004 11:55:03 +0300

> -----Original Message-----
> From: Miguel Garcia [mailto:[email-masked]]
> Sent: 07.July.2004 17:16
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Simple] WGLC: Event Filtering
> 
> 
> Khartabil Hisham (Nokia-TP-MSW/Helsinki) wrote:
> 
> > 
> >>b) Implementations MUST support this MIME type.
> > 
> > 
> > Functionality draft issue.
> > 
> 
> M.G: I think I expressed myself wrong, because obviously it does not 
> make sense that you define a MIME type and in the same 
> document you say 
> that implementations MUST suppport it, so I agree with you. 
> But I think 
> the text I am looking for is something that indicates that when an 
> implementation encodes a Filter Criteria document, it MUST set the 
> Content-Type header (or whatever protocol) to simple-filter+xml. Then 
> the functionality draft can say that implementations MUST 
> support filter 
> criteria documents.

We don't want to dictate how a filter arrives at a server or what protocol is used to upload such filters. Content-type header gives the false impression that this XML document is only used with SUBSCRIBE requests. A filter can be uploaded using some other means than SIP SUBSCRIBE.

> 
> 
> > 
> >>c) Filter criteria documents MUST be sent setting the 
> Content-Type to 
> >>"simple-filter+xml".
> > 
> > 
> > Functionality draft issue.
> > 
> 
> No, this is what I said in point b) above, I think this 
> should be stated 
> in the filter criteria format.
> 
> 
> > 
> >>- Namespaces prefixes. There are many elements that accept 
> a namespace
> >>prefix to identify the correct element. The question is, 
> where is the
> >>binding between the namespace and the prefix defined? None of the
> >>examples show this binding, but all of them refer to "pidf", "rpid",
> >>"wi" namespaces. For instance, this is an excerpt from an example:
> >>
> >>          <simple-filter:include type="xml-element">
> >>            //pidf:tuple/pidf:status/pidf:basic[rpid:class="IM"
> >>            or rpid:class="SMS" or rpid:class="MMS"]
> >>          </simple-filter:include>
> >>
> >>Where is it define that "rpid" refers to either
> >>urn:ietf:params:xml:ns:pidf:rpid-tuple or
> >>urn:ietf:params:xml:ns:pidf:status:rpid-status? And to which one?
> >>
> >>I see two possible solutions. One is that you use the regular
> >>prefix-namespace binding used in XML. The only problem is that this
> >>binding refers to elements that you use in your XML 
> document. However,
> >>you want to prefix ***values*** that refer, in turn, to an 
> >>XML element.
> >>It is not quite the same thing. For instance, if you want 
> to use rpid
> >>and pidf, you could use the following <filter-set> element.
> >>
> >><filter-set xmlns:n="urn:ietf:params:xml:ns:simple-filter"
> >>     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> >>     xsi:schemaLocation="urn:ietf:params:xml:ns:simple-filter"
> >>     xmlns:rpid="urn:ietf:params:xml:ns:pidf:rpid-tuple"
> >>     xmlns:pidf="urn:ietf:params:xml:ns:pidf"
> >>     elementFormDefault="qualified"
> >>     attributeFormDefault="unqualified">
> > 
> > 
> > I don't believe this is the right solution. As you said, 
> those apply to qualifying elements not values of elements.
> > 
> > 
> >>The other solution is that you explicitly define some XML <binding>
> >>element as part of your schema. This will be used to define 
> >>the binding
> >>you use later. Something like:
> >>
> >><filter-set xmlns:n="urn:ietf:params:xml:ns:simple-filter"
> >>     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> >>     xsi:schemaLocation="urn:ietf:params:xml:ns:simple-filter"
> >>     elementFormDefault="qualified"
> >>     attributeFormDefault="unqualified">
> >>
> >>     <binding xmlns:rpid="urn:ietf:params:xml:ns:pidf:rpid-tuple"/>
> >>     <binding xmlns:pidf="urn:ietf:params:xml:ns:pidf"/>
> > 
> > 
> > This works. I used 
> > 
> > <ns-bindings>
> >   <ns-binding prefix="rpid" 
> urn="urn:ietf:params:xml:ns:pidf:rpid-tuple"/>
> >   <ns-binding prefix="pidf" urn="urn:ietf:params:xml:ns:pidf"/>
> > </ns-bindings>
> > 
> > Is this acceptable?
> > 
> > 
> 
> Yes, at least to me.

Ok, I'll add.

> 
> 
> >>
> 
> >>- Section 3.3.1.1. The first paragraph is ok, but the 
> remaining of the
> >>section has nothing to do with the 'type' attribute. I 
> >>believe the rest
> >>should be moved to Section 4, as it discusses the syntax.
> > 
> > 
> > I moved to section 3.3.1 where <include> is defined.
> > 
> 
> I don't think it makes much sense. Basically, most of the 
> section 3.3.1 
> speaks about syntax of Xpath expressions, which happens to be the 
> subject of section 4. I see a duplication. So you should 
> choose how to 
> document it, but make sure you don't repeat "syntax" sections.

Sorry, typo. I did move to section 4.

Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Thu, 08 Jul 2004 13:09:09 +0300

> We don't want to dictate how a filter arrives at a server or what protocol is used to upload such filters. Content-type header gives the false impression that this XML document is only used with SU…

Hisham, as you know, a Content-Type header is not SIP-specific. It is 
available for SIP, HTTP, e-mail, etc. This header just describes the 
type of body, irrespective the protocol used to transfer the contents. 
So even if you use HTTP or MSRP (crazy, I know it, just a hypothetical 
example) to transfer a filter criteria document, still you will need to 
populate the Content-Type header with a simple-filter+xml.

As a consequence, I believe the filter format document should state that 
whatever is the protocol you use to transfer the contents, the MIME type 
is set to simple-filter+xml, so is the Content-Type header.

Regards,

       Miguel
-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Research Center      Helsinki, Finland