Subject: [Simple] <display-name> syntax in draft-ietf-simple-cipid-03

From: "Orit Levin" <[email-masked]>
Date: Fri, 23 Jul 2004 16:57:14 -0700

Henning,
The new <display-element> appears in the text of
draft-ietf-simple-cipid-03 but was unfortunately omitted from the XML
schema.
I would like to confirm the right syntax of the <display-name> by
running the following example through you and the list:
 
    <?xml version="1.0" encoding="UTF-8"?>
         <presence xmlns="urn:ietf:params:xml:ns:pidf"
                   xmlns:es="urn:ietf:params:xml:ns:pidf:rpid-status"
                   xmlns:ci="urn:ietf:params:xml:ns:pidf:cipid"
          entity="sip:[email-masked]">
           <tuple id="0">
             <status>
               <basic>open</basic>
                     <es:activities>
               <es:activity>on-the-phone</es:activity>
             </es:activities>
             </status>
             <contact>sip:[email-masked]</contact>
             <ci:display-name>Tom Jones</ci:display-name>
           </tuple>
           <ci:display-name>Tom Jones</ci:display-name>
         </presence>
 
Is this compliant with the XML schema that will be included in the next
version?
 
Thanks a lot,
Orit.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 23 Jul 2004 21:17:01 -0400

Oops - I had updated the schema, but not copied it into the draft. (If 
somebody knows how to include files within CDATA, let me know...). You 
can see the schema at

http://www.cs.columbia.edu/sip/draft/cipid/cipid.xsd

Extensions in PIDF appear before <contact>, so your tuple example is 
slightly wrong, since the PIDF schema reads, in part,

          <xs:element name="status" type="tns:status"/>
          <xs:any namespace="##other" processContents="lax" minOccurs="0"
             maxOccurs="unbounded"/>
          <xs:element name="contact" type="tns:contact" minOccurs="0"/>
          <xs:element name="note" type="tns:note" minOccurs="0"
             maxOccurs="unbounded"/>

Thanks for catching this.

Orit Levin wrote:

> Henning,
> 
> The new <display-element> appears in the text of draft-ietf-simple-cipid-03 but was unfortunately omitted from the XML schema.
> 
> I would like to confirm the right syntax of the <display-name> by running the following example through you and the list:
> 
>  
> 
> Is this compliant with the XML schema that will be included in the next version?
> 
>  
> 
> Thanks a lot,
> 
> Orit.
> 
>  
>