Subject: RE: [Simple] Re: MSRP: Max message size indication

From: "Gunnar Hellstrom" <[email-masked]>
Date: Wed, 30 Jun 2004 21:55:19 +0200

Thanks Cullen, for helping to make the goals and intentions of the real time text
conversation work more known to all by telling "T.140 jokes". :-)

---------snip-----------
>
>And if it is set to 1 it means you are in character by character T.140 mode
>:-) The previos line is a joke I'm not suggesting that
>
---------snip------------

Appreciated.

Gunnar
-------------------------------------------
Gunnar Hellström
Omnitor AB
Renathvägen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 01 Jul 2004 10:34:34 -0700

On 6/30/04 6:37 AM, "Ben Campbell" <[email-masked]> wrote:

> I don't want to solve that problem just yet. _But_, do you really
> consider a real time text usage of MSRP by sending one character per
> chunk to be acceptable? Talk about a bandwidth explosion. I think we
> will need something more complicated for that to work.

I don't think this would it be used across 300 baud modems - no. Would
anyone care if I did it across my broadband DSL/Cable connection? I really
doubt it. The same can be said of voice or video over a network. This media
has different bandwidth usage characteristics and will be used where
appropriate.  

I find the whole bandwidth argument on this uninteresting - the bandwidth
used is more than traditional IM and less than voice - that's about all you
can say on the bandwidth. Would it be used on a cell phone network? I don't
know - depends on much per byte they change and what the value of this mode
is. I point out, it is less bandwidth than voice no matter how you count it.
On a compressed link, it will compress to very little bandwidth.

The the MSRP draft allows you send very short message, like one character. I
send one and two character IMs all the time. We are already somewhat doing
this - what we are talking about is a hint about if a chunk should be
displayed before the whole message is received or not.

Cullen

---

From: [email-masked]
Date: Wed, 7 Jul 2004 10:20:42 +0300

I haven't seen any technical arguments against it besides the arguments I made about how that number is calculated. People felt that the number calculation is local policy.

People who want this feature feel very strongly about it and obviously have a need for it. I take Ben's word that it is trivial to specify, so unless someone brings forward technical arguments against having it in, then it will be in, but under one condition: any valid technical arguments brought forward that might cause delay will result in removing that feature.

So Ben, please go ahead an specify it in the next version. We can still take a hum at the meeting in San Diego to confirm.

Thanks,
Hisham

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: 06.July.2004 18:02
> To: Drage, Keith (Keith); Khartabil Hisham (Nokia-TP-MSW/Helsinki);
> Robert Sparks
> Cc: [email-masked]
> Subject: Re: [Simple] Re: MSRP: Max message size indication
> 
> 
> Hi Keith,
> 
> I am sensitive to your concern, and my initial position was 
> to push back 
> on _any_ new MSRP features at this time. You are correct, the 
> votes were 
> about even from the people who responded.
> 
> I pretty much gave in to the feature because it is fairly trivial to 
> specify, doesn't appear to break anything, and it began to look like 
> less work to add it than to argue about it. Its presence in 
> Jonathan's 
> Advanced Messaging Requirements document gave some weight to the 
> argument to put it in. We can discuss whether that document is 
> authoritative, but that gives us even more time spent arguing.
> 
> So, perhaps the chairs would like to assert a final opinion on the 
> consensus about this item?
> 
> Drage, Keith (Keith) wrote:
> > Having reread the entire thread, the only winner I have 
> seen in this vote is Christer Holmberg for the sheer number 
> of messages sent. If that is the criteria that is being used 
> for decision, then you should have made this clear at the 
> beginning. What I do see from the list is that the balance of 
> the votes was pretty even, even on the send capability. I do 
> not call that rough working consensus.
> > 
> > What I am seeing here is feature creep. People are 
> justifying their arguments on the basis that it does not take 
> much time to add a particular feature, therefore lets add it. 
> What this means is that this continues to happen and we never 
> get the deliverable out of the door.
> > 
> > We saw it happen in SIP, we are seeing it happen in 
> sdp-new, and we are seeing it happen now in XCAP as well.
> > 
> > MSRP is needed pretty damn soon.
> > 
> > Can we please stop the feature creep and deliver what is 
> already in the document, and deal with other stuff as extensions.
> > 
> > regards
> > 
> > Keith Drage
> > 
> > 
> > 
> >>-----Original Message-----
> >>From: Ben Campbell [mailto:[email-masked]]
> >>Sent: 28 June 2004 20:57
> >>To: Christer Holmberg (JO/LMF)
> >>Cc: Adam Roach; [email-masked]; [email-masked]'; 'Paul
> >>Kyzivat'; [email-masked]; [email-masked]
> >>Subject: Re: [Simple] Re: MSRP: Max message size indication
> >>
> >>
> >>I believe the conclusion is to allow signaling max size you wish to 
> >>receive, but not to signal the max you intend to send.
> >>
> >>Christer Holmberg (JO/LMF) wrote:
> >>
> >>
> >>>Hi,
> >>>
> >>>So, do we have some kind of conclusion on this?
> >>>
> >>>Some people have asked for use-cases, and scenarios where 
> >>
> >>this can be useful, and I think a number of those have now 
> >>been presented.
> >>
> >>>Regards,
> >>>
> >>>Christer Holmberg
> >>>Ericsson Finland
> >>>
> >>>
> >>>
> >>>
> >>>>-----Original Message-----
> >>>>From: Paul Kyzivat [mailto:[email-masked]]
> >>>>Sent: 15. kesäkuuta 2004 2:04
> >>>>To: [email-masked]
> >>>>Cc: Adam Roach; [email-masked]'; 
> >>>>[email-masked]; Christer
> >>>>Holmberg (JO/LMF); [email-masked]; Ben Campbell
> >>>>Subject: Re: [Simple] Re: MSRP: Max message size indication
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>Alex Audu wrote:
> >>>>
> >>>>
> >>>>>I think there is great value in  end-point being able to 
> >>
> >>signal the 
> >>
> >>>>>maximum size of data it is
> >>>>>willing /able to accept at a time. This information could 
> >>>>
> >>>>be used by the 
> >>>>
> >>>>
> >>>>>sender to, for example
> >>>>>send a less memory intensive version of say an image, 
> >>>>
> >>>>instead of a full 
> >>>>
> >>>>
> >>>>>blown memory hungry
> >>>>>version.  This will allow the information to be 
> >>
> >>communicated with a 
> >>
> >>>>>decreased risk of truncation
> >>>>>at first try. That makes for a more efficient 
> communication (than 
> >>>>>without this feature).
> >>>>
> >>>>This is the most compelling argument for this feature that I 
> >>>>have seen.
> >>>>
> >>>>	Paul
> >>>>
> >>