Subject: RE: [Simple] RE: [Sipping] RE: text/T140 andaudio/t140 was:[avt]Comments/questions on draft-ietf-av

From: [email-masked]
Date: Fri, 2 Jul 2004 12:02:03 +0300

There is no hostility here. We are negotiating the usefulness of it. Some people prefer IM, others prefer interactive text, so it might an additional value service or a waste of implementer's time. No one knows.

I would never, for example, use real time text since I, like many people in the world, am a very slow typist, make many typos and change my mind a lot about what I should say or how I should say it.

One comment inline...

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Arnoud van Wijk
> Sent: 25.June.2004 12:51
> To: 'Paul E. Jones'; 'Paul Kyzivat'; 'Guido Gybels'
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Simple] RE: [Sipping] RE: text/T140 andaudio/t140
> was:[avt]Comments/questions on draft-ietf-av
> 
> 
> Good point Paul!
> 
> Also..I want to point it out again...
> WE ARE NOT TALKING ABOUT REPLACING INSTANT MESSAGING WITH 
> INTERACTIVE TEXT!
> 
> Most of you already know that. But just today I met another 
> person who still
> thinks Interactive text is to replace IM.
> 
> I do not understand the hostility from several IM people. 
> Interactive text
> is even going to make IM better! See it as an additional 
> valuable service
> for IM.
> Users exchange IM messages, and then a discussion starts, 
> they switch over
> into real-time chat mode. Discuss things, work out plans in 
> real-time. Then
> end the real-time chat mode.
> And the next 2 hours they exchange a few IM messages.

What makes this character-by-character (or x number of characters for 300ms) more interactive than IM in the scenario you describe above (besides the fact that you will see all my spelling mistakes, that I typed a message then changed my mind and deleted it)?

> 
> And I do hear from many ICQ users who miss the real-time chat 
> mode. That was
> easier to use. And with SIP, server load is not an issue 
> anymore, which
> caused ICQ to scrap this option.
> 
> Cheers
> 
> Arnoud
> 
> 
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> Of Paul E. Jones
> Sent: vrijdag 25 juni 2004 1:16
> To: 'Paul Kyzivat'; 'Guido Gybels'
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> Subject: RE: [Simple] RE: [Sipping] RE: text/T140 and audio/t140
> was:[avt]Comments/questions on draft-ietf-av
> 
> Paul,
> 
> > I accept your point that IM isn't suitable for a bunch of the
> > communication needs of the hearing impaired. (Among 
> others.) But I also
> > want you to accept that RTT isn't a suitable substitute for 
> IM in the
> > applications that millions (actually probably 10s or 100s 
> of millions)
> > of people use it everyday.
> 
> ICQ once had a mode wherein one could send 
> character-at-a-time and it worked
> pretty well (may still be in there).  What was nice about it 
> was that one
> could begin his/her reply even before the other person 
> finished his/her
> message.  I found the two-way exchange much better than 
> today's IM systems,
> as there was virtually no delay-- it was real-time.
> 
> One of the reasons why the IM systems today have problems in 
> scaling is that
> they have to interface with servers that handle message 
> exchange between all
> those users you spoke about.  The farm of servers to run the 
> existing IM
> systems do a lot of work and it's not a trivial task.  The 
> problem with the
> model is that farm of central servers that receive and 
> dispatch messages.
> (Perhaps SIMPLE has done something to improve on the current state of
> technology, but I'll confess that I don't know.)
> 
> If we can solve the scalability issues required to handle 
> lots of voice and
> video streams flowing between users, then it would not take a 
> great leap to
> do the same thing for text (literally).  There may be more 
> text sessions,
> but the only change in resource requirements from blocks of 
> text and RTT are
> the resources required to process messages (as there are more 
> RTT packets).
> For voice, those fifty or so packets per second would not flow through
> centralized servers and neither should the text.  If the 
> system operated
> allowing media to flow point-to-point, the RTT would scale.  
> I guess the
> question is whether we will be able to allow audio to flow 
> point-to-point or
> whether the FWs, NATs, "session border controllers", and such 
> devices will
> inhibit that.
> 
> Paul
> 
> 
> -
> This list is maintained by Snowshore Networks - 
http://www.snowshore.com
All comments on this list are the comments of the message originators and
Snowshore is not to be held responsible for any actions or comments found
on this list. The archives for this list can be found at
http://flyingfox.snowshore.com/toip_archive/maillist.html

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Mike Hammer <[email-masked]>
Date: Fri, 02 Jul 2004 11:52:49 -0400

Not really.  If this were an election, and money were votes, then the 
current state of the market is the count which says that most people, with 
no discrimination for/against their physical abilities, bought and 
therefore voted for IM over other RTT options that have been available in 
the past.

Your logic suggests that if only more people had voted for a candidate, 
then they would have liked that candidate. :)

Nice thing though, there is always room for niche markets.  And we need not 
be ruled by the tyranny of the majority.  And even the mainstream products 
try to cram every possible feature in over time.

Mike

At 10:05 AM 7/2/2004 +0100, Guido Gybels wrote:
>Hisham,
>
><<We are negotiating the usefulness of it. Some people prefer IM, others 
>prefer interactive text>>
>
>Precisely that argument is seriously flawed IMHO. In reality, the overall 
>majority of users only has access to IM, not RTT. To argue therefore that 
>a substantial amount of people actually prefer IM over RTT is IMHO flawed 
>logic.
>
>Guido
>
>
>************************************************************************
>This email and any files transmitted with it are confidential
>and intended solely for the use of the individual or entity to
>whom they are addressed. Any views or opinions expressed
>are solely those of the author and do not necessarily represent
>RNID policy.
>
>If you are not the intended recipient you are advised that any
>use, dissemination, forwarding, printing or copying of this
>email is strictly prohibited.
>
>If you have received this email in error please notify the RNID
>Helpdesk by telephone on: +44 (0) 207 296 8282.
>
>The Royal National Institute for Deaf People
>Registered Office 19-23 Featherstone Street
>London EC1Y 8SL No. 454169 (England)
>Registered Charity No. 207720
>************************************************************************
>
>