Subject: RE: [Simple] Re: MSRP: Max message size indication

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 5 Jul 2004 19:04:32 +0100

Having reread the entire thread, the only winner I have seen in this vote is Christer Holmberg for the sheer number of messages sent. If that is the criteria that is being used for decision, then you should have made this clear at the beginning. What I do see from the list is that the balance of the votes was pretty even, even on the send capability. I do not call that rough working consensus.

What I am seeing here is feature creep. People are justifying their arguments on the basis that it does not take much time to add a particular feature, therefore lets add it. What this means is that this continues to happen and we never get the deliverable out of the door.

We saw it happen in SIP, we are seeing it happen in sdp-new, and we are seeing it happen now in XCAP as well.

MSRP is needed pretty damn soon.

Can we please stop the feature creep and deliver what is already in the document, and deal with other stuff as extensions.

regards

Keith Drage

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: 28 June 2004 20:57
> To: Christer Holmberg (JO/LMF)
> Cc: Adam Roach; [email-masked]; [email-masked]'; 'Paul
> Kyzivat'; [email-masked]; [email-masked]
> Subject: Re: [Simple] Re: MSRP: Max message size indication
> 
> 
> I believe the conclusion is to allow signaling max size you wish to 
> receive, but not to signal the max you intend to send.
> 
> Christer Holmberg (JO/LMF) wrote:
> 
> > Hi,
> > 
> > So, do we have some kind of conclusion on this?
> > 
> > Some people have asked for use-cases, and scenarios where 
> this can be useful, and I think a number of those have now 
> been presented.
> > 
> > Regards,
> > 
> > Christer Holmberg
> > Ericsson Finland
> > 
> > 
> > 
> >>-----Original Message-----
> >>From: Paul Kyzivat [mailto:[email-masked]]
> >>Sent: 15. kesäkuuta 2004 2:04
> >>To: [email-masked]
> >>Cc: Adam Roach; [email-masked]'; 
> >>[email-masked]; Christer
> >>Holmberg (JO/LMF); [email-masked]; Ben Campbell
> >>Subject: Re: [Simple] Re: MSRP: Max message size indication
> >>
> >>
> >>
> >>
> >>Alex Audu wrote:
> >>
> >>>I think there is great value in  end-point being able to 
> signal the 
> >>>maximum size of data it is
> >>>willing /able to accept at a time. This information could 
> >>
> >>be used by the 
> >>
> >>>sender to, for example
> >>>send a less memory intensive version of say an image, 
> >>
> >>instead of a full 
> >>
> >>>blown memory hungry
> >>>version.  This will allow the information to be 
> communicated with a 
> >>>decreased risk of truncation
> >>>at first try. That makes for a more efficient communication (than 
> >>>without this feature).
> >>
> >>This is the most compelling argument for this feature that I 
> >>have seen.
> >>
> >>	Paul
> >>
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 06 Jul 2004 10:01:48 -0500

Hi Keith,

I am sensitive to your concern, and my initial position was to push back 
on _any_ new MSRP features at this time. You are correct, the votes were 
about even from the people who responded.

I pretty much gave in to the feature because it is fairly trivial to 
specify, doesn't appear to break anything, and it began to look like 
less work to add it than to argue about it. Its presence in Jonathan's 
Advanced Messaging Requirements document gave some weight to the 
argument to put it in. We can discuss whether that document is 
authoritative, but that gives us even more time spent arguing.

So, perhaps the chairs would like to assert a final opinion on the 
consensus about this item?