Subject: RE: [Simple] RE: XCAP Directory: Large response ?

From: "George Foti (QA/EMC)" <[email-masked]>
Date: Fri, 2 Jul 2004 07:39:09 -0500

A potential solution is for a client to be able to ask either of the following questions:
1) Give me a *maximum* of X bytes ranges Z onwards
2) Give me a *maximum* of X bytes ranges Y-Z

The XCAP server should return in a successfull response an XML document that is schema compliant that does not exceed the *maximum* range. The client can then perform operations on such a document.
A request could fail for multiple reasons, no document meets the maximum length, server does not understand the schema, etcc..

The above implies that XCAP servers must understand different schemas, but that may be unavoidable for some operations.
The other thing, I dont know if HTTP headers do allow for the above.

Rgds/gf

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of Henrik Albertsson (KI/EAB)
> Sent: Friday, July 02, 2004 6:38 AM
> To: 'Miguel Garcia'; ext Jonathan Rosenberg
> Cc: [email-masked]
> Subject: [Simple] RE: XCAP Directory: Large response ?
> 
> 
> I agree with you Miguel that the "give me X byte" solution is 
> not usable for the reasons you mentioned. However most likely 
> the XCAP client will operate on a well known AUDI and have 
> knowledge about what the structure of the XCAP document is so 
> it can roughly estimate what size 30 elements would be. 
> 
> Is it so that when specifying a XCAP document we also need to 
> define what element will be used for indexing when asking for 
> a range of elements? 
> 
> Regards
> /Henrik 
> 
> 
> 
> > -----Original Message-----
> > From: Miguel Garcia [mailto:[email-masked]]
> > Sent: den 2 juli 2004 12:14
> > To: ext Jonathan Rosenberg
> > Cc: Henrik Albertsson (KI/EAB); [email-masked]
> > Subject: Re: XCAP Directory: Large response ?
> > 
> > 
> > Jonathan Rosenberg wrote:
> > 
> > > 
> > > I would propose that we not put this functionality in xcap 
> > itself, but 
> > > use the existing HTTP mechanisms. I will note that these 
> > mechanisms are 
> > > *byte* oriented, and not XML oriented. Thus, you may cut an 
> > element off 
> > > in the middle by asking for the first 50 bytes. However, if 
> > your main 
> > > concern is bandwidth or latency, then bytes are much more 
> > significant of 
> > > a measure than elements. If I say, "give me 30 elements", 
> > that could be 
> > > 30 bytes or 30MB, depennding on the amount of data in 
> each element.
> > > 
> > > -Jonathan R.
> > > 
> > 
> > Jonathan, I think the HTTP byte ranges will not work. Let's say I 
> > request a long document, and I request bytes 1 to 10000. The 
> > HTTP server 
> > will cut the XML document exacltly when the number of bytes 
> > has reached 
> > the count, and will send it to the XCAP client. The XCAP 
> client can't 
> > check if the document is well-formed, not even check if it is valid 
> > according to the XML schema. As a consequence, it won't 
> display it to 
> > the user, or dare to do any operation on it. The only thing 
> the XCAP 
> > client can do is to request the next byte range.
> > 
> > I am concerned with the limited amount of memory a device 
> might have, 
> > AND the bandwidth. The latter can be solved with byte 
> ranges, but not 
> > the former.
> > 
> > However, if we provide a mechanism to request ranges of 
> entries in a 
> > list, this will solve the problem: the XCAP server create a 
> valid XML 
> > document that complies with the schema and send it to the 
> > XCAP client. 
> > The client can request additional ranges once it has freed 
> > the memory. 
> > The drawback is that we cannot accurately control the bandwidth (we 
> > don't know how many bytes will come), but I don't think this 
> > is a big issue.
> > 
> > - Miguel
> > 
> > -- 
> > Miguel A. Garcia           tel:+358-50-4804586
> > Nokia Research Center      Helsinki, Finland
> > 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Fri, 02 Jul 2004 16:02:44 +0300

George:

I don't like this solution. It requires the XCAP server to do a "trial 
and error" of the XML document that will be send to the user. Build an 
XML document with "n" entries, if the size of the document exceeds X 
bytes, start reducing the number entries, one by one, until the result 
is less than X bytes. That's awful.

I believe we have two constraints here: one is the display size of the 
device and the other is the memory of the device. I believe a device may 
want to get a page of entries it can render in the display, then release 
the memory, and request a new page.

I don't think this can be achieved by selecting the size in bytes, but 
with the number of entries in a list.

- Miguel