Subject: Suggested RTT text (was RE: [Simple] RE: [Sipping] RE: text/T140 andaudio/t140)

From: Eric Burger <[email-masked]>
Date: Sun, 18 Jul 2004 02:32:59 -0400

After 420 pages of "discussion", may I humbly propose the following text for
the MSRP document:

User interfaces and user communities for instant messaging and real-time
text telephony are extremely similar.  MSRP is not an ideal protocol for the
negotiation and transport of real-time text.  However, devices that
implement MRSP SHOULD implement real-time text telephony, using standard SIP
(RFC3261) and text/t140 (RFC2793bis) mechanisms.

Rationale:
1. It looks like consensus to putting RTP under MSRP is far, far, away,
assuming it even makes sense, which it probably doesn't.

2. A whole bunch (80%?) of the code for an IM device would be shared with a
RTT device - character input, character display, Internet connectivity, SIP
stack, etc.

3. We have a charter obligation to make protocols amenable to building
devices that are accessible to everyone.

This is an opportunity to meet the objections to trying to shoehorn RTT into
MSRP (#1) with our Charter obligations (#3) without an undue burden on the
implementer (#2).

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Monday, July 05, 2004 5:54 AM
> To: [email-masked]
> Subject: RE: [Simple] RE: [Sipping] RE: text/T140 andaudio/t140
> was:[avt]C omments/questions on draft-ietf-av
> 
> 
> Given the length of time this discussion has been going on, 
> and the number of messages exchanged, is it not about time we 
> reached some conclusions. These lists are to advance the 
> deliverables in the working groups concerned, so how do any 
> conclusions affect those deliverables.
> 
> SIMPLE has a charter to produce instant messaging protocols. 
> I do not see in all the discussion of the advantages of 
> instant messaging versus real-time text removing that charter 
> item. Therefore I suggest we STOP that discussion, or the 
> proponents move it elsewhere.
> 
> SIMPLE does not have a charter item to produce real-time text 
> protocols. There is already an existing capability in IETF 
> for real-time text protocols. It is not really up to SIMPLE 
> to discuss whether that works well or not, as it was not 
> developed under SIMPLEs charter.
> 
> How terminals mix and match applications is not something 
> that IETF traditionally deals with. Therefore I would suggest 
> that any requirements that state RTT and IM must be 
> implemented in the same terminal are out of scope of IETF. 
> They should certainly be in some device specification rather 
> than in the MSRP specification which SIMPLE is specifically 
> delivering. 
> 
> I guess the questions as affecting MSRP really fall down to these:
> 
> -	Are there capabilities in MSRP that would lead to a 
> valid RTT protocol that works better than the existing IETF 
> solution, in addition to it fulfilling the requirements to 
> provide an IM protocol. From the exchange of messages I have 
> seem so far, it seems to me that the conclusion should be NO.
> 
> -	In order to deal with a body of users that have IM, and 
> prefer to use IM, and a body of users that have RTT, and 
> prefer to use RTT, is there a need to be able to interwork 
> the two protocols at some intermediate point, and not just 
> within the terminal by supporting both protocols under a 
> common user interface? I see that as an element of the 
> discussion just raised by Paul. Does such interworking, if 
> required, have any impact on the contents of MSRP?
> 
> regards
> 
> Keith
> 
> Keith Drage
> Lucent Technologies
> [email-masked]
> tel: +44 1793 776249
> 
> 
> > -----Original Message-----
> > From: Arnoud van Wijk [mailto:[email-masked]]
> > Sent: 04 July 2004 10:43
> > To: [email-masked]; [email-masked];
> > [email-masked]; [email-masked]
> > Cc: [email-masked]; [email-masked]; [email-masked];
> > [email-masked]; [email-masked]; [email-masked]
> > Subject: RE: [Simple] RE: [Sipping] RE: text/T140 andaudio/t140
> > was:[avt]Comments/questions on draft-ietf-av
> > 
> > 
> > Never say never.
> > Have you tried interactive text/real-time text?
> > Did you?
> > 
> > First try it and THEN you can say if you like it or not.
> > 
> > If you want to determine how useful it is. Test it.
> > Use it
> > Try it
> > Compare it with IM.
> > See the differences between IM and RTT/Interactive text.
> > See that both text communication methods have their advantages and
> > disadvantages.
> > And use both for the best situations.
> > 
> > And if you still don't want to use RTT/Interactive 
> > text..fine..I just hope
> > that when I call you, that you can still receive my call. 
> > Just use it only
> > when the other person uses Interactive text/RTT.
> > Even if it is then 3-4 times per year.
> > 
> > Can you with IM:
> > * directly call the other?
> > * forward the call?
> > * put on hold?
> > * have the call go to multiple terminals?
> > * not being logged on a buddy list server, where you may get 
> > flooded by 20
> > users at the same time saying hi! And such?
> > * being able to leave a message on an answering machine?
> > * using a service that allows a ring notifivation as soon the 
> > other user is
> > ready with his/her other phonecall? (ring back on busy).
> > 
> > There are more.. but I am unfamiliar with voice calls. I am 
> > just enjoying my
> > freedom of communications beyond the IM limitations.
> > 
> > And I enjoy using IM also..even though I am forced to use 
> > Trillian, since
> > there is NO one universal standard for IM right now!
> > 
> > Interactive text is!
> > 
> > Greetz
> > 
> > Arnoud
> > 
> > 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Arnoud van Wijk" <[email-masked]>
Date: Sun, 18 Jul 2004 10:59:35 +0200

Hello Eric,
I am happy to see that we have the same view here!
I so totally agree with you!

And frankly..why would people object to this? This is the best of both
worlds.
Greetz

Arnoud

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Eric Burger
Sent: zondag 18 juli 2004 8:33
To: [email-masked]
Cc: Drage, Keith (Keith)
Subject: Suggested RTT text (was RE: [Simple] RE: [Sipping] RE: text/T140
andaudio/t140)

Rationale:

---

From: Ben Campbell <[email-masked]>
Date: Sun, 18 Jul 2004 10:21:58 -0500

I think that sort of statement belongs in the (apparently now dormant) 
SIMPLE architecture document, not in MSRP.

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Sun, 18 Jul 2004 22:50:07 +0200

Eric,
Good proposal.
Some comments say that the MSRP protocol spec is not the right place for this kind of
terminal requirements.
Is there anywhere, where relations to other real time conversational services like voice
and video are mentioned. If it is, that is the right place for also requiring a
possibility to enter real time text conversation.

I have some small proposals for changes in the text: ( whereever it ois placed )

1. Use the term "real time text conversation". From the discussions it is apparent that
direct end to end IM is seen as a real time service. I agree. The term used to distinguish
voice telephony, video telephony, video conferencing, text telephony and total
conversation is "real time conversational" services.

2. There is no need to say that the user interfaces and user communities are EXTREMELY
similar. It is enough that they are similar but also important that they do not completely
overlap, so there is still a reason to strongly recommend to implement both. Therefore, I
suggest to delete the word "extremely"

So, here is my modified proposal for the text. I hope you can find the right place for it.

"User interfaces and user communities for instant messaging and real-time
text conversation have many similarities. MSRP is not an ideal protocol for the
negotiation and transport of real-time text conversation.  However, devices that
implement MRSP SHOULD implement real-time text conversation, using standard SIP
(RFC3261) and text/t140 (RFC2793bis) mechanisms."

Gunnar
-------------------------------------------
Gunnar Hellström
Omnitor AB
Renathvägen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

>From: [email-masked] [mailto:[email-masked]]On Behalf
>Of Eric Burger
>Sent: Sunday, July 18, 2004 8:33 AM
>To: [email-masked]
>Cc: Drage, Keith (Keith)
>Subject: Suggested RTT text (was RE: [Simple] RE: [Sipping] RE:
>text/T140 andaudio/t140)
>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 19 Jul 2004 14:30:26 -0400

I agree with both Eric and Ben. I agree with Eric for now. If/when there 
is a more suitable document, then put the statement there too. Compared 
to the cost (420 pages of discussion?) incurred so far, putting these 
few words into MSRP is cheap.

	Paul