Subject: [Simple] XCap Directory: Large respons ?

From: "Henrik Albertsson (KI/EAB)" <[email-masked]>
Date: Thu, 1 Jul 2004 15:09:50 +0200

Hi,

The current version of the XCAP Directory does not contain any limit of the size of the response. An XCAP Directory can potentially be very large if it collects all list for a user, especially in a mobile environment this would be problem. Any ideas how to limit the response? 

Regards
/Henrik 

Henrik Albertsson 
System Manager
IMS Service Layer

Multimedia Solutions System Management
Ericsson AB
S-125 26 Stockholm 
Sweden
Tel: +46 8 719 90 73
Mobile: +46 705 19 85 39
Fax: +46  8 404 92 22
Visiting address: Kistagången 26

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Fri, 02 Jul 2004 10:14:42 +0300

Hi Henrik:

I think you got a good point. I think we need to add a new requirement 
to the draft that reads something like:

- The XCAP client MUST be able to limit the amount of information 
returned by the XCAP server, so that the XCAP directory document does 
not flood the client.

As for a possible solution... I need to think about it... Most likely we 
will need to define some sort of convention, kind of adding a parameter 
to the URI to limit the number of entries in the response. Something like:

GET http://xcap.example.com/services/directory/users/
bill/directory.xml?entries=50 HTTP/1.1

I am open to hear suggestions.

Regards,

          Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Research Center      Helsinki, Finland