Subject: RE: Tiny ant vs big Mammoths, was RE: [Simple] Using MSRP forrealtime text conversation

From: "Guido Gybels" <[email-masked]>
Date: Fri, 2 Jul 2004 10:00:10 +0100

Hisham,

<<If a deaf person wants to have a "voice" call with someone, then s/he would
use the interactive text application. It is a different application than the
one s/he use if s/he wants to IM with someone.>>

I remember the days when different email systems didn't talk to each other. It didn't have real mainstream appeal. When I got my first GSM mobile phone in 1994, SMS didn't work across network boundaries. It didn't have much appeal.

Now that email and SMS are, from a user's perspective, fairly seamless: they are available almost everywhere, even on the move, it's interoperable between handsets and it traverses network boundaries just fine, these have become mainstream provisions. IM has similar problems. So, the gradual convergence in that technology is good. I suspect that for quite a while though, there will be different, competing systems. However, because this is a mainstream technology, the pressure on various implementers and service providers to offer interoperability between their systems will increase and if IM is really to become as widespread as voice telephony or email, it will have to offer a similar experience in terms of interworking between various networks.

For interactive texting, something similar can be argued, with the big difference that if it is not available, it is not just an inconvenience, it is actually disenfranchising deaf and hard of hearing people who rely on text.

<<But I guess what you are saying is that both those applications can be one of
the same, right? By replay to that is why? If interactive text to deaf people
is the "voice" communication and the IM is IM for them, then those 2
applications need to be separated.>>

You can use RTT as an alternative to IM. But not the other way around. That is not to say that I am not interested in IM. Just that if you have to make a choice, the more inclusive one of the two is RTT. How manufacturers build there devices, their UI etc is mostly up to them. Different manufacturers have different views on how to position devices etc.

As someone who has been working on UI issues for about 20 years, I would argue that what users want is actually something which is easy to use, doesn't require different ways of working for different functions and meets their needs. IMHO that means that integrating text messaging into user friendly, mostly integrated applications is wise. Whether or not the marketing boys are bothered by that is another question of course!

Non technical users don't think segmented. They "use a mobile phone". Whether or not they talk into it or send SMS, such users don't really bother with the logical and technical analysis of how applications/protocols and the like are technically separated and implemented. From a user's perspective, they have a mobile phone and they use it for different things. Users want things that are intuitive and easy to use. Whether or not underneath it's using two modules and separate protocols, the user doesn't care.

To argue that because IM and RTT are different technologies, they should also be visible to the user as clearly different things is a techie/scientific viewpoint, it does not IMHO relate to average users at all.

Best regards,

Guido

Guido Gybels
Director of New Technologies

RNID, 19-23 Featherstone Street
London EC1Y 8SL, UK
Tel +44(0)207 294 3713
Fax +44(0)207 296 8069

************************************************************************
This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom they are addressed. Any views or opinions expressed
are solely those of the author and do not necessarily represent
RNID policy.

If you are not the intended recipient you are advised that any
use, dissemination, forwarding, printing or copying of this
email is strictly prohibited.

If you have received this email in error please notify the RNID
Helpdesk by telephone on: +44 (0) 207 296 8282.

The Royal National Institute for Deaf People  
Registered Office 19-23 Featherstone Street 
London EC1Y 8SL No. 454169 (England)
Registered Charity No. 207720
************************************************************************

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 02 Jul 2004 13:23:23 -0400

Guido Gybels wrote:
> 
> You can use RTT as an alternative to IM. But not the other way around.

I understand your point, but I don't think I fully agree with it.

Let me give an analogy: email is to IM as IM is to RTT.
I can use email as a substitute for IM, but it is clumsy and annoying.
I can use IM as a substitute for email, but it is clumsy and annoying.
Similarly I can use RTT as a substitute for IM but it is clumsy and 
annoying, and visa versa.

When you compare X with Y you find each gains something and loses 
something compared to the other. When you substitute one for another you 
notice what you lose but probably not what you gain. So you are annoyed 
or inconvenienced.

 > That is not to say that I am not interested in IM. Just that if you have
 > to make a choice, the more inclusive one of the two is RTT.

I don't agree. I consider the fact that what I type is not transmitted 
immediately as one of the features of IM. RTT loses that, and so is not 
inclusive. In fact, from my perspective it has no features I want over 
and above IM. And it possibly loses other features, like ability to 
transmit other media types.

*If* we had a *protocol* that supported everything we are putting into 
MSRP, and *also* reasonably supported the sending of RTT, *then* it 
would be possible to design clients such that RTT was just a mode 
setting - controlling the decision of when to send. Then you could set 
your client to RTT and I could set mine to message-mode and we could 
communicate. I would see your char at a time typing, and you wouldn't 
see mine.

 > How manufacturers build there devices, their UI etc is mostly up to them.
 > Different manufacturers have different views on how to position 
devices etc.
> As someone who has been working on UI issues for about 20 years, I would argue that what users want is actually something which is easy to use, doesn't require different ways of working for differe…

I agree that however the technology works, at the product level you want 
to hide as much as possible. There may still need to be a mode setting, 
but perhaps nothing more.

> Non technical users don't think segmented. They "use a mobile phone". Whether or not they talk into it or send SMS, such users don't really bother with the logical and technical analysis of how applications/protocols and the like are technically separated and implemented.

I think this has a lot to do with addressing. If I can communicate to 
the same user using the same address, then is is conceptually the same 
technology.

  From a user's perspective, they have a mobile phone and they use it 
for different things. Users want things that are intuitive and easy to 
use. Whether or not underneath it's using two modules and separate 
protocols, the user doesn't care.
> To argue that because IM and RTT are different technologies, they should also be visible to the user as clearly different things is a techie/scientific viewpoint, it does not IMHO relate to average…

I still *think* there are assumptions being made that aren't yet clearly 
identified:

- deaf people want to use RTT to communicate with one another,
   or with others that are fluent in RTT. In this role, IM is not
   in any way a substitute for RTT.

- many non-deaf people want to communicate with one another using
   text even though voice is an option. To date most of them seem
   to find IM meets this need.

- deaf people want to communicate with people who are not fluent
   in RTT. I get the impression the preference of the deaf person
   is to use RTT. The best style to use (IM or RTT) is in dispute
   in this case.

- when a communication channel is established, the capabilities
   of the two endpoints (for IM, RTT, and Voice) may not be known
   a priori. Ideally any capabilities shared in common should be
   available.

I get the impression that there is a feeling among some RTT advocates 
that if only people would bother to become fluent with RTT they would 
prefer it to IM in all cases. I disagree, but this is in the realm of 
opinions - AFAIK there have been no studies on this. (At least I have 
not seen any cited.)

Unless it can be demonstrated that RTT should totally replace IM, I it 
seems that there are a couple of issues arising from the above:

- how should text communication be transacted between those fluent
   in RTT and those who aren't. (Assuming both are available.)
   The answer to this question will in part determine whether all
   IM clients must be capable of supporting RTT.

- When A is calling B, it may be that B has multiple devices
   where he may be reached, with different capabilities. (E.g.
   a voice phone and a text IM client on a pc.) How can call
   setup be arranged so that the device chosen maximizes the
   ability for A and B to communicate? This should work for
   all combinations of capabilities for Voice, IM, and RTT at
   A and B.

	Paul