Subject: RE: [Simple] Friendly Display Name in Presence Schema?

From: "Orit Levin" <[email-masked]>
Date: Thu, 8 Jul 2004 13:17:23 -0700

The protocol difference or flexibility is in who generates the display
name.  In some systems, the watcher sets the display name, indeed.  In
others, it is being set by presentities' aggregation point per user.
Still in others, it is the presentity instance itself.  Of cause, it is
always the policy of the watcher which one(s) to display to the user.

There are obvious application usages for each of the approaches. 

Would somebody object for adding "presentity-display-name" as one of the
optional elements to the CIPID XML schema? Along the same lines as
"card", "icon", etc. (both for the whole presence document and for an
individual tuple) ?

Thanks,
Orit.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
> Sent: Wednesday, July 07, 2004 6:13 PM
> To: Orit Levin
> Cc: [email-masked]
> Subject: Re: [Simple] Friendly Display Name in Presence Schema?
> 
> I dont think so, no.
> 
> I would think that, in most cases, the display name would be 
> set by the watcher, and present in their resource list. The 
> resource list XML does have a display name.
> 
> -Jonathan R.
> 
> Orit Levin wrote:
> 
> > Guys,
> > Do we have a friendly display name defined per user in one of our 
> > presence XML schemas (in addition to the entity URI) ?
> >  
> > Thanks,
> > Orit.
> > 
> > 
> > 
> ----------------------------------------------------------------------
> > --
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 09 Jul 2004 04:39:42 -0400

I think this would be fine.

-Jonathan R.

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 09 Jul 2004 05:39:18 -0400

The vcard already contains name information, but I'll add <display-name> 
as an additional element for simplicity since I suspect that the two may 
differ on occasion.