Subject: [Simple] RE: simple-filter Max Size or Max number of element as filter criterias?

From: [email-masked]
Date: Fri, 2 Jul 2004 11:07:08 +0300

I believe that you are asking for is outside the scope of the simple-filter drafts. It can be done with filters, but not those ones.

The current filter drafts talk about filtering unwanted or uninteresting information sent in a NOTIFY. They also talk about triggering of notifications when certain changes to the state of an event occur.

Regards,
Hisham

> -----Original Message-----
> From: ext Anders Lindgren C (HF/EAB)
> [mailto:[email-masked]]
> Sent: 02.July.2004 10:53
> To: [email-masked]; Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Subject: simple-filter Max Size or Max number of element as filter
> criterias?
> 
> 
> Hi,
> The XML documents sent from the network to the client can be 
> very large or it can contains a very long sequence of 
> elements ( e.g a resource list with 1000 buddies)
> It will also exist different types of clients. Some clients 
> can specify a very large resource list and it will exist 
> clients that can not handle that large list.
> 
> I have not found how a client can inform the network about 
> how large documents is can handle or how many elements of a 
> certain type it can handle.
> My question is now if this information can be regarded as 
> filter criterias and includes in this filter specification?
> 
> Best regards
> 
> Anders Lindgren Ericsson AB Sweden
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Fri, 02 Jul 2004 12:10:34 +0300

Note that we are currently discussing the same problem applied to XCAP 
in a similar thread. I believe in XCAP there are no means to filter the 
number of entries returned in a list. The thread is named: "XCAP 
Directory: Large response?"

- Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Research Center      Helsinki, Finland