Subject: [Simple] RE: simple-filter Max Size or Max number of element as filter cri terias?

From: "Anders Lindgren C (HF/EAB)" <[email-masked]>
Date: Fri, 2 Jul 2004 14:22:35 +0200

Hi
The question is what "unwanted" information" mean? Can it be that a XML document that is to large to handle can be regarded as "unwanted" information and therefore can be regarded as being inside the scope of the simple-filter draft.
Regards
Anders

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: den 2 juli 2004 10:07
To: Anders Lindgren C (HF/EAB); [email-masked]
Subject: RE: simple-filter Max Size or Max number of element as filter
criterias?

I believe that you are asking for is outside the scope of the simple-filter drafts. It can be done with filters, but not those ones.

The current filter drafts talk about filtering unwanted or uninteresting information sent in a NOTIFY. They also talk about triggering of notifications when certain changes to the state of an event occur.

Regards,
Hisham

> -----Original Message-----
> From: ext Anders Lindgren C (HF/EAB)
> [mailto:[email-masked]]
> Sent: 02.July.2004 10:53
> To: [email-masked]; Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Subject: simple-filter Max Size or Max number of element as filter
> criterias?
> 
> 
> Hi,
> The XML documents sent from the network to the client can be 
> very large or it can contains a very long sequence of 
> elements ( e.g a resource list with 1000 buddies)
> It will also exist different types of clients. Some clients 
> can specify a very large resource list and it will exist 
> clients that can not handle that large list.
> 
> I have not found how a client can inform the network about 
> how large documents is can handle or how many elements of a 
> certain type it can handle.
> My question is now if this information can be regarded as 
> filter criterias and includes in this filter specification?
> 
> Best regards
> 
> Anders Lindgren Ericsson AB Sweden
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Anders Lindgren C (HF/EAB)" <[email-masked]>
Date: Fri, 2 Jul 2004 15:41:49 +0200

Ok
Can I select the number of elements of a certain type I want to receive? Ie give my at the most 100 buddies in a resource list when subscribing to a list? Or is it that something complete new is needed or is it covered by some other spec?  As I see it this is a general problem for all types of Subscribe for event packages if  you can not control the size of what is send in the Notify. 
Regards Anders

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: den 2 juli 2004 14:40
To: Anders Lindgren C (HF/EAB); [email-masked]
Subject: RE: simple-filter Max Size or Max number of element as filter
criterias?

You can reduce the size of the document delivered in the NOTIFY by using the filters (but selecting the elements that you really want to be delivered to you), but you cannot filter based on size. You cannot say "send me a NOTIFY with a body no larger than 1000 bytes".

If you want something like that, then this is outside the scope of the filtering drafts in question.

Regards,
Hisham

> Sent: 02.July.2004 15:23
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> The question is what "unwanted" information" mean? Can it be 
> that a XML document that is to large to handle can be 
> regarded as "unwanted" information and therefore can be 
> regarded as being inside the scope of the simple-filter draft.
> Regards
> Anders
> 
> I believe that you are asking for is outside the scope of the 
> simple-filter drafts. It can be done with filters, but not those ones.
> 
> The current filter drafts talk about filtering unwanted or 
> uninteresting information sent in a NOTIFY. They also talk 
> about triggering of notifications when certain changes to the 
> state of an event occur.
> 
> Regards,
> Hisham
>

---

From: "Anders Lindgren C (HF/EAB)" <[email-masked]>
Date: Mon, 5 Jul 2004 17:26:02 +0200

Hi
In the  tread #RE: [Simple] Re: XCAP Directory: Large response ?"  you asked Miguel to have a look at the filter draft to solve the XCAP problem. I qoute:
"I wonder if you can use the following event filtering draft with HTTP GET?

http://www.ietf.org/internet-drafts/draft-ietf-simple-filter-format-01.txt (currently in WGLC)

At least the <what> part could be useful."

My view is that it is the same thing Miguel and I are addressing, but on different protocols ( SIP, XCAP). A client can get a list of users that is to more that it can handle. How can it be that the filter draft can solve the XCAP problem but not the Subscribe problem?
/Anders

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: den 2 juli 2004 16:01
To: Anders Lindgren C (HF/EAB); [email-masked]
Subject: RE: simple-filter Max Size or Max number of element as filter
criterias?

> Sent: 02.July.2004 16:42
> Can I select the number of elements of a certain type I want 
> to receive? Ie give my at the most 100 buddies in a resource 
> list when subscribing to a list?

No you cannot, but what you can do is list in the filter the buddies you are interested in receiving information about. I think this is more useful that using the filter to tell the server to send you the first x buddies.

/Hisham

> Or is it that something 
> complete new is needed or is it covered by some other spec?  
> As I see it this is a general problem for all types of 
> Subscribe for event packages if  you can not control the size 
> of what is send in the Notify.
> Regards Anders
> 
> You can reduce the size of the document delivered in the 
> NOTIFY by using the filters (but selecting the elements that 
> you really want to be delivered to you), but you cannot 
> filter based on size. You cannot say "send me a NOTIFY with a 
> body no larger than 1000 bytes".
> 
> If you want something like that, then this is outside the 
> scope of the filtering drafts in question.
> 
> Regards,
> Hisham
>