Subject: RE: [Simple] RE: simple-filter Max Size or Max number of element asfilter cri terias?

From: [email-masked]
Date: Tue, 6 Jul 2004 13:13:27 +0300

Perhaps I wasn't clear

I was suggesting that the filter, when applied to a HTTP GET, lists the resources in the buddy list that the client wants to get, much like what I suggested for the SUBSCRIBE.

For example, we have a list containing Bob, Sarah, John and Alice:

   <?xml version="1.0" encoding="UTF-8"?>
   <resource-lists xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
     <list name="friends" uri="sip:[email-masked]" subscribeable="true">
       <entry name="Bob" uri="sip:[email-masked]"/>
       <entry name="Sarah" uri="sip:[email-masked]"/>
       <entry name="John" uri="sip:[email-masked]"/>
       <entry name="Alice" uri="sip:[email-masked]"/>
     </list>
   </resource-lists>

If I want to SUBSCRIBE and receive information about Bob and Alice, this is what the filter in the SUBSCRIBE would look like (the xpath expression is according the event list package):

   <?xml version="1.0" encoding="UTF-8"?>
   <filter-set xmlns="urn:ietf:params:xml:ns:simple-filter">
     <filter id="8439" uri="sip:[email-masked]">
       <what>
         <include>
           //rlmi:list/rlmi:resource[@uri=""[email-masked]"]
         </include>
         <include>
           //rlmi:list/rlmi:resource[@uri=""[email-masked]"]
         </include>
       </what>
       </filter>
   </filter-set>

Now, if I do a HTTP GET and want to get those resources, then the GET would have a filter:

   <?xml version="1.0" encoding="UTF-8"?>
   <filter-set xmlns="urn:ietf:params:xml:ns:simple-filter">
     <filter id="8439" uri="sip:[email-masked]">
       <what>
         <include>
           //resource-lists/list[@name="friends"]/entry[@uri=""[email-masked]"]
         </include>
         <include>
           //resource-lists/list[@name="friends"]/entry[@uri=""[email-masked]"]
         </include>
       </what>
       </filter>
   </filter-set>

Thanks,
Hisham

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Anders Lindgren C (HF/EAB)
> Sent: 05.July.2004 18:26
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> Cc: Garcia Miguel.An (Nokia-NRC/Helsinki)
> Subject: [Simple] RE: simple-filter Max Size or Max number of element
> asfilter cri terias?
> 
> 
> Hi
> In the  tread #RE: [Simple] Re: XCAP Directory: Large 
> response ?"  you asked Miguel to have a look at the filter 
> draft to solve the XCAP problem. I qoute:
> "I wonder if you can use the following event filtering draft 
> with HTTP GET?
> 
> http://www.ietf.org/internet-drafts/draft-ietf-simple-filter-f
> ormat-01.txt (currently in WGLC)
> 
> At least the <what> part could be useful."
> 
> My view is that it is the same thing Miguel and I are 
> addressing, but on different protocols ( SIP, XCAP). A client 
> can get a list of users that is to more that it can handle. 
> How can it be that the filter draft can solve the XCAP 
> problem but not the Subscribe problem?
> /Anders
> 
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: den 2 juli 2004 16:01
> To: Anders Lindgren C (HF/EAB); [email-masked]
> Subject: RE: simple-filter Max Size or Max number of element as filter
> criterias?
> 
> 
> 
> 
> > -----Original Message-----
> > From: ext Anders Lindgren C (HF/EAB)
> > [mailto:[email-masked]]
> > Sent: 02.July.2004 16:42
> > To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> > Subject: RE: simple-filter Max Size or Max number of 
> element as filter
> > criterias?
> > 
> > 
> > Ok
> > Can I select the number of elements of a certain type I want 
> > to receive? Ie give my at the most 100 buddies in a resource 
> > list when subscribing to a list?
> 
> No you cannot, but what you can do is list in the filter the 
> buddies you are interested in receiving information about. I 
> think this is more useful that using the filter to tell the 
> server to send you the first x buddies.
> 
> /Hisham
> 
> > Or is it that something 
> > complete new is needed or is it covered by some other spec?  
> > As I see it this is a general problem for all types of 
> > Subscribe for event packages if  you can not control the size 
> > of what is send in the Notify.
> > Regards Anders
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: den 2 juli 2004 14:40
> > To: Anders Lindgren C (HF/EAB); [email-masked]
> > Subject: RE: simple-filter Max Size or Max number of 
> element as filter
> > criterias?
> > 
> > 
> > You can reduce the size of the document delivered in the 
> > NOTIFY by using the filters (but selecting the elements that 
> > you really want to be delivered to you), but you cannot 
> > filter based on size. You cannot say "send me a NOTIFY with a 
> > body no larger than 1000 bytes".
> > 
> > If you want something like that, then this is outside the 
> > scope of the filtering drafts in question.
> > 
> > Regards,
> > Hisham
> > 
> > > -----Original Message-----
> > > From: ext Anders Lindgren C (HF/EAB)
> > > [mailto:[email-masked]]
> > > Sent: 02.July.2004 15:23
> > > To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> > > Subject: RE: simple-filter Max Size or Max number of 
> > element as filter
> > > criterias?
> > > 
> > > 
> > > Hi
> > > The question is what "unwanted" information" mean? Can it be 
> > > that a XML document that is to large to handle can be 
> > > regarded as "unwanted" information and therefore can be 
> > > regarded as being inside the scope of the simple-filter draft.
> > > Regards
> > > Anders
> > > 
> > > -----Original Message-----
> > > From: [email-masked] 
[mailto:[email-masked]]
> > Sent: den 2 juli 2004 10:07
> > To: Anders Lindgren C (HF/EAB); [email-masked]
> > Subject: RE: simple-filter Max Size or Max number of 
> element as filter
> > criterias?
> > 
> > 
> > I believe that you are asking for is outside the scope of the 
> > simple-filter drafts. It can be done with filters, but not 
> those ones.
> > 
> > The current filter drafts talk about filtering unwanted or 
> > uninteresting information sent in a NOTIFY. They also talk 
> > about triggering of notifications when certain changes to the 
> > state of an event occur.
> > 
> > Regards,
> > Hisham
> > 
> > > -----Original Message-----
> > > From: ext Anders Lindgren C (HF/EAB)
> > > [mailto:[email-masked]]
> > > Sent: 02.July.2004 10:53
> > > To: [email-masked]; Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> > > Subject: simple-filter Max Size or Max number of element as filter
> > > criterias?
> > > 
> > > 
> > > Hi,
> > > The XML documents sent from the network to the client can be 
> > > very large or it can contains a very long sequence of 
> > > elements ( e.g a resource list with 1000 buddies)
> > > It will also exist different types of clients. Some clients 
> > > can specify a very large resource list and it will exist 
> > > clients that can not handle that large list.
> > > 
> > > I have not found how a client can inform the network about 
> > > how large documents is can handle or how many elements of a 
> > > certain type it can handle.
> > > My question is now if this information can be regarded as 
> > > filter criterias and includes in this filter specification?
> > > 
> > > Best regards
> > > 
> > > Anders Lindgren Ericsson AB Sweden
> > > 
> > 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Tue, 06 Jul 2004 14:28:29 +0300

Hisham:

I find this explanation very interesting, but unfortunately this is not 
the functionality I was thining of.

I thought that I would like to limit the number of entries returned in a 
document. I don't even know, at the time of requesting, if there is an 
entry by name Bob, Sarah, John or Alice in my list. I don't even know 
how many entries and lists I have in the XML document I am trying to 
retrieve. I just know that my device has some limitations, perhas due to 
a small display, perhaps due to memory constraints, that makes me want 
to limit the number of entries returned in the XML document.

I don't think the filter fulfills this requirement.

- Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Research Center      Helsinki, Finland

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 07 Jul 2004 06:10:14 -0400

Directly using the filters in xcap would be a major change in how xcap 
does things. We'd probably have to start with a totally new protocol 
(i.e., it couldnt be HTTP based anymore). As such, I am opposed to such 
a change.

I will note that the filter work and xcap both use similar concepts in 
addressing elements  - xpath expressions for selection. Indeed, I would 
argue that, given the scope of xcap, all of the information in the 
filter is not needed except for this expression, and that expression 
appears in the URI of the XCAP request.

-Jonathan R.

Miguel Garcia wrote:

>> I was suggesting that the filter, when applied to a HTTP GET, lists 
>> the resources in the buddy list that the client wants to get, much 
>> like what I suggested for the SUBSCRIBE.
>>
>> If I want to SUBSCRIBE and receive information about Bob and Alice, 
>> this is what the filter in the SUBSCRIBE would look like (the xpath 
>> expression is according the event list package):
>>
>>> From: [email-masked] [mailto:[email-masked]]On Behalf
>>> In the  tread #RE: [Simple] Re: XCAP Directory: Large response ?"  
>>> you asked Miguel to have a look at the filter draft to solve the XCAP 
>>> problem. I qoute:
>>> "I wonder if you can use the following event filtering draft with 
>>> HTTP GET?
>>>
>>> My view is that it is the same thing Miguel and I are addressing, but 
>>> on different protocols ( SIP, XCAP). A client can get a list of users 
>>> that is to more that it can handle. How can it be that the filter 
>>> draft can solve the XCAP problem but not the Subscribe problem?
>>> /Anders
>>>
>>>
>>>
>>>> Can I select the number of elements of a certain type I want to 
>>>> receive? Ie give my at the most 100 buddies in a resource list when 
>>>> subscribing to a list?
>>>
>>>
>>> No you cannot, but what you can do is list in the filter the buddies 
>>> you are interested in receiving information about. I think this is 
>>> more useful that using the filter to tell the server to send you the 
>>> first x buddies.
>>>
>>> /Hisham
>>>
>>>
>>>> Or is it that something complete new is needed or is it covered by 
>>>> some other spec?  As I see it this is a general problem for all 
>>>> types of Subscribe for event packages if  you can not control the 
>>>> size of what is send in the Notify.
>>>> Regards Anders
>>>>
>>>> You can reduce the size of the document delivered in the NOTIFY by 
>>>> using the filters (but selecting the elements that you really want 
>>>> to be delivered to you), but you cannot filter based on size. You 
>>>> cannot say "send me a NOTIFY with a body no larger than 1000 bytes".
>>>>
>>>> If you want something like that, then this is outside the scope of 
>>>> the filtering drafts in question.
>>>>
>>>> Regards,
>>>> Hisham
>>>>
>>>>
>>>>> The question is what "unwanted" information" mean? Can it be that a 
>>>>> XML document that is to large to handle can be regarded as 
>>>>> "unwanted" information and therefore can be regarded as being 
>>>>> inside the scope of the simple-filter draft.
>>>>> Regards
>>>>> Anders
>>>>>
>>>> uninteresting information sent in a NOTIFY. They also talk about 
>>>> triggering of notifications when certain changes to the state of an 
>>>> event occur.
>>>>
>>>> Regards,
>>>> Hisham
>>>>
>>>>
>>>>> The XML documents sent from the network to the client can be very 
>>>>> large or it can contains a very long sequence of elements ( e.g a 
>>>>> resource list with 1000 buddies)
>>>>> It will also exist different types of clients. Some clients can 
>>>>> specify a very large resource list and it will exist clients that 
>>>>> can not handle that large list.
>>>>>
>>>>> I have not found how a client can inform the network about how 
>>>>> large documents is can handle or how many elements of a certain 
>>>>> type it can handle.
>>>>> My question is now if this information can be regarded as filter 
>>>>> criterias and includes in this filter specification?
>>>>>
>>>>> Best regards
>>>>>

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com