Subject: RE: [Simple] RE: [Sipping] RE: text/T140 andaudio/t140 was:[avt]Comments/questions on draft-ietf-av

From: [email-masked]
Date: Fri, 2 Jul 2004 11:26:55 +0300

There is no hostility here. We are negotiating the usefulness of it. Some people prefer IM, others prefer interactive text, so it might an additional value service or a waste of implementer's time. No one knows.

I would never, for example, use real time text since I, like many people in the world, am a very slow typist, make many typos and change my mind a lot about what I should say or how I should say it.

One comment inline...

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Arnoud van Wijk
> Sent: 25.June.2004 12:51
> To: 'Paul E. Jones'; 'Paul Kyzivat'; 'Guido Gybels'
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Simple] RE: [Sipping] RE: text/T140 andaudio/t140
> was:[avt]Comments/questions on draft-ietf-av
> 
> 
> Good point Paul!
> 
> Also..I want to point it out again...
> WE ARE NOT TALKING ABOUT REPLACING INSTANT MESSAGING WITH 
> INTERACTIVE TEXT!
> 
> Most of you already know that. But just today I met another 
> person who still
> thinks Interactive text is to replace IM.
> 
> I do not understand the hostility from several IM people. 
> Interactive text
> is even going to make IM better! See it as an additional 
> valuable service
> for IM.
> Users exchange IM messages, and then a discussion starts, 
> they switch over
> into real-time chat mode. Discuss things, work out plans in 
> real-time. Then
> end the real-time chat mode.
> And the next 2 hours they exchange a few IM messages.

What makes this character-by-character (or x number of characters for 300ms) more interactive than IM in the scenario you describe above (besides the fact that you will see all my spelling mistakes, that I typed a message then changed my mind and deleted it)?

> 
> And I do hear from many ICQ users who miss the real-time chat 
> mode. That was
> easier to use. And with SIP, server load is not an issue 
> anymore, which
> caused ICQ to scrap this option.
> 
> Cheers
> 
> Arnoud
> 
> 
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> Of Paul E. Jones
> Sent: vrijdag 25 juni 2004 1:16
> To: 'Paul Kyzivat'; 'Guido Gybels'
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> Subject: RE: [Simple] RE: [Sipping] RE: text/T140 and audio/t140
> was:[avt]Comments/questions on draft-ietf-av
> 
> Paul,
> 
> > I accept your point that IM isn't suitable for a bunch of the
> > communication needs of the hearing impaired. (Among 
> others.) But I also
> > want you to accept that RTT isn't a suitable substitute for 
> IM in the
> > applications that millions (actually probably 10s or 100s 
> of millions)
> > of people use it everyday.
> 
> ICQ once had a mode wherein one could send 
> character-at-a-time and it worked
> pretty well (may still be in there).  What was nice about it 
> was that one
> could begin his/her reply even before the other person 
> finished his/her
> message.  I found the two-way exchange much better than 
> today's IM systems,
> as there was virtually no delay-- it was real-time.
> 
> One of the reasons why the IM systems today have problems in 
> scaling is that
> they have to interface with servers that handle message 
> exchange between all
> those users you spoke about.  The farm of servers to run the 
> existing IM
> systems do a lot of work and it's not a trivial task.  The 
> problem with the
> model is that farm of central servers that receive and 
> dispatch messages.
> (Perhaps SIMPLE has done something to improve on the current state of
> technology, but I'll confess that I don't know.)
> 
> If we can solve the scalability issues required to handle 
> lots of voice and
> video streams flowing between users, then it would not take a 
> great leap to
> do the same thing for text (literally).  There may be more 
> text sessions,
> but the only change in resource requirements from blocks of 
> text and RTT are
> the resources required to process messages (as there are more 
> RTT packets).
> For voice, those fifty or so packets per second would not flow through
> centralized servers and neither should the text.  If the 
> system operated
> allowing media to flow point-to-point, the RTT would scale.  
> I guess the
> question is whether we will be able to allow audio to flow 
> point-to-point or
> whether the FWs, NATs, "session border controllers", and such 
> devices will
> inhibit that.
> 
> Paul
> 
> 
> -
> This list is maintained by Snowshore Networks - 
http://www.snowshore.com
All comments on this list are the comments of the message originators and
Snowshore is not to be held responsible for any actions or comments found
on this list. The archives for this list can be found at
http://flyingfox.snowshore.com/toip_archive/maillist.html

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Arnoud van Wijk" <[email-masked]>
Date: Sun, 4 Jul 2004 11:42:38 +0200

Never say never.
Have you tried interactive text/real-time text?
Did you?

First try it and THEN you can say if you like it or not.

If you want to determine how useful it is. Test it.
Use it
Try it
Compare it with IM.
See the differences between IM and RTT/Interactive text.
See that both text communication methods have their advantages and
disadvantages.
And use both for the best situations.

And if you still don't want to use RTT/Interactive text..fine..I just hope
that when I call you, that you can still receive my call. Just use it only
when the other person uses Interactive text/RTT.
Even if it is then 3-4 times per year.

Can you with IM:
* directly call the other?
* forward the call?
* put on hold?
* have the call go to multiple terminals?
* not being logged on a buddy list server, where you may get flooded by 20
users at the same time saying hi! And such?
* being able to leave a message on an answering machine?
* using a service that allows a ring notifivation as soon the other user is
ready with his/her other phonecall? (ring back on busy).

There are more.. but I am unfamiliar with voice calls. I am just enjoying my
freedom of communications beyond the IM limitations.

And I enjoy using IM also..even though I am forced to use Trillian, since
there is NO one universal standard for IM right now!

Interactive text is!

Greetz

Arnoud

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: vrijdag 2 juli 2004 10:27
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]

There is no hostility here. We are negotiating the usefulness of it. Some
people prefer IM, others prefer interactive text, so it might an additional
value service or a waste of implementer's time. No one knows.

I would never, for example, use real time text since I, like many people in
the world, am a very slow typist, make many typos and change my mind a lot
about what I should say or how I should say it.

One comment inline...

> And the next 2 hours they exchange a few IM messages.

What makes this character-by-character (or x number of characters for 300ms)
more interactive than IM in the scenario you describe above (besides the
fact that you will see all my spelling mistakes, that I typed a message then
changed my mind and deleted it)?

http://www.snowshore.com