Subject: RE: [Simple] Please comment: Do we want to take on partial public ation?

From: "Atle Monrad (GR/ETO)" <[email-masked]>
Date: Tue, 31 Aug 2004 11:42:31 +0200

Hello

Partial publication has been requested by 3gpp for over 18 months, and we have just been waiting for Markus' solution to be adopted.

My preference would be that SIMPLE adopt the i-d as WG-item. It has been hanging around for quite some time and should be familiar to the interested parties. If such optionality it is not found useful for certain clients, just leave it out...

regards

Atle Monrad
Ericsson Mobile Platform (EMP) 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Avshalom Houri
Sent: Tuesday, August 31, 2004 10:25 AM
To: [email-masked]
Subject: RE: [Simple] Please comment: Do we want to take on partial publication?

Think that we should adopt this as working group item. 
It is not important only for low bandwidth networks. It is also important for very big deployments given the 
very big size that a presence document may turn into. 

Avshalom 
IBM 

[email-masked] wrote on 30/08/2004 05:34:59 PM:

> Hi,
> 
> It seems that there are a few individuals who are strongly opposed 
> to accepting this as a WG item. I'm not totally sure why people are 
> so worried about this kind of optional-to-implement extension. If 
> they don't think it's useful, they can just ignore it (of course 
> provided that it does not introduce anything that would break other 
> parts in the protocol).
> 
> On the other hand, I understand that this may be of interest only to
> the "(low-bandwidth ;-) wireless community", and SIMPLE has plenty 
> of unfinished work. 3GPP wants this for Rel 6, so putting this at 
> the end of the queue wouldn't be that good anyway.
> 
> So probably this should be progressed as a non-WG item toward an 
> Informational RFC. I also proposed this privately to the chairs, 
> some 3GPP people etc. Would those people who are objecting taking 
> this to SIMPLE be concerned if this was the way forward with this 
> draft? At least the authors don't seem to have a problem with that.
> 
> Regards,
>    Markus   
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]]On Behalf
> > Of ext Robert Sparks
> > Sent: 12 August, 2004 23:06
> > To: [email-masked]
> > Subject: [Simple] Please comment: Do we want to take on partial
> > publication?
> > 
> > 
> > Folks -
> > 
> > If you haven't already read it, please take a moment and
> > skim
> > http://www.ietf.org/internet-drafts/draft-lonnfors-simple-part
> > ial-publish-01.txt
> > 
> > We've had _very_ light list discussion on this draft. We talked
> > about it briefly at the interim in Boston, but it wasn't clear
> > that there was sufficient interest even in that room.
> > 
> > The primary question in that meeting was whether or not we
> > could meet the requirements this draft intends without doing
> > any additional standardization work (by having endpoints that
> > want to publish pieces act as one publisher per piece).
> > 
> > So speak up. Do you think this is a place SIMPLE needs to take
> > on more work? Who thinks we have a good enough solution for this
> > already? Who, in addition to the  authors of this draft, is willing
> > to spend time working on this problem?
> > 
> > Thanks,
> > 
> > RjS
> > 
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> > 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 31 Aug 2004 07:45:52 -0400

My take on this is that I find the specification of limited utility, but 
certainly not harmful, and thus would not object to proceeding with it.

The reason I think its of limited utility is that we don't yet know 
whether or not it is really going to reduce bandwidth; this depends on 
the evolving usage of presence documents in deployment. If most folks 
end up using documents with a single tuple and lots of data within that 
tuple, the mechanism will not be useful. We don't know that yet; as 
such, its a solution to an anticipated problem rather than a real one.

In as much as it is a proper solution to this potential problem, I think 
it is OK. It has clear benefits over having the PUA publish and refresh 
each tuple independently, though the exact scope of those benefits again 
depends on what presence documents end up looking like.

So, I am OK with adopting and proceeding.

-Jonathan R.

Atle Monrad (GR/ETO) wrote:

> Hello
> 
> Partial publication has been requested by 3gpp for over 18 months, and 
> we have just been waiting for Markus' solution to be adopted.
> 
> My preference would be that SIMPLE adopt the i-d as WG-item. It has been 
> hanging around for quite some time and should be familiar to the 
> interested parties. If such optionality it is not found useful 
> for certain clients, just leave it out...
> 
> regards
> 
> Atle Monrad
>     *From:* [email-masked] [mailto:[email-masked]]*On
>     Behalf Of *Avshalom Houri
>     *Sent:* Tuesday, August 31, 2004 10:25 AM
>     *To:* [email-masked]
>     *Subject:* RE: [Simple] Please comment: Do we want to take on
>     partial publication?
> 
> 
>     It is not important only for low bandwidth networks. It is also
>     important for very big deployments given the
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Thanos Diacakis" <[email-masked]>
Date: Tue, 31 Aug 2004 09:02:21 -0600

I would also very much support proceeding with this.  

In addition to being required by 3GPP, it seems it is also required by OMA,
if you looking the latest publically available version of their Presence
Requirements document
(http://member.openmobilealliance.org/ftp/public_documents/req/Permanent_doc
uments/OMA-RD_Presence-V1_0_0-20040622-D.zip) Section 6.1.3.1, Item 4.

As such, it would be best if IETF undertook this work, rather than having
multiple other fora undertake the same effort.

Thanos
---
Thanos Diacakis
Openwave Systems, Inc.
+1-303 385 6705  

> [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
> Sent: Tuesday, August 31, 2004 5:46 AM
> To: Atle Monrad (GR/ETO)
> Cc: [email-masked]
> Subject: Re: [Simple] Please comment: Do we want to take on 
> partial publication?
> 
> My take on this is that I find the specification of limited 
> utility, but certainly not harmful, and thus would not object 
> to proceeding with it.
> 
> The reason I think its of limited utility is that we don't 
> yet know whether or not it is really going to reduce 
> bandwidth; this depends on the evolving usage of presence 
> documents in deployment. If most folks end up using documents 
> with a single tuple and lots of data within that tuple, the 
> mechanism will not be useful. We don't know that yet; as 
> In as much as it is a proper solution to this potential 
> problem, I think it is OK. It has clear benefits over having 
> the PUA publish and refresh each tuple independently, though 
> the exact scope of those benefits again depends on what 
> presence documents end up looking like.
> 
> > My preference would be that SIMPLE adopt the i-d as WG-item. It has 
> > been hanging around for quite some time and should be 
> familiar to the 
> > interested parties. If such optionality it is not found useful for 
> > certain clients, just leave it out...
> > 
> > regards
> > 
> > Atle Monrad