Subject: [Simple] Please comment: Do we want to take on partial publication?

From: Robert Sparks <[email-masked]>
Date: Thu, 12 Aug 2004 15:05:31 -0500

Folks -

If you haven't already read it, please take a moment and
skim
http://www.ietf.org/internet-drafts/draft-lonnfors-simple-partial-publish-01.txt

We've had _very_ light list discussion on this draft. We talked
about it briefly at the interim in Boston, but it wasn't clear
that there was sufficient interest even in that room.

The primary question in that meeting was whether or not we
could meet the requirements this draft intends without doing
any additional standardization work (by having endpoints that
want to publish pieces act as one publisher per piece).

So speak up. Do you think this is a place SIMPLE needs to take
on more work? Who thinks we have a good enough solution for this
already? Who, in addition to the  authors of this draft, is willing
to spend time working on this problem?

Thanks,

RjS

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 16 Aug 2004 12:23:37 +0300

Hi,

Inline:

> 
> Hi Robert,
> 
> mobile networks are always interested in increasing
> efficiency. Requirements for Presence Service in 3GPP 
> Wireless Systems 
> (draft-kiss-simple-presence-wireless-reqs-03) contains:
> PUBL-REQ2: Partial publishing
> The publish mechanism must allow a PUA to change only part of 
> the presentity's presence information. For example, a        
> PUA must be able to publish one single <tuple> element of the 
> presentity's PIDF document, while the document contains 
> several <tuple> elements.
> 
> So, in general, I am interested in this work. Nevertheless,
> some information, concerning the possible increase in 
> efficiency could be helpful for motivation.
> 
> Two short comments to the current version of the draft.
> 
> Section 4.2.
> ".. the PUA MUST NOT change the content type between full and
> partial event state publications."
> 
> is somehow in contradiction to Section 4.3. exceptional
> cases: "In case the PUA changes the content type..."

The intention in section 4.2 is to say that if PUA wants to send a partial event state it must provide full event state using 'application/pidf-partial+xml' before it can send partial state. This will be fixed if we decide to move this work forward.   

> 
> In Section 4.2 it is mentioned:
> "When a presence user agent decides to use the partial
> publication machanism.." What could be the basis for this 
> decision? Keep in mind, that in case, the PA do not support 
> partial publication, this decision could even decrease 
> efficiency (fallback to full publication).

One option is to use OPTIONS. Decision can be based on local policy or device configuration. I don't think that loss of one request is really a problem here because it should happen only once before device knows that PA doesn't support partial publications.

- Mikko  

> Best Regards,
> Christian Schmidt
> 
> 
> 
> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]
> Im Auftrag von Robert Sparks
> Gesendet: Donnerstag, 12. August 2004 22:06
> An: [email-masked]
> Betreff: [Simple] Please comment: Do we want to take on 
> partial publication?
> 
> 
> Folks -
> 

We've had _very_ light list discussion on this draft. We talked about it briefly at the interim in Boston, but it wasn't clear that there was sufficient interest even in that room.

The primary question in that meeting was whether or not we could meet the requirements this draft intends without doing any additional standardization work (by having endpoints that want to publish pieces act as one publisher per piece).

So speak up. Do you think this is a place SIMPLE needs to take on more work? Who thinks we have a good enough solution for this already? Who, in addition to the  authors of this draft, is willing to spend time working on this problem?

Thanks,

RjS