Subject: [Simple] Policies and Events

From: "Alexeitsev, D" <[email-masked]>
Date: Wed, 18 Aug 2004 11:15:35 +0200

Hello All

Was it considered to unify the policy XML document with the related state event XML document (for example watcher auth)?

In such scenario a presentity would receive event XML document in a NOTIFY, change the state to "accepted" and upload it as a policy document or a fragment.  

In the current situation where policy and event documents are separated there is an additional need to define transitions between the states depending on the values in the policy document. Or is it considered obvious?

Greetings,
Denis Alexeitsev

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 19 Aug 2004 17:24:38 -0400

Alexeitsev, D wrote:

> Hello All
> 
> Was it considered to unify the policy XML document with the related
> state event XML document (for example watcher auth)?
> 
> In such scenario a presentity would receive event XML document in a
> NOTIFY, change the state to "accepted" and upload it as a policy
> document or a fragment.

That is not how it works, no. The watcherinfo states do not contain 
policy document fragments that would be uploaded.

> 
> In the current situation where policy and event documents are
> separated there is an additional need to define transitions between
> the states depending on the values in the policy document. Or is it
> considered obvious?

I don't see the problem here. There is a transition in the subscription 
states (and thus the watcherinfo states) based on policy changes. 
Perhaps you are asking for there to be a clear definition of the state 
changes in the subscription states when policy documents are uploaded? I 
think that is a reasonable request, and I can make that more explicit 
than it is today.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com