Subject: RE: [Simple] MSRP: Contributor ID

From: [email-masked]
Date: Tue, 10 Aug 2004 14:08:01 +0300

Does it seem reasonable to require the focus to wrap each chunk with cpim mime type and then having the end point unwrap it? or it is better that the focus just inserts a header indicating the sender? To me, it seems the latter is more straight forward.

In either case, we need to state conflict resolution: for the former, it can be stated that if the sender wrapped the message with cpim itself, the outer most cpim from-header wins. For the latter, the msrp header wins over any cpim from-header. This should be normative text for the receiver.

Also, I don't like the name "Contributor-ID". What is he contributing? I prefer something like "Sender".

/Hisham

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: 10.August.2004 00:14
> To: Ben Campbell
> Cc: Khartabil Hisham (Nokia-TP-MSW/Helsinki); Orit Levin; Rohan Mahy;
> Chris Boulton; Adam Roach; Cullen Jennings; Robert Sparks; Simple WG
> Subject: Re: [Simple] MSRP: Contributor ID
> 
> 
> 
> 
> Ben Campbell wrote:
> > 
> >>>> I think the two approaches aren't different enough in the work 
> >>>> required that they should be judged based on that.
> >>>>
> >>>> Its probably more important to get the semantics right. 
> Suppose we 
> >>>> were to go with this new header. And then suppose we had 
> conference 
> >>>> participants sending CPIM wrapped messages that contain a From 
> >>>> header. What identity should the recipient display?
> >>>
> >>> It seems to me that this is a matter for the conference policy to 
> >>> solve, and is not significantly different than if you 
> have a voice 
> >>> conference, and a caller has a different identity in the 
> credentials 
> >>> for a SIP dialog than in the conference policy.
> >>
> >> Certainly it *can*. But as long as the endpoint can 
> receive identity 
> >> information in two ways there will always be more 
> confusion that if 
> >> there is only one way.
> > 
> > It seems like the same problem can exist, regardless of 
> whether we use 
> > cpim or a header for this. Even if we just use cpim, you 
> could still 
> > have an endpoint use a cpim envelope, just to have the 
> focus blindly 
> > stick that inside _another_ cpim envelope.
> 
> Well, maybe that is the case. I wouldn't expect the mixer to 
> put another 
> CPIM wrapper around a message that already had one. I would 
> expect it to 
> either adjust the existing wrapper, possibly changing the From header;
> 
> OR, (equivalently) remove the incoming CPIM wrapper and 
> replace it with 
> a new one constructed by the mixer, possibly using some of the header 
> values from the incoming one.
> 
> If this new header is added, then either the mixer should remove the 
>  From header from any CPIM wrapper, or else should force the 
> two to be 
> the same.
> 
> I think I am still inclined to prefer using CPIM, but I don't 
> have any 
> compelling arguments for it.
> 
> 	Paul
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 11 Aug 2004 10:51:17 -0400

[email-masked] wrote:
> Does it seem reasonable to require the focus to wrap each chunk
 > with cpim mime type and then having the end point unwrap it?
 > or it is better that the focus just inserts a header indicating
 > the sender? To me, it seems the latter is more straight forward.

The point of this discussion has been that it isn't necessary to wrap 
*each chunk*. The wrapping only requires an alteration to the first 
chunk and the last chunk.

> In either case, we need to state conflict resolution: for the former,
 > it can be stated that if the sender wrapped the message with cpim
 > itself, the outer most cpim from-header wins. For the latter,
 > the msrp header wins over any cpim from-header. This should be
 > normative text for the receiver.

How does this apply to messages that pass through one or more CPIM 
gateways?

Consider the following case:

- Message comes in through CPIM gateway (say from an XMPP system).
CPIM headers specify From and To, and a text/plain message.

- It is sent (in CPIM format) via MSRP to a conference mixer.

- The mixer stamps the message (using a TBD technique) with the identity 
of the sender as known to the mixer, and sends it out to the other 
participants.

- It arrives at another CPIM gateway, where it is converted again to 
XMPP format.

What should the XMPP recipient see? I think it should see a message that 
appears to come from the identity inserted by the mixer.

Ideally we would be able to achieve this without changes to the RFCs 
2778 and 2779. To achieve this, I think that by the time the message 
flows thru the outgoing gateway it should have *one* CPIM wrapper that 
contains the From address provided by the mixer.

Perhaps this doesn't change anything - the gateway could take the Sender 
header from the MSRP message and insert it into the CPIM From header 
before passing the message on. This is a problem for messages that are 
to be signed or encrypted e2e (between the xmpp systems), but that is 
always going to be a problem in this case.

It may be that in some of these cases we must live with the fact that 
messages may have multiple sources of sender identity, and all should be 
presented to the recipient.

 > I prefer something like "Sender".

I agree.

	Paul

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 11 Aug 2004 13:41:00 -0700

You would just wrap the complete message.  However Hisham's point is 
still valid (although the integers were off ;-). If you were sending a 
complete message that is 2000 bytes, if the focus adds 100 bytes of 
CPIM, the resulting message will be larger than 2048 bytes and will 
need to interruptible or explicitly chunked.  I think its reasonable to 
try to prevent this situation.

If we do decide to use a separate header (ex: "Sender") then I suggest 
that the syntax allows any type of URI.

thanks,
-rohan

On Aug 11, 2004, at 7:51 AM, Paul Kyzivat wrote:

> - The mixer stamps the message (using a TBD technique) with the 
> identity of the sender as known to the mixer, and sends it out to the 
> other participants.
>
> What should the XMPP recipient see? I think it should see a message 
> that appears to come from the identity inserted by the mixer.
>
> Perhaps this doesn't change anything - the gateway could take the 
> Sender header from the MSRP message and insert it into the CPIM From 
> header before passing the message on. This is a problem for messages 
> that are to be signed or encrypted e2e (between the xmpp systems), but 
> that is always going to be a problem in this case.
>
> messages may have multiple sources of sender identity, and all should 
> be presented to the recipient.
>