Subject: [Simple] FW: CPCP Issue 37: Generic privileges solution

From: [email-masked]
Date: Mon, 13 Sep 2004 16:51:56 +0300

The draft can be found at:
http://www.imsbook.com/hisham/draft-ietf-xcon-conference-policy-privileges-00.txt

SIMPLE WG comments are being sorted on this issue presented below.

Thanks,
Hisham

> -----Original Message-----
> From: Khartabil Hisham (Nokia-TP-MSW/Helsinki) 
> Sent: 13.September.2004 16:46
> To: [email-masked]'
> Subject: CPCP Issue 37: Generic privileges solution
> 
> 
> This issue affects 
> draft-ietf-xcon-conference-policy-privileges-00.txt.
> 
> The schema in this draft is generic and can be used for any 
> XML document that carries user information and resides on a 
> server. It is useful especially for XCAP.
> 
> I have been toying with the idea of extracting the schema 
> into a separate draft and submitting that in SIMPLE. XCON can 
> then use that draft and customise it for conferencing needs. 
> By customising it, I mean defining the actions and 
> transformations that grant the conferencing specific 
> privileges to users.
> 
> This solution uses common policy as well where the conditions 
> carry the document URI and the identity of users and the 
> actions carry the privileges (read/modify certain parts of 
> the conference policy).
> 
> BTW, the draft defines a sematic approach as agreed in San Diego.
> 
> So, what do people think of that?
> 
> I'll forward this email to SIMPLE for comments.
> 
> Regards,
> Hisham
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Tue, 21 Sep 2004 10:57:56 +0300

It would be great if I can get people's gut feeling on this.

Thanks,
Hisham

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext [email-masked]
> Sent: 13.September.2004 16:52
> To: [email-masked]
> Subject: [Simple] FW: CPCP Issue 37: Generic privileges solution
> 
>