Subject: [Simple] URI for Resource Lists

From: "Alexeitsev, D" <[email-masked]>
Date: Mon, 13 Sep 2004 13:15:48 +0200

Hi All,

I would like to discuss the issue of resource lists URI starting with the introduction.

Resource lists draft does not give much guidelines about the creation of URI for the resource lists.

It is only says that it is a SIP URI and from the given examples one can assume that the URIs are taken from the same namespace as URIs for the "real" resources that actually provide presence information.

I can see the idea behind looking at the resource lists from the namespace perspective just as at any other resource that one can subscribe to receive presence information.

However such definition complicates the assignment of the URI to the "real" resources (subscribers) as one must check if the URI that subscriber has picked up (e.g. Web-Provisioning) is not only already taken by another subscriber, but also if it is not already somewhere taken for the resource list.

Additionally there is no automatic provisioning at the UA, as subscribers will have to fill just another form to point to the resource list URI.

A proposal would be to use something like user=resource-list URI parameter to separate this namespaces. Provisioning of the resource list URI in the UA could be done automatically by the UA, as it would be the same as the subscribers own URI with the the user=resource-list parameter. 

Surly extra resource lists URIs can be assign to the subscriber, but that would be a specific add-on for which subscribers will have to take the pain to manually provision them in to their UAs.    

Greetings,
Denis Alexeitsev

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 13 Sep 2004 08:40:27 -0400

Denis,

I'm sure there are a multitude of ways to do this, and I'm not convinced 
it needs to be a matter for IETF standardization.

Personally, I have been thinking that a resource list server would 
normally have a domain name distinct from that normally used for "user" 
AORs.

For instance:

- User AORs:
   sip:[email-masked]

- Resource list AORs:
   sip:[email-masked]
   sip:[email-masked]

	Paul