Subject: RE: [Simple] Strength of XML validity requirements in SIMPLE documents

From: [email-masked]
Date: Mon, 20 Sep 2004 11:00:50 +0300

I see Jonathan's point here. 

I think what we need is 2 normative sentences here: The XML document MUST be valid for the creator and SHOULD be valid for the consumer. It is a MUST for the creator since there is no reason whatsoever for the document to be produced and not validated. It is a SHOULD for the consumer since the XML document may have extensions that are not understood but are valid according to the base schema. The consumer can truly validate the XML document if he possesses all schema extensions required.

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Jonathan Rosenberg
> Sent: 20.September.2004 08:16
> To: Urpalainen Jari (Nokia-NRC/Helsinki)
> Cc: Pessi Pekka (Nokia-NRC/Helsinki); Robert Sparks; [email-masked]
> Subject: Re: [Simple] Strength of XML validity requirements in SIMPLE
> documents
> 
> 
> inline.
> 
> Jari Urpalainen wrote:
> 
> > ext Jonathan Rosenberg wrote:
> > 
> >> inline.
> >>
> >> Pekka Pessi wrote:
> >>
> >>> Jonathan Rosenberg <[email-masked]> writes:
> >>>
> >>>> Hmm, its a good question. I think that the vast majority of XML
> >>>> docs produced in the SIP/SIPPING/SIMPLE groups have the same
> >>>> words, and to be honest, I had not given a ton of thought to MUST
> >>>> vs. SHOULD for valid. I can't really think of a reason why it
> >>>> would ever be the right thing to produce a document that is not
> >>>> valid, particularly if the recipient does schema validation.
> >>>
> >>>
> >>>
> >>>
> >>> The presence documents may contain all kind of extensions, which
> >>> may be only meaningful for a single application using the presence
> >>> service. The presence servers or any intermediate nodes (not to
> >>> speak about any innocent watcher) can't really know if the
> >>> documents are valid unless they know the schema for all of
> >>> those extensions.
> >>>
> >>> Like, if composer puts two tuples from two different sources to
> >>> the combined document in the presence server. Both the extensions
> >>> use ID attributes, but how could the composer know which
> >>> attributes have xs:ID type? The following example may be valid, or
> >>> then not, but who is to say without a schema?
> >>
> >>
> >>
> >> It depends on how you want to define "valid". If a 
> document has some 
> >> extensions (say, rpid ones), such a document is still 
> valid according 
> >> to just the pidf schema, since it contains well-formed 
> elements from 
> >> another namespace in a place allowed by the schema.
> >>
> >> So, when we say "SHOULD be valid", do we mean that all 
> elements in the 
> >> document should be valid according to their defined 
> schemas, or just 
> >> that the document is valid according to the pidf schema?
> >>
> >> -Jonathan R.
> > 
> > 
> > IMO pidf schema requirement is a "MUST" as content-type 
> > application/pidf+xml is defined by that schema. How could 
> you use some 
> > instance document with that content-type if it is not valid ? 
> 
> No, that's not what I'm saying.
> 
> I'm saying that a document of type application/pidf+xml could 
> be valid 
> against the PIDF schema, but it contains extensions (which 
> are allowed 
> in the pidf schema), and those extensions make use of 
> elements defined 
> in another schema. However, those elements are not valid according to 
> that other schema.
> 
> In this case, do we consider this document "valid"?
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Pete Cordell" <[email-masked]>
Date: Mon, 20 Sep 2004 10:27:29 +0100

I think the statements needs to be something like:

The XML document MUST be valid for the creator (no change).

The XML document MUST be valid for the consumer according to the perhaps
incomplete set of schema copies that it holds (or has access to) that are
applicable to the XML document.

The wording sucks, but hopefully you can see the intent!

Pete.
--
=============================================
Pete Cordell
Tech-Know-Ware
pete(at)tech-know-ware.com
http://www.tech-know-ware.com
http://www.xml2cpp.com - Now Available
+44 1473 635863
=============================================

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Monday, September 20, 2004 9:00 AM
Subject: RE: [Simple] Strength of XML validity requirements in SIMPLE
documents

I think what we need is 2 normative sentences here: The XML document MUST be
valid for the creator and SHOULD be valid for the consumer. It is a MUST for
the creator since there is no reason whatsoever for the document to be
produced and not validated. It is a SHOULD for the consumer since the XML
document may have extensions that are not understood but are valid according
to the base schema. The consumer can truly validate the XML document if he
possesses all schema extensions required.

Regards,
Hisham

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 20 Sep 2004 10:50:02 -0400

[email-masked] wrote:
> I think what we need is 2 normative sentences here:
 > The XML document MUST be valid for the creator

I think the above can cause problems, depending on how you define "creator".

Consider a presence document that is created by a UA and published to a 
PS. The PS then aggregates the contents of this published document, 
filters that, and thus creates another presence document that is send 
out in a NOTIFY.

The UA could have used an extension that is unknown to the PS. But IMO 
the PS should still have the option of including that unknown portion 
into the document it sends out in the NOTIFY. But then it would be 
violating this new proposed rule.

Imposing this rule *requires* that the PS be aware of any extensions 
used by any of its sources of presence information.

So I think this all needs to be SHOULD level. Also, I agree with Pete's 
later comment that validity according to PIDF is always a requirement.

	Paul

 > and SHOULD be valid for the consumer. It is a MUST for the creator 
since there is no reason whatsoever for the document to be produced and 
not validated. It is a SHOULD for the consumer since the XML document 
may have extensions that are not understood but are valid according to 
the base schema. The consumer can truly validate the XML document if he 
possesses all schema extensions required.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 20 Sep 2004 12:31:33 -0400

inline.

> violating this new proposed rule.

Right. It can be easier to define these validity rules in the context of 
a specific protocol usage, and in the above case we could except a 
presence server from needing to generate valid documents. Those kinds of 
rules belong in protocol documents, not in the specifications of the 
document formats themselves.

-Jonathan R.