Subject: RE: [Simple] Extend UA Capabiity Extension to PIDF

From: Goix Walter <[email-masked]>
Date: Mon, 27 Sep 2004 18:04:14 +0200

I also agree that UAProf-type of information should not be carried along
with presence information. I would rather prefer some kind of Profile:
header in SIP requests that points to an OMA-like UAProf URL which also
describes SIP caps in a more complete way than RFC3840 does (I don't
think that RFC has been thought to define such info)

Laurent-Walter Goix
Telecom Italia - TILAB
Service and Platform Innovation - Service Control Platforms

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Helsen Frank
> Sent: Monday, September 27, 2004 1:44 PM
> To: 'Jonathan Rosenberg'
> Cc: Paul Kyzivat; [email-masked]'
> Subject: RE: [Simple] Extend UA Capabiity Extension to PIDF
> 
> 
> This is indeed what I had in mind.  Thanks for the 
> clarification.  And I agree that this is not presence 
> information. The approach in RFC3840 where the device 
> capabilities are transported in the REGISTER seems the 
> correct solution.  Better then having it in a NOTIFY.  
> However, RFC3840 does not create the option to specify the 
> device.  One would not have to think about what device 
> information a provider/PS/Application would like to have.  
> Just specify which device it is and it is up to him to get 
> the required information (using device profiles).
> 
> Regards,
> 
> Frank
> 
> Frank Helsen - MPM/IMC System Engineer
> Mail: [email-masked]
> Tel:+32 14 252573
> Mobile: +32 494 692959
> Siemens HRT IC MN D D1
> 
> 
> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: vrijdag 24 september 2004 17:48
> To: Paul Kyzivat
> Cc: Helsen Frank; [email-masked]'
> Subject: Re: [Simple] Extend UA Capabiity Extension to PIDF
> 
> 
> My guess is that Helsen is looking at something equivalent to 
> the UAProf 
> functions in WAP, which allow a client to push fairly complicated 
> information about itself, such as screen size and JVM. I don't think 
> this is "presence" in the sense that much of this information is 
> probably not useful to watchers. However, it does represent 
> valid device 
> information and could conceivably appear there.
> 
> We do have a specification, RFC 3840, which allows a client 
> to declare 
> its capabilities to the server. That specification does not 
> dictate how 
> this information is used. One usage is caller preferences, RFC 3841, 
> which allows for capability-based called routing. However, I think 
> Helsen has in mind a usage where the provider/domain owner 
> simply wants 
> to look at this profile data for some reason, and that is certainly 
> possible.
> 
> We have only a very limited set of capabilities declare right now, a 
> much, much, much smaller subset of what is in UAProf.
> 
> -Jonathan R.

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to 
[email-masked]. Thank you
====================================================================

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Aki Niemi <[email-masked]>
Date: Tue, 28 Sep 2004 14:58:57 +0300

> think that RFC has been thought to define such info)

How about using the User-Agent header field?

Cheers,
Aki