Subject: [Simple] MIME type in presence-rules

From: [email-masked]
Date: Thu, 14 Oct 2004 15:49:43 -0700

Hi,

While the xcap-list-usage draft defines appropriate MIME types both for resource-lists and rls-services, the presence-rules draft does not have a MIME type definition. Any particular reason for this? 

Thanks
Krisztian

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 14 Oct 2004 21:03:48 -0400

This is a good question.

I didnt put one in since the presence-rules are actually extensions of 
common policy. Just like RPID, the MIME type is the type of the parent 
definition. In this case, its common-policy. However, common-policy 
doesnt define a MIME type either, but it needs to.

Hannes - this is a bug in the common-policy spec. Can you define a MIME 
type for the document? I'd suggest application/common-auth-policy+xml.

Thanks,
Jonathan R.

[email-masked] wrote:
> Hi,
> 
> While the xcap-list-usage draft defines appropriate MIME types both
> for resource-lists and rls-services, the presence-rules draft does
> not have a MIME type definition. Any particular reason for this?
> 
> Thanks Krisztian
> 
> _______________________________________________ Simple mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/simple
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com