Subject: RE: [Simple] Re: Presence Data Model: Overriding services (tuples)

From: [email-masked]
Date: Wed, 13 Oct 2004 16:49:25 +0300

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Jonathan Rosenberg
> Sent: 13.October.2004 13:26
> To: Henning Schulzrinne
> Cc: Paul Kyzivat; [email-masked]; Dag Ekengren; Isomaki Markus
> (Nokia-TP/Espoo)
> Subject: Re: [Simple] Re: Presence Data Model: Overriding services
> (tuples)
> 
> 
> 
> 
> Henning Schulzrinne wrote:
> 
> > 
> >> At the moment the answer is that Jonathan's data model 
> document says 
> >> they must be unique.
> > 
> > 
> > Hmm; I thought the discussions in the design team allowed 
> them to be 
> > non-unique. I don't see how this can realistically be enforced. 
> 
> The enforcement is only within a document. The entity that 
> creates the 
> document, be it the compositor or the publishers, just doesn't put 
> multiple services with the same URI. I dont understand why 
> this is hard.

This is a point that needs emphasising. I think people misunderstood it as no PUA can publish a service with the same service URI as another PUA.

Regards,
Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 13 Oct 2004 10:42:23 -0400

> This is a point that needs emphasising. I think people misunderstood it as no PUA can publish a service with the same service URI as another PUA.

Yes, this was understood.

But it also means that a composer cannot create a document with two 
services having the same service URI. And that in turn means that when a 
composer is presented with two documents that each have a service that 
share the same URI, it MUST either make a choice or merge them in some 
way, or else somehow substitute a different URI in one of them. These 
all require a relatively sophisticated composition policy if you expect 
the result to be reasonable.

I also want to note that while this discussion has so far focused on 
contact addresses in tuples, the issue of allowing conflicting 
information in the document also applies to <person> and <device>.

	Paul