Subject: [Simple] New partial publish draft

From: Aki Niemi <[email-masked]>
Date: Thu, 28 Oct 2004 11:35:24 +0300

All,

A new version of the partial publication draft is available. Until it
appears in the archives, a copy has been placed at:

http://people.nokia.net/~aki/drafts/draft-ietf-simple-partial-publish-01.txt

Changes:

- This version uses the updated partial-format, meaning that rather than
working on a per tuple basis, the PUA can make finer-grained granular
updates to the presence information.

- Initial publications now contain full-state using the normal PIDF
format. Clients will also fall back to PIDF if a partial update receives
a 415 error response.

Comments most welcome.

Cheers,
Aki

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Thu, 28 Oct 2004 22:00:02 +0300

Hi,

> Hi Aki,
> 
> I like it, it is short and pregnant. Nevertheless some ideas:
> 
> - What about PDIF extensions, for example RPID, CIPID ...? 
> Could this paper cover partial publish for other presence 
> related informations as well? Would there be a need for a 
> partial-rpid format draft? What extensions would be necessary 
> in your draft?

Actually the draft should already be covering those cases. All partial drafts (publish and notify) utilize new PIDF diff format (http://www-nrc.nokia.com/ietf-sip/draft-ietf-simple-partial-pidf-format-02.txt) which allows sending updates to RPID, CIPID or to any other extension. 

BR
- Mikko
> Regards,
> Christian