Subject: FW: Re: [Simple] Pres Data Model Open Issue #5: what does idle mean?

From: "Boyer, David G \(Dave\)" <[email-masked]>
Date: Wed, 6 Oct 2004 10:23:01 -0400

[Boyer, David G (Dave)]  Johnathan,

hmmm.
Not sure what the right answer is here - inline

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Friday, October 01, 2004 10:21 PM
> To: Boyer, David G (Dave)
> Subject: Re: [Simple] Pres Data Model Open Issue #5: what does idle
> mean?
> 
> 
> inline.
> 
> Boyer, David G (Dave) wrote:
> 
> > Jonathan -
> > 
> > 
> >>service-idle: For a service which receives input while it is 
> >>the "focus" of the user interaction (focus in the user 
> >>interface sense), there has been no input. For example, if my 
> >>IM app is running, but I haven't selected it on my PC, its 
> >>idle even though I may be typing into another app.
> >>
> > 
> > If the IM app is idle long enough it might report "unavailable."
> 
> Are you saying that the IM app would change the <basic> 
> status from open 
> to close if it detects excessive idle?
> 
Yes.  This was actually a customer request we had a few years ago.  Some users are
good about updating their availability status ("out to lunch", "in meeting", etc.),
others don't want to be bothered and prefer that the system, after an appropriate
period of idleness, change their status to off-line.

> 
> > If the device (PC in this case) detects typing, even though it is
> > in another app, isn't appropriate to treat the IM client as 
> available?
> 
> Sure. What we're trying to do here is come up with a well-defined 
> meaning for <idle> in the context of devices or services. That doesn't 
> imply that any particular definition for service idle MUST have the 
> property that service idle implies "unavailability". A watcher could 
> choose to present a single icon to the user indicating 
> "availability", 
> and compute that icon locally based on a combination of all of the 
> information in the presence document.
> 
> That said, in my original post, I had proposed that another 
> formulation 
> of idle is that it means that the presentity believes that there is a 
> high likelihood that attempts to communicate with this service will 
> result in a no-answer. Perhaps you are arguing that we should define 
> idle in that fashion?

This is tricky.  On the one hand, if the user is typing at their computer 
(checking their email first thing in the morning) you
could argue that all applications that have a <basic> status to be
closed should have it changed  to open.  If each application is
not checking for keyboard/mouse activity, how is it going to be possible to do this?
The Presence server will only know that the Service basic state is closed,
the user may have set it that way, or it could have been set by the application when
it reaches it's idle threshold.
Not sure what the answer is.  Seems you need to know what entity set
the <basic> status to make this decision.

dave

> 
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Henning Schulzrinne" <[email-masked]>
Date: Wed, 6 Oct 2004 12:32:19 -0400

FW: Re: [Simple] Pres Data Model Open Issue #5: what does idle mean?On some 
systems, activity for all applications monitors the equivalent of /dev/kbd, 
rather than input to a particular application. This may not always be 
possible. But I suppose one could distinguish between "direct" activity 
('user input to this application') and inferred activity ('system/device 
that hosts the service has shown user input').

------------

not checking for keyboard/mouse activity, how is it going to be possible to 
do this?
the user may have set it that way, or it could have been set by the 
application when