Subject: RE: [Simple] Data model - attempt at summary

From: [email-masked]
Date: Wed, 20 Oct 2004 11:36:53 +0300

Henning,

I like the proposal presented in the web page. I think we need element identifiers beyond contact URI for tuple and device-id for device, and I think we should define a simple default composition policy. 

I think the composition policy where latest publication with a particular element identifier always wins over other publications with that element identifier is the best we can do right now. 

The main issue with that policy is that if a PUA updates (not just refresh) its publication state automatically, it is not possible to permanently override if from another PUA. For instance PUA1 publishes person element with activity "in a meeting" and with idle attribute. The user is actually somewhere else and would like to set the person state to something else. The default composition policy would allow creating a UI with this kind of explicit override option, and PUA2 could thus publish person element with the same id as PUA1 is using. For a while everything is as the user wants, but unfortunately PUA1 can anytime update the idle element, thus making the person to appear to be in the meeting once again...

This seems hard to solve until we really specify how to set the rules to solve this. It is certainly possible to address this already now by adding more meta-data within the presence state, but I have got the feeling that people don't want this.

So I would resign myself to stick with what is proposed on the web page at this point.

Markus

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Henning Schulzrinne
> Sent: 18 October, 2004 06:27
> To: Simple WG
> Subject: [Simple] Data model - attempt at summary
> 
> 
> After a brief absence, I find it difficult to reconnect to the 
> discussion and its >>>>> layers.
> 
> I'm trying a slightly different approach in summarizing the 
> issues on a 
> web page, as I then might be able to update some of the 
> differences and 
> agreements:
> 
> http://www.cs.columbia.edu/sip/draft/rpid/presence_model.html
> 
> I don't think anything that I'm proposing is more than a tweak and 
> slight generalization of the existing data model. I believe 
> the meaning 
> to the watcher is clearly defined in all such cases, except 
> that I don't 
> sweep uncertainty under the rug.
> 
> If there are core assumptions that should be added, let me know.
> 
> I expect people to disagree with some of the assumptions, but 
> it would 
> also be helpful if we can move some of these bullets, 
> possibly modified, 
> into a common understanding section.
> 
> Henning
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Boehmer Bernhard ICM Berlin <[email-masked]>
Date: Thu, 21 Oct 2004 11:39:21 +0200

Henning,
very helpful. Should do that for more threads...
Unfortunately, I see two candidates for the 
critical open issues section:
- service identification is not yet resolved if haven't missed
  something. There seems to be some convergence in the group regarding 
  URI as a basis but I think there are some issues here;
  see also the draft 
http://www.ietf.org/internet-drafts/draft-boehmer-simple-service-identification-00.txt
  for a discussion of them. 
- You once brought up the question of device identification. 
  Probably I missed here something but I had the impression
  that it remains an open issue.

Another feature which, however, could be deferred is the question
of internal service states as presence information (this relies to
the fifth bullet in your web page). In the abovemetioned draft I
touched a bit upon that but there is no clear answer on that in the
moment. 
		Best regards Bernhard

> -----Ursprüngliche Nachricht-----
> Von: Henning Schulzrinne [mailto:[email-masked]] 
> Gesendet: Montag, 18. Oktober 2004 05:27
> An: Simple WG
> Betreff: [Simple] Data model - attempt at summary
> 
>