Subject: Re: [Simple] Review of draft-ietf-simple-message-sessions-08 - Byte Ranges in REPORTs

From: Ben Campbell <[email-masked]>
Date: Fri, 1 Oct 2004 17:17:56 -0500

On Sep 27, 2004, at 5:57 AM, [email-masked] wrote:

> I agree. The situation is further complicated when a relay decides to 
> re-chunk. The relay then has to consume the REPORTs and generate it 
> own to pass upstream.
>

I don't see why. There is no requirement that the byte-range in a 
REPORT match the precise byte-range in any chunk that you sent.

> /Hisham
>
>> -----Original Message-----
>> From: [email-masked]
>> [mailto:[email-masked]]On Behalf
>> Of ext Paul Kyzivat
>> Sent: 24.September.2004 19:21
>> To: [email-masked]
>> Subject: [Simple] Review of
>> draft-ietf-simple-message-sessions-08 - Byte
>> Ranges in REPORTs
>>
>>
>> I am really confused about how byte ranges are supposed to work in
>> reports, and I suspect we are permitting a bunch of nonsense.
>>
>> Fundamentally, a message can only be considered a success if all its
>> bytes are received successfully. If it is to be positively
>> acknowledged
>>    with success reports, then there must be success reports covering
>> every byte. Is there any point in sending a success report
>> for less than
>> the entire message? It doesn't help the receiver, and actually makes
>> more work because it then requires keeping track of what
>> bytes have been
>> confirmed. And it doesn't ease the job of the sender, who could easily
>> just wait until all has been received before sending the
>> success report.
>>
>> The flip side is that a message fails if a single byte fails. At that
>> point it does no good to know that other parts succeeded or failed. So
>> while it makes sense to send a failure report based on problems with a
>> single chunk, there is little value in saying which byte range failed.
>>
>> Bottom line: unless I have missed something, there is no reason for
>> Byte-Range in REPORT or responses. A success report should
>> only be sent
>> after all the chunks of a message have been received. A
>> failure report,
>> or an error status, can be sent at the time the failure of a single
>> chunk is known, but need not identify the byte range. (In that case,
>> maybe the Byte-Range could be optional for debugging purposes only.)
>>
>>
>>
>>
>> _______________________________________________
>> Simple mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/simple
>>
>
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
>

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Mon, 4 Oct 2004 12:46:39 +0300

> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: 02.October.2004 01:18
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] Review of 
> draft-ietf-simple-message-sessions-08 -
> Byte Ranges in REPORTs
> 
> 
> 

If that is the case, then please clarify the text in the ID.

Thanks,
Hisham