Subject: Re: [Simple] Review of draft-ietf-simple-message-sessions-08 - Syntax

From: Ben Campbell <[email-masked]>
Date: Fri, 1 Oct 2004 17:44:37 -0500

On Sep 24, 2004, at 11:21 AM, Paul Kyzivat wrote:

> Section 5: MSRP URL syntax:
>
> There is an undefined reference to "ALPHANUM". RFC2396 defines 
> "alphanum", but that is only a single byte. Suggest replacing ALPHANUM 
> with 1*alphanum, and reference 2396 for alphanum.

ok. (I thought I fixed that one already, too. Grumble.)

>
> Rohan wanted "?" syntax added.

I don't understand the statement.

>
> Section 8: Formal Syntax:
>
> I don't know what resulted in the following:
>
>     dUmMy= "Status:" SP namespace SP short-status [SP text-reason]
>
> It must have been intentional. But the 'Status' element is undefined, 
> so I think this needs to be changed to:
>
>     Status = "Status:" SP namespace SP short-status [SP text-reason]
>

Hmm... OK.

> We define pval as:
>
>     pval = token / quoted-string
>
> We might want to consider making it compatible with generic-param in 
> 3261, which also permits it to be a 'host'.

OK.

>
>
>
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
>

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 05 Oct 2004 10:56:36 -0400

> I don't understand the statement.

We had better check with him, but I believe he wanted the "?" syntax for 
queries (that http uses) added to the msrp url syntax, so that clients 
of relays could use that to generate a family of distinct URLs after 
receiving a single one from the relay. (This is analogous to the use of 
the grid parameter with GRUUs.)

So, I could connect to my friendly neighborhood relay, and get back a 
url like:

	msrp://atlanta.example.com:7654/jshA

and then establish multiple sessions using things like:

	msrp://atlanta.example.com:7654/jshA?one
	msrp://atlanta.example.com:7654/jshA?two

Interestingly, I just noticed that section 3 already has an example using:

	msrp://atlanta.example.com:7654/jshA7we;tcp

which isn't legal according to the current syntax.

	Paul

---

From: Ben Campbell <[email-masked]>
Date: Tue, 5 Oct 2004 17:20:18 -0500

On Oct 5, 2004, at 9:56 AM, Paul Kyzivat wrote:

> We had better check with him, but I believe he wanted the "?" syntax 
> for queries (that http uses) added to the msrp url syntax, so that 
> clients of relays could use that to generate a family of distinct URLs 
> after receiving a single one from the relay. (This is analogous to the 
> use of the grid parameter with GRUUs.)
>

Right. I remember now...

> which isn't legal according to the current syntax.

I must be missing something--what is illegal about it?

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 05 Oct 2004 18:36:17 -0400

> I must be missing something--what is illegal about it?

Never mind. I'm just blind today. I guess I had "?" on my mind because I 
read "jshA7we" as "jshA?we". :-(

	Paul