Subject: [Simple] Re: RFC 3856 - Fetching Mechanism

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 22 Nov 2004 02:41:16 -0500

A fetch is done with a SUBSCRIBE with an Expires of zero seconds. This 
results in a single NOTIFY containing the state of the resource.

-Jonathan R.

Rajesh Karunamurthy wrote:

> Hi,
> 
> I have a small clarification regarding the fetching operation that could 
> be performed with subscription mechanism in RFC 3856.
> 
> The RFC tells that the SUBSCRIBE with an immediate expiration results in 
> fetching of the presence information. What it exactly means by immediate 
> time? Is it 5 seconds, 10 seconds, 30 seconds ?How is this fixed?
> 
> Let us assume that the rate of notification is 5 seconds. A user who is 
> not aware of the rate of notification time needs to fetch a presence 
> document. He  sends a subscribe request with 60 seconds, assuming its an 
> "immediate " time. On the other hand the implemented system assumes that 
> user needs subscription for 60 seconds and sends 10-12 notifications. 
> But this is not what the user expected. I think this is a possible 
> scenario. How can this be handled ? Am i wrong?
> 
> If this is really a problem, the solution would be something like this. 
> The presence document is fetched once if the expiration time is lesser 
> than the rate of notification time. If the expiration time is greater 
> than rate of notification time the user gets subscribed and ofcourse the 
> user can unsubscribe by sending the expiration time set to zero.
> 
> Am I wrong or missing out something? Please respond and advice me if I 
> am out of track.
> 
> Thanks a lot,
> Rajesh
> 
> _________________________________________________________________
> Designer Mail isn't just fun to send, it's fun to receive. Use special 
> stationery, fonts and colors. 
> http://join.msn.com/?pgmarket=en-ca&page=byoa/prem&xAPID=1994&DI=1034&SU=http://hotmail.com/enca&HL=Market_MSNIS_Taglines 
>  Start enjoying all the benefits of MSN® Premium right now and get the 
> first two months FREE*.
> 
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Rajesh Karunamurthy" <[email-masked]>
Date: Thu, 18 Nov 2004 07:37:53 +0000

Hi,

I have a small clarification regarding the fetching operation that could be 
performed with subscription mechanism in RFC 3856.

Let us assume that the rate of notification is 5 seconds. A user who is not 
aware of the rate of notification time needs to fetch a presence document. 
He  sends a subscribe request with 60 seconds, assuming its an "immediate " 
time. On the other hand the implemented system assumes that user needs 
subscription for 60 seconds and sends 10-12 notifications. But this is not 
what the user expected. I think this is a possible scenario. How can this be 
handled ? Am i wrong?

If this is really a problem, the solution would be something like this. The 
presence document is fetched once if the expiration time is lesser than the 
rate of notification time. If the expiration time is greater than rate of 
notification time the user gets subscribed and ofcourse the user can 
unsubscribe by sending the expiration time set to zero.

Am I wrong or missing out something? Please respond and advice me if I am 
out of track.

Thanks a lot,
Rajesh

---

From: Srini Krishnamoorthy <[email-masked]>
Date: Tue, 23 Nov 2004 17:16:17 -0500 (EST)

Expires:0 in the SUBSCRIBE, does a immediate fetch (see 3.3.6 RFC3265)

Notifiers are supposed to respond with a NOTIFY as soon as a 
SUBSCRIBE is received.  

-Srini

On Thu, 18 Nov 2004, Rajesh Karunamurthy wrote:

rajesh>Hi,
rajesh>
rajesh>I have a small clarification regarding the fetching operation that could be 
rajesh>performed with subscription mechanism in RFC 3856.
rajesh>
rajesh>The RFC tells that the SUBSCRIBE with an immediate expiration results in 
rajesh>fetching of the presence information. What it exactly means by immediate 
rajesh>time? Is it 5 seconds, 10 seconds, 30 seconds ?How is this fixed?
rajesh>
rajesh>Let us assume that the rate of notification is 5 seconds. A user who is not 
rajesh>aware of the rate of notification time needs to fetch a presence document. 
rajesh>He  sends a subscribe request with 60 seconds, assuming its an "immediate " 
rajesh>time. On the other hand the implemented system assumes that user needs 
rajesh>subscription for 60 seconds and sends 10-12 notifications. But this is not 
rajesh>what the user expected. I think this is a possible scenario. How can this be 
rajesh>handled ? Am i wrong?
rajesh>
rajesh>If this is really a problem, the solution would be something like this. The 
rajesh>presence document is fetched once if the expiration time is lesser than the 
rajesh>rate of notification time. If the expiration time is greater than rate of 
rajesh>notification time the user gets subscribed and ofcourse the user can 
rajesh>unsubscribe by sending the expiration time set to zero.
rajesh>
rajesh>Am I wrong or missing out something? Please respond and advice me if I am 
rajesh>out of track.
rajesh>
rajesh>Thanks a lot,
rajesh>Rajesh
rajesh>
rajesh>_________________________________________________________________
rajesh>Designer Mail isn't just fun to send, it's fun to receive. Use special 
rajesh>stationery, fonts and colors. 
rajesh>http://join.msn.com/?pgmarket=en-ca&page=byoa/prem&xAPID=1994&DI=1034&SU=http://hotmail.com/enca&HL=Market_MSNIS_Taglines 
rajesh>  Start enjoying all the benefits of MSN(r) Premium right now and get the 
rajesh>first two months FREE*.
rajesh>
rajesh>
rajesh>_______________________________________________
rajesh>Simple mailing list
rajesh>[email-masked]
rajesh>https://www1.ietf.org/mailman/listinfo/simple
rajesh>