Subject: RE: [Simple] I-D ACTION:draft-ietf-simple-prescaps-ext-02.txt

From: [email-masked]
Date: Tue, 2 Nov 2004 17:43:18 +0200

Hi,

> [email-masked] wrote:
> > 
> > Jumping to other topic. 
>  > Prescaps now defines <description> and <priority> elements that
>  > belong to <devcaps> documents. I think these elements provide
>  > useful information but I think that their place is not exactly
>  > in the prescaps I-D.
> 
> I agree that these aren't "capabilities".
> OTOH, these are things that are part of RFC 3840 (callee caps).
> A case can be made that prescaps is the place to define how 
> everything 
> in 3840 maps to presence.

Yes and this is now causing this issue. <priority> and <description> are already being defined in <servcaps> document. Now, if we have same similar information also in <devcaps> mapping to callee caps becomes bit ubiquitous. What I had in mind was that call caps description and priority would map to <description> and <priority> elements of devcaps document. I also though that priority and description might make sense in devcaps but those would not have any mapping to callee caps. For this reason I though it might make sense to move these elements to somewhere else.

- Mikko

>  > It might make more sense to move them for example to presence
>  > data model (include them into 
> urn:ietf:params:xml:ns:pidf:device schema).
>  > What do you think?
> 
> It doesn't matter much to me where the data elements are defined, as 
> long as they are defined somewhere. I don't know if the data 
> model is a 
> very good place - it mainly defines a framework rather than 
> the detailed 
> contents. If not prescaps, then I would think rpid would be the other 
> likely place, or else yet another independent draft.
> 
> But if these are not defined in prescaps, then I think it 
> would be good 
> for prescaps to cross reference where they are defined.
> 
> 	Paul
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Nov 2004 18:56:19 -0500

Mikko,

Maybe I misunderstood you.

Even though the prescaps stuff is now split between a <servcaps> element 
and a <devcaps> element, aren't both of those being defined in the same 
prescaps-ext I-D?

I only meant that I hope this I-D will discuss how all the things in 
callee-caps map to presence. It doesn't even have to be the 
authoritative place where all the elements are defined. If it makes 
sense to have more than one I-D, then it would be fine to simply refer.

	Paul