Subject: RE: AW: AW: [Simple] Data model - attempt at summary

From: [email-masked]
Date: Wed, 10 Nov 2004 14:18:28 +0200

Hi,

It would be good if the data model explicitly addressed the issue of how to describe "proprietary" services in tuples. By "proprietary" I mean in this case something that can't be expressed with prescaps capabilities. Of course we can leave it completely open, but I think there would be some value to have a recommendation how to do this consistently.

I still think that there should be this kind of service ID in the tuple for this purpose with a certain type of registry to avoid overlaps. The main benefit for this would be the ability to do authorization rules for this type of proprietary services. Currently it is hard, if those services use SIP AOR as a contact address, i.e. the contact address field alone is not enough to pinpoint the tuple describing such a service.

Markus 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Jonathan Rosenberg
> Sent: 10 November, 2004 08:54
> To: Henning Schulzrinne
> Cc: Simple WG; Boehmer Bernhard ICM Berlin
> Subject: Re: AW: AW: [Simple] Data model - attempt at summary
> 
> 
> I agree with Henning here; I don't see how the layer of indirection 
> solves anything.
> 
> -Jonathan R.
> 
> Henning Schulzrinne wrote:
> 
> > Boehmer Bernhard ICM Berlin wrote:
> > 
> >> Hi Henning,
> >> service ID: certainly indirection has its drawbacks;
> >> in this case the main question is whether the higher
> >> flexibility of indirection outweighs the overhead
> >> introduced with that. Actually, the whole XML schema
> >> architecture is using it heavily (this becomes obvious
> >> to me each time I edit XML schemas without being connected
> >> to the Internet...:).
> > 
> > 
> > While it is easy for a mobile provider to publish a UDDI 
> directory entry 
> > for its limited number of phones, say, it seems much harder for the 
> > average user in a corporate network or using a provider. 
> They will have 
> > to rely on the provider or corporate network to host this 
> information. 
> > Unless you want to rely on web pages for configuration, 
> every new source 
> > of information means that there needs to be authentication, 
> a means to 
> > publish this information and to change it.
> > 
> > The only advantage of inclusion by reference is space 
> saving. Otherwise, 
> > whatever service description you include by reference can also be 
> > included by value.
> > 
> > The space saving only matters if the mobile transmits the 
> information. 
> > This seems unlikely, even with inclusion.
> > 
> > Thus, I'm at a loss to see why adding another protocol 
> machinery for 
> > managing UDDI stores to every PUA or PA adds significant value that 
> > outweighs the complexity incurred.
> > 
> > Henning
> > 
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> > 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
> Director, Service Provider VoIP Architecture   Parsippany, NJ 
> 07054-2711
> Cisco Systems
> [email-masked]                              FAX:   (973) 952-5050
> http://www.jdrosen.net                         PHONE: (973) 952-5000
> http://www.cisco.com
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 10 Nov 2004 08:39:13 -0500

Markus,

To describe a service that can't be described with prescaps, you just 
need to use some other (perhaps proprietary) extension entitites within 
tuple or status.

I had wanted the callerprefs extension mechanism mapped over to prescaps 
in order to make extensions to presence as simple as extensions to 
callee caps, but that got lost along the way. Nevertheless I don't think 
it is very hard to define your own xml schema for this purpose.

	Paul