Subject: RE: [Simple] Question about extending mood in rpids-04

From: [email-masked]
Date: Mon, 8 Nov 2004 21:13:36 +0200

Hi,
 
> > 2. Specific element names
> > 
> > In this approach, the element name contains the information 
> of interest:
> > 
> > <working/>
> > 
> > There are two variations on this:
> > 
> > a. the schema uses substitution groups, declaring an 
> abstract element 
> > like <activity> that things like <working> replace
> > 
> > b. the schema allow elements from any namespace
> I'm wondering about the future proofness when using the substitution 
> groups. If the recipient is doing document validation, but doesn't 
> possess the extension schema, will it be able to validate the 
> document.

As far as I understand, yes it can.

> That seems like a bad thing, especially considering a composer might 
> need to do document validation. It should be able to 
> transparently treat 
> data it doesn't understand, so that extensions can be made in 
> endpoints 
> only without requiring a network entity to be upgraded.
> 
> Therefore, 2b would seem like a better alternative here...

My understanding about this is that only difference between A and B is that in A you specify your new elements to inherit from the abstract element that is defined in 'base' document. In B you would be able to introduce any type of new element, regardless what has been defined before.
So both models have same properties what comes to schema validation.

> Cheers,
> Aki
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 08 Nov 2004 21:15:44 -0500

> As far as I understand, yes it can.

Can you explain? If I receive a document that has an element I don't 
understand, how can I tell it is an instance of a particular 
substitution group if that is what is required for the document to be valid?

	Paul