Subject: RE: [Simple] I-D ACTION:draft-ietf-simple-prescaps-ext-02.txt

From: [email-masked]
Date: Mon, 1 Nov 2004 12:24:32 +0200

Hi,

> [email-masked] wrote:
> > Paul,
> > 
> > Do you assume that prescaps would always be generated based 
> on registration information?
> 
> No. But I think some will do it that way.
> 
>  > At least I think in many cases it will be directly 
> published by the 
> PUA/device itself,
> 
> Yes, I agree.
> 
>  > in which case there obviously won't be a problem in 
> associating e.g. 
> mobility with a device. If someone is forming prescaps based on 
> registered contacts, I suggest to simply leave mobility away, 
> since as 
> you say association with any device id could be impossible, and I too 
> woudn't like to mess the service model by talking about 
> mobile services.
> 
> I guess leaving mobility out is an option. Not great, but perhaps a 
> tolerable limitation.
> 
> 	Paul

Yes, it would be nice to have it but I cannot figure out how to do it.

Jumping to other topic. Prescaps now defines <description> and <priority> elements that belong to <devcaps> documents. I think these elements provide useful information but I think that their place is not exactly in the prescaps I-D. It might make more sense to move them for example to presence data model (include them into urn:ietf:params:xml:ns:pidf:device schema). What do you think?

- Mikko

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 01 Nov 2004 10:18:39 -0500

[email-masked] wrote:
> 
> Jumping to other topic. 
 > Prescaps now defines <description> and <priority> elements that
 > belong to <devcaps> documents. I think these elements provide
 > useful information but I think that their place is not exactly
 > in the prescaps I-D.

I agree that these aren't "capabilities".
OTOH, these are things that are part of RFC 3840 (callee caps).
A case can be made that prescaps is the place to define how everything 
in 3840 maps to presence.

 > It might make more sense to move them for example to presence
 > data model (include them into urn:ietf:params:xml:ns:pidf:device schema).
 > What do you think?

It doesn't matter much to me where the data elements are defined, as 
long as they are defined somewhere. I don't know if the data model is a 
very good place - it mainly defines a framework rather than the detailed 
contents. If not prescaps, then I would think rpid would be the other 
likely place, or else yet another independent draft.

But if these are not defined in prescaps, then I think it would be good 
for prescaps to cross reference where they are defined.

	Paul