Subject: [Simple] Last Call: 'The Extensible Markup Language (XML) Configuration Access Protocol (XCAP)' to Proposed Standard

From: The IESG <[email-masked]>
Date: Thu, 09 Dec 2004 16:26:40 -0500

The IESG has received a request from the SIP for Instant Messaging and 
Presence Leveraging Extensions WG to consider the following document:

- 'The Extensible Markup Language (XML) Configuration Access Protocol (XCAP) '
   <draft-ietf-simple-xcap-05.txt> as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by 2004-12-28.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-05.txt

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Pete Cordell" <[email-masked]>
Date: Mon, 13 Dec 2004 11:06:02 -0000

I haven't followed XCAP, but I wonder if the following XML schema types
should be empty elements (e.g. <not-well-formed/>) rather than ur-type (e.g.
<not-well-formed>blah<foo/>etc</not-well-formed>)?

    <xs:element name="not-well-formed" substitutionGroup="error-element">
    </xs:element>
    <xs:element name="constraint-failure" substitutionGroup="error-element">
    </xs:element>
    <xs:element name="cannot-delete">
    </xs:element>

If some of them are meant to be empty, then the syntax is:

    <xs:element name="not-well-formed" substitutionGroup="error-element">
      <xs:complexType/>
    </xs:element>
    <xs:element name="constraint-failure" substitutionGroup="error-element">
      <xs:complexType/>
    </xs:element>
    <xs:element name="cannot-delete">
      <xs:complexType/>
    </xs:element>

Regards,

Pete.
--
=============================================
Pete Cordell
Tech-Know-Ware
http://www.tech-know-ware.com/lmx
For LMX XML to C++ binding
(or http://www.xml2cpp.com)
=============================================

----- Original Message ----- 
From: "The IESG" <[email-masked]>
To: "IETF-Announce" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, December 09, 2004 9:26 PM
Subject: [Simple] Last Call: 'The Extensible Markup Language (XML)
Configuration Access Protocol (XCAP)' to Proposed Standard