Subject: Re: [Simple] Mistake in PRES-URI BNF

From: Robert Sparks <[email-masked]>
Date: Wed, 1 Dec 2004 10:26:19 -0600

Tamar -

I don't think that production was what anybody had in mind.
The intent was probably to = addr-spec.

We can put together a correction and figure out how to submit it.

Comments from anyone?

RjS

On Nov 29, 2004, at 5:51 AM, Tamar Barzuza wrote:

>> Hi,
>>
>> I found a problem in the BNF of PRES-URI.
>>
>> RFC 2396 defined the generic syntax of URI. It explicitly says that 
>> the following (delims) characters are disallowed within URI:
>> delims= "<" | ">" | "#" | "%" | <">
>>
>> However, in RFCs 3859 and 2822 the definition for PRES-URI is:
>> 	PRES URI = "pres:" [ to ] [ headers ]
>> 	to = mailbox
>> 	mailbox = name-addr / addr-spec
>> 	name-addr = [display-name] angle-addr
>> 	angle-addr = [CFWS] "<" addr-spec ">" [CFWS] / obs-angle-addr
>> 	addr-spec = local-part "@" domain
>> 	display-name = phrase
>> Which means that pres addresses can look like pres:"name"<user@host>, 
>> hence may contain " and <>.
>>
>> Therefore I believe that the PRES-URI BNF is mistaken.
>>
>> Thanks,
>> Tamar.
>>
>
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 03 Dec 2004 19:25:29 -0500

I agree this is definitely a mistake.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com