Subject: [Simple] XML parsing

From: "Anir P" <[email-masked]>
Date: 15 Dec 2004 13:57:57 -0000

Hi
I want a generic C XML parser source code which can parse XML body (including schema). The library form will be specifi to a platform. Is there any source code available which can do XML (including schema) decoding, encoding etc.

Regards

On Wed, 15 Dec 2004 Jari Urpalainen wrote :
>ext Anir P wrote:
>
>>Hi
>>Is there any XML parser freely available which I can use for SIMPLE implementation.
>>
>>Any information regarding this highly appriciated.
>>
>>Thanks
>>
>There are many freely available xml parsers available, I have mostly used libxml2 and Xerces. However, the proper answer to your question depends a lot of your implementation environment, i.e. your operation system and what languages are you using. Anyway, if your environment matches with what libxml2 provides/needs I can really recommend it. Although it is written with C it has quite so many other language bindings (C++, python etc.). I have also used Xerces (C++ and Java) for Schema validation.
>
>br,
>Jari
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jari Urpalainen <[email-masked]>
Date: Wed, 15 Dec 2004 16:51:17 +0200

ext Anir P wrote:

>  
> Hi
> I want a generic C XML parser source code which can parse XML body 
> (including schema). The library form will be specifi to a platform. Is 
> there any source code available which can do XML (including schema) 
> decoding, encoding etc.
>
> Regards
>
Look at http://www.xmlsoft.org/. It can also handle some xml Schema 
validation. Since I previously tried this validation it seems to have 
been improved quite a lot as it could flawlessly validate e.g. rfc 3863 
examples. I'll have to run also some more complex examples, but even 
this looks promising.

br,
Jari