Subject: RE: [Simple] tel as device identifier

From: Goix Walter <[email-masked]>
Date: Sun, 19 Jun 2005 23:20:30 +0200

Henning,
 
in current networks, most of the cell and residential phones do not actually know the public phone number they're attached to, so the information would need to be entered either manually on the device whenever possible, or automatically within the network. Whenever entered manually (for example on a mobile phone), the tel: URI shall be asserted in some way, which is not easy to check. When assigned by a network by a presence network agent, which publishes on behalf of the device, the publishing entity would probably need to know both the phone number and the SIP identity of the user to publish for. This would imply the publisher to be part of a company, which is both ilec+SIP service provider.
 
as easily deployable solution, do we need/want a device-id, which is human understandable or meaningfull in some way, or does any kind of unique id meet our reqs? in that case some kind of urn:uuid may be easier.
 
Walter

________________________________

From: [email-masked] on behalf of Henning Schulzrinne
Sent: Sat 6/18/2005 9:08 PM
To: Paul Kyzivat
Cc: Simple WG
Subject: Re: [Simple] tel as device identifier

Paul Kyzivat wrote:
> Henning,
>
> I think the problem is that presumably the device itself must decide if
> this can be used as a device-id. I don't know how the device would be
> able to decide that it is the only one that will be trying to use the
> phone number as a device id.
>
> If it is a human deciding to do this then I think it can work.

Initially, I suspect that most devices won't do any publishing on their
own, so this will have to be entered manually. I agree that this is not
a long-term or universal solution, but we lack deployable alternatives.

For current cell phones, 'tel' should work reasonably well. As far as I
know, each cell number is assigned to exactly one device at a time.

Even for residential phones, while there might be multiple devices on a
single piece of wire, the phone company (ILEC) could certainly assign
this as an identifier. These multiple devices act essentially as if they
were one - there's no way to reach just one of them. (Indeed, this
application motivates my question.)

Henning

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to 
[email-masked]. Thank you
====================================================================

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 20 Jun 2005 17:56:51 -0400

You should have mentioned IMEI which GSM phones use.

But, to get to the heart of your question, would you consider an IP
address a device identifier?

I would suspect not, but don't see why one type of routing address
should be treated different from another.  The use of such addresses
could be problematic.  There are services where one tel number may alert
multiple devices.  I don't have a better answer for you, but would just
note that on the ENUM list there was much gnashing of teeth over the
fact that someone might put an E.164 number into the directory without
the user opting-in.  They viewed it as a white pages thing, versus a
core routing infrastructure dependency.  Just wondering what sort of
privacy gotchas will result.

Mike

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Henning Schulzrinne
> Sent: Saturday, June 18, 2005 12:43 PM
> To: Simple WG
> Subject: [Simple] tel as device identifier
> 
> Currently, there is no really good device identifier 
> (device-id), as none of the obvious candidates (IMSI, MAC 
> address, etc) currently have a URN definition. In order to 
> speed deployment, one quick-and-easy suggestion is to use the 
> tel URL. While this does not always identify a single device, 
> in many practical cases of interest, it does. Examples where 
> this is likely to work reasonably well include mobile phones 
> and residential analog phones (i.e., without ENUM).
> 
> Comments?
> 
> Henning
>

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 23 Jun 2005 14:04:07 -0400

Yeah, I agree with Cullen.

Tel is definitively not a device identifier. Even in most old traditional
PBXs, you
have a device identifier that is used internally for that purpose.

There are hunt group numbers, 800 numbers, portable numbers, and with SIP
now, my telephone
numbers rings a whole bunch of different devices. 

It is anything but a device identifier, and the trend is intensifying.

> [mailto:[email-masked]] On Behalf Of Cullen Jennings
> Sent: Tuesday, June 21, 2005 11:31
> To: Henning Schulzrinne; [email-masked]
> tel is definitely not a unique device identifier - i have 
> many devices with the same tel. Why not just use an UUID  URN 
> as a device id.
> 
> 
> 
> 
> On 6/18/05 9:42 AM, "Henning Schulzrinne" <[email-masked]> wrote:
> 
> (device-id), as 
> > none of the obvious candidates (IMSI, MAC address, etc) 
> currently have 
> > a URN definition. In order to speed deployment, one quick-and-easy 
> > suggestion is to use the tel URL. While this does not 
> always identify 
> > a single device, in many practical cases of interest, it does. 
> > Examples where this is likely to work reasonably well 
> include mobile 
> > phones and residential analog phones (i.e., without ENUM).
> > 
> > Comments?
> > 
> > Henning
> >