Subject: RE: [Simple] Expiration of partial publish

From: [email-masked]
Date: Thu, 7 Jul 2005 12:28:31 +0300

Hi Avshalom,

The draft states that "Unless otherwise specified in this document, the presence user agent
   and presence agent behavior are as defined in the Event State Publication Extension to SIP [2]."

And in the subsection "4.3  Processing of Partial Publications" it is said that "The compositor MUST apply the partial publication operations in sequence against its locally stored presence information."

So the partial publication should function in a similar way as the "normal" Event State Publication. If the publication published by a PUA is not refreshed the whole publication sequence (basically meaning the current locally stored version of it) expires. 

BR, Eva

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Avshalom Houri
Sent: 06 July, 2005 16:04
To: Simple WG
Subject: [Simple] Expiration of partial publish

draft-ietf-simple-partial-publish-02 does not relate to the expiration of the 
partial publish or at least I could not see it. 
Is the intention is that each partial publish will have its own expiration and 
the server will undo the partial publish when it expires? 

It may be quite complex. The server may need to roll back to a previous full 
or partial publish is that publish have not expired yet. 
It is not like an expiration of a full publish where we can just delete the 
whole element. 

Avshalom 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Avshalom Houri <[email-masked]>
Date: Thu, 7 Jul 2005 13:23:18 +0300

Hi Maria,

Thanks for the response.

So it simply means the partial publishes also contain
expiration time and

that time should be processes as if it was send in
a full publish.

So it may be just my misunderstanding but it may be
good to add some text

clarifies this.

Avshalom

[email-masked]

Sent by: [email-masked]

07/07/2005 12:28 PM

To

Avshalom Houri/Haifa/IBM@IBMIL, <[email-masked]>

cc

Subject

RE: [Simple] Expiration of partial publish

Hi Avshalom,

The draft states that "Unless otherwise specified in this document,
the presence user agent

and presence agent behavior are as defined in the Event State Publication
Extension to SIP [2]."

And in the subsection "4.3  Processing of Partial Publications"
it is said that "The compositor MUST apply the partial publication
operations in sequence against its locally stored presence information."

So the partial publication should function in a similar way as the "normal"
Event State Publication. If the publication published by a PUA is not refreshed
the whole publication sequence (basically meaning the current locally stored
version of it) expires.

BR, Eva

-----Original Message-----

From: [email-masked] [mailto:[email-masked]]On Behalf
Of ext Avshalom Houri

To: Simple WG

draft-ietf-simple-partial-publish-02 does not relate to the expiration
of the

Is the intention is that each partial publish will have its own expiration
and

It may be quite complex. The server may need to roll back to a previous
full

It is not like an expiration of a full publish where we can just delete
the

whole element.

Avshalom

Simple mailing list

[email-masked]

---

From: Aki Niemi <[email-masked]>
Date: Fri, 15 Jul 2005 18:28:53 +0300

Correct. I've added some text that clarifies this in the new revision of
the partial-publish draft.

Thanks,
Aki

ext Avshalom Houri wrote:
> 
> Hi Maria,
> 
> Thanks for the response.
> 
> So it simply means the partial publishes also contain expiration time and
> that time should be processes as if it was send in a full publish.
> 
> So it may be just my misunderstanding but it may be good to add some text
> clarifies this.
> 
> Avshalom
> 
> 
> 
> 
> [email-masked]*
> And in the subsection "4.3  Processing of Partial Publications" it is 
> said that "The compositor MUST apply the partial publication operations 
> in sequence against its locally stored presence information."
> 
> So the partial publication should function in a similar way as the 
> "normal" Event State Publication. If the publication published by a PUA 
> is not refreshed the whole publication sequence (basically meaning the 
> current locally stored version of it) expires.
> 
> BR, Eva
> 
> ------------------------------------------------------------------------
>