Subject: [SIMPLE][Pres-Rules] PDM and specific information transformation in draft-ietf-simple-presence-rules-02

From: "Fridy Sharon-Fridman" <[email-masked]>
Date: Mon, 4 Jul 2005 14:40:54 +0300

Hi,

How (and if) it is possible to allow a watcher to see some presence attribute on one PDM section (e.g. person) but not in another, without harming the other presence attributes visibility? It seems that allowing each of the sections (tuple / person / device) in one "layer" of transformations, and allowing the specific attributes in another layer, is not sufficient for this scenario. 

Are these limitations acceptable?

Sample: presentity has <note> in some service <tuple> with additional attributes, and also a <note> for the <person>. He wants to authorize the note for the person and not for the service, for a particular watcher.

The naïve solution of trying to use provide-person and provide-note, but not provide-service would achieve the result "shallowly" for note, but prevent the other service presence information.

Same kind (but different) problem occurs on allowing some PA for one service but not for the other service (and again for devices).

What are your thoughts on this? Perhaps I am missing something...

--Fridy / Followap

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 19 Jul 2005 04:59:04 -0400

This kind of capability had been discussed (and indeed present in 
previous versions of the draft IIRC). However, we decided to keep things 
simple and just provide attributes globally. It is very easy to think of 
all different kinds of permissions and we are trying to keep the scope 
narrow.

Thanks,
Jonathan R.

Fridy Sharon-Fridman wrote:

> Hi,
> 
>  
> 
> How (and if) it is possible to allow a watcher to see some presence 
> attribute on one PDM section (e.g. person) but not in another, without 
> harming the other presence attributes visibility? It seems that allowing 
> each of the sections (tuple / person / device) in one “layer” of 
> transformations, and allowing the specific attributes in another layer, 
> is not sufficient for this scenario.
> 
>  
> 
> _Sample_: presentity has <note> in some service <tuple> with additional 
> attributes, and also a <note> for the <person>. He wants to authorize 
> the note for the person and not for the service, for a particular watcher.
> 
>  
> 
> The naïve solution of trying to use provide-person and provide-note, but 
> not provide-service would achieve the result “shallowly” for note, but 
> prevent the other service presence information.
> 
>  
> 
> Same kind (but different) problem occurs on allowing some PA for one 
> service but not for the other service (and again for devices).
> 
>  
> 
> What are your thoughts on this? Perhaps I am missing something…
> 
>  
> 
> --Fridy / Followap
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com